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日本語訳版まえがき  

 

Ocean Data View (ODV) は、様々な海洋データを簡単に解析・可視化できるソフトウェアで、 アルフレ

ッド・ヴェゲナー極域海洋研究所 (AWI) から無償で公開されています。 

ODV ユーザーズマニュアル日本語訳版は作者の了解を得て、日本海洋データセンター(Japan 

Oceanographic Data Center; JODC)が翻訳を、(一財)日本水路協会海洋情報研究センター(Marine 

Information Research Center; MIRC)が監修を担当いたしました。 

 

本ユーザーズガイドが皆様にお役立ていただければ幸いです。  

 

ウインドウやダイアログ・ボックスのタイトルや項目名などは原文のまま表記しています。 

 

メインメニューやポップアップ・メニューなどに表示される選択可能なメニューはイタリック体で表記して 

います。  

 

Ocean Data View に関するオフィシャルサイト 

 http://odv.awi.de/  

 

日本語訳版に関するお問い合わせ先  

日本海洋データセンター  

〒100-8932 東京都千代田区霞が関 3-1-1  

   

     

海洋情報研究センター  

一般財団法人日本水路協会  

〒144-0041 東京都大田区羽田空港 1-6-6 第一総合ビル６階  

 

 

 

 

 

 

http://odv.awi.de/


ODV User’s Guide 

 

iii 

 

日本語訳版履歴 

 

2003 年 3 月 3 日  Version 1.4 公開 

2004 年 8 月 25 日 Version 2.0 公開 

2005 年 11 月 7 日 Version 3.0 暫定版公開 

2006 年 9 月 11 日 Version 3.1.0 第一版 

2019 年 4 月 9 日 Version 4.7.2（未公開） 

2020 年 2 月 21 日 Version 5.2.0（未公開） 

2020 年 2 月 25 日 Version 5.2.1（未公開） 

2020 年 ３月 20 日 軽微な修正（未公開） 

2020 年 10 月 9 日 Version 5.3.0（未公開） 

2021 年 4 月 27 日 Version 5.4.0（未公開） 

2021 年 10 月 12 日 Version 5.5.1（未公開） 

2021 年 12 月 3 日 Version 5.5.2（未公開） 

2022 年 5 月 26 日 Versiion 5.6.2 公開 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Version 56.2 

 

iv 

 

謝辞（Acknowledgements）:  

多くのユーザーからのコメント、提案、バグレポートの提供を頂き、ODV を安定した有用な製品にする事が

出来ました。 Liege 大学の Jean-Marie Beckers は、格子化ソフトウェア DIVA を ODV に統合する作業を

支援してくれました。 Stephan Heckendorff と Michael Menzel は ODV コード作成に大きく貢献して頂き

ました。これには、ODV へのインポート・ルーチンの移植、SDN ファイル集約ツールの実装、xview 機能

の作成、ESRI シェープファイルのサポートが含まれています。European Union Horizon 2020 および許諾

承認番号 730960 SeaDa-taCloud、283607 SeaDataNet2、211384 EPOCA、264879 CarboChange の

元での Seventh Framework Programmes からの資金援助に感謝の意を表します。



i 

 

ライセンスの同意（License Agreement） 

本ソフトウェアのダウンロードまたは使用によって、あなたはアルフレッド・ヴェゲナー極地海洋研究所 (AWI) との間

に次の法的な合意に従うことに同意したことになります。この合意項目に同意できない場合は、本ソフトウェアをダウン

ロードしたり使用したりしないでください。 

 

1.科学および教育での利用（SCIENTIFIC USE AND TEACHING） 

Ocean Data View は非商用、非軍事研究、および教育目的の場合に無償で使用することができます。科学的な作業で本ソ

フトウェアを使用する場合、あなたの出版物において Ocean Data View を次のように引用してください：Schlitzer, Reiner,  

Ocean Data View, https://odv.awi.de, 2020. 

 

2.商用利用（COMMERCIAL USE） 

商用または製品のために、Ocean Data View またはその如何なる部分をも使用する場合には、特別な書面のソフトウェ

ア・ライセンスが必要です。詳細は下記のアドレスにお問い合わせください。 

 

3. 軍事利用（MILITARY USE） 

AWI は、その活動を民間の目的に集中させています。 軍事目的に Ocean Data View ソフトウェアのライセンスを付与

するのは、ケースバイケースの評価判断を受けた場合のみです。 詳細は下記のアドレスにお問い合わせください。 

 

4. 再配布 (REDISTRIBUTION) 

CD-ROM、DVD または他の電子媒体、またはインターネットによる Ocean Data View の再配布には、AWI による事前

の書面での許可が必要です。詳細は下記のアドレスにお問い合わせください。 

 

5. 保証の放棄 (WARRANTY DISCLAIMER) 

ODV ソフトウェアは、明示の如何にかかわらず、いかなる種類の保証なしにあるがまま提供されるものです。商用利用や

特定目的に関する利用の適合性に関する暗黙の保証もありません。ソフトウェアの品質や性能に関する全てのリスクは、

利用者が負うものであり、ソフトウェアに欠陥があった場合、全ての必要なサービス、復旧あるいは修正にかかる費用は、

利用者の負担となります。AWI, ODV の協力者ならびにその著作権保有者のいずれも、利用者に対し、あらゆる直接的、

間接的、一般的、特殊的、典型的、偶発的あるいは必然的な損害がどのように生じたとしても、また、ソフトウェアの利

用による、あるいは利用できないことによる責任（データあるいは誤って提出されたデータの損失、利用者あるいは第三

者が被った損失、他のソフトウェアと同時に利用したために生じたソフトウェアの被害や営業の中断を含み、尚且つそれ

だけに留まらない損失）を一切負いません。 

 

Alfred Wegener Institute, Am Handelshafen 12, 27570 Bremenhaven, Germany,E-Mail: odv_license at awi.de 
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1 概要（General Overview） 

Ocean Data View(ODV)は、海洋学および他のジオリファレンスを与えられた(空間的位置情報が付加された)

プロファイル、軌跡、時系列データを対話的に探究しグラフ化するアプリケーションソフトウェアです。この

ソフトウェアは、Windows、MacOS、Linux、および UNIX システムで使用できます。 ODV データと設定フ

ァイルはプラットフォームに依存せず、サポートされている全てのシステム間で交換することができます。

ODV を使用すると、安価でポータブルなハードウェア上で非常に大きなデータセットを保存し分析すること

ができます。高品質な測点図、一つ以上の測点の一般的な成分間プロット、選択された測点の散布図、任意の

航跡に沿った鉛直断面図、一般的な等値面上の成分分布など、さまざまな種類のグラフィックス出力を簡単に

作成する事が出来ます。 

 

ODV はオリジナルのスカラーデータやベクトルデータをカラー点、数値データ、または矢符で表示すること

ができます。さらに、自動的に生成される格子上での推定値を提供し、断面に沿った、あるいは等値面上のカ

ラー彩色および等値線を描画するための、三つの異なる格子化アルゴリズムがあります。多くの派生量をソフ

トウェア実行中に計算できます。これらの変数は、ディスクに保存されている基本変数と同じ方法で表示およ

び分析する事ができます。 

 

ODV 4 はオブジェクト指向の C ++ソフトウェアコードに基づいており、以前の ODV バージョンの多くの制

限を克服しました。下位互換性を確保するため、ODV は ODV3 で作成された既存のデータコレクションと構

成ファイル（現在ではビューと呼ばれる）をサポートし続けています。ただし、新しく作成される全てのコレ

クションでは、新しい一般的なデータモデルと内部記憶フォーマットが使用されるようになっています。以前

のように、ODV データコレクションはプラットフォームへの非依存性を維持しているので、サポートされる

システム間で移動することができます。新しいデータモデルの新機能には、より柔軟なメタデータ・スキーム、

無制限の数のデータ変数のサポート、ユーザー指定のデータタイプ、メタデータとデータ変数のための特別な

品質フラグスキームがあります。 

 

1.1 使いやすさ（Ease of Use） 

ODV は柔軟性に富んで使いやすく設計されています。ユーザーは内部のデータ記憶フォーマットの詳細を知

る必要がなく、プログラミングの経験も不要です。ODV は利用可能な測点分布図を常に画面上に表示するの

で、ユーザーはマウスで測点、サンプル、断面、等値面を選んで簡単にデータを操作できます。測点図と

ODV 描画キャンバスのデータウィンドウのレイアウトは、他の多くのビュー設定と同様に容易に修正でき、

後で使用するために好みの設定をビューファイルの中に記憶できます。 

ODV は比較的安価でポータブルなハードウェア上で何百万もの測点を含む非常に大きなデータコレクション

を処理することができ、新しいデータが利用可能になると既存のデータコレクションを拡張することができま

す。ODV の広範囲なプロットの種類と柔軟な対話的制御によりデータの品質管理がとても容易になり、訓練

や教育にも役立ちます。 
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1.2 高密度データフォーマット（Dense Data Format） 

ODV データフォーマットは、可変長で不等間隔なプロファイル、軌跡、および時系列データを最適化します。

非常に大きなデータコレクションであっても、高密度記憶を提供し、任意の測点のデータへの即時アクセスを

可能にします。データフォーマットは柔軟性があり、測点数、サンプル数、変数の数は事実上無制限です。ODV

コレクションのメタデータおよびデータ変数のリストは、コレクション作成時にユーザーによって定義されま

す。プロファイル、軌跡、または時系列の様に非常に異なるデータタイプのデータを格納するために、異なる

ODV コレクションが作成されます。 

 

ODV はまた、実際のデータ値に加えて全ての個々の値について品質フラグを維持します。これらの品質フラ

グは、例えば不良または疑わしいデータを解析から除外するときのデータ品質フィルタリングに使用されます。

数値および品質フラグは編集および変更することができます。全ての変更は記録されるので、必要に応じて意

図しない変更を元に戻すことが可能になります。 

 

1.3 拡張性 (Extensibility) 

ODV はコレクションへの新しいデータのインポートおよびコレクションからデータのエクスポートも容易で

す。広く使用されている以下のフォーマットの海洋データを ODV システムに直接読み込むことができます： 

• ASCII スプレッドシート・データ 

• Argo プロファイルと軌跡データ 

• GTSPP データ 

• SeaDataNet データ 

• Sea-Bird データ(.cnv format)  

• WOCE と CLIVAR の WHP 交換フォーマットによるデータ 

• World Ocean Database データ 

 

1.4 派生変数（Derived Variables） 

データファイルに格納された基本的な測定変数に加えて、ODV は多数の派生変数を計算して表示することが

できます。これらの派生変数のアルゴリズムは、ODV ソフトウェアにコード化されているか(ポテンシャル水

温、ポテンシャル密度、力学高度(いずれも基準層は任意)、中立密度、Brunt-Väisälä Frequency (ブラント

ーバイサラ振動数)、音速、酸素飽和度など)、もしくはユーザーのマクロファイルまたは数式で定義されます。

新しい派生変量に数式やマクロファイルが使えることによって ODV の適用範囲は一層広がり、科学分野では

未だ確立されていない新しい数量に関する実験が容易に行えます。ODV にはマクロエディタが組み込まれて

いるので、ODV マクロの作成および修正は簡単にできます。 
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1.5 プロットの種類 (Plot Types) 

任意の基本変数または派生変数を一つまたは複数のデータウィンドウに表示することができます。 さらに、

任意の変数を使用して等深面、等密度面、等温面、または等塩分面などの様な等値面を定義することができま

す。例えば中層水における塩分極小層のような、ある成分の極小もしくは極大層は、その成分の鉛直微分がゼ

ロの等値面として選択することができます。 

 

ODV はデータを次の二つの基本的な方法：（1）データの位置にオリジナルデータをユーザー定義サイズの

カラー点（図 1-1a 参照）、数値、または矢符（図 1-2 参照）で；または（2）オリジナルデータを等距離ま

たは可変解像度の矩形格子の格子領域に投影して表示します（図 1-1b 参照）。方法１は最も基本的で、デ

ータの「ありのまま」の分布を瞬時に描くので、不良データやサンプリングが粗な領域を明らかにできま

す。これに対して方法２は見た目が「美しく」、方法１で見られるようなカラーの、特にサイズの大きな点

が重なりあう状態を回避することができます。ただし方法 2 の格子領域は、実際には加工されたデータを表

わしているので、格子化の結果としてデータの小規模スケールまたは顕著な特徴が変更または失われる可能

性があることに注意してください。どちらの表示モードでも ODV はウィンドウデータと格子領域を ASCII

ファイルまたはクリップボードにエクスポートできるので、ODV を離れて事後利用できます。 

 

スカラー成分フィールドに加えて、ODV は X および Y ベクトル成分を別個の変数として提供するデータセッ

トのベクトル場の表示もサポートしています。(図 1-2 参照)。 

 

 

図 1-1(a)：カラー点および(b)格子領域として表示されるデータ 

 

 

1.6 ウィンドウスコープ（Window Scopes） 

ODV アプリケーションウィンドウは、常に利用可能な測点のマップを表示します。さらに、ユーザーは実デ

ータの表示のために無制限の数の他のウィンドウを定義することが出来ます。これら各々のデータウィンドウ
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は、次の画面のうちの一つを有することができます： STATION、SCATTER、SECTION、SURFACE。各ウィ

ンドウは独自の画面を有し、異なるデータウィンドウの画面には違いがあります。 

 

図 1-2：歴史的風応力場の矢符プロット 

 

1.6.1 STATION スコープ（STATION Scope） 

STATION スコープウィンドウ(図 1-3 参照)は、マップのピックリスト内にある測点のデータのみを示す X/Y

プロットを提供します。+ (プラス)ボタンを押すと現在の測点をピックリストに追加するでき、- (マイナス)

ボタンを押すと削除できます。マップポップアップメニューの Manage Pick List > Edit Pick List オプションを

使用して測点ピックリストの編集が出来ます。とりわけ、これによって個々の選んだ測点ごとにグラフィック

ススタイルを調整することが可能になります。他の全てのデータウィンドウのタイプに関して、STATION ウ

ィンドウでは、X 軸と Y 軸に任意の(基本または派生)データ変数を割り当てることができます。識別を容易に

するために、選んだ測点はデータウィンドウと同じ記号および色を用いてマップ内に印づけられます。マップ

の注釈スイッチが on になっていれば、選んだ測点の位置に測点ラベルとともに表示されます。 

 

1.6.2 SCATTER スコープ（SCATTER Scope） 

SCATTER スコープウィンドウ（図 1-4 を参照）は、マップに現在表示されている全ての測点のデータを表示

するので、潜在的に非常に大きなデータセットの概要を表します。SCATTER ウィンドウは、特にデータ品質

管理に役立ちます。以降の全てのスコープと同様に、SCATTER ウィンドウでは X と Y の変数に加えて Z 変

数がサポートされています。Z 変数の値は、指定された X/Y データ位置に描画される色を決定します。Z 変数

のプロットには（SECTION モードおよび SURFACE モードと同様に)次の二つの方法：(1) X/Y の位置にカ

ラー点または実際のデータ値を表示(初期設定)、または(2)観測データに基づいて推定した連続的な格子領域

として表示します。格子領域にはカラーの陰影や等値線で描画できます。 
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図 1-3：STATION スコープを使用した正射図および六つのデータウィンドウによるウィンドウレ

イアウト例。測点ピックリストは識別を容易にするためにマップ内に印付けられる。 

 

図 1-4：SCATTER スコープを使用した二つのデータウィンドウでのウィンドウレイアウト例。一測

点のデータは、記号セット・グラフィックスオブジェクトを使用して強調表示されていま

す。 
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1.6.3 SECTION スコープ（SECTION Scope） 

SECTION スコープウィンドウ（図 1-5 を参照）は、地図に現在定義されている断面に属する全ての測点、例

えば赤い断面帯の内側にある全測点のデータを表示します。断面図はマップポップアップメニューの Manage 

Section オプションを使用して定義または変更します。 SECTION ウィンドウはまた、Z 変数とオリジナルデ

ータまたは格子領域の表示もサポートしています。SECTION ウィンドウは、航跡に沿った成分分布や所定の

軌道に沿った調査の測点に関する成分間プロットの表示をするのに最も有用なウィンドウです。 

 

図 1-5：二つの SECTION スコープ（1 と 2）と一つの SCATTER データウィンドウ（3）のウィンド

ウレイアウト例。 SCATTER ウィンドウ 3 はマップ内の全測点の全データを表示しているのに対し、

SECTION ウィンドウ 1 と 2 は断面帯内の測点データのみを表示している。 

 

1.6.4 SURFACE スコープ（SURFACE Scope） 

ODV はメタデータとデータ変数に加えて、第三の変数セット isosurface variables（等値面変数）を定義できま

す。 等値面変数は特定の等値面上の所定のデータ変数の値（例えば図 1-6 の水温または深度）を提供します。

等値面は一定の深度または密度の層のような別のデータ変数が一定値である層です。 

 

SURFACE スコープウィンドウはマップ内の全ての測点の等値面の値を表示します。SURFACE ウィンドウは

X, Y, Z の等値面変数をサポートしています。 経度と緯度が等値面変数として X 軸と Y 軸に割り当てられて

いる場合、ウィンドウは選択された Z 変数を表示するマップになります（図 1-6 を参照）。このようなマップ
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データウィンドウは、測点図の投影法およびレイヤー設定を使用します。SURFACE データウィンドウの X 軸

と Y 軸に他の等値面変数を割り当てることもできるので、Z 変数として別の等値面変数を使用して色付けする

ことにより、一般的な等値面変数の相関プロットになります。 

 

図 1-6：等値面上の成分分布を示す、SURFACE スコープの二つのデータウィンドウのレイアウト例 

 

 

1.7 グラフィックスの出力（Graphics Output） 

メインメニューのオプションの File > Save Canvas As を使用してキャンバス、マップ、および個々のデータウ

ィンドウのイメージファイルを gif, png, jpg, tif および eps で作ることが出来ます。または、キャンバス、マッ

プおよびデータウィンドウの各々の Save Canvas As, Save Map As, Save Plot As コンテキストメニューオプション

も使用できます。あるいは、キャンバス、マップまたはデータウィンドウ上にマウスを移動させて Ctrl-S ショ

ートカットキーを押すとこれらと同じオプションが即座に起動されます。 

 

ファイル保存ダイアログが表示されますので、ターゲットイメージのパス、ファイル名、タイプを指定してく

ださい。続いて Image Properties ダイアログでイメージの解像度を指定し、displya style では normal か pure

を、背景では透明か不透明かを選んでください。 

 

 

図 1-7: Image properties ダイアログ 

 

GeoTIFF 
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Tiff イメージフォーマットを選ぶと測点図もしくはいずれかのマップデータウィンドウの座標系が定義され

た GeoTIFF イメージが作成されます。これらの GeoTIFF イメージは GIS のレイヤーとして使うことができ

ます。最良の結果を得るには、display style で pure を選択し（軸ラベル、カラーバーまたはグラフィックオ

ブジェクトは描画せず）、Transparent background ボックスをチェックしてください。以下に GIS アプリケ

ーションでの表示例を示します。 

 

 

図 1-8: σ0=27.0 の等密度面の等深線および色付けされた同じ等密度面上でのリン酸塩濃度の GIS での表示

例。 

断裂投影図（Interupted Maps） 

測点図およびマップデータウィンドウ（X 軸と Y 軸が経度と緯度のデータウィンドウ）のコンテキストメニ

ューには Save As Interruped Map オプションがあります。Interrupted Map Properties ダイアログでは、タ

イトル、著作権表示、および北極および南極のサブウィンドウを含むかどうか、といったプロパティを指定

します。彩色および等値線のプロパティは親ウインドウから引き継がれます。 
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図 1-9: 断裂投影図法で表示された 500ｍ深の酸素分布。断裂投影図はプロットコンテキストメニューの

"Save As Interrupted Map"を介して作成される。 

 

1.8 データ統計（Data Statistics） 

データウィンドウ内の X, Y, Z データ、またはマップ内の測点の位置と日付/時刻メタデータの統計情報は、

マウスがそれぞれのデータウィンドウまたはマップ上にあるときに F4 キーを押すと簡単に得られます。平均

値、標準偏差、データ点数は X, Y, Z 変数の各々の最小値と最大値と同様にダイアログに表示されます。加え

て X, Y, Z データの柱状グラフは X/Y データ分布図と同様に単純にボタンをクリックするだけで得られます。

マップについては時間または季節(訳注: 1 月 1 日からの経過日)に対する測点数の柱状グラフも得られます。 

 

1.9 推定と平均化（Estimation and Averaging） 

ODV は任意の緯度-経度-深度における基本変数もしくは派生変数の値の推定に使えます(3D estimation (三

次元推定))。三次元推定には高速加重平均処理が実装されていて、ユーザーが指定した経度、緯度、深度の平

均の長さスケールおよびその時点で有効な測点とサンプルとのセットが使用されます。推定の座標は ASCII

ファイルで提供されます。これらの点は不規則に配置されているか、あるいは均一または不均一な矩形または

曲線状の格子上にあります。メインメニューから Tools > 3D Estimation を選択して 3D 次元推定を呼び出しま

す。 

 

Z 変数を持つデータウィンドウの場合、別の方法である二次元推定を使用して、任意の X/Y 点の Z 値を推定

することができます。三次元推定の場合、X/Y 座標は ASCII ファイルで提供されます。これらの点は不規則に
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配置されているか、あるいは均一または不均一な矩形または曲線状の格子上にあります。 各々のデータウィ

ンドウのポップアップメニューから Extras > 2D Estimation を選択して二次元推定を呼び出します。 

 

第三の推定方法である一次元推定は、X 軸または Y 軸に主要変数を持つデータプロットに対して使用できま

す。プロットに含まれる全ての測点に対してこのオプションを使用すると、ユーザーが指定した基本変数の値

に対する他の変数の値を推定できます。これらのユーザー指定の座標は一座標につき一行の ASCII ファイル

で提供する必要があります。推定結果は（求められた測点から続々と）ODV スプレッドシートフォーマット

のファイルに書き込まれ、例えばこれらのファイル自身は ODV で簡単にインポートして可視化できます。1D 

Estimation オプションを使用すると、例えばコレクションに格納されている変数の標準層（圧力）プロファ

イルが得られます。 それぞれのデータプロットポップアップメニューから Extras > 1D Estimation を選択して

一次元推定を呼び出します。 

 

上述した様々な推定方法に加えて、ODV はユーザー指定の緯度-経度-深度ボックス内の平均と標準偏差を計

算できます。指定されたボックス内のその時点で有効な全てのサンプルが平均化に使用されます。 

 

1.10 NetCDF サポート（NetCDF Support）  

ネイティブな ODV データコレクションに加えて、ODV はモデル出力のようなグリッドデータのプラットフ

ォーム非依存保管に広く使われている、ローカルまたはリモート netCDF ファイルにアクセスしてデータを可

視化することもできます。ODV は netCDF ファイルの中の重要な次元数と変数を四段階の netCDF エミュレ

ーション・ウィザードを介してユーザーに問い合わせます。それによって netCDF ファイルの内容は netCDF

ファイルがネイティブの ODV コレクションであるかのようにユーザーに提示されます。全ての ODV 解析お

よび可視化オプションは、netCDF ファイル内のデータの探索に使用できます。 NetCDF ファイルはプラット

フォーム非依存なので、全ての ODV 対応システムで使用できます。 
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2 ファースト・ステップ（First Steps） 

2.1 Ocean Data View のインストール（Installing Ocean Data View） 

ソフトウェアを使用する前に、コンピュータに ODV をインストールする必要があります。Windows, MacOS, 

Linux, お よ び UNIX シ ス テ ム 向 け の 最 新 の ODV イ ン ス ト ー ル フ ァ イ ル は 、

https://odv.awi.de/ja/software/download/からダウンロードできます。 ダウンロードページにアクセスす

るには個人ログインデータを登録して使用する必要があります。詳しいインストール手順は INSTALL.txt フ

ァイルで提供されています。ODV 使用規則の使用許諾契約書を参照してください。 

 

サポートされるプラットフォーム：ODV は以下のプラットフォームで動作します：Windows（全てのバージ

ョン）;  MacOS 10.5 以降; カーネルバージョン 2.6.15 以降で 2006 年 6 月以降にリリースされた Linux

配布パッケージ。ODV は Debian 7.7, Ubuntu 14.0.4 および 16.0.4, CentOS 7 上で動作確認されていま

す。 

 

ユーザーのドキュメントディレクトリ内のサブディレクトリ ODV は ODV ユーザーディレクトリとして機能

します。 このディレクトリは ODV のインストール時に自動的に作成され、マップリソースのみならずパレッ

ト、マクロ、地名辞典、コマンド、またはグラフィックスオブジェクトファイルが、インストールパッケージ

からこのディレクトリにコピーされます。ユーザーは、これらのファイルのカスタマイズバージョンを ODV

ユーザーディレクトリに作成することができます。 ここで重要なことは、カスタマイズしたファイルを新し

い名前で保存することです。 さもなければ、変更されたバージョンは次の新しい ODV ソフトウェアバージョ

ンがインストールされたときに上書きされて失われます。ユーザーディレクトリの絶対パスのみならず他の

ODV インストール設定は Help > About ODV または MacOS では odv > About odv で取得できます。 

 

補足的な高解像度の海岸線と地形のパッケージは View > Settings（MacOS では ODV > Preferences）オプショ

ンを使用してインストールできます。 詳細は 2.12 節以降を参照してください。 

 

ODV ユーザーディレクトリは View > Settings > System > User Directory でシステムディスク上の別の場所に移

動できます。 パフォーマンス上の理由からユーザーディレクトリをネットワークドライブには移動しないで

ください。 

 

2.2 Ocean Data View の起動（Running Ocean Data View） 

ODV がシステムにインストールされると、さまざまな方法でソフトウェアを起動できます。 

 

Windows では、インストール手順によってデスクトップ上に ODV アイコンが作成され、.odv および.var コレ

クションファイルタイプが ODV アプリケーションに自動的に関連付けられます。 ODV を起動するには、.odv

または.var ファイルをダブルクリックするか、ODV デスクトップアイコンをダブルクリックします。 

https://odv.awi.de/ja/software/download/
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ODV でサポートされているファイルを ODV アイコンにドラッグ・アンド・ドロップすることもできます。 

これにより ODV が起動してドロップされたファイルが開きます。すでに ODV が実行されている場合は、任

意の ODV サポートファイルを ODV ウィンドウにドラッグ・アンド・ドロップしてこのファイルを開くこと

ができます。 サポートされているファイルタイプには、ODV コレクション（.odv および.var）、netCDF ファ

イル（* .nc、* cdf）および ODV スプレッドシートファイル（.txt）があります。 

 

MacOS、Linux、およびUNIXシステムでは、オペレーティングシステム固有のメソッドを使用してODV実行

可能ファイルodvまたはODV起動スクリプトファイルrun_odvのエイリアスまたはアイコンを作成できます。

ODV実行可能ファイルodvは、ODVをインストールしたbin_...ディレクトリにあります（例えばMacOS Xでは

bin_macx、Linuxシステムではbin_linux-i386など）。 デスクトップまたはタスクバー/ドックアイコンが作成さ

れたら、ODVアイコンをダブルクリックするかシングルクリックしてODVを起動できます。 ほとんどのシス

テムではODVコレクション.odvおよび.varファイル、netCDFファイル、またはサポートされているデータイン

ポートファイルをODVアイコンにドラッグ・アンド・ドロップすることもできます。 

 

ODV は DOS ボックスやターミナルウィンドウからパス名を伴った実行可能ファイルと（オプションの）引数

を共に入力して起動することもできます。 いくつかのシステムでは、スクリプトファイル run_odv を使用し

てコマンドラインから ODV を起動できます。 コマンドラインから ODV を起動すると以下の引数がサポート

されます。ファイルとパス名に空白が含まれる場合には、それらを引用符""で囲む必要があることに注意して

ください。 

 

コマンドラインから ODV を起動する方法は二つあります： 

odv file [-access accessMode] [-view view_file] [-setting_file settings_file] 

または 

odv -x cmd_file [-q]  
 

最初のケースでは、アクセスモード accessMode を使用して ODV コレクション（.odv または..var コレクション

ファイル）または netCDF .nc または.cdf ファイルを開き（可能な値は ReadOnly または ReadWrite で、デフォ

ルトは ReadWrite）、ビューファイル view_file からビューを読み込みます。-access および-view 引数はオプシ

ョンです。 

 

view_file は.xview または.cfg ファイルパス、あるいは$FullScreenMap$または$TowPickWin$のようなテンプレー

トビュー指示子となります(注：Windows PowerShell では`$FullScreenMap`$のように“`” (バッククォート)

エ ス ケ ー プ キ ャ ラ ク タ ー を ビ ュ ー 指 示 子 の 前 に 入 れ る 必 要 が あ り 、 Linux や MacOS で は 

\$FullScreenMap\$ の様に\(バックスラッシュ)をエスケープキャラクターとして使用します。 ) もし

view_file が空もしくはファイルが存在しない場合は親コレクションの最後のビューファイルが読み込まれます。 
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ODV バイナリディレクトリが環境変数 PATH にない場合、例えば Windows の場合は"c:¥Program 

Files¥Ocean Data View¥bin_w64¥odv"、 MacOS の場合は"/Applications/Ocean Data View"のように

ODV 実行可能ファイルを絶対パス名で指定しなければなりません。 file は絶対パス名またはカレントディレ

クトリからの相対パスでなければなりません。view_file は絶対パス名または file を含むディレクトリからの相

対パスでなければなりません。 

 

Setting_file オプションで代わりの ODV アプリケーション設定ファイルを指定します。このオプションは内

容を理解できるユーザーのみ使用してください。 

 

上の二番目のコマンドラインは、ODV コマンドファイル cmd_file を開いてファイルに含まれるコマンドを実

行します。 オプション引数-q が指定されていれば、全てのコマンドが処理された後に ODV は自動的にシャ

ットダウンします。 cmd_file は絶対パス名または現在のディレクトリからの相対パスでなければなりません。 

 

一部のプラットフォームでは、ODV は初めての実行時に以下の Quick Installation 情報を要求します： 

1. bin ディレクトリを含むディレクトリの絶対パス名（ODVHOME 環境変数）。 

2. 一時ファイルを書き込むために ODV が実行時に使用する、ディスク上のディレクトリの絶対パス

名（ODVTEMP 環境変数）。このディレクトリに対する書き込み権限が必要であることに注意して

ください。システムの tmp ディレクトリを使用するか、ローカルディスクに特別なディレクトリ

（例えば/odvtmp）を作成してこの目的で使用することができます。 ネットワークドライブ上での

これらのディレクトリの使用は、おそらくパフォーマンスが低下するので推奨できません。 

3. コンピュータの名前。 

4. ユーザー名またはログイン名。 

[OK]を押して Quick Installation を終了します。 次に View > Settings（MacOS の場合：odv > Preferences）ダイ

アログを使用して ODV フォントと外部プログラムの設定をカスタマイズします。 

 

ODV が起動したら、File > Open オプションを使用してデータコレクション、netCDF ファイル、またはサポ

ートされている任意のインポートデータファイルを開きます。標準の「ファイルを開く」ダイアログが表示さ

れ、開きたいファイルの種類とファイル名を選択できます。サポートされているインポートデータファイルを

開くと、選択したファイルのディレクトリに新しいコレクションが自動的に作成され、ファイルからデータが

インポートされ、新しく作成されたデータコレクションが開きます。 

 

コレクションを開いた後、ODV はコレクションの最新のビュー設定を読み込むことに注意してください。 こ

れらのビュー設定には、測点およびサンプル選択フィルタが含まれているので、コレクション内の測点とデー

タ値のサブセットのみがマップウィンドウとデータウィンドウに表示されます。View > Station Filter を使用し

て、測点フィルタの設定を解除または変更します。 
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ビューバーの「+」(plus）ボタンを右クリックするか、View > Load Views を使用して、以前に保存した他のビ

ューファイルを読み込むことができます。ビューバーの layout ボタンをクリックするか、View > Window 

Layout を使用してウィンドウレイアウトを変更できます。ビューバーの「+」(plus)ボタンを左クリックする

か、View > Layout Templates  > ...を使用して、定義済みのレイアウトテンプレートのいずれかを読み込めま

す。View メニューオプション、あるいはキャンバス領域、マップ、またはデータウィンドウの一つの上で右ク

リックすると表示される context-specific ポップアップメニューを使用して、さまざまなビュー設定を対話形

式に変更できます。 

 

2.3 ヘルプの取得（Getting Help） 

F1 キーを押すか、Help > User’s Guide オプションを使用すると、ODV ユーザーズガイド（本書）が開きます。

ユーザーズガイドの pdf 版は ODV のウェブサイトから入手できます。多くの ODV ダイアログで help ボタン

を押すと、コンテキストセンシティブ・ヘルプが提供されます。これは View > Settings > Program Locations

（MacOS の場合：odv > Preferences > Program Locations）で指定された Web ブラウザが起動し、ブラウザは

ユーザーズガイドの特定の章にジャンプします。Windows では、コンテキストセンシティブ・ヘルプは Chrome

と Firefox で最も効果的です。 Internet Explorer を使用している場合は、アドレスフィールドをクリックして

Enter キーを押す必要があります。MacOS および一部の Linux システムでは、実行中の Web ブラウザを閉じ

て、ODV コンテキスト・ヘルプを表示する必要があります。 

 

2.4 アプリケーションウィンドウ（Application Window） 

ODV アプリケーションウィンドウは次の要素で構成されています（図 2-1 を参照）： 

Menu Bar: メニューバーからメインメニューにアクセスできます。 

Views Bar: ビューバーには、開いているビューごとにクリック可能なタブと、（1）さらにビューを開く

（「＋」(plus)ボタン）、（2）変更ビューを保存する（save ボタン）、（3）ビューを元に戻す/

やり直す（history ボタン）、（4）レイアウトモードの切り替え(layout ボタン)のセットがあり

ます。 

Canvas: グラフィックスキャンバスはマップ（常に表示されます）と無制限のデータウィンドウを含みます。 

キャンバス、マップ、およびデータウィンドウは、注釈テキスト、記号、またはユーザー定義図形

といった、無制限の数のグラフィックスオブジェクトを含みます。 

Status Bar: 別々の区画で（1）ステータス情報、（2）現在のマウス位置の座標または進行状況バー、（3）

現在選択されている測点数、コレクション内の測点の総数、および現在のビューの名前等を提供し

ます。 

Current Station Window: 現在の測点のメタデータ値（マップ上に赤い十字印で示されます）。 

Current Sample Window: 現在のサンプルのデータ値と品質フラグ（データウィンドウ上に赤い十字印で示さ

れます）。現在のサンプルフィルタ設定を満足するデータのみが示されます。 

Isosurface Data Window: 現在の測点の等値面の値。 
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図 2-1：ODV アプリケーションウィンドウの要素 

 

ビューバーは、それぞれのオープンビューにクリック出来るタブのみならず次のボタンのセットを備えていま

す：（1）複数のビューを開く（「＋」(plus)ボタン）、（2）ビューの変更を元に戻す（アンドゥボタン）、

（3）ビューの変更をやり直す（リドゥボタン）、（4）レイアウトモードから／への切り替え（レイアウトボ

タン）、（5）変更したビューの保存（セーブボタン）。 

 

マップまたは任意のデータウィンドウに示された測点またはデータを左クリックすると、それぞれの測点また

はサンプルが選択されます。ほとんどのウィンドウ要素を右クリックすると、要素固有のさまざまなオプショ

ンを持つコンテキストメニューが表示されます。データリスト項目の上にマウスを置くと、詳細なデータ情報

を含むポップアップウィンドウが表示されます。 

 

マップには現在の測点フィルタ設定を満たす測点が表示されます。それは pick station list を保持し section を

持ちます。データウィンドウは次のスコープのいずれかを持ちます：（1）STATION：選択した測点の X/Y デ

ータを表示し、選択した測点はデータウィンドウと同じマークでマップに示されます；（2）SCATTER：マッ

プに表示している全ての選択した測点の X/Y/Z データを表示します；（3）SECTION：断面帯内の全測点の

X/Y/Z データを示します；（4）SURFACE：マップに示された全ての選択した測点の等値面 X/Y/Z データを表

示します。現在のウィンドウレイアウトとパラメータ設定はまとめてビューと呼ばれます。ビューは後で使用

するためにファイルに保存できます。 

 

ODV ウィンドウ要素およびポップアップメニューのいくつかは以降で詳細を説明します。 
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2.5 メニューバー（Menu Bar） 

メインメニューには基本的な機能があります： 

File: コレクションを開くまたは作成；netCDF ファイルを開く； ODV でサポートされているデータファイル

を開く；バッチモードでの ODV コマンドの実行；現在の ODV グラフィックスキャンバスの gif,png, 

jpg, tiff または PostScript ファイルの生成； ODV の終了。 

Collection: コレクションのコピー、名前の変更、削除；データコレクションの並び替えおよび圧縮；現在の測

点または有効な測点のサブセットの削除；コレクション情報、目録、およびログファイルの閲覧。コ

レクションログファイルへのコメントの追加；主要変数の特定；良好なカバレッジ基準の定義；コレ

クションのプロパティと変数の表示または編集。 

View: 測点とサンプルフィルタの設定；派生変数の定義；等値面変数の定義；マップとデータウィンドウのレ

イアウト変更；変数ラベル、数値形式、リスト表示ウィンドウの表示順序の変更；直近のビュー変更

を元に戻す/やり直す; ビュー設定を読み込んで保存し、一般的な ODV 設定を定義します。 

Import: 現在のコレクションへのデータのインポート（サポートしているフォーマットには、さまざまなスプ

レッドシートフォーマット、Argo、MedAtlas、World Ocean Database、WOCE が含まれます）。 

Export: 現在選択されている測点データを ASCII ファイル、ODV コレクションまたは netCDF ファイルにエ

クスポート；ウィンドウの X, Y, Z データを ASCII ファイルにエクスポート；参照データセットとし

てウィンドウ X, Y, Z データをエクスポート；等値面値を ASCII ファイルにエクスポート。 

Tools: 地衡流の計算; 三次元推定; ボックス平均値の計算; 異常値と重複測点の特定；マクロエディタ; カラ

ーパレットエディタ（Windows のみ）。リストファイルの生成；海洋計算。 

Help: ODV ヘルプシステムの起動；ODV ウェブページの参照；バグレポートの送信; ODV のバージョンとイ

ンストールの詳細を表示。 

 

2.6 ビューバー（Views Bar） 

データコレクションを開くと ODV は最後に使用したビューを読み込んで表示します。このビューはメニュー

バーのすぐ下にあるビューバーのタブで表されます。 

 

 

図 2-2：三つのオープンビューのタブが付いたバーと、プラス（「＋」）、アンドゥ、リドゥ、レ

イアウト、および保存ボタンのビューバーの例。 

 

「＋」(plus)ボタンを右クリックすると現れる「ファイルを開く」ダイアログから一つ以上のビューファイル

を選んで既存のビューを追加できます。「＋」(plus)ボタンを左クリックして現れるリストからテンプレート

を選んで有効なテンプレートビューの中から一つを新しいビューとして選択できます。それぞれのタブをク
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リックしてビューを切り替えると、それが現在のビューになります。 タブ内の「×」ボタンをクリックする

と、開いているビューを閉じることができます。 最後の開いているビューを閉じると、データコレクション

が閉じられるので注意してください。 

 

Save ボタンを左クリックすると現在のビューが保存されます。save ボタンを右クリックすると現在のビュー

を新しい名前で保存することができます（名前を付けて保存）。赤色の save ボタンは現在のビューに保存さ

れていない変更があることを示しています。Undo または Redo ボタンをクリックして最後のビューの変更を

元に戻すかやり直してください。Undo または redo ボタンを右クリックすると、元に戻す/やり直す操作が可

能な直近の動作リストが表示されます。Layout ボタンをクリックするとレイアウトモードに切り替わり、作

成/削除やウィンドウサイズの変更ができます。 

 

2.7 メタデータとデータリスト・ウィンドウ（Metadata and Data List Windows） 

Current Station Window では（地図上に赤い十字印で示されている）現在の測点のメタデータ値が含まれ、

Current Sample Window には（データウィンドウ上に赤い十字印で示されている）現在のサンプルのデータ値

とそれに関連付けられた品質フラグが含まれ、Isosurface Data Window には現在の測点の等値面の値が含まれ

ています。データ値は、値の品質がすぐわかるように異なる色で表示されます。また Current Sample Window

にはまた、データエラーおよび／またはデータ情報が実データと共に提供されている場合、1-σ データエラ

ー（訳注：サンプル群が正規分布 N(μ, σ2) (ここでμは平均、σ２は分散)であるとき、そのサンプルがμ±1σ

を超えた場合）および／またはⓘ記号が表示されます。データ情報の値を見るにはⓘの上にマウスを置いて

ください。もし情報の値が URL もしくはコレクション内の情報ファイルへの参照（lf で始まる値）の場合、

（青色の）ⓘ記号を左クリックすると、Web ブラウザにそれぞれの文書が表示されます。スプレッドシート

ファイルにデータエラーとデータ情報の値を含める方法の詳細については汎用 ODV スプレッドシートフォー

マットの説明を参照してください。 

 

Current Sample Window リスト項目の一つにマウスを置くと、完全な変数ラベル、データ値、関連付けられた

データエラー（利用可能な場合）、品質フラグテキスト、データ情報値（利用可能な場合）を含むツールチ

ップメッセージが自動的に表示されます 。 

 

リストウィンドウの一つをマウスで右クリックすると、ウィンドウ固有のポップアップメニューが表示されま

す。Current Sample Window では、一列目の変数ラベル、二列目および三列目のデータ値と品質フラグ、また

はデータ情報が利用可能な場合はⓘ記号を含む四列目を右クリックすると、別々のメニューが表示されます。

これらのメニューでは、派生変数の定義、変数の表示順序の変更、変数のプロパティ（ラベルと数値形式）の

変更、またはデータ可用性情報の表示（一列目）、データ値、データエラーまたは品質フラグの編集（二列目
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または三列目） またはデータ情報値の編集（一列目）ができます。Sample .. / ..見出しを右クリックすると、

新しいサンプルの追加、現在のサンプルの削除、または別のサンプルを現在のサンプルとして選択できます。 

 

2.8 グラフィックスキャンバス（Graphics Canvas） 

キャンバスは ODV の描画エリアで、測点図と 0 個以上のデータウィンドウが含まれます。View > Settings > 

Canvas（MacOS の場合：odv > Preferences > Canvas）でキャンバスのサイズを調整できます。 

 

2.9 ポップアップメニュー（Popup Menus） 

キャンバス、マップ、データウィンドウ、グラフィックスオブジェクト、または任意のリストウィンドウ上で

マウスの右ボタンをクリック（MacOS システムでは Alt キーを押しながらマウスをクリック）すると、クリッ

クされた要素に固有のオプションを提供する別々のポップアップが呼び出されます。ほとんどの ODV 機能は、

これらのポップアップメニューから利用できます。 

 

 

図 2-3：キャンバスポップアップメニュ

ー 

キャンバスポップアップメニューには、次のオプショ

ンがあります： 

• 1: キャンバス全体とその全てのウィンドウの再描画。 

• 2: キャンバス全体とその全てのウィンドウを gif、png、

jpg、tiff または PostScript ファイルに保存。 

• 3: 全てのウィンドウの軸範囲をフルレンジに調整。 

• 4: 全てのデータウィンドウに対するサンプルフィルタの設

定。 

• 5: マップおよびデータウィンドウのプロパティの変更。 

• 6: キャンバスのグラフィックスオブジェクトの追加または管

理。 

• 7: マップおよびデータウィンドウのレイアウトの変更、ウィ

ンドウレイアウトのテンプレートの実装。 

• 8: 直近のビューの変更を元に戻す/やり直す。 

• 9: ビューをファイルに保存/ファイルから読み込み。 
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図2-4：マップポップアップメニュー 

マップポップアップメニューには、次のオプションがあり

ます： 

• 1: マップの再描画。 

• 2: マップをgif、png、jpg、tiff、またはPostScriptファイルに保

存。 

• 3: 断裂地図で再描画し保存。 

• 4: コレクションの全領域に設定。 

• 5: 全球地図に設定。 

• 6: 地図表示領域を手動でズームインまたはズームアウト。 

• 7: 自動ズームインまたはズームアウト。 

• 8: 現在有効な測点の領域をセット。 

• 9: 測点ID、受入番号、または名前による新しい現在の測点の選択。 

• 10: 地図の測点ピックリストの操作。 

• 11: セクションの定義およびそのプロパティの変更。 

• 12: マップの拡張メニューにアクセス。 

• 13: 地図上の測点に関する統計値の取得。 

• 14: 測点フィルタの設定変更。 

• 15: マップのプロパティ変更。 

 

 

図2-5：データウィンドウポップアップ

メニュー 

 

データウィンドウポップアップメニューには、次のオプシ

ョンがあります： 

• 1: データウィンドウの再描画。 

• 2: データウィンドウをgif, png, jpg, tiffまたはPostScriptファイル

に保存。 

• 3: データウィンドウを断裂地図として再描画および保存(マップ・デ

ータウィンドウのみ)。 

• 4: このウィンドウの軸範囲をフルスケールに調整。 

• 5: データウィンドウのX/Yドメインを手動でズームインまたはズー

ムアウト。 

• 6: ウィンドウのカラーバーを拡大してZ範囲を修正。 

• 7: 自動拡大または縮小。 

• 8: 軸範囲を手動で設定。 

• 9: このウィンドウを前面または背面に移動。 

• 10: X, Y, Z軸に新しい（訳注：別の）変数を選択。 

• 11: データウィンドウの拡張メニューにアクセス。 

• 12: ウィンドウ中のデータに関する統計値の取得。 

• 13: データウィンドウのサンプルフィルタの設定を変更。 

• 14: このデータウィンドウのプロパティ変更。 
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2.10 ステータスバー（Status Bar） 

ODV のステータスバーには、ヘルプ、ステータス、進行状況の情報が表示されます。 ステータスバーの一番

右の区画には、マップに現在表示されている測点の数、コレクション内の測点の総数、および現在のビューフ

ァイルの名前が表示されます。 この区画の上にマウスを置くと、現在のビューに関するより詳細な情報を含

むポップアップウィンドウが表示されます。 

 

測点フィルタ区画の S は測点選択フィルタが有効であり、コレクション内の使用可能な測点のサブセットの

みが現在のマップに表示されていることを示しています。測点フィルタが有効でない場合、測点フィルタ区

画は空です。測点フィルタの設定は View > Station Filter で解除または変更できます。 

 

サンプルフィルタ区画は、範囲および品質サンプルのフィルタがデータウィンドウの一つに対して（マウスを

特定のデータウィンドウ上に移動した場合）、または等値面変数値の計算に関して（マウスを等値面データウ

ィンドウ上に移動した場合）、有効かどうかを示します。サンプルフィルタ区画に表示される値は、 -| -，Q | 

-，-| R および Q|R です。Q および／または R が表示されている場合、品質および／または範囲フィルタがマウ

スのある項目で有効です。- | -はサンプルフィルタが有効でないことを示しています。（データウィンドウま

たは等値面ウィンドウの）項目を右クリックしてサンプルフィルタオプションを選択すると、サンプルフィル

タ設定を解除または変更できます。 

 

アクセス表示区画には現在のコレクションのアクセスモードが表示されます。RW は Read-Write アクセスを

示し、R は ReadOnly を示します。ReadOnly モードでコレクションを開くとメタデータとデータは編集できず、

追加データをインポートできないことに注意してください。全ての編集およびインポートオプションは無効に

なります。あるコレクションを ODV の第一インスタンスで開き、同じコレクションを第二インスタンスで開

くと、第二インスタンスは ReadOnly アクセスになります。さらに、第二インスタンスがコレクションの使用

を開始すると、第一インスタンスの ReadWrite アクセスモードは、第二インスタンスがシャットダウンするま

で ReadOnly に格下げされます。一時的に格下げされた ReadOnly アクセスは R-として示されます。 そのコレ

クションを使用する他の全ての ODV インスタンスが終了すると、第一インスタンスは自動的に ReadWrite ア

クセスに完全復帰します。 ここで記述したアクセス管理戦略は、ある ODV インスタンスが現在そのコレクシ

ョンを使用している唯一のインスタンスである場合のみ、コレクションに対する変更を保証するものです。 

 

アクセス管理は ODVCF6 および ODVCF5 .odv コレクションでのみ利用可能であることに注意してください。 

NetCDF ファイルはデフォルトでは ReadOnly モードで読み込まれます。 

 

2.11 現在の測点とサンプル（Current Station and Sample） 
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ODVは常に現在の測点を示しています。この測点は赤い十字印でマップに表示され、そのメタデータは Current 

Station Window に表示されます。新しい（別の）現在の測点を選択するには、マップ内の測点をマウスの左ボ

タンでクリックします。例えば、同じ海域での繰り返し観測など、同一地点に一つ以上の測点があると思われ

る場合には、SHIFT キーを押しながらその測点の位置をクリックすると、クリックした位置に実際に複数の測

点がある場合は、これらの測点のリストが表示されるので、リストから新しい現在の測点を選択できます。キ

ーボードのキーを使って新しい現在の測点を選択することもできます：右矢印キーで次の測点を選択でき（コ

レクション内の測点の順番に従います）、左矢印キーで前の測点を選択できます。 

 

マップポップアップメニューから Current Stationby Name を選択すると、特定のクルーズラベル、測点ラベル、

および測点のタイプに合致した測点を現在の測点にできます。 マップポップアップメニューから Current 

Stationby ID を選択して（またはマウスがマップ上にあるときに＃キーを押して）内部 ID 番号を入力すると新

しい現在の測点を選択できます（測点ラベルと混同しないでください）。 

 

現在の測点のサンプルの一つが現在のサンプルです。現在のサンプルはデータウィンドウに赤い十字印で表示

され、そのデータ値と品質フラグが Current Sample Window に表示されます。新しい現在のサンプル（および

場合によっては新しい現在の測点）を選択するには、データウィンドウの任意のデータポイント上でマウスを

左クリックします。下矢印キーで次のサンプルを（主要変数値の昇順で）選択し、上矢印キーで前のサンプル

を選択します。PgUp または PgDn キーを押すと、現在のサンプルが何ステップか前方または後方に移動しま

す。 Pos 1（訳注：日本語/US キーボードでは HOME キー）または End を押すと、測点の最初または最後のサ

ンプルに移動します。 

 

2.12 マップおよびデータウィンドウの描画（Map and Data Window Drawing） 

マップウィンドウとデータウィンドウは、プログラムの開始時に、またはビューが読み込まれたり、多数のレ

イアウトまたは表示プロパティのいずれかが変更されたりするたびに、自動的に描画または再描画されます。 

選択された測点のリストが空で、現在のセクションが定義されていない場合、STATION または SECTION スコ

ープのデータウィンドウは空のままです。 

 

選択リストに測点を追加するには、マップ内の特定の測点マークをダブルクリックするか、マークをクリック

して測点を現在の測点にしてから ENTER を押します。選択リストに追加する他の測点にもこの手順を繰り返

します。選択リストには無制限に測点を収容できます。選択リストから測点を削除するには、現在の測点にし

て（例えば STATION ウィンドウでデータ点の一つをクリックして）Delete ボタンを押します。選択リスト・エ

ントリのプロパティは、マップポップアップメニューの Manage Pick List > Edit Pick List オプションを使用し

て編集できます。 
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セクションを定義する、またはセクション・プロパティを変更するには、マップポップアップメニューの

Manage Section メニューのオプションを使用します。セクションが定義されるとセクションに沿った座標を派

生変数として使用できます。これはセクション座標の選択に応じて Section Longitude, Section Latitude または

Section Distance にすることができます。 セクションに沿った成分分布を作成する場合は、セクション座標を

プロットの X 軸に配置します。 

 

2.13 設定（Settings） 

オプション View > Settings（MacOS の場合は odv > Preferences ）を使用してグラフィックスやテキストフォン

ト、キャンバスのサイズ、ブラウザやテキストファイルの表示コマンドなど、一般的な ODV 設定をカスタマ

イズできます。 

 

キャンバスサイズ（Canvas Size:） 

ODV グラフィックスキャンバスの幅と高さ、例えばマップウィンドウとデータウィンドウが描画される白い

領域を調整します。 現在の画面に最適な設定を確立するには Fit to screen をクリックします。 キャンバスサ

イズを大幅に変更した際は Font タブで Graphics Font Size を調整する必要があるでしょう。 

 

フォント（Fonts:） 

フォントファミリーとさまざまなフォントプロパティを選択し、グローバルフォントスケールファクタの Size

を設定します。 グラフィックステキストと軸の注釈を大きくする場合は Size の値を大きくし、そうでない場

合は小さくします。 一部のフォントは ODV の PostScript 出力ではサポートされていない可能性があります。 

また、キャンバスサイズを大きく変更した後は Graphics Font Size の調整が必要になる場合があります（下記参

照）。 

テキストフォント Size エントリは、メニュー、ダイアログ、および現在の測点とサンプルリストウィンドウに

使用されるフォントサイズを決定します。 

 

ハイライト（Highlighting:） 

マップ内の現在の測点の位置と、データウィンドウ内の現在の測点の現在のサンプルとデータを強調表示する

ために使用する色を選択します。 

 

軸同期（Axis Synchronization:） 

異なるデータウィンドウ間の範囲同期をオンまたはオフにします。 範囲の同期がオンになっていて、一方の

ウィンドウで変数の軸範囲が変更されると、他方のウィンドウでもこの変数の範囲がそれに応じて変更されま

す。 範囲の同期がオフになっていると、他方のウィンドウは変更されません。 この設定はコレクションごと

に有効で、現在コレクションが開いていない場合はエントリが無効になります。 
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グリッド海底地形リソース（Gridded Bathymetry Resources:） 

%H オペランドを使用したマクロおよび数式と同様に DIVA ドメインの設定において、セクションの海底地形

として使用されるオプションの全球または地域グリッド海底地形リソースをインストールまたはアンインス

トールします。インターネット接続が必要です。 

 

マップリソース（Map Resources:）  

全世界または特定の地域用のオプションの高解像度の海岸線および等深線のリソースをインストールまたは

アンインストールします。 等深線リソースは ODV マップで使用されます。 インターネット接続が必要です。 

 

次のマップリソースのダウンロードおよびインストールによって利用可能になります：（1）2'x2'および 6'x6'

の解像度の Amanteand Eakins (2009)の ETOPO1 global relief data, (2)2'x2'および 6'x6'の解像度の

GEBCO_2014 global elevation data (version 2014-11-12, http://www.gebco.net/)、(3)30”x30”の解像度で

北緯 60 度以北における IBCAO V3 bathymetric data（http://www.ngdc.noaa.gov/mgg/） （ETOPO1（2009）

のリソースより取得）、(4)1’x1’, 2’x2’, 6’x6’の解像度で南緯 45 度以南における Timmermann et al. (2010)

の RTOPO gridded relief data, (5）バルト海、北海、地中海、およびケルゲレン諸島海域に関する地域シリ

ーズ。 

 

 
 

図 2-6：フラム海峡周辺のサンプル地図(左から(a)GlobHR、(b)ETOPO1_6min、(c)ETOPO1_2min) 

 

これらの追加リソースは、ODV 内からいつでも View > Settings > Map > Resources (MacOS では、odv > 

Preferences > Map > Resources）オプションを使用してインストール（またはアンインストール）出来ます。マ

ニュアルダウンロードとオプションパッケージのインストールは不要になりました。 

 

ETOPO1、GEBCO_2014、IBCAO、RTOPO のマップデータはタイル表示されます。これらのリソースは二つの方

法でインストールできます：(1)完全、または(2)オンデマンド（必要に応じてダウンロードする; download-on-

demand）パッケージです。 (1)の場合、Install ボタンを押すと完全パッケージのダウンロードと展開が始まり

ます。この作業には数分かかるでしょう。その後、全領域の地図データがシステム上で即座に利用可能になり、

http://www.gebco.net/
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地図の描画が直ちに実行されます。 (2)のインストールはすぐに終わります。 ただし測点図を描画するとき、

描画を開始する前に ODV は現在のマップに必要な全てのタイルデータをシステムにダウンロードします。 ダ

ウンロードされたタイルはあなたのシステムにキャッシュされるので、二回目以降はダウンロードされません。 

 

ディスク容量が制限されない場合は、完全な ETOPO1 または GEBCO_2014 の 6min および 2min パッケージの

インストールをお勧めします。 複数の ODV ユーザーが使用するシステムの管理者は、ダウンロードした地図

データを ODV ユーザーディレクトリ<ODV user directory>/coast/*_?min から ODV インストールディレクトリ

<ODV installation directory>/coast/*_?min に移動させるべきです。 そうすることでマップリソースはシステム

上の全ての ODV ユーザーが利用できるようになり、ユーザー毎に ODV ユーザーディレクトリへ複数インスト

ールされることを回避できます。 

パッケージ領域が関心のある地域をカバーしている場合は、地域パッケージをインストールしたほうがよいで

しょう。繰り返しますが、マルチ ODV ユーザー・システムの管理者はリソースを ODV ユーザーディレクトリ

から ODV インストールディレクトリに移動させるべきです。 

 

ETOPO1 および GEBCO_2014 2min パッケージは、既存の地域別オプションパッケージの多くを置き換え、同

等またはそれ以上の品質を提供します。 

 

特定の小さな領域に対してのみ高解像度マップが必要な場合は、ダウンロード時間とストレージ容量を減らす

ために、完全パッケージの代わりに ETOPO1 または GEBCO_2014_2min のオンデマンド（download-on-demand）

パッケージのインストールをお勧めします。 

 

インターネット接続はマップレイヤシリーズ・インストールのいずれかを実行するために必須です。自動また

は手動モードでマップリソースを使用する方法に関する情報は 9.1 章にあります。 

 

リソースプライオリティ（Resource Priorities） 

マップレイヤの Automatic selection が有効で、現在のマップ領域で複数のインストール済みマップリソースが

利用可能な場合、デフォルトでは中程度の描画コストで高い解像度を提供する特定のリソースが選択されます。

Resource Priorities ページでマップリソースの優先順位を指定し優先順位を明示できます。リストの一番上に

あるリソースは下のものよりも優先されます。 

 

スプレッドシートのインポート（ Spreadsheet Import） 
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測点間の位置（度単位での経度または緯度）と時間（時単位）の差の制限を指定します。これらの制限を超え

た場合、たとえ測点ラベルがあって両測点でそれが同じでも測点は常に分割されます。インポートファイルに

測点ラベルが指定されていない場合は、位置および／または日付時刻が異なれば常に測点は分割されます。 

 

SDN (SeaDataNet)のインポート（SDN Import） 

SeaDataNet データのインポートの際の出力親ディレクトリを指定します。 実際の SDN インポートは親ディレ

クトリのサブディレクトリ yyyy-mm-ddThh-mm-ss にあります（ここで yyyy-mm-ddThh-mm-ss はインポートが

行われたときの日付時刻を表します）。 

 

Sea-Bird CNV のインポート（Sea-Bird CNV Import） 

アップキャストとダウンキャストを別々の測点に分割するか、または圧力毎に値を平均化するかどうかを指定

します。 

 

WOD (World Ocean Database)のインポート（WOD Import） 

WOD 識別子と二文字の国コードのみで構成される WOD13_GR などの短い航海ラベルか、OCL 航海番号も含む

長い航海ラベル（例：WOD13_US014887）のどちらかを選択します。長い航海ラベルを選択すると大量のデー

タをインポートする際に非常に多数のクルーズが発生するのでお勧めしません。 

 

プログラムロケーション（Program Locations） 

Web ブラウザ（ODV ヘルプに必要）とテキストビューア（テキストファイルの表示に必要）の絶対パスを指

定します。 

 

MacOS、Linux、および UNIX プラットフォームでは、テキストビューアコマンドは 0 個以上の引数をスペー

スで区切って指定できます。 テキストビューアと引数のパスにスペースが含まれる場合は、スペースをバッ

クスラッシュ(\)でエスケープしてください。 

 

例：テキストビューアとして "/usr/local/My editor path"にインストールした emacs を使用する際に、すで

に開かれている emacs エディタを再利用するために emacs クライアントを呼び出す。 

 

/usr/local/ My\ editor\ path/emacsclient -a /usr/local/My\ editor\ path/emacs 

 

MacOS では Web ブラウザを指定することはできません。 ODV は代わりにシステムデフォルトブラウザを

呼び出します。 

 

サイドバーフォルダー（Sidebar Folders） 



Version 56.2 

 

26 

 

ODV の「ファイルを開く」ダイアログと「ファイルを保存する」ダイアログでは、ダイアログの左側のサイド

バーに一覧表示されているいくつかのディレクトリにすばやくアクセスできます。サイドバーリストの一部に

なるように、よく使用するディレクトリを二つまで指定できます（MacOS システムでは使用できません）。 

 

ユーザーディレクトリ（User Directory） 

ODV ユーザーディレクトリの絶対パスを指定します。ODV はこのディレクトリをカスタムデータコレクショ

ン、パレット、マクロ、およびコマンドファイル、地図および海底地形リソースのために使用します。 

 

ODV ユーザーディレクトリを変更するには Change User Directory ボタンを押して新しい ODV ユーザーディレ

クトリの親ディレクトリを選択します。最高のパフォーマンスを得るには高速のローカルディスク上のディレ

クトリを選択し、ネットワークおよび USB ドライブは避けてください。 

 

注：このオプションはコレクションが開いていないときにのみ使用可能です。他の ODV インスタンスが実行

されていないことを確認してください。以前のユーザーディレクトリの内容は、手動で新しい場所に移動する

必要があります。その後 ODV を終了して再起動します。 

 

ウェブリンク（Web Links） 

ODV Web サイトの URL、ODV Web サイトからファイルをダウンロードするためのルート URL、および

NERC vocabulary server のルート URL を指定します。 

 

DIVA（DIVA） 

新しいデータウィンドウに最初に適用される DIVA 設定を指定します。ユーザーは Properties > DIVA Settings 

ページから何時でもデータウィンドウの DIVA 設定を個々にカスタマイズできます。 

 

Threads ページでは DIVA 実行時の並列スレッドの最大数を指定できます。いくつかの並行スレッドを使うと

読み込みと複数のデータウィンドウ表示が著しく高速化されます。もしあなたのシステムに 4 論理 CPU コア

と 8GB 以上の RAM が搭載されていれば、4 並列スレッドを、8 以上の論理 CPU コアと 16GB 以上の RAM

が搭載されていれば 8 並列スレッドを試してみてください。もし一つ以上のデータウィンドウが空のままな

ら最小スレッド数に戻してください。 
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3 ODVコレクション（ODV Collections） 

ODV は非常に大きなデータセットを効率的に処理できる特別なデータ保存形式を使用しています。 このフォ

ーマットは不等間隔の可変長データ用に最適化されており、高密度の記憶域と高速データアクセスを提供しま

す。ある意味で ODV データストレージモデルは、格子データ用に最適化された netCDF データフォーマット

を補完するものです。 

 

ODV コレクションフォーマットは、プロファイル、航跡、時系列など、広範囲な環境データをサポートして

います。 当初 ODV の開発は海洋データに焦点を合わせていましたが、コレクションフォーマットの一般的な

設計により、大気、堆積物、氷床など他のさまざまな分野のデータも同様に扱うことができます。 通常 ODV

によって処理される観測データは空間的にも時間的にも不規則に分布しています。 さらに ODV は格子デー

タと数値モデル出力も維持できます。 

 

ODV は、以前のバージョンの ODV で使用されていた以前の形式の ODVCF5 および ODVGENERIC よりも強力

な新しいコレクションデータ形式（ODVCF6）をサポートし、以前の形式の多くの制限を克服しています。現

在、事実上無制限のメタデータとデータ変数のセット、およびコレクション内の事実上無制限の数の測点とサ

ンプルがサポートされています。ODVCF6 はメタデータとデータ変数のデータ品質フラグをサポートしており、

ユーザーは 16 の一般的な海洋学的スキームのセットからカスタム品質フラグスキームを選択できます。メタ

データおよびデータ変数は、数値（値ごとに 1 から 8 バイト）、あるいはユーザー指定の固定最大長（TEXT

型）または任意の長さ（INDEXED_TEXT）のテキストを含むこともできます。 

 

ODV は下位互換性があり、ODVCF5 および ODVGENERIC コレクション、および以前のバージョンの ODV で作

成されたビューまたは構成ファイルを完全にサポートしています。 新しいコレクションを作成するとき、ODV

は常に ODVCF6 フォーマットを使用して、全ての新機能を提供し、メタデータとデータ変数のより柔軟な定義

を可能にします。 

 

特に ODVCF6 は以下の機能を提供します： 

1. コレクション内の全ての測点に対して固有で変更不可能な識別子を提供する新しい Accession 

Number メタデータ変数。測点の Accession Number は測点がコレクションに追加されたときに（通常

はインポート中に）割り当てられ、Sort および Condense 操作中は保持されます。これは、コレクシ

ョン内のステーションの順序が変わると連携して変更される Station IDs とは対照的です。 

2. メタデータおよびデータ変数の新しい型：SIGNED_BYTE、UNSIGNED_SHORT、UNSIGNED_INTEGER、

INDEXED_TEXT（下記の表を参照）。 INDEXED_TEXT は任意の長さの UNICODE 文字列をサポート

しています。 何度も発生する文字列（クルーズラベルなど）は非常に効率的に処理されます。 
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3. 測点ごとの履歴記録。全てのインポートおよびデータ編集操作は所定の測点の履歴に記憶されます。 

履歴情報はデータをコレクションまたは ODV スプレッドシートファイルにエクスポートするときに

維持されます。 

4. 全てのデータ変数は、実データ値と品質フラグに加えてデータエラー値とデータ情報文字列を保持

できるようになりました。データエラーと情報文字列は STANDARD_DEV 列と INFOS 列を使用してス

プレッドシートファイルに提供されます。 

5. 適切な ReadWrite または ReadOnly アクセス管理。コレクションへの ReadWrite アクセスは、現在そ

のコレクションを処理している唯一のアプリケーションである場合にのみ許可されます。同じコレ

クションを開く二番目のアプリケーションは ReadOnly アクセスのみになります。コレクションが複

数のアプリケーションで開かれると、最初のアプリケーションのアクセス権は動的に ReadOnly にな

ります。コレクションを使用している他の全てのアプリケーションが終了すると、元の ReadWrite ア

クセスは動的に復元されます。 

6. コレクションのパスワード保護。不正使用を防止するために ODVCF6 コレクションをパスワードで保

護できるようになりました。 

 

3.1 データモデル（Data Model） 

ODV はプロファイル（海洋、大気、湖沼、海洋および湖成堆積物、氷床など）、航跡（航走データ）、海洋、

流氷、陸上の漂流点や固定点での時系列など、非常に広範囲のデータタイプを処理できます。 

 

ODV によって維持されている基本的なデータ実体は station で、所定の地理的位置および日付/時刻で得られ

たデータの二次元の表で示されます。ODV は、ODV データコレクション内の潜在的に非常に多数の測点デー

タを照合します。通常ユーザーはデータコレクションを開き、このコレクション内の測点データを操作します。 

コレクションは拡張可能であり、新しい測点データは逐次追加できます。測点は、航海や測点の名前、時空間

座標など、さまざまなメタデータ変数によって記述されます。下記の必須メタデータ変数のセットに加えて、

ODV コレクションは無制限の数の他のメタ変数を持つことができます。メタ変数には数値またはテキストを

含みます。 

 

メタデータに加えて、各測点には一行以上かつ二列以上で構成される二次元データ表も含まれています（表 3-

2）。各行は所定のサンプルのデータを保持し、各列はコレクションに格納されているデータ変数の一つを表

します。データ変数の数と型はユーザー定義であり、コレクションごとに異なります。データ変数の一つであ

る primary variable は特殊で、測点のサンプルの順序変数として機能します。 必ずというわけではありませ

んが、通常これが最初のデータ変数です。メタデータとデータ変数のセットはコレクションの作成時に定義さ

れますが、後からいつでも変更できます。 
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どの測点についても、ODV は全てのメタ変数、さらに全てのデータ変数と全てのサンプルのデータ値を保持

します。さらに ODV は個々のメタデータとデータ値に関連する quality flag values も保持します。一つの測

点（station quality flag）と個々のサンプル（sample quality flags）の総合的な品質を記述する追加の品質

フラグがあります。品質フラグの値はデータに対する信頼度を反映しており、データセットの中で非常に有益

な部分です。 

 

ODV は海洋学界で広く使用されている 15 の品質フラグスキームをサポートしており、また海洋学や他の種

類の環境データに適用できる独自のシンプルで一般的な品質フラグスキームも定義しています。ODV はデー

タのフィルタリングにデータ品質フラグの値を活用しています。データ変数のデータ品質フラグ値は品質フラ

グ派生変数を用いて作図や他の目的にも使用されます。 

 

個々のメタデータおよびデータ変数は、異なる品質フラグスキームを使用しています。サンプルデータ値のみ

ならずメタデータ（経度と緯度を除く）が欠落している可能性があります。 

 

3.1.1 メタ変数（Meta-Variables） 

ODV は、航海名と測点名、および与えられた測点の地理的位置と日時に関する情報を含む必須のメタ変数の

セットを定義しています（表 3-1 参照）。全ての ODV コレクションには必須のメタ変数が含まれていて、コ

レクションに格納されている測点を記述するために、全ての値を指定することが望まれます。観測の日付と時

刻または測点名とそれが属する航海（または探査）名は測点を完全に識別し、強力な測点選択フィルタを適用

させるために必要です。それらがデータセットに与えられていない場合は、経度と緯度を除く全てのメタデー

タが空になります。 経度と緯度は常に与えられなければならず、この情報がない測点は ODV コレクションに

読み込まれません。 

 

必須のメタ変数に加えて、ODV コレクションは数値型またはテキスト型の追加のメタ変数を無制限に持つこ

とができます。必須メタ変数の型は変更できませんが、バイトサイズは変更できます。一例として、ユーザー

が経度および緯度のメタ変数型を８バイトの倍精度(実数)に設定すると数センチメートル以下の高解像度な

位置情報を設定できます。 [0 から 255]または[-32,768 から 32,767]の範囲内のメタ変数は、必要なディス

ク記憶領域を減らすためにそれぞれ 1 または 2 バイトの整数として表すことができます。 

 

表 3-1：必須およびオプションの ODV メタ変数。 

メタ変数 推奨ラベル 

 
必須 

航海ラベル(テキスト) Cruise  

測点ラベル(テキスト) Station 
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測点タイプ(テキスト) Type  

観測日付・時刻(年、月、日、時、分、秒の数値) yyyy-mm-ddThh:mm:ss.sss 

経度(数値; 東経(度)) Longitude [degrees_east] 

緯度(数値; 北緯(度)) Latitude [degrees_north] 

 

オプション 

SeaDataNet測点識別子(テキスト) LOCAL_CDI_ID 

SeaDataNet機関識別子(数値) EDMO_code 

測点の水深または測器深度(数値) Bot. Depth [m] 

...  

ユーザー定義のメタ変数(テキストまたは数値)の追加  

 

3.1.2 データ変数（Data Variables） 

ODV データコレクションは、一般的にデータファイルの全ての測定パラメータ（例えば圧力、水温、塩分、

等）に対して一つのデータ変数を含みます。データ変数の総数とそれらの名前、単位、および値のプロパティ

はユーザー定義であり、データコレクションごとに異なります。メタ変数と同様に、データ変数は数値または

テキスト値を持つことができます。データ変数の一つ（Primary variable (主要変数)）は特別で、サンプルを主

要変数値の昇順に並び替えるために使用されます。デフォルトでは最初のデータ変数が主要変数として機能し

ますが、この目的のために他の変数を選択できます。主要変数はコレクションが作成されるときに定義されま

す。 

 

3.2 コレクションタイプの例（Example Collection Types）  

上記の ODV データモデルは柔軟性があり、下記の例を含む広範囲の異なるデータタイプをサポートします。 

 

3.2.1 プロファイルデータ（Profile Data）  

このカテゴリは、例えば固定位置、あるいは係留系または漂流機器による操縦されたもしくは受動的な（海流

に乗った）航跡に沿った、または船舶から得られた海洋プロファイルを含む広範囲の観測を取り扱います。こ

れら全ての場合において表 3-2 のメタデータとデータ変数の割り当てを使用し、それぞれ個々のプロファイ

ルは個別の測点として扱う必要があります。大気、氷床または堆積物中のプロファイルデータも同様に取り扱

うことができ、唯一の違いは主要変数の選択（例えば大気中の高度、あるいは氷または堆積物コアの深さ）で

す。 

 

表 3-2：プロファイルデータの推奨メタデータおよびデータ変数。 

メタ変数 値 

Cruise 航海名、探査名、測器名(テキスト) 

Station 固有な測点識別子(テキスト) 
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Type Bはボトル採水機、CはCTD、XBT、または250サンプルを超える測点 

yyyy-mm-ddThh:mm:ss.sss 測点（測器の深度）の日付と時刻 

Longitude [degrees_east] 測点（測器の深度）の縦度（東経（度）） 

Latitude [degrees_north] 測点（測器の深度）の緯度（北緯（度）） 

  

Bot. Depth[m] 測点の水深 

無制限の他のメタ変数 （テキストまたは数値） 

データ変数 注釈 

水柱、氷コア、堆積物コア、ま

たは土壌の深度または圧力；大

気中の標高または高度；等 

主要変数として使用 

無制限の他の測定変数または計

算変数 

(テキストまたは数値) 

 

3.2.2 時系列データ (Time Series Data)  

このカテゴリは、時間とともに繰り返される特定の（固定）位置での観測を取り扱います。例としては、係留

された海洋センサー上の海流と海象パラメータの測定、沿岸観測所での海面高度測定、陸上観測所での気象観

測があります。これら全ての場合において、与えられた測器または測点の時系列全体は、十進数の時間変数を

主要変数として使用し、表 3-3 の他のメタデータとデータ変数の割り当てを使用し、個別の測点として扱う必

要があります。 

 

表 3-3：時系列データの推奨メタデータとデータ変数。 

メタ変数 値 

Cruise 航海名、探査名、測器名(テキスト) 

Station 固有な測点識別子(テキスト) 

Type Bはボトル採水機、CはCTD、XBT、または250サンプルを超える測点 

yyyy-mm-ddThh:mm:ss.sss 測器を配置した日付と時刻 

Longitude [degrees_east] 測器を配置した経度（東経（度）） 

Latitude [degrees_north] 測器を配置した緯度（北緯（度）） 

  

Bot. Depth [m] 測点の水深 

測器とその配置した深度を記述
する、無制限の他のメタ変数 （テキストまたは数字） 

データ変数 注釈 
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連続十進時間変数 

または 

列名がtime_IOS8601である、単

一列のISO8601日付形式2003-

02-17T13:57:12.3 

主要変数として使用 

 

無制限の他の測定変数または計
算変数 

(テキストまたは数値) 

 

3.2.3 軌跡データ（Trajectory Data） 

このカテゴリは、時間とともに繰り返される移動プラットフォーム（例えば、船舶、ドリフター、フロート、

グライダー、飛行機など）で行われる観測を取り扱います。例としては観測航海中、および能動的に移動また

は受動的に漂流するラグランジュ型測器から得られる所定の水深における海象パラメータの航走時観測です。

これら全ての場合において、所定の場所と時間で行われた個々の測定は、測定の深度または標高を主要変数と

して、表 3-4 の他のメタデータとデータ変数の割り当てを使用し、個々の測点として扱う必要があります。こ

の形式の軌跡データには、測点ごとに必ず一つのサンプルがあります。測点数は軌跡に沿った観測数に等しく、

通常は多くなります。 

 

表 3-4：軌跡データの推奨メタデータおよびデータ変数。 

メタ変数 値 

Cruise 航跡名、探査名、測器名(テキスト) 

Station 固有な測点識別子(テキスト) 

Type B 

yyyy-mm-ddThh:mm:ss.sss 測定日付・時刻 

Longitude [degrees_east] 測定の経度（東経（度）） 

Latitude [degrees_north] 測定の緯度（北緯（度）） 

  

Bot. Depth [m] 測点の水深または標高 

無制限の個々の測定を記述する他のメタ変数 （テキストまたは数字） 

  

データ変数 注釈 

連続十進時間変数 主要変数として使用 

無制限の他の測定変数または計算変数 （テキストまたは数字） 

 

3.3 コレクションの作成（Creating Collections） 

新しいODVコレクションは、さまざまな方法で作成できます：（1）File > Newオプションを使用する、（2）



ODV User’s Guide 

 

33 

 

File > Openでスプレッドシートデータファイルを開く、（3）ODVアイコンに（Windowsのみ）またはコレク

ションが開かれていない場合はODVアプリケーションウィンドウにスプレッドシートデータファイルをドロ

ップするか、Importメインメニューオプションのいずれかを使用して開きます。 

 

File > Newオプションを使用すると「ファイルを開く」ダイアログが表示されるので、コレクションの名前とコ

レクションを作成するディレクトリを指定します。 次の「」内の文字はコレクション名には使用できません：

「\ /：*？ “ <> | スペース」（訳注：日本語環境では「\」も使用できません）。 

 

ODV ではコレクションに格納されるメタデータとデータ変数をユーザーが定義します。どちらの種類の変数

もいくつかの方法で指定できます。サポートされているテンプレートファイル（<.txt>、<.odv>、<.var>、また

は任意の拡張子を持つ ASCII スプレッドシートファイル）から取得した変数名を使用するか、手動で変数ラ

ベルを入力するか、または公開されている様々な海洋データセット（図 3-1 参照）に適した（標準およびユー

ザー提供テンプレートの）変数の既定値を使用できます。標準テンプレートのリストには Argo のプロファイ

ルおよび軌跡データ、NOAA NCEI (米国大気海洋庁国立環境情報センター)によって公開されている World 

Ocean Database、World Ocean Circulation Experiment（WOCE; 世界海洋循環実験計画）のさまざまな

データタイプ、および Medatlas プロジェクトが含まれています。 

図 3-1：Collection tempelate selection ダイアログ 

 

既定標準テンプレートに加えて、ユーザーはカスタムコレクションテンプレートを準備し、それらのテンプレ

ートを ODV ユーザーディレクトリの templates/collections サブディレクトリに保存することができます。 ユ

ーザーによるコレクションテンプレートファイルの拡張子は<.odv>であり、.odv コレクションファイルの形式

に従います。 
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3.3.1 テンプレートとしてファイルを使用（Using a File as Template） 

もし.txt、.odv、.varあるいは他のファイルをテンプレートとして使用する場合（図3-1の最初のオプショ

ン）、テンプレートファイルを選択するために「ファイルを開く」ダイアログが表示されます。それから

ODVはMetadata and Data Variablesダイアログ（図3-2）が表示されるので、メタデータとデータ変数を変更し

ます。 

 

最初の 11 個のメタ変数（Accession Number まで、およびそれを含む）は必須である事に注意して下さい。

Accession Number を除き、必須のメタ変数のプロパティを変更することはできますが（変数を選択して Edit を

押す）、削除したり並べ替えたりすることはできません。他のメタ変数は並べ替えたり、削除したり、あるい

はそれらのプロパティを編集したりすることができます。まだ使用されていないスプレッドシートの列ラベル

をメタ変数として追加するには Spreadsheet Column Labels リストからこのラベルを選択して Meta Variables >> 

ボタンを押してください。追加されたメタ変数を追加するには New をクリックして新しいメタ変数のプロパ

ティを定義します（以下の Properties ダイアログを参照）。メタ変数の総数は無制限です。 

 

図 3-2：Metadata and Data Variables ダイアログ 

 

メタ変数のプロパティを検査または変更するには、変数を選択して Edit を押します。 Properties ダイアロ

グ（図 3-3）が表示されるので、変数のラベルと単位、現在の測点ウィンドウに値を表示するために使用され

る有効桁数（数値の場合）、この変数に使用される品質フラグスキーム、データ型とバイト長（テキストの場

合）を指定します。 
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メタ変数のラベルまたは単位を入力するときには書式制御シーケンスを使用して、下付き文字、上付き文字、

および特殊記号を作成できます。ラベルと単位に「;」または「TAB」を含めることはできません。 測点位置に

約 100m 以下の精度が必要な場合は、経度および緯度メタ変数のデータ型が DOUBLE であることを確認して

ください。また、経度、緯度、または時間に関わるメタ変数のデータ型に TEXT を使用しないでください。 サ

ポートされている品質フラグスキームとスキーム間のマッピング（対応表）の説明については、

ODV_QualityFlagSets.pdf を参照してください。 

 

 

図 3-3：メタデータおよびデータ変数のプロパティダイアログ 

 

メタ変数のセットが定義されたら、引き続き変数の追加、削除、並べ替え、またはそれらのプロパティの変更

によるデータ変数を定義します。変数にラベルや単位を入力するときは、書式制御シーケンスを使用して下付

き文字、上付き文字、特殊記号を作成できます。ラベルと単位には「;」または「TAB」を含めることはできま

せん。サポートされている品質フラグスキームとスキーム間のマッピング（対応表）の説明については、

ODV_QualityFlagSets.pdf を参照してください。 

 

表 3-5：メタデータおよびデータ変数の ODV データ型 

名前 バイ

ト数 

数値範囲 注釈 

BYTE 1 0～255  

SIGNED_BYTE 1 – 128~127  

SHORT 

 

2 – 32,768 ~32,767  

UNSIGNED_SHORT 2 0～65,535  

INTEGER 
4 -2,147,483,648～2,147,483,647  

UNSIGNED_INTEGER 4 0～4,294,967,295  

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
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表 3-5 に ODV メタデータとデータ変数に使用できる値型の種類をまとめています。数値変数のデフォルトの

型は FLOAT で、ほとんどの場合に十分な精度があります。例えば、非常に正確な経度/緯度を記述するために

7 桁以上が必要な場合は DOUBLE 型を使用してください。 限られた範囲の整数を持つ変数の場合は、コレク

ションの格納サイズを減らすために 1 または 2 バイト型のいずれかを使用することを考慮してください。 

 

テキストを格納するための二つの値型：TEXT と INDEXED_TEXT があります。 

 

次の場合は TEXT を使用してください（最大テキストバイト長を指定; テキスト終端文字に 1 バイトを追加し

ます）： 

⚫ 全てのテキスト値は同じ長さ、 

⚫ 最大テキスト長は 10 未満、 

⚫ ほとんどのテキスト値は異なる、 

⚫ テキストには ASCII 文字またはローカル文字セットの拡張部のみが含まれ、コレクションは国際配

布用ではない。 

 

次の場合は INDEXED_TEXT を使用してください： 

⚫ テキスト値は高度な可変長、 

⚫ 同じテキスト値が繰り返し使用されている、 

⚫ テキストに ASCII 以外の文字が含まれている。 

 

デフォルトでは、ODV はクルーズラベル（通常は多くの測点で同じクルーズラベルが使用されています）と、

Web サイトまたは Web ドキュメントへのリンクを含む全てのメタデータ変数に INDEXED_TEXT を使用し

ます。 

 

3.3.2 マニュアル入力（Manual Entry） 

FLOAT 
4 3.4E+/-38(7桁) デフォルトの数値型 

DOUBLE 
8 1.7E+/-308(15桁)  

TEXT  ASCII+ローカル文字セット ユーザー指定の文字長；文字列終端文

字に1バイトを追加 

INDEXED_TEXT  任意の長さのUTF-8文字符号化形式

の文字列 

メタデータファイルに格納された4バイ

トの文字列インデックス；実際の文字

列はstringpoolファイルに保持される。 
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変数の手動入力（図 3-1 の二行目のオプション）を選択した場合は、上記のセクション 3.3.1 で説明したも

のと同様の方法でメタ変数とデータ変数を変更する Meta Variables と Data Bariables の両ダイアログ（図 3-

4）が表示されます。 

 

3.3.3 既定テンプレートの使用（Using a Pre-defined Template） 

 標準またはユーザー提供のコレクションテンプレートのいずれかを選択した場合、ODV はそのテンプレー

トからメタデータとデータ変数のリストを読み込みます。ユーザーによる変数のプロパティの変更はサポー

トされていません。標準の変数テンプレートを適合させたい場合はカスタムテンプレートを作成し、そのテ

ンプレートを ODV ユーザーディレクトリの templates/collections サブディレクトリに配置する必要がありま

す。ユーザーによるコレクションテンプレートファイルの拡張子は.odv で、.odv コレクションファイルの形

式に従います。 

 

新しいコレクションの定義の最終段階として、ODV は Collection Properties ダイアログ（図 3-5）を表示しま

す。このダイアログで、コレクションに保存するデータのフィールドと種類を指定できます。データの並び替

えに使用される主要変数も選択できます。 

 

     

 図 3-4：メタデータおよびデータ変数の定義に関するダイアログ 

 

ODV はコレクションを作成し、キャンバスに全球地図を描画します。 この段階では、そのコレクションはま

だ空っぽで、測点データは一つも含まれていない事に注意して下さい。メニューバーにある Import メニュー

のオプションを使用して、データをそのコレクションにインポートしなければなりません。コレクションの作

成中に表示される全てのダイアログには意味のある初期設定が含まれている事に注意して下さい。特別な要求

がなければ、これら全てのダイアログで OK をクリックするだけで、完全に有効なコレクションが生成されま

す。 
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図 3-5：コレクションプロパティの定義ダイアログ 

 

3.4 コレクションファイル（Collection Files） 

このセクションでは、ディレクトリ構造と、それぞれ ODVCF6、ODVCF5、または ODVGENERIC コレクションを

構成するさまざまなファイルの概要を説明します。この情報は熟練したユーザーに向けて提供されており、問

題が発生した場合や予期しない問題が発生した場合に役立つことがあります。 通常ユーザーはコレクション

ファイルの構造を気にする必要はありません。 

 

3.4.1 ODVCF6 and ODVCF5 

メタデータとデータ変数に関する情報は、ファイル<col>.odv に保存されています。これはコレクション

<col>の定義ファイルで、コレクションを開くときにはこのファイルを選択する必要があります。Windows

では.odv ファイルタイプは ODV 実行ファイルに関連付けられています。例えば.odv ファイルをダブルクリッ

クすると ODV が起動してコレクションを開きます。.odv ファイルを含むディレクトリは、コレクションのル

ートディレクトリです。 コレクションの他の全てのファイルは<col>.Data という名前のコレクションのルー

トディレクトリのサブディレクトリ（コレクションのベースディレクトリ）に格納されています。 

 

コレクションのベースディレクトリには、コレクションのメタデータとデータファイル、およびビュー、セク

ション、またはグラフィックスオブジェクトファイル用の多数のサブディレクトリが含まれています。サブデ

ィレクトリ views には、ユーザーがコレクション内のデータを表示する方法を定義するビューファイルが格納

されています。ビューファイルは、マップ領域、測点およびサンプルフィルタ設定、ウィンドウレイアウト、

その他多くのパラメータの設定を定義しています。 

 

ODVCF6 または ODVCF5 コレクションをコピー、移動、または名前変更するには Collection > Copy または

Collection > Move/Rename オプションを使用します。コレクションを手動でコピーまたは移動する場合は.odv

ファイルと<col>.Data ディレクトリと全てのサブディレクトリをコピーまたは移動してください。ODV コレ

クションファイルは手動で編集しないでください。 
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表 3-6：ODVCF6 または ODVCF5 コレクションファイルの概要。コレクション名<col>に”/”または”\(訳

注：日本語キーボードでは\)”は含まず、スペースは含めないでください。 

ファイル フォーマット 注釈 

   

Collection file (コレクションファイル) 

<col>.odv ASCII 
メタデータとデータ変数、コレクションのフィールドとタイプを定義しま
す。 Windowsでは、このファイルタイプはODV実行可能ファイルに関
連付けられています。 .odvファイルをダブルクリックすると、ODVが起
動してコレクションを開きます。 

   

サブディレクトリ<col>.Data 

metadata binary 測点のメタデータ(名前、位置、日付など)を格納する。 

data binary 測点データと品質フラグを格納する。 

   

info ASCII コレクションの説明(自由書式TEXT形式;ファイルはオプション)。 

inventory binary コレクションの航海毎の目録リスト。 

logfile ASCII コレクションのログファイル。データ変更の記録を保存する。 

settings ASCII キー変数の識別子、最後に使用したビューファイルの名前、または直近の

読み込みおよび出力ディレクトリなどの設定が含まれる。 

stringpool binary INDEXED_TEXT文字列および関連するインデックスを含む。 

history binary History string indexesを含む。 

historypool binary History stringsを含む。 

stringpool, history および historypool ファイルは ODVCF6 コレクションにのみ存在します。 

 

表 3-7：ODVCF6 または ODVCF5 のビューおよびセクションファイルの概要。ファイル名<name>は任

意。xview および sec ファイルのデフォルトの場所はディレクトリ<col>.Data/views ですが、これらのフ

ァイルは他の任意のディレクトリに格納することもできます。 

 

3.4.2 ODVGENERIC 

ODVGENERIC コレクション形式は ODV3 以前のソフトウェアで導入されたもので、下位互換性のために引き

続きサポートされています。ODV によって作成された新しいコレクションは全て ODVCF6 コレクションです。 

 

拡張子 フォーマット 注釈 

<name>.xview ASCII 
レイアウト、値の範囲、派生変数と等値面変数の選択、およびその他多
くの設定を格納しているビューファイル。 親コレクションの名前は、
xviewファイル内に記録されています。 他のコレクションがxviewフ
ァイルを使用すると、派生変数の設定は失われます。 

<name>.sec ASCII セクションの輪郭と特性を格納します。 
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データ変数のリスト、測点メタデータ、および実際の測点データは.var、.hob および.dob ファイルに分けて保

存されます。cfg ファイルにはユーザーがコレクション内のデータを表示する方法を定義するビュー設定が格

納されています。ビュー設定にはマップ領域、測点フィルタ設定、ウィンドウレイアウト、その他多くのパラ

メータなどの項目が含まれています。コレクションに必要な.var、.hob および.dob ファイルは全て同じディレ

クトリに配置する必要があります（コレクションディレクトリ）。cfg ファイルはディスクのどこにでも保存

できます。 

 

ODV コレクションファイルは手動で編集しないでください。 

 

表 3-8：ODVGENERIC コレクションファイルの概要。コレクション名<col>に“/”または“\(日本語キーボード

では\)”は含まれず、スペースを含んではいけません。全てのファイルは同じディレクトリ(コレクションデ

ィレクトリ)にある必要があります。 

 

表 3-9：ODVGENERIC ビューおよびセクションファイルの概要。ファイル名<name>は任意で、cfg および sec

ファイルは任意のディレクトリに配置することができる。 

ファイル フォーマット 注釈 

   

基本ファイル  必須 

<col>.var ASCII データ変数を定義し、コレクション名と測点数を格納します。Windowsで
は、このファイルタイプは自動的にODV実行ファイルに関連付けられ、例え
ば.varファイルをダブルクリックするとODVが開始し、それぞれのコレクシ
ョンを開きます。 

<col>.hob binary 測点のメタデータ(名前、位置、日付など)を格納します。 

<col>.dob binary 実際の測点データと品質フラグを格納します。 

   

情報ファイル  オプション 

<col>.info ASCII 
コレクションの説明(自由書式TEXT形式)。netCDFファイルを開くときに、
自動的にODVは、次元と変数に関する情報を含む.infoを作成します。 

  
 

補助ファイル  存在しない場合は自動作成 

<col>.inv ASCII コレクションの航海別目録リスト。 

<col>.cid binary 航海ID番号 

<col>.log ASCII コレクションのログファイル。データ変更の記録を保存する。 

<col>.idv ASCII 派生変数の入力に使用されるキー変数(深度、水温、酸素など)のID一覧 

<col>.cfl ASCII 最後に使用した定義ファイルおよび出力ディレクトリの名前を含む。 

拡張子 フォーマット 注釈 
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3.5 プラットフォーム非依存（Platform Independence）  

全ての ODV データコレクションとビューファイルはプラットフォームに依存せず、サポートされている全て

のシステム（Windows、MacOS、Linux、および UNIX）で変更なしに使用できます。 

  

<name>.cfg binary 
レイアウト、値の範囲、派生変数および等値面変数の選択、および他の多く
の設定を格納する定義ファイル。定義を所有するコレクションの名前はcfgフ
ァイル内に記録されています。別のコレクションがcfgファイルを使用する場
合は一定の制限が適用されます。 

< name >.sec ASCII セクションの輪郭と特性を格納。 
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4 データのインポート（Importing Data） 

ODV は新しいデータをインポートして、インポートしたデータを既存のコレクションに追加したり、自動的

に作成された新しいコレクションにデータを加えたりできます。多くの一般的な海洋データのフォーマットや

幅広い列指向のスプレッドシートファイルを含む多種多様なデータファイルフォーマットのサポートが提供

されています。データのインポートは、一度に一ファイルずつ、もしくは大量のインポートファイルを一度に

処理することによって実行することができます。インポートファイルは、ファイル選択ダイアログを使用して

手動で選択するか、別ファイルに記述したファイル名のリストを使用して選択できます。ファイルリストは組

み込みリストファイルジェネレータを使用して簡単に生成できます。インポートファイルのアーカイブ（zip、

gz、または tar.gz）を指定すると自動的に展開されます。 

 

後述する全てのインポートは二つの方法で実行されます：インポート開始時に（1）コレクションを開くか、

（2）開かないか、です。 

 

(1) コレクションを開く（Collection open） 

インポートが開始された時点でコレクションが開いている場合、ODV は選択された全てのインポートファイ

ルを分析し、そのファイルに含まれる変数の上位集合（ソース変数）を構築します。次に ODV はインポート

ファイル内のメタデータとデータ変数を、現在開いているコレクションの変数（ターゲット変数）に関連付け

ることを可能にするダイアログを表示します。その後 ODV は全てのインポートファイルから現在開いている

コレクションにデータをインポートします。 

 

(2) コレクションを開かない（No collection open） 

インポート開始時にコレクションが開かれていない場合、ODV は選択された全てのインポートファイルを分

析し、ファイルに含まれるメタデータと変数データ（ソース変数）の上位集合を構築します。次に ODV はイ

ンポートしたデータを受け取るため、自動的に一つ以上の適切なターゲットコレクションを作成します。ター

ゲットコレクションには、分析中にインポートファイルで見つかった一連の変数が含まれています。ソース変

数とターゲット変数間の関連付けは自動的に確立され、インポートはそれ以上のユーザー介入なしに進行しま

す。 

 

ターゲットコレクションの自動作成を伴うデータのインポート（タイプ 2；インポート開始時にコレクション

を開かない）では、インポートファイルにある全てのメタデータとデータ変数の全てのデータが実際にインポ

ートされます。これは、インポートしたデータの完全性が主な関心事である場合に好ましいインポートタイプ

です。既存のコレクションへの読み込み（タイプ 1；インポート開始時にコレクションを開く）は、既存のコ

レクションを新しいデータで拡張することが主な関心事である場合にのみ使用してください。このインポート
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タイプでは、既存のコレクションに含まれていない変数はインポートファイル内のメタデータまたはデータか

らインポートされません。 

 

以下の表 4-1 に、さまざまなインポータの概要とデータ読み込みの開始方法を示します。 

 

表 4-1：ODV データ読み込みとその読み込みの開始方法 
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インポートメニューオプション ■ ■ ■ ■ ■ ■ ■ ■ ■ 

File > Openオプション ■ - - - - - - - - 

ファイルのドラッグとドロップ ■ - - - - ■ - - ■ 

コマンドファイル ■ ■ ■ ■ ■ - - ■ - 

 

インポートメニュー（Import menu）：これはインポートを開始する通常の方法です。Import メニューか

ら適切なエントリを選択してインポートするファイルを選択します。開かれているコレクションにインポート

するとき、一部のインポートは互換性のないデータのインポートを防ぐために無効となります。 例えば時系

列データは、プロファイルデータを含むコレクションにはインポートされません。 

File > Open オプション：File > Open メニューからのインポートは、単一のスプレッドシートファイルのイ

ンポートを開始するのに便利な方法です。Open ダイアログが表示されたらタイプフィルタを Data Files に切り

替えてスプレッドシートファイルを選択します。 

ドラッグ・アンド・ドロップ：一部のインポートでは、ファイルブラウザで一つ以上のファイルを選択し、そ

れらのファイルを ODV ウィンドウにドロップするだけでデータのインポートができます。 ODV は最初にド

ロップされたファイルのファイルタイプに基づいて適切なインポートを選択します。 未知のファイルタイプ

の場合は ODV スプレッドシートのインポートを仮定します。 

コマンドファイル：一部のインポートは、ODV コマンドファイルを呼び出すことによってバッチモードで実

行できます。 詳細については ODV コマンドファイルの章を参照してください。 

マルチファイルインポート：全てのインポートは、インポート毎に複数のファイルを許可します。インポート

ファイルは、ファイル選択ダイアログ、複数ファイルのドラッグ＆ドロップ、または別ファイルに記載された

ファイル名のリストを提供することによって手動で選択できます。組み込みリストファイルジェネレータで簡



Version 56.2 

 

44 

 

単にファイルリストを生成することができます。これは、複数のディレクトリから多数のファイルをインポー

トする場合、または手動で大量のファイル選択を繰り返したくない場合に便利です。 

ファイル固有の変数：全てのインポートでは、インポートファイルを分析し、ファイル内で見つかった変数の

上位集合を収集することによって、インポートメタデータとデータ変数のリストを自動的に構成します。タイ

プ 2 のインポート（インポート時にコレクションを開かない）では、インポートファイル内の全ての変数につ

いてインポートしたデータを受け取るのに適切なターゲットコレクションを自動的に作成します。 

 

4.1 ODV スプレッドシートファイル（ODV Spreadsheet Files）  

ODV は、さまざまなスプレッドシートタイプのファイルからデータを読み取ってインポートします。 インポ

ートファイルの形式が汎用 ODV スプレッドシートフォーマットに準拠している場合、データのインポートは

完全に自動化され、ユーザーは操作の必要がありません。スプレッドシートファイルは、メニューオプション

の Import > ODV Spreadsheet および File > Open を使用して開いてからインポートするか、あるいはインポート

ファイルを単に ODV ウィンドウまたはアイコンにドロップすることができます。準拠していないスプレッド

シートデータファイルもインポートできますが、例えば経度、緯度、日付、時刻のように必須なメタデータ変

数に関するインポートファイル内の列の識別など、ODV はユーザーに操作を求めます。 

 

測点メタデータ情報や列ラベルの有無にかかわらずスプレッドシートファイルのインポートは可能です。ODV

スプレッドシートファイルにはコメントを含めることができ、列区切り文字はタブまたはセミコロンです。欠

測データは、特別な数値、テキストインジケータまたは空欄で表されます。スプレッドシートファイルは一つ

以上のクルーズによる多数の測点データを含んでいます。各測点は無制限の数のサンプル（一行につき一サン

プル）を含んでいます。測点のサンプルは連続していなければなりませんが、必ずしも並び替えられている必

要はありません。 

 

スプレッドシートファイルを読み込むとき、ODV は Cruise、Station、Type および存在する場合は LOCAL_CDI_ID

の一つ以上のエントリが一行から次の行に変わるたびにデータを測点に分割します。Cruise、Station、および

Type が変わらなくても、日付/時刻、経度および/または緯度が指定された許容範囲を超えて変わった場合も測

点に分割されます。デフォルトの許容値は一時間かつ緯度経度 0.1 度です。これらの値は View > Settings > 

Spreadsheet Import オプションで変更できます。 

 

データファイルに Station 情報が与えられていない場合は、Date, Time, Longitude および Latitude の各値がチ

ェックされ、これらの値の一つ以上が変わる毎に測点に分割されます。日付/時刻、経度、緯度のような測点の

全てのメタデータは、インポートファイル内の測点の最初のサンプル行から取得されます。 

 

ファイルからインポートしたデータは、現在開いているデータコレクションに追加されるか、または現在開い

ているコレクションがない場合は、新しく作成される適切なコレクションに追加されます。 
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スプレッドシートファイルのデータを現在開いているコレクションにインポートするには、Import > ODV 

Spreadsheet を選択し、標準の「ファイル選択」ダイアログを使用してデータファイルを識別します。インポー

トオプションを指定して OK を押すとデータのインポートが始まります。 スプレッドシートファイルを ODV

アイコンまたは開いている ODV ウィンドウにドラッグ・アンド・ドロップすることもできます。 

 

 

図 4-1：スプレッドシートファイルのプロパティダイアログ 

 

ファイルが汎用 ODV スプレッドシートファイルではない場合、Spreadsheet File Properties ダイアログボック

スが表示され、列の区切り文字と一つ以上の欠測値の指定が促されます。複数の欠測値は一つ以上のスペース

で区切る必要があります。インポートファイル内のフィールドが空欄または欠測値の一つを含んでいれば欠測

データと見なされます。最初のデータ行および列ラベルと単位を含む行を指定することもできます。後者の二

つの行番号はラベルと単位が別々の行にある場合にのみ異なるでしょう。ODV は全ての項目に対して妥当な

デフォルト値を提供しているので、ほとんどの場合ほんの少し変更するだけです。Column separator は Column 

labels ボックスをクリックすると表示される縦長のラベル一覧から選択します。スプレッドシートファイルの

全てのプロパティを設定したら OK を押し、インポートを中止する場合は Cancel を押します。 

 

メタデータ列のラベルが汎用 ODV スプレッドシートフォーマット（下記参照）で定義されている推奨ラベル

と異なる場合、Meta Variable Association ダイアログボックスが表示されます。このダイアログでは、入力列を
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コレクションのメタ変数に関連付けるか、入力ファイルで提供されていないメタ変数にデフォルトを設定する

ことができます。既に関連付けられた変数にはアスタリスク（*）が付いています。 詳細については「メタ変

数関連付けダイアログ（Meta Variable Association Dialog）」の章を参照してください。 

 

4.2 SDN スプレッドシートおよび netCDF ファイル（SDN Spreadsheet and netCDF 

Files） 

European SeaDataNet（SDN）プロジェクトは、欧州のデータセンターのネットワークから海洋データを

提供しています（http://www.seadatanet.org）。データ問合せの結果として、SDN は問合せ単一のプロ

ファイル、時系列、または軌跡のデータがそれぞれ格納された潜在的に多数のファイルを含む多数の zip フ

ァイルを配信します。データファイルに含まれるデータ変数に関する情報を格納した

param_decompositions.txt も配信されます。 

SDN は ODV スプレッドシートフォーマットまたは netCDF ファイルを配信します。Import > SeaDataNet 

Formats オプションは両タイプのデータファイルをインポートでき、非常に多数のファイルに対しても簡単な

データインポート手順を提供しています。選択した個々のインポートファイル（zip、csv、txt、および nc ファ

イルは一度のインポートステップに組み合わせることができます）は全て一ステップで処理され、SDN イン

ポートファイルセットに含まれるデータタイプごとに別々の ODV データコレクションが作成されます。  

 

SDN データの.zip ファイルをダウンロードしたら Import > SeaDataNet Formats を呼び出します。次にダウン

ロードしたファイルが含まれているディレクトリに移動して、インポートするファイルを選択します。

param_decompositions.txt ファイルの選択も確認してください。SDN のインポートを開始するたびに SDN

の親ディレクトリの中にサブディレクトリが作成され、インポートプロセスからの出力がこのサブディレクト

リに書き込まれます。SDN の親ディレクトリの名前は View > Settings > Import > SDN Import で確認および変更

できます。新しいコレクションが書き込まれるサブディレクトリの名前は現在の日時で構成されるので、実行

する全ての SDN インポートに関して固有の名前となります。 

 

ODV は選択された全ての SDN .zip アーカイブファイルを自動的に展開し、抽出された全てのスプレッドシー

トまたは netCDF ファイルの内容を分析します。これには、そのファイル内の入力ファイルの SDN セマンテ

ィックヘッダー行と列ヘッダー行の分析、SDN スプレッドシート形式準拠の検査（準拠していないファイル

は除かれます）、使用可能な変数に関する情報の収集、ファイル中で見つかった主要変数に関するファイルの

グループ化が含まれます。さらに ODV は.csv メタデータファイルを検索し、その内容を追加のメタ変数に抽

出します。//<SDN_REFERENCES>および//<sdn_reference>のコメント行の内容が抽出され、Reference メタ変数

に提供されます。Reference メタ変数の LOCAL_CDI_ID、EDMO_code、および URL のエントリはクリック可能で

あるため、より詳細な情報を含むドキュメントを Web ブラウザで開くことができます。readme.txt ファイル

の内容が抽出され（存在する場合）、作成された全てのコレクションの使用許諾契約ダイアログに使用されま

す。 
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ODV は検出されたデータタイプごとに別々のデータコレクションを作成し、一致するファイルのデータを特

定のコレクションに読み込みます。SDN インポートプロセスが完了したら File > Recent Files オプションを使

用して新しく作成されたコレクションを開くことができます。コレクションの別ディレクトリへの移動および

／または別名への変更には Collection > Move / Rename を使用します。 

 

以下は、ターゲットコレクションの作成のために ODV によって適用される戦略とそれぞれの変数セットの構

成の詳細な説明です。 

 

最初のステップとして、ODV は全ての SDN インポートファイルのヘッダー列行を解析し、どのファイルでも

使用されている主要変数（メタ変数の後の最初の変数）を検出し、インポートファイルをその主要変数に従っ

てグループ化します。 

 

次に、ODV は全てのファイルグループについて、これらのファイル内に存在する変数の上位集合に編集し、

続いて編集済み上位集合の全ての変数からなる ODV コレクションを一つ作成します。グループ内の全てのフ

ァイルからのデータは、最終的にその特定のコレクションにインポートされます。 

 

セマンティックヘッダーの SDN パラメータコードに関係なく、所定のファイルグループの変数の上位集合を

編集している間、ファイルのヘッダー列行に新しい変数ラベルが見つかると、新しい変数が作成されます。例

えば Tempera_sensor1 と Temperature_sensor2（どちらもセマンティックヘッダエントリ SDN：P01 :: TEMPPR01

を持つ）の二つのラベルが単一のファイルまたはグループの別々のファイルにある場合、ODV はターゲット

コレクション内に Temperature 変数の中に別々の変数 Temperature_sensor1 と Temperature_sensor2 を作成し

ます。  

 

同じ派生変数名で異なる単位が異なるファイルにある場合は別々の変数が作成されます。例えば Phosphate 

[umol/l]と Phosphate [umol/kg]が二つのファイルで見つかると、二つの別々の変数になります。どのファイル

でもヘッダー行の変数名は固有でなければなりません。一つのファイルで同じ名前を二回以上使用すること

（Phosphate [umol/l]および Phosphate [umol/kg]など）は ODV ではサポートされていません。ある変数の二つ

の異形が単一ファイルに表れることはありますが、変数名は異なっている必要があります（例えば Phosphate_1

と Phosphate_2）。 

 

個 別 の 変 数 を 作 成 す る た め の 上 記 の 規 則 は 、 <install>/include/import デ ィ レ ク ト リ に あ る

sdn_import_settings.xml ファイルの Labels グループにリストされている変数には適用されません。ユーザーは

追加したユーザー指定の設定を含む追加の sdn_import_settings.xml ファイルを<user>/import ディレクトリに作

成できます。競合が発生した場合はユーザー設定が優先されます。 
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SDN インポートファイルで sdn_import_settings.xml ファイルの Labels グループに含まれる変数が見つかると、

SDN インポートファイルのラベルではなく、設定ファイルで指定された変数ラベルが使用されます。例えば

コード SDN:P01 :: PRESPR01、SDN:P01 :: PRESPS01、および SDN:P01 :: PRESPS02 の変数には全てラベル Pressure

が割り当てられ、一つのデータ変数 Pressure のみが作成されます。インポート中に三つの全てのインポート変

数からのデータは単一の Pressure ターゲット変数に割り当てられます。 

 

いくつかの個々の変数を一つのターゲット変数に結合することは、同じ単位を使用する個々の変数に対しての

み機能します。異なる単位が見つかった場合は別々の 変数が作成されます。 例えば上記の例で

SDN:P01::PRESPR01 および SDN:P01: PRESPS01 変数が dBar を使用しているのに対し、SDN:P01::PRESPS02 変数

が Bar を使用している場合、二つのターゲット変数 Pressure[dBar]および Pressure[Bar]が作成されます。イン

ポート中に SDN:P01 ::PRESPR01 と SDN:P01:: PRESPS01 が Pressure [dBar]に読み込まれ、SDN:P01::PRESPS02 が

Pressure[Bar]に読み込まれます。 

 

二つ以上の SDN パラメータコードのデータを一つのデータ変数に確実に統合するには、ユーザー設定ファイ

ル <user>/import/sdn_import_settings.xml を作 成 して 特定 の コー ドの エ ント リを 追 加し ます 。 例え ば

SDN:P01::ODSDM021、SDN:P01::PPSUCS01、SDN:P01 ::PSALCC01 などの異なるコードが異なる SDN インポート

ファイルの Salinity に使用されていて、これらの全てのデータを単一の変数 Salinity に統合したい場合は、ユ

ーザーの sdn_import_settings.xml ファイルの<Labels>タグに次の行を追加する必要があります： 

<Entry code="SDN:P01::ODSDM021" value="Salinity" />  
<Entry code="SDN:P01::PPSUCS01" value="Salinity" />  
<Entry code="SDN:P01::PSALCC01" value="Salinity" /> 

 

上記のように、単一のターゲット変数への統合は、同じ単位を使用している個々の変数に対してのみ機能しま

す。 

 

また、 sdn_import_settings.xml ファイル には、主要変数と知られている コレクションデータタイプ

（ DEPTH_WATER, MINDEPTH_WATER, MAXDEPTH_WATER, PRESS_WATER, PRESS_ATMOSPHERE, 

DEPTH_SEDIMENT, TIME_SERIES および TIMESERIES_CDJ のいずれか一つ）を指定する<PrimaryVarTypes>タグ

も含まれています。 

Bot.Depth メタ変数の値は検証されて、おそらく次の方法で修正されます。ゼロまたは 9999, または 11000

より大きい値、または特定の測点の最大サンプル深度より小さい全ての値は取り除かれます。もし Water depth

メタ変数が存在し、最大サンプル深度より大きいか等しい場合は、この値が Bot.Depth として使用されます。

このような修正の全ては EDITMETADATA メッセージとして測点履歴に記録されます。 

SDN データファイルをインポートしたら、File > Recent Files で新規作成されたコレクションのいずれかを開く

ことができ Expor >Data>SDN Aggregated ODV Collection オプションを使用して変数の自動集約を実行できます。

Export > Data > SDN Harmonized ODV Collection を使うと、混在しているデータを好ましい単位に自動変換しま
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す。Collection > Browse Info File オプションを使うと説明を含むコレクション内のデータ変数のリストを閲覧で

きます。 

 

注意：直前の測点からおよそ距離 250m および時間 10 分以内の軌跡点（一測点に一サンプル）は無視されま

す。このルールはデータファイルのサイズが 5KB をこえる場合にのみ適用されます。 

 

4.3 World Ocean Database データ（World Ocean Database Data）  

ODV を使用して、NOAA NCEI（米国大気海洋庁国立環境情報センター；旧 NODC(米国海洋データセンター)）

の World Ocean Database（WOD）からオリジナルの海象データを既存または新規のデータコレクション内

にインポートできます。WOD のインポートはコレクションを開いていなくても実行でき、インポートしたデ

ータを受け取る適切なターゲットコレクションが自動的に作成されます。ODV は WOD バージョン 2018 の

ASCII および netCDF ファイルをサポートしていますが、それ以前のバージョンの WOD データファイルは、

多 く の 海 洋 変 数 の 単 位 が 異 な る た め 受 け 付 け ま せ ん 。 例 え ば

https://www.nodc.noaa.gov/OC5/WOD/datawodgeo.html からダウンロードするなどして WOD native 

ASCII または netCDF format のデータファイルを入手してください。csv フォーマットの WOD データはインポ

ートできません。 

 

WOD データを既存のコレクションにインポートするには、そのコレクションを開きます。 新しいコレクショ

ンにインポートするには、インポートを呼び出す前に他の開いているコレクションを閉じてください。Import 

> NOAA NCEI Formats > World Ocean Database の手順でインポートを呼び出します。標準の「ファイルを開く」

ダイアログを使用してインポートする一つ以上の WOD .gz または .nc データファイルを選択します。すでに

展開されている WOD アスキーファイルを選択したい場合にはファイルタイプで All Files (*.*)を選択してくだ

さい。 

 

必要があればインポートオプションを指定して OK を押すとデータのインポートが始まります。ODV は選択

された WOD データファイルを読み、測点フィルタ設定を満たす全ての測点をインポートします。インポート

した測点のクルーズラベルは WOD18 識別子とそれに続く二文字の NCEI 国コードおよび固有の OCL クルー

ズ番号で構成されています。個々のエントリはアンダースコア “_”で区切られています（注：OCL クルーズ番

号を除いた簡易クルーズラベルを作成するには View > Settings オプションで Short WOD cruise labels ボックス

をチェックして WOD Import 設定を変更してください）。 

 

固有の OCL プロファイル番号は測点番号として ODV によって使用されます。ODV はインポートファイルに

ある WOD データ品質フラグを認識して使用します（下記参照）。データ保有者から提供された品質フラグは

無視されます。追加のメタデータとして OCL クルーズ番号、データ保有者によるクルーズ名、測点名、およ

び調査員の名前が提供されます。 

https://www.nodc.noaa.gov/OC5/WOD/datawodgeo.html
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「ファイルを開く」ダイアログを使用してインポートファイルを手動で選択する代わりに、インポートしたい

全てのファイルの名前を含む ASCII ファイルを準備してから、「ファイルを開く」ダイアログでリストファイ

ルを選択することもできます。これは、複数のディレクトリから多数のファイルをインポートする場合、また

は手動で多数のファイルを選択してのインポートを繰り返したくない場合に便利です。リストファイル内のフ

ァイル名は絶対パス名で、一行に一つのファイル名でなければなりません。 ODV リストファイルのデフォル

トの拡張子は.lst です。 組み込みリストファイルジェネレータで簡単にファイルリストを生成することができ

ます。 

 

リストファイルが作成されたら Import > NOAA NCEI Formats > World Ocean Database を選択して事前に作成し

たリストファイルを選択します。 前述のようにインポートオプションを指定して OK を押すとデータのイン

ポートが始まります。ODV はリストファイルにリストされている全てのファイルを読み、現在開いているコ

レクションに全ての測点をインポートします。 

 

WOD データは品質管理されており、データ保有者または NOAA NCEI によって品質が低い、または疑わし

いと判定されたフラグがかなりの量のデータに付与されている場合がある事に注意して下さい。ODV は

WOD ファイル内のデータ品質情報をインポートして維持し、WOD 品質フラグをターゲットデータコレクシ

ョンで使用されている品質フラグスキームに自動的にマッピングします。ターゲットコレクションが World 

Ocean Database variables を使用して作成された場合、データ変数は WOD 品質フラグスキームを使用

し、インポートファイル内の元の WOD 品質フラグは ODV コレクションに維持されます。データを見るとき

には、解析から疑わしいデータや不良データを除外するために、オプションの Sample Filter を使用してデー

タ品質と範囲フィルタを適用することを検討してください。 

4.4 Argo フロートデータ（Argo Float Data）  

ODV を使用して、単一または複数の Argo core, bio (バージョン 3.1)、および synthetic s-profile (バージ

ョン 1.0) netCDF ファイルから ODV プロファイルまたは軌跡データコレクションにプロファイルおよび軌

跡データをインポートできます。Argo のインポートはコレクションを開いていないときでも実行でき、その

場合はインポートしたデータを受け取る適切なターゲットコレクションが自動的に作成されます。Argo ファ

イ ル は Coriolis お よ び GODAE の デ ー タ セ ン タ ー （ http://www.corio-lis.eu.org/ お よ び 

http://www.usgodae.org/argo/argo.html）からダウンロードできます。ODV は Argo の.nc ファイルのみ

ならず.gz または.zip パッケージも受け付けます。 

 

Argo データは、Argo プロファイルまたは軌跡変数セットを使用してデータコレクションに読み込まなければ

なりません。そのようなコレクションをまだ開いていない場合は File > New オプションを使用して作成してく

ださい。データ変数を定義するように求められたら、インポートしたいデータの種類に応じて Argo Profile ま

たは Argo Trajectory を選んでください。Argo 中間パラメータのデータもインポートしたい場合は Argo Profile 

http://www.corio-lis.eu.org/
http://www.usgodae.org/argo/argo.html
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( including intermediate variables)を選択してください。受け取るコレクションが作成されて開かれていたら

Import > Argo Formats > Profiles または Import > Argo Formats > Trajectories を選択するとデータのインポート

が始まります。Argo プロファイルまたは軌跡のインポートはコレクションが開かれていなくても呼び出すこ

とができ、その場合はインポートしたデータを受け取る適切なターゲットコレクションが自動的に作成されま

す。その後 ODV は標準の「ファイルを開く」ダイアログを表示するので、所定のディレクトリの中の一つ以

上の Argo netCDF データファイルを選択してください。 あるいは処理対象のファイル名のリストを含む

ASCII ファイルを選択することもできます。このリストファイルはインポートを始める前に準備する必要があ

ります。一行につき一つの絶対ファイルパスのエントリを含める必要があります。リストファイルの拡張子

は.lst でなければなりません。組み込みリストファイルジェネレータで簡単にファイルリストを生成すること

ができます。 

 

ODV はインポートオプションダイアログを表示します。Argo プロファイルや軌跡データ（上記参照）用に作

成されたコレクションにインポートする場合は単に OK を押すだけでデータのインポートが始まります。 

 

Argo プロファイルまたは軌跡コレクションの変数には圧力、水温、塩分、酸素、および bioArgo ファイルで

提供される多くの生物光学変数が含まれます。これらの変数には二つのバージョンがあります：（1）リアル

タイムまたはオリジナルデータ（第一グループ; 変数ラベルの接尾辞が Original）、および（2）遅延モードま

たは補正データ（第二グループ; 接尾辞が adjusted）。ファイルにある補正エラーデータはそれぞれの補正済

み変数の 1-σ エラーデータ（上述訳注参照）として使用されます。リアルタイムデータファイルには補正済み

データが含まれていないことに注意してください。 

 

NetCDF ファイル内の Argo データ品質フラグは認識され、インポート中にターゲット変数の品質フラグスキ

ームに変換されます。ターゲットコレクションが Argo プロファイルまたは軌跡コレクションの場合はオリジ

ナルの Argo 品質フラグ値が使用され、品質フラグ変換は行われません。 品質フラグマッピングの詳細につ

いては ODV_QualityFlagSets.pdf ファイルを参照してください。 

 

Argo プロファイルデータの場合、ODV 測点名はサイクル数、オプションのサブサイクルインジケータ（a、b、

c など）、データモードインジケータ（R はリアルタイムデータ、D は遅延モードデータ、A は補正済みリアル

タイムデータ）およびプロファイル方向コード（A は昇順、D は降順）で構成されます。Argo 軌跡データの場

合、ODV 測点名は軌跡指標とデータモードインジケータ（R はリアルタイムデータ、D は遅延モードデータ、

A は補正済みリアルタイムデータ）で構成されます。データが bioArgo ファイルからインポートした場合、接

尾語_bio が測点名に追加されます。一例として、測点ラベル 71a_R_A は、フロートサイクル 71 の第２昇順プ

ロファイルからのリアルタイムデータを含む測点を示します。ラベル 15_D_A は、フロートサイクル 15 の第

一昇順プロファイルの遅延モードデータ用です。それぞれのプロファイル測定の説明については Vertical 

Sampling Scheme メタ変数の値を参照してください。 

 

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
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全ての場合において Argo プラットフォーム番号が Cruise メタ変数に使用されます。Argo 軌跡ファイルをイ

ンポートするときは有効な地理的位置を持つサイクルのみがインポートされます。 

 

上記の手順に従った Argo プロファイルと軌跡のインポートでは、多くの生物光学および生化学パラメータに

関して定義された、いくつかの bioArgo ファイルに含まれている Argo 中間パラメータ（Argo リファレンス

表 3 を参照）は除外されます。最初に File > New で新しいターゲットコレクションを作成し、Argo Profile

（including intermediate variables）コレクションテンプレートを選ぶと、インポートに中間パラメータを含め

ることができます。このコレクションを開いた状態で Import > Argo Formats > …の順に選択して Argo のイン

ポートを始めると上述の処理が進行します。 

 

インポートが完了したら View > Sample Filter オプションで適切な品質フラグ選択基準を設定してデータをフ

ィルタリングし、解析から不良データを除外することができます。 

 

4.5 CORA 水温・塩分データ（CORA Temperature and Salinity Data） 

ODV を使用して、単一または複合 Coriolis Ocean database for ReAnalysis (CORA, netCDF バージョン

3.0)ファイルから水温・塩分データのプロファイルを ODV プロファイルデータコレクションにインポートで

きます。CORA のインポートはコレクションを開いていなくても実行できます；この場合、インポートした

データを受け取るのに適切なターゲットコレクションが自動的に作成されます。CORA ファイルは Coriolis

データセンター http://www.coriolis.eu.org/Data-Products/Products/CORA からダウンロードできます。ODV

は CORA .tgz パッケージだけでなく.nc ファイルも受け付けます。 

 

Import > CORA netCDF 3.0 を選択すると CORA のインポートが始まります。ODV は標準の「ファイルを開

く」ダイアログを表示するので、所定のディレクトリから一つ以上のファイル(.nc または.tgz)を選んでくださ

い。もしくは処理対象のファイル名のリストを含む ASCII ファイルを選ぶこともできます。リストファイル

の拡張子は.lst でなければなりません。組み込みリストファイルジェネレータで簡単にファイルのリストを作

成できます。 

 

ODV はインポートオプションダイアログを表示します。CORA プロファイルデータのために作られるコレク

ションに読みこむ場合は単に OK を押すだけでデータのインポートが始まります。 

 

CORA プロファイルコレクションの変数には深度、水温および塩分が含まれています。これらの変数には二

つのバージョンが入ります：(1)リアルタイムまたはオリジナルデータ(第一グループ；変数ラベルに接尾語

(original))、(2)遅延モードまたは補正データ(第二グループ；接尾語は(adjusted))。ファイル中に見られる補

正エラーデータは各々の補正変数の 1-σエラーデータが使用されています。リアルタイムデータファイルに

は補正データが含まれていないことに注意してください。 

 

http://www.coriolis.eu.org/Data-Products/Products/CORA
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NetCDF ファイル中の CORA データ品質フラグは識別されて、読み込み中にターゲット変数の品質フラグス

キームに変換されます。ターゲットコレクションが CORA プロファイルコレクションであれば、オリジナル

CORA 品質フラグ値が使用され、品質フラグ変換は行われません。品質フラグ変換の詳細は ODV 品質フラグ

セットを参照してください。 

 

CORA プロファイルデータの場合、ODV 測点名はサイクル数、オプションのサブサイクルインジケータ(a, b, 

c など)、データモードインジケータ（R はリアルタイムデータ、D は遅延モードデータ、A は補正済みリアル

タイムデータ）、およびプロファイル並びコード（A は昇順、D は降順）で構成されます。例えば測点ラベル

71a_R_A は、フロートサイクル 71 の第二昇順プロファイルからのリアルタイムデータを含む測点であること

を示しています。ラベル 15_D_A はフロートサイクル 15 の第一昇順プロファイルの遅延モードデータである

ことを示しています。それぞれのプロファイル測定の説明に関しては Vertical Sampling Scheme メタ変数の値

を参照してください。CORA プラットフォーム番号は全ての場合において Cruise メタ変数に使用されていま

す。 

 

インポートが完了したら View > Sample Filter オプションで適切な品質フラグ選択基準を設定してデータをフ

ィルタリングし、解析から不良データを除外することができます。 

 

4.6 GTSPP – (全球水温・塩分プロファイルプログラム/Global Temperature-Salinity 

Profile Program） 

ODV を使用して GTSPP netCDF バージョン 3.8 および 4.0 形式のファイルから ODV データコレクションに

データをインポートできます。GTSPP のインポートはコレクションを開いていなくても実行できます。その

場合、インポートしたデータを受け取る適切なターゲットコレクションが自動的に作成されます。GTSPP フ

ァイルは米国海洋データセンター（US National Oceanographic Data Center; 訳注：現 NOAA NCEI（米国大気海

洋庁国立環境情報センター））からダウンロードできます: http://www.nodc.noaa.gov/GTSPP/ 

 

GTSPP データは GTSPP 変数を使用してデータコレクションにインポートしなければなりません。そのよう

なコレクションをまだ開いていない場合は File > New オプションを使用して作成してください。データ変数を

定義するように促されたら GTSPP（Global Temperature-Salinity Pro-file Program）を選択します。データのイン

ポートを開始するには Import > NOAA NCEI Formats > GTSPP を選んでください。ODV は標準の「ファイルを

開く」ダイアログを表示するので、所定のディレクトリから一つ以上の圧縮形式の GTSPP パッケージファイ

ル（.tgz または.zip）または GTSPP netCDF データファイル（.nc）を選択してください。あるいは処理対象の

ファイル名のリストを含む ASCII ファイルを選択することもできます。このリストファイルはインポートを

開始する前に準備する必要があります。一行に一つのファイルパスエントリが必要で、ファイルパスは絶対パ

ス名にする必要があります。リストファイルの拡張子は.lst でなければなりません。組み込みリストファイル

ジェネレータで簡単にファイルリストを生成することができます。 

 

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
http://www.nodc.noaa.gov/GTSPP/
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ODV はインポートオプションダイアログを表示します。GTSPP データ用に作成されたコレクション（上記参

照）にインポートする場合は単に OK を押すだけでインポートが始まります。 

 

GTSPP コレクションの変数は深度、水温、塩分です。GTSPP ファイル内の圧力値は全てインポート中に深度

に変換されます。GTSPP コレクションには Data Type という追加のメタ変数があります。この変数は使用され

る IGOSS 無線メッセージの種類または測器の種類に関する情報を保持します。この情報にアクセスするには

ODV バージョン 4.4.2 以降が必要で、それ以前のバージョンではこれらの値は表示されません。 

 

NetCDF ファイル内の GTSPP データ品質フラグは認識され、インポート中にターゲット変数の品質フラグス

キームに変換されます。ターゲットコレクションが ODV で作成された GTSPP コレクション（推奨）の場合、

品質フラグ変換は行われずにオリジナルの GTSPP 品質フラグ値がコレクションに格納されます。品質フラグ

マッピングの詳細については ODV_QualityFlagSets.pdf ファイルを参照してください。 

 

インポートが完了したら、適切な品質フラグまたは範囲サンプルフィルタ設定を設定することでデータをフィ

ルタリングし、解析から不良データを除外することができます。 

 

4.7 GOSUD – (全球海洋表層航走データ/Global Temperature-Salinity Underway 

Data) 

ODV を使用して GOSUD netCDF バージョン 3 フォーマットファイルから ODV データコレクションにデー

タをインポートできます。GOSUDのインポートはコレクションを開いていなくても実行できます。この場合、

インポートしたデータを受け取るのに適切なターゲットコレクションが自動的に作成されます。GOSUD のリ

アルタイムファイルと遅延モードファイルは http://www.gosud.org/からダウンロードできます。 

 

GOSUD データは GOSUD 変数を使用してデータコレクションにインポートしなければなりません。そのよう

なコレクションをまだ開いていない場合は File > New オプションを使用して作成してください。データ変数を

定義するように促されたら GOSUD（Global Ocean Surface Underway Data）を選択します。データのインポート

を開始するには Import > GOSUD netCDF v3.を選んでください。その後 ODV は標準の「ファイルを開く」ダイ

アログを表示するので、所定のディレクトリの中から一つ以上の GOSUD netCDF データファイル（.nc）を選

択してください。あるいは処理するファイル名のリストを含む ASCII ファイルを選択することもできます。 

このリストファイルはインポートを開始する前に準備する必要があります。一行につき一つの nc ファイルの

パスエントリを含める必要があり、ファイルパスは絶対パス名にする必要があります。リストファイルの拡張

子は.lst でなければなりません。組み込みリストファイルジェネレータで簡単にファイルリストを生成するこ

とができます。 

 

それから ODV はインポートオプションダイアログを表示します。GOSUD データ用に作成されたコレクション

（上記を参照）にインポートする場合は単に OK を押すだけでデータのインポートが始まります。 

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
http://www.gosud.org/
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GOSUD コレクションの変数は深度、水温、塩分です。 品質管理された遅延モードデータは通常、オリジナル

の値に加えて補正水温および塩分のデータも含んでいます。 

 

NetCDF ファイルの GOSUD データ品質フラグは認識され、インポート中にターゲット変数の品質フラグスキ

ームに変換されます。ターゲットコレクションが ODV で作成された GOSUD コレクションの場合（推奨）、品

質フラグの変換は行われずにオリジナルの GOSUD 品質フラグの値がコレクションに格納されます。品質フラ

グマッピングの詳細については ODV_QualityFlagSets.pdf ファイルを参照してください。 

 

インポートが完了したら、適切な品質フラグまたは範囲サンプルフィルタ設定を設定してデータをフィルタリ

ングし、解析から不良データを除外することができます。 

 

4.8 WOCE 海洋観測データ (WOCE Hydrographic Data) 

ODV を使用して WHP 交換フォーマットによるオリジナル海洋観測データを既存または新規のデータコレク

ションにインポートができます。WOCE のインポートはコレクションが開かれていなくても実行できます。

この場合、インポートファイルに含まれる変数の上位集合が決定されて適切な受け取りコレクションが自動的

に作成されます。 

 

WHP 交換フォーマットのデータファイルは CLIVAR＆Carbon Hydrographic Data Office（CCHDO）にあり

ます。 

 

データを既存のコレクションにインポートするには、そのコレクションを開いてください。新しいコレクショ

ンにインポートするには、コレクションを作成する際にコレクションに格納する変数を定義するときに必ず

WOCE WHP Bottle variables または WOCE WHP CTD variables を選択してください。選択した WOCE インポート

ファイルの内容に基づいて適切なコレクションを自動的に作成するには、どのコレクションも開かずに Import 

> WOCE Formats > ...を使用して適切な WOCE のインポートを開始して、新しい ODV データコレクションの名

前と場所を指定してください。 

 

WHP 交換フォーマットの採水データを現在開いているコレクションにインポートするには、ODV のメインメ

ニューから Import > WOCE Formats > WHP Bottle (exchange format)の順に選択してください。標準のファイル

選択ダイアログを使用して WHP データセットを選択します。WHP bottle 交換ファイルのデフォルトの接尾

辞は_hy1.csv です。データファイルの拡張子が異なる場合は、ファイル選択ダイアログのファイルタイプで All 

Files を選択してください。次にインポートオプションを指定して OK を押すとデータのインポートが始まりま

す。ODV はデータファイル内の全ての測点を読んでインポートします。ODV は実データ値に加えて WOCE

データ品質フラグを識別してインポートします。これらの品質フラグは、例えば解析から不良もしくは疑わし

いデータを除外するためのデータのフィルタリングとして後で使用する事ができます。マップポップアップメ

ニュー（Sample Selection タブを選択)から選択基準を選んでデータ品質フィルタを変更できます。 

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
http://whpo.ucsd.edu/format.html
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複数の測点を含むファイルをインポートする場合、ODV は航海名または測点番号が変わるたびに測点を分割

します。測点の経度、緯度および占有時間は個々のサンプル値の平均として得られます。無効な経度または緯

度の値を持つサンプルはインポートされません。 

 

WOCE WHP Bottle ファイルの先頭にあるコメントは抽出されてコレクションの一部として別々のテキスト

ファイルに保存されます。これらのファイルへのリンクはメタ変数 Comments に記録されており、その内容は

Comments リンクをクリックするだけで見ることができます。データファイルと共に見つかった航海レポート

もコレクションに追加され、航海レポートへのリンクはメタ変数 Report に保持されます。Report 項目をクリ

ックすると Web ブラウザに文書が表示されます。 

 

現在開いているコレクションにCTDデータをインポートするには、ODVのメインメニューから Import > WOCE 

Formats > WHP CTD (exchange format) の順に選択してインポートする CTD データが含まれている_ct1.zip ファ

イルを選択します。インポートオプションを設定した後、ODV は圧縮ファイルを展開して全ての CTD 測点を

現在開いているコレクションにインポートします。拡張子が異なるインポートファイルは、ファイルタイプフ

ィルタを単一の CTD プロファイルの場合は_ct1.csv に、または All Files に切り替えて選びます。 

 

一度のインポート操作で複数の WHP Bottle または CTD 交換ファイルからデータをインポートできます。そ

のための方法の一つは、インポートファイルの名前を含むデフォルトの拡張子.lst を持つ ASCII ファイルを用

意することです。絶対パス名を使用して一行につき一つのファイル名を指定してください。次に WOCE formats 

> WHP Bottle（exchange format）または WOCE formats > WHP CTD（exchange format）のいずれかを選択し、

ファイルタイプフィルタを.lst に変更してリストファイルを選択し、読み込みオプションを指定して OK を押

すとデータのインポートが始まります。複数のデータファイルをインポートするもう一つの方法は、「ファイ

ルを開く」ダイアログで複数の WHP ボトルまたは CTD 交換ファイルを単純に選択することです。複数の.lst

リストファイルを選択すると最初の一ファイルだけがデータインポート用に認識されます。 

 

4.9 Medatlas フォーマット・データ（Medatlas Format Data） 

地 中 海 と 黒 海 の 海 中 デ ー タ を 含 む MEDAR/Medatlas 2002 デ ー タ 集  (MEDAR Group, 2002 – 

MEDATLAS/2002 database, Mediterranean and Black Sea database of temperature salinity and bio-

chemical parameters. Climatological Atlas. IFREMER Edition (4 CDs)) を作成するために Medatlas フォ

ーマットが使用されました。流速計、サーミスタチェーン、験潮儀、気象ブイ、セジメントトラップによる様々

な形式の時系列データにも Medatlas フォーマットは使用されています。 

 

ODV はこれらの多様なデータ型を全てインポートできます。 異なるデータ型の変数セットは大きく異なるた

め、受け取るデータコレクションがそれらと一致する変数セットを使用していることが重要となります。

Medatlas ボトルおよび CTD プロファイルデータ用に事前に定義されている変数セットと、二つの時系列デー
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タ用の変数セット（一つはセジメントトラップのデータ、もう一つはその他全ての時系列データ）があります。

Medatlas データ用の新しいコレクションを作成するときには適切な変数セットを選んでください（下記参照）。 

 

Medatlas フォーマットのデータは任意の ODV データコレクションにインポートできますが、Medatlas イン

ポート変数とコレクションのターゲット変数との手動の関連付けが常に求められます。Medatlas 時系列コレ

クションの Time は、1900-01-01 00:00 からの経過年として提供されています。他の単位（例えば日数）や別の

参照日を使用することはできません。データのインポートを容易にし、手動による変数の関連付けを避けるた

めには適切な Medatlas 変数セットを使用してターゲットコレクションを作成してください。そのようなコレ

クションを作成するには File > New オプションを使用してください。データ変数を定義するように求められた

ら、Medatlas ボトルデータには Medatlas Bottle variables、Medatlas CTD、XBT または MBT データには

Medatlas CTD variables、Medatlas セジメントトラップデータには Medatlas Sediment Trap variables、その他の

Medatlas 時系列データ（例えば流速計、サーミスタチェーン、験潮儀、気象ブイ）には Medatlas Time Series 

variables を選択してください。 

 

Medatlas のインポートはコレクションを開いていなくても実行できます。その場合はインポートしたデータ

を受け取るのに適切なターゲットコレクションが自動的に作成されます。 

 

データのインポートを開始するには、ボトル、CTD、XBT または MBT データの場合は Import > Medatlas Formats 

> Profile Data、または任意の種類の時系列データの場合は Import > Medatlas Formats > Time Series Data を選択

してください。どちらのインポートタイプでもインポートする一つ以上の Medatlas データファイルを選択で

きます。あるいは処理するファイル名のリストを含むテキストファイルを選択することもできます。このリス

トファイルはインポートを開始する前に準備する必要があります。一行に一つのファイルエントリを含める必

要があり、ファイル名は絶対パス名とする必要があります。 リストファイルの拡張子は.lst でなければなりま

せん。組み込みリストファイルジェネレータで使って簡単にファイルリストを生成することができます。 

 

ODV によって作成された Medatlas の時系列データおよびセジメントトラップのデータコレクションには、

流速計、サーミスタ、海面計、気象ブイ、セジメントトラップといった個々の測器の配置深度を含むメタ変数

Instrument Depth が含まれます。  

 

Medatlas データファイルの GTSPP 品質フラグは認識され、インポート中にターゲット変数の品質フラグス

キームに変換されます。ターゲットコレクションが ODV で作成された Medatlas プロファイル、時系列、ま

たはセジメントトラップのコレクションの場合、品質フラグ変換は行われずにオリジナルの GTSPP 品質フラ

グ値がコレクションに格納されます。品質フラグマッピングの詳細については ODV_QualityFlagSets.pdf ファイ

ルを参照してください。 

 

4.10 MEOP 海洋哺乳類データ（MEOP Marine Manmals Data） 

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
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MEOP 海洋哺乳類プログラム https://www.meop.net/からプロファイルデータをインポートできます。

MEOP netCDF データファイルは https://www.meop.net/database/からダウンロードできます。 

 

MEOP データは MEOP 変数を使ってデータコレクションにインポートしてください。もしそのコレクション

をまだ開いていなければ、File > New オプションを使って作成してください。データ変数の定義を促されたら

MEOP Sea-Manmals Profile を選んでください。データインポートを開始するには Import > MEOP netCDF を選

んでください。ODV は標準の「ファイルを開く」ダイアログを表示するので、そのディレクトリにある一つ

以上の MEOP netCDF データファイル(.nc)を選んでください。もしくは、処理されるファイル名のリストを

含んだアスキーファイルを選んでください。このリストファイルはインポートを始める前に用意してくださ

い。一行につき一 nc ファイルパスを記入し、ファイルパスは絶対パス名としてください。リストファイルの

拡張子は.lst でなければなりません。組み込みリストファイル生成機能で簡単にリストファイルを作成できま

す。 

 

ODV はインポートオプションダイアログを表示します。作成された MEOP データのコレクション（上記参

照）にインポートするには、単に OK を押すだけでデータインポートが始まります。 

 

netCDF ファイルの中の MEOP データ品質フラグはインポート中にターゲット変数の品質フラグスキームに

従って解釈され変換されます。ターゲットコレクションが ODV で作成された MEOP コレクション（推奨）で

あれば、品質フラグは変換されず、元の MEOP 品質フラグ値がコレクションに収録されます。品質フラグマ

ッピングの詳細は ODV_QualityFlagSets.pdf を参照してください。 

 

一度インポートすると、適切な品質フラグの設定またはサンプルフィルタ設定によりデータをフィルタリン

グして解析から不良データを除外することができます。 

 

4.11 Sea-Bird CNV ファイル（Sea-Bird CNV Files） 

ODV を使用して Sea-Bird .cnv ファイルから既存のコレクション、またはインポートファイルの特定の内容に

適するよう自動的に作成された新しい ODV データコレクションにデータをインポートできます。Sea-

Bird.cnv ファイルは Sea-Bird 社製 SBE データ処理ソフトウェアを使用して生の Sea-Bird ファイルから作成

されます。そのファイルをインポートするとき、ODV はダウンキャストとアップキャストを別々の測点とし

て分割することができます。ODV はユーザー指定の圧力区間毎にデータを平均することもできます。これら

の機能を有効にする方法は 2.13 節 Sea-Bird CNV のインポートを参照してください。 

 

Sea-Bird.cnv ファイルから既存の ODV データコレクションにデータをインポートするには、まず受け取るコ

レクションを ODV で開きます。次に一つ以上の Sea-Bird CNV ファイルを ODV アプリケーションウィンド

ウにドラッグ・アンド・ドロップします。またはメインメニューから Import > Sea-Bird CNV を選んで一つ以上

の Sea-Bird.cnv ファイルを選択します。処理する.cnv ファイル名のリストを含む ASCII ファイルを選択する

https://www.meop.net/
https://www.meop.net/database/
http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf


ODV User’s Guide 

 

59 

 

こともできます。このリストファイルはインポートを開始する前に準備する必要があります。一行につき一つ

のファイルパスエントリを含める必要があり、ファイルパスは絶対パス名である必要があります。リストファ

イルの拡張子は.lst でなければなりません。組み込みリストファイルジェネレータで簡単にファイルリストを

作成することができます。その後 ODV はインポートオプションダイアログを表示し、承認された場合は選択

した全てのファイルをインポートします。 

 

コレクションが開かれていない場合は Sea-Bird.cnv ファイルを ODV ウィンドウにドロップしたとき、また

は Import > Sea-Bird CNV オプションで Sea-Bird.cnv ファイルを選択したとき、ODV は Sea-Bird ファイルの

内容を分析してインポートファイルに含まれる全ての変数を含むコレクションを自動的に作成します。このコ

レクションがファイルからデータを受け取ります。ODV は標準の「ファイルを保存する」ダイアログを表示

するので、新しく作成されたデータコレクションの名前とパスを指定します。 

 

名前の一部として次の文字列: depth、pressure、time または julian days のいずれかを含む.cnv ファイルの最初

の変数が、新しく作成されたコレクションの主要変数になります。これはプロファイルの場合は圧力または深

度であり、時系列の場合は時間変数です。.cnv ファイルの深度、圧力、または時間変数が別の名前を使用して

いて自動的に識別されない場合は、インポートが完了した後に手動でコレクションの主要変数を設定する必要

があります。これを行う方法については Changing Collection Properties（コレクションのプロパティの変

更）の章を参照し、鉛直プロファイルファイルには圧力または深度を、時系列データには Julian Days などの時

間変数を選択してください。 

 

ODV はユーザー指定の圧力区間毎に Sea-Bird データの区間平均プロファイルを作成できます。この機能を有

効にする方法は 2.13 節 Sea-Bird CNV インポートを参照してください。ODV はファイルごとに鉛直座標変

数を検索し、必要に応じてデータを圧力に変換し、区間平均を実行します。現在の ODV では指定された順序

で次の Sea-Bird パラメータコードを検索します： 

1. 圧力[db]: prM, prDM, pr50M, prSM, prdM (変換なし)  

2. 圧力[psi]: prE, prDE, pr50E, prSE, prdE (0.0689476 倍)  

3. 圧力、FGP [KPa]: fgp0-fgp7 (0.001 倍)  

4. 深度 Depth [m]: depSM, depFM, dNMEA (TEOS10 変換)  

5. 深度 Depth [ft]: depSF, depFF (0.3048 倍, TEOS10 変換)  

 

圧力データまたは深度データを含むファイルごとに、ODV はファイルにダウンキャストとアップキャストが

含まれるかどうかをチェックし、二つの別々の測点としてデータを保存します。ターゲットコレクションでは

Cast Type メタ変数で up-cast と down-cast 文字列で表されています。アップキャストとダウンキャストへ

の分割は、設定ダイアログにおいてオンまたはオフに切り替えることができます（2.13 節 Sea-Bird CNV イ

ンポート参照）。 
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Sea-Bird.cnv ファイルのヘッダーは提供されるメタデータ項目の数と形式においてかなり異なります。次の

規則が満たされる場合、ODV は航海名、測点名、日付と時刻、経度と緯度などのメタデータ項目を認識しま

す： 

1. メタデータ行は「**」（ユーザーメタデータ）または「* NMEA」で始まっていなければなりません。 

2. NMEA メタデータには名前と値を区切るための「=」文字を含める必要があり（例：* NMEA Latitude = 44 

01.58 N）、ユーザーメタデータには区切り文字として「：」を使用する必要があります（例：** Latitude: 

44 01.58 N） 

3. 次の NMEA メタデータがサポートされています：NMEA Latitude、NMEA Longitude、NMEA UTC (Time） 

4. 航海名には Cruise ラベルを付けなければなりません 

5. 測点名には Station ラベルを付けるか、Station という単語を含める必要があります。 

6. 経度と緯度には Longitude と Latitude のラベルを付ける必要があります。 

7. 経度と緯度の値は「(D)DD MM.mm O」フォーマットに従う必要があります：ここで(D)DD は二桁また

は三桁の度を、MM.mm は十進分を、O は方位 N、S、E または W を表します。 

8. 日付と時刻には UTC（Time）ラベルを付けなければなりません。 

9. 日付と時刻は「MMM dd yyyy hh:mm:ss」フォーマットに従う必要があります：ここで MMM は三文字

の英語の月の省略形（例：May）を表します。 

10. 水深情報には Bottom Depth [m]ラベルを付ける必要があります。 

 

Sea-Bird.cnv ファイルには複数のキャストのデータが含まれています。マルチキャスト.cnv ファイルはファイ

ルのヘッダーに特殊なキャスト説明行を含める必要があります。ファイル内のキャストごとに一つのキャスト

説明行がなければなりません。キャスト説明行は次のフォーマットでなければなりません： 

* cast 4 07 Jul 2015 09:00:29 samples 6415 to 7768, avg = 1, stop = mag switch 

ここで samples エントリはそれぞれのキャストの最初と最後のデータ行インデックスを指定します。* END *ヘ

ッダー終端子の後の最初のデータ行がデータ行インデックス 1 となります。 

 

Sea-Bird.cnv ファイルのデータは経度または緯度をファイルから取得できないとインポートされません。航海

名および／または測点名が見つからない場合、ODV はそれぞれ unknown とそのファイル名を割り当てます。 

 

Sea-Bird.cnv ファイルのインポート中に作成されたコレクションには、コレクションの misc/comments ディ

レクトリに自動的に作成されたコメントファイルの名前を測点毎に保持する Comments メタ変数が追加で含

まれています。コメントファイルには.cnv ファイルの先頭から抽出された全てのヘッダー行が含まれていま

おり、通常はセンサーの識別子やキャリブレーションデータなどの重要な情報が含まれています。Comments

メタデータ値をクリックすると Web ブラウザにコメントファイルの内容が表示されます。ODV は cnv ファ
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イルからオペレーターおよび ship/vessel メタデータを抽出し、その値を Operator および Ship メタ変数に

提供します。 

 

4.12 Associate Meta-variables ダイアログ（Associate Meta-variables Dialog） 

データをインポートするとき、ODV は自動的にインポートファイル内から航海名、測点名、観測日、経度、緯

度といった必須のメタデータの位置を突き止めようとします。このメタ変数の自動関連付けに失敗して既存の

コレクションにインポートする場合（インポートタイプ 1）、Associate Meta Variables ダイアログを表示して

（図 4-2 を参照）、ユーザーにメタデータのソースを手動で識別するように求めます。 

 

新しい関連付けを定義するには Source Variables リストと Meta Variables リストから関連付けたい変数を選択

して Associate を押します。インポート中に変換を実行するには Convert を押して使用可能な変換アルゴリズ

ムを一つ選択します。既存の関連付けを削除するには、それぞれの変数を選択して Undo を押します。インポ

ートファイルに所定のメタ変数に関する情報が含まれていない場合は、次の手順でデフォルト値を指定しま

す：（１）それぞれのメタ変数を選択し；（2）Set Default を押して（3）デフォルト値を入力します。指定し

たデフォルト設定がファイル内の全てのデータ行に使用されることに注意してください。完了したら OK を押

し、もしくは Cancel を押して読み込みを中止します。Longitude と Latitude のメタ変数は関連付けられている

必要があり（ODV は地理的位置がないと測点を処理できません）、そうでなければ OK ボタンは無効のままで

す。 

 

ISO8601 の日付と時刻の仕様 YYYY-MM-DDTHH:MM:SS.SSS のような複合ソース変数の関連付けまたは変

換の際には、複数のターゲットメタ変数（例えば年、月、日、など）が自動的に結合されます。 

 

図 4-2：Associate Meta Variables ダイアログ 

 

4.13 インポートオプションダイアログ （Import Options Dialog） 
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既存のコレクションにデータをインポートするとき（インポートタイプ 1）、Import Options ダイアログが表

示されるので、インポートファイルのソースデータ変数とターゲットコレクションのデータ変数を関連付けて

ください。インポートモードを選択し、インポートする測点がターゲットコレクションに既に存在するかどう

かを確認するために必要とされるパラメータを指定する事が出来ます（図 4-3 を参照）。 

 

 

図 4-3：インポートオプションダイアログ 

 

インポートモード（Import Mode） 

Add/Replace Station Data：インポートファイルからコレクションにデータを追加する場合はこのオプショ

ンを選択します。Check for existing stations ボックスがチェックされている場合、ODV はユーザー指定の

基準を適用して一致する測点をターゲットコレクションから検索し、見つかった場合はターゲットコレク

ション内の既存の測点をインポートファイルから新しいデータで置き換える許可を求めます（測点検索手

順の説明については下記 Station and Sample Match-ing Criteria を参照）。 

 

SDN データファイルまたは SDN ターゲットデータコレクションに SDN データコレクションをインポー

トするとき、LOCAL_CDI_ID, データバージョン、および EDMO コードを基に既知の同一測点を検索し

ます。バージョンが下位もしくは同じ既知の同一測点は上書きされます。 

 

Merge Data (selected variables)：一つ以上の変数のデータを追加し（変数の統合）、他の変数の既存のデー

タを変更しない場合はこのオプションを選択します。あるサンプルの統合変数の統合値は表 4-2 に示す
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ように既存のデータ値と新しいデータ値に依存します。このモードでは Check for existing stations ボック

スのチェックを外すことはできません。データを追加する前に ODV はコレクション内で一致する測点を

検索し（測点検索手順の説明については Station and Sample Matching Criteria を参照）、見つかった場合そ

のコレクションからオリジナルの測点を読み取り、選択した変数を追加して更新されたバージョンでオリ

ジナルの測点を置き換えます。一致する測点が見つからない場合はユーザーに通知します。 

 

Merge Data (selected variables)をインポートする場合、ターゲットコレクションの主要変数がソース変数

の一つに関連付けられていることを確認する必要があります。この関連付けはインポートしたデータを受

け取るサンプルを正しく識別するために必要です。主要変数が関連付けられていない場合 Import Options 

ダイアログ（図 4-3 を参照）の OK ボタンは無効になります。コレクションの主要変数を決定するにはオ

プション Collection > Properties > General を使用します。 

 

表 4-2：既存の値と読み込まれた値をマージした結果 

既存値 新値 統合値 

yes yes 既存と新しい値の平均 

yes no 既存値 

no yes 新値 

no no 欠測値 

 

Update Data (selected variables)：一つ以上の変数のデータを更新し（変数の更新）、他の変数の既存のデ

ータを変更しない場合はこのオプションを選択します。あるサンプルの更新変数の更新値は新しいデータ

値にのみ依存し、既存の値は破棄されます。このモードでは Check for Existing Stations ボックスのチェッ

クを外すことはできません。データを更新する前に ODV はコレクション内で一致する測点を検索し（測

点の検索手順の説明については下記 Station and Sample Matching Criteria を参照）、見つかった場合はコレ

クションからオリジナル測点を読み取り、選択された変数のデータを更新し、オリジナル測点を更新され

たバージョンに置き換えます。一致する測点が見つからない場合はユーザーに通知します。 

 

変数の関連付け (Variable Association) 

通常、インポートファイル内の変数の数、順序、および意味はターゲットコレクション内の変数の数、順

序、および意味とは異なり、実際のインポートが行われる前にソース変数とターゲット変数の間の接続を

確立する必要があります。最初に ODV は一致するラベル（名前と単位）を使用して変数を自動的に接続

しようと試み、ダイアログのソース変数リストとターゲット変数リストの中でアスタリスク「*」を使用

して関連付けされた変数に印を付けます。印付けられた変数をクリックすると接続相手の変数を識別でき

ます。 
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Import Options ダイアログでは追加の接続を手動で作成するか、既存の接続を元に戻すことができます。 

あるターゲット変数は複数のソース変数と接続する事ができます。 

 

ソース/ターゲット変数ペア間の接続を確立するには、それぞれのターゲット変数をクリックしてからタ

ーゲット変数に関連付けるソース変数をクリックして Associate または Convert ボタンのどちらかをクリ

ックします。インポートファイルのデータ値を変更せずにインポートする場合は Associate を使用し、イ

ンポート中に変換を実行する必要がある場合は Convert を使用します。Convert 変換を使用するときは事

前に定義された一般的に使用される変換（例えば単位変換）の中から選択することも、またはその代わり

に独自の一般的な一次変換式を確立することもできます。 

 

質量当たり（例えば μmol/kg）と体積当たり（例えば μmol/l）との単位間の変換のために一定密度値 ρ=1.025 

[kg/l]が使用されます。この特定の密度値は変換に必要な実験室条件（p=0 dbar; T=20°C）における平均海

水密度を表します。サンプルの実際の塩分値を使用しないことによってもたらされる誤差は、海洋環境で

は 0.2％未満です。μmol/kg と ml/l との間の酸素単位変換もまた ρ=1.025 [kg/l] の密度値および STP 

(Standard Temperature and Pressure (標準状態); T=0[℃], p=1[bar] )で 22.391 l のにおけるモル

O2 体積を使用します。 深度/圧力変換は適切な TEOS-10 関数を使用します。 

 

あるターゲット変数に対して複数のソース変数を接続できます。これはインポートファイル内の異なる測

点ごとに、あるターゲット変数（例えば Oxygen）のデータが異なる列（そしておそらく異なる単位、例え

ば Oxygen [μmol/kg]と Oxygen [ml/l]）にある場合に便利です。 

 

ソース/ターゲット変数接続の代わりに、インポートファイルに対応するソース変数が提供されていない

ターゲット変数にデフォルト値を指定する事ができます。あるターゲット変数にデフォルト値を設定する

には Target Collection リストでターゲット変数を選択し、Set Default ボタンを押してターゲット変数に希

望するデフォルト値を入力します。デフォルト値を使用するターゲット変数には「+」記号が付きます。

指定された値はこの操作中にインポートした全ての測点の全てのサンプルに使用されます。 

 

ターゲット変数に関連付けられていないソース変数はコレクションにインポートされません。データをコ

レクションに統合する場合は、ターゲットコレクションの主要変数とコレクションに追加する必要がある

変数のセットとの関連付けを確立する必要があります。コレクション内に変更を加えたくないデータが既

にある場合は変数を関連付けないでください。 

 

Import Options ダイアログの OK ボタンは、ターゲットコレクションの主要変数がいずれかのソース変数

に関連付けられるまで無効のままになります。 

 

測点とサンプルの合致基準（Station and Sample Matching Criteria） 

Check for existing stations ボックスをチェックした場合は Edit Matching Criteria…ボタンをクリックして、

インポートファイルの測点がターゲットコレクションの既存の測点の一つと合致するかどうかを判断し
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ます（Station Matching ページ；図 4-4 を参照）。インポートする測点とターゲット測点のサンプルを一

致させるための基準を変更することもできます（Sample Matching ページ）。サンプルマッチングは Merge 

Data (selected variables)および Update Data (selected variables)のインポートにのみ実行されます。 

 

Station Matching ページでは、インポートする測点とターゲット測点の位置、日付/時刻、および名前など

を比較するさまざまなテストをオンまたはオフにすることができます。要求されたテストが全て成功した

場合、二つの測点は合致すると見なされます。 経度、緯度、および時間の場合、インポート値とターゲッ

ト値が指定された許容範囲内であれば合致となります。 

 

インポートファイル内の航海ラベルがターゲットコレクション内の同じ測点の航海ラベルと異なる場合

は、Target collection cruise label コンボボックスで航海を選択し、Source file cruise label フィールドに別の

航海名を入力して Associate ボタンを押すと別の航海名として確立できます。インポートファイルで見つ

かった別の航海名は、測点マッチング手順が開始される前に対応するターゲット航海名に自動的に変換さ

れます。これはインポートファイルとターゲットコレクションで航海名の異なるバージョンが使用されて

いる場合に便利です（例えば図 4-4 の ANT XV/4 対 SR04_06AQANTXV_4）。別名が定義されていない場合

は正確なクルーズ名の合致が必要です。 

     

図 4-4：合致基準ダイアログの二つのページ 

 

コレクション内で合致するターゲット測点を見つけることに加えて、Merge Data（selected variables）と

Update Data (selected variables)のインポートを実行するとき、インポートする測点とターゲット測点のサ

ンプルも合致している必要があります。サンプルマッチングはインポートサンプルとターゲットサンプル

の主要変数値を比較し、最も近い合致を見つけることによって行われます。サンプルMatchingページでは

インポートサンプルとターゲットサンプルを合致と見なすためにどれだけ近いかを決定するパラメータ

を指定できます。Add non-matching samples as new samplesボックスがチェックされている場合、不一致サ

ンプルは新しいサンプルとしてターゲット測点に追加されます。それ以外の場合で一致しないサンプルは

無視され、警告メッセージがインポートログファイルに書き込まれます。 
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4.14 ファイルリストの生成（Generating File Lists） 

ODV には、複数ファイルのデータをインポートするための.lst ファイルを作成するために利用できる、組み込

みリストファイルジェネレータがあります。これらのリストファイルは大量の Argo、SDN、WOD、または

WOCE データファイルを一度に ODV にインポートする場合に便利です。リストファイルジェネレータを呼び

出すには Tools > List File Generator オプションを使用します。 

 

これらのファイルを生成するには、目的のファイルまたはディレクトリ全体をダイアログにドラッグ・アンド・

ドロップするだけです。ディレクトリをドロップすると、そのディレクトリまたはサブディレクトリ内の全て

のファイルがリストに追加されます。ファイル名の先頭または末尾を指定したフィルタを適用すると、フィル

タを満たすファイルだけがリストに追加されます。これらのフィルタはファイルをドロップする前に適用する

必要があります。これにより開始および／または接尾辞が異なるファイルのリストを作成できます。

Casesensitive check ボックスをチェックすると、大文字と小文字を区別するフィルタリングを有効にできます。

ファイルリストが作成されたら重複の除去、または Validate ボタンか Clear ボタンを押して現在の選択内容を

消去することもできます。個々のエントリはリストから直接削除または編集できます。 
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5 データのエクスポート（Exporting Data） 
 

5.1 スプレッドシートファイル（Spreadsheet Files） 

Export> Data> ODV Spreadsheet File を選択して、現在選択されている測点のデータを単一の汎用 ODV スプレ

ッドシートファイルにエクスポートすることができます。対象ディレクトリ、ファイル名、およびファイルタ

イプを選択してください。ODV スプレッドシートファイルのヘッダーを含むタブ区切りファイルをエクスポ

ートするには Spreadsheet File (*.txt)ファイルタイプ（デフォルト）を、または Excel で簡単に使うために

最適なコンマ区切りファイルをエクスポートするには Comma Separated File (*.csv)ファイルタイプを選

んでください。両ファイルタイプは ODV デスクトップアイコンにファイルをドロップするだけで ODV に再

インポートできます。ODV は列区切り文字の出現をエクスポートされるテキストから探索して、適切な代替

文字に置き換えることに注意してください。例えば csv エクスポートでは、テキスト中のコンマはセミコロン

に置き換えられます。 

 

次にエクスポートファイルに含める拡張メタ変数およびデータ変数を選択し（デフォルト：全ての拡張メタ変

数および全ての基本変数；実際にデータが含まれているデータ変数を選択する場合は Select Items with Data ボ

タンを押してください）、最後にエクスポートファイルのプロパティを指定します。Spreadsheet File Properties

ダイアログ（図 5-1 参照）では、欠測値を表す文字列（デフォルト：空の文字列）、経度の範囲（0～360°E

または-180～180°E）、メタデータ日付形式 (ISO8601 yyyy-mm-ddThh:mm:ss.sss または mon/day/year)、時系

列の日付/時刻値に使用される日付/時刻形式（ISO8601 yyyy-mm-ddThh:mm:ss.sss または Chronological Julian 

Days （訳注：CJD; Julian Day に 0.5 を加えてタイムゾーンを考慮したもの）または Decimal Time in years（十

進化年））を指定できます。Data date format エントリは時系列データに対してのみ有効になります。 

 

Data filter エントリでは、全てのデータをエクスポートするか、Spreadsheet File Properties ダイアログに続く

Sample Filter Settings ダイアログで指定できる品質および/または範囲選択基準を満たすサンプルのみをエクス

ポートするかを指定できます。Use compact format チェックボックスをチェックすると、測点メタデータは最

初のサンプルにのみエクスポートし、その他の全てのサンプルのメタデータフィールドは空のままになります。

このオプションを使用すると、特に CTD、XBT、および多くの種類の時系列データなど、一測点あたりのサン

プル数が多いデータの場合にエクスポートファイルのサイズが大幅に節約できます。メタデータおよび／また

はデータ変数の品質フラグ値を出力したくない場合は Export metadata quality flags または Export data quality 

flags ボックスのチェックを外してください。 

 

Export history ボックスがチェックされている場合、エクスポートした測点の履歴はスプレッドシートファイ

ルに書き出されます。履歴は//<History>のコメント行にまとめられ、所定の測点の履歴はその測点のデータの

後に書き出されます。 

 



Version 56.2 

 

68 

 

Export>Data ODV Collection を選択して、現在選択されている測点のデータを新しい ODV コレクションにエク

スポートできます。 次に新しいコレクションに含める変数（デフォルト：全ての変数）を選択し、標準のファ

イル選択ダイアログボックスを使用して保存先ディレクトリとファイル名を指定します。 

 

図 5-1：Spreadsheet File Properties ダイアログ 

 

5.2 NetCDF ファイル (NetCDF Files) 

Export > Data > NetCDF File を選択して、現在選択されている測点のデータを単一の NetCDF ファイルにエク

スポートできます。次にターゲットディレクトリとファイル名を選択し、エクスポートファイルに含める拡張

メタ変数およびデータ変数を選択し（デフォルト：全ての拡張メタ変数および全ての基本データ変数；実デー

タを含むデータ変数を選択する場合は Select Items with Data ボタンを押してください）、最後にエクスポート

ファイルのプロパティを指定します。NetCDF File Properties ダイアログでは経度の範囲（0～360°E または-

180～180°E）と、全てのデータ（サンプル）をエクスポートするか、現在の品質および／または範囲フィル

タを満たすものだけかを指定します。メタデータおよび／またはデータ変数の品質フラグ値をエクスポートし

たくない場合は Export metadata quality flags および／または Export data quality flags ボックスのチェックを外

します。Data filter エントリでは、全てのデータをエクスポートするか、NetCDF File Properties ダイアログに

続く Sample Filter Settings ダイアログで指定できる品質および／または範囲の選択基準を満たすサンプルのみ

をエクスポートするかを指定します。 

 

エクスポートした netCDF ファイルの構造は以下の通りです： 

次元： 

⚫ N_STATIONS にはファイルに含まれている測点の数が含まれています。 

⚫ N_SAMPLES には一測点あたりの最大サンプル数が含まれています。 

⚫ さらに、一次元以上の STRINGi という形式があり、ここで i は整数で、関連するテキスト変数の最

大文字数を表します。 

変数： 

⚫ longitude と latitude には測点の位置が保存されています。 
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⚫ date_time には、ある基準日からの測点のグレゴリオ暦の十進化日が含まれ、小数部は一日の端数を

表します。基準日には最も古い測点の年の 1 月 1 月が選択されています。 

⚫ 整数値 i を含む変数 metavari は他の ODV メタ変数の値を保存しています。全ての metavari 変数は

longitude, latitude および date_time と同様に N_STATIONS の次元にのみ依存します。 

⚫ Vari 形式の名前を持つ変数は ODV データ変数のデータ値を格納します。これらの変数は

N_STATIONS と N_SAMPLES の次元に依存します。 

⚫ 必要があればメタデータおよび/またはデータ変数の品質フラグ値は vari_QC 形式の名前を持つ変数

に格納されます。 

属性（主に標準の NetCDF 属性）： 

⚫ 最低限、品質フラグ変数を除く全ての netCDF データ変数は属性 long_name と_FillValue を含みます。

long_name は ODV で使用されている変数の名前を格納します。_FillValue は使用された欠測値を格納

します。一部の変数には属性 units、C_format、FORTRAN_format、valid_min、valid_max、および/また

は comment も含まれます。 

⚫ メタ変数 longitude, latitude および date_time はそれぞれ standard_name 属性値である longitudfe, 

latitude および time を格納します。長名 time_ISO8601 または Chronological Julian Date は standard_name

属性 time を持ちます。Ocean Profiles コレクションの基本変数は属性 positive の値 down を持ちます。 

⚫ NetCDF 品質フラグ変数は使用されている品質フラグスキームを説明する属性 Conventions および

comment を持ちます。 

 

データのソースおよびファイルの作成に使用されたソフトウェアに関する情報はグローバル属性で提供され

ます（表 16-6 を参照）。 

 

追加ファイル<nc filename> _nc_variables.txt が、関連する ODV メタデータおよびデータ変数名、単位、コメ

ントとともに NetCDF 変数名のリストを含む出力ディレクトリに作成されます。 

 

ODV の netCDF ファイルはチャンキングと圧縮を使用しているため、読み取りには netCDF4 ベースのツー

ルが必要です。 

 

5.3 WHP 交換フォーマットでのエクスポート (WHP Exchange Format Export) 

Export > Data > WHP Exchange File を選択して現在選択されている測点データを WHP 交換形式ファイルでエク

スポートできます。ODV は Description of WHP-Exchange Format for CTD/Hydrographic Data（James H. Swift 

＆ Stephen C. Diggs; September 2001, updated May 2006 & April 2008; 

http://cchdo.ucsd.edu/format/exchange/index.html）に記載されている Bottle および CTD 出力ファイ

ルの両方をサポートします。 

 

WHP Bottle または CTD エクスポートは次の手順で実行します： 

http://cchdo.ucsd.edu/format/exchange/index.html
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1. 必要に応じて地図領域を調整してエクスポートしたい測点のセットを選択および／または特別な測

点フィルタ設定を適用します。 

2. ODV のメインメニューから Export > Data > WHP Exchange File > Bottle または Export > Data > WHP 

Exchange File > CTD from の順に選択します。  

3. ODV が重要な変数を自動的に識別できない場合は、これらの変数を識別するように促されます： 

a. WHP ボトルのエクスポート：Pressure in Water Column[db]または Depth in Water Column[m]を

キー変数として特定する必要があります。 

b. WHP CTD のエクスポート：CTD として出力する場合は変数 Temperature [°C]および Pressure in 

Water Column[db]または Depth in Water Column[m]のいずれかが必要です。さらに Salinity [psu] 

と Oxygen を[μmol/ kg]または[ml / l]で識別するよう求められます。 

4. 出力ディレクトリとファイル名を指定します。 

5. WOCE ファイルのヘッダー（ファイルの最初の行）に必要な情報と、出力ファイルの一部にしたい

追加のコメントを指定します。 

 

エクスポートが完了するとファイルは手順 3 で指定した場所に書き込まれます。Bottle データをエクスポート

した場合、出力ファイルは"_hy1.csv"で終わる単一の CSV テキストファイルになります。CTD としてエクスポ

ートした場合、結果のファイルは出力された各測点に対して一つの CSV ファイルを含む接尾辞"_ct1.zip"を持

つ ZIP パッケージになります。 

 

WHP 交換ファイルでのエクスポートは主要変数（プロファイル）として圧力または深度を持つ ODV コレク

ションに対してのみ可能もしくは意味があります。コレクション内の深度値は WHP パラメータ CTDPRS に

書き込む前に圧力に変換されます。 

 

ODV 航海名は WHP パラメータ EXPOCODE、測点名は STNNBR、測点の日時情報は DATE と TIME の下に

エクスポートされます。欠落している時間と日付の情報は出力ファイルではゼロで示されるので、時間が不明

の場合その値は"0000"になります。位置は、緯度の場合は[-90、90]、経度の場合は[-180、180]の範囲で保

存されます。水深が ODV コレクションに存在する場合は、WHP パラメータ DEPTH に対応付けられます。 

ODV コレクションにメタ変数 SECT_ID が含まれている場合、その値は WHP パラメータ SECT_ID の下にエ

クスポートされます。 

 

WOCE WHP Bottle ファイルとしてエクスポートするとき、コレクションは変数 CASTNO、SAMPNO、およ

び BTLNBR についてスキャンされます。CASTNO（キャスト番号）がコレクションに含まれていない場合は

デフォルト値として 1 が使用されます。SAMPLNO（サンプル番号）が欠落している場合、ODV は 1 から始

まる連続サンプル番号を割り当てます。BTLNBR（ボトル番号）がコレクションにない場合、そのような列は

出力ファイルには現れません。他の全ての変数はコレクション内の名前を使用してエクスポートされます。エ
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クスポートされる測点セットでデータ値が含まれていない変数は出力ファイルから除外されます。ODV 派生

変数はエクスポートされません。 

 

コレクションが既に WOCE 品質フラグを使用している場合、品質フラグは保持されます。それ以外の場合、

コレクション内の品質フラグはエクスポート前に WOCE スキーマに対応付けられます（対応付けの詳細につ

いては ODV_QualityFlagSets.pdf を参照してください）。WHP CTD としてエクスポートする場合、出力品質フ

ラグは WOCECTD または GTSPP です（IGOSS と同じ）。WHP ボトルとしてエクスポートする場合、出力品

質フラグは WOCEBOTTLE，または、WOCECTD または GTSPP で使用される CTDSAL 変数または CTDOXY

変数、 および WOCESAMPLE または GTSPP で使用される BTLNBR 変数を除く GTSPP のいずれかです。 

 

5.4 SDN 集約 ODV コレクション (SDN Aggregated ODV Collection) 

Import > SeaDataNet Formats で作成されたデータコレクションは変数を自動的に集約し、Export > Data > SDN 

Aggregated ODV Collection で結果を新しいコレクションに書き込むことでさらに処理できます。 

 

集約を実行する前に ODV はまず http://vocab.nerc.ac.uk/collection/P35/current/から最新バージョンの P35

語彙をダウンロードします。P35 は寄与変数のリストと集約変数の優先単位を指定することによって多数の集

約変数を定義します。また ODV は ODV ウェブサイトから単位変換のリストの最新版をダウンロードします。 

インターネットに接続されていない場合 ODV はシステム上で利用可能なこれらのファイルの最新バージョン

を使用します。必要な単位変換は集計中に自動的に適用されます。P35 集約変数は SEADATANET 品質フラ

グスキームを使用します。 

 

出力コレクション内の変数の順序は次の通りです： 

⚫ ソースコレクションの主要変数、 

⚫ ソースコレクションで寄与変数が見つかった P35 集約変数、 

⚫ ソースコレクション内の P35 集約変数に寄与していない変数。 

 

ODV は P35 集約変数の値と品質フラグを計算するための二つのアルゴリズムを提供します：（a）利用可能

な最高品質の寄与値のみを使用する Best-of aggregation アルゴリズム、および（b）利用可能な全ての寄与値

を使用する Use-all アルゴリズムです。 

 

ODV では、使用されている元の変数の P01/P06 コードを含むサンプルごとの情報文字列を作成することもで

きます。 この機能により出所情報が提供され、実際に計算に使用された元のデータを追跡することができま

す。サンプルごとの情報文字列の作成と保存にはかなりのリソースが必要なので、詳細なバックトレーサビリ

ティが重要な場合にのみこの機能を使用してください。充分なストレージと長期処理時間に対する耐久性をも

っていないのであれば、数百万の測点や非常に多くの変数を含む大規模コレクションに情報文字列を作成する

のを防ぎます。 

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
http://vocab.nerc.ac.uk/collection/P35/current/
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P35 集約変数の値と品質フラグは次のようにして得られます： 

 

⚫ 一つの寄与変数のみにデータが含まれる場合 （only one contributing variable contains data）：値および

SDN 品質フラグを変更せずに使用します（Best of および Use-all アルゴリズムの両方で同じ手順）、 

⚫ 複数の寄与変数にデータが含まれている場合（more than one contributing variable contain data）：全て

の品質フラグを ODV スキームに対応付けし、最小（最高品質）および最大（最低品質）フラグ値を決

定します。その後で二つの集約アルゴリズムに対して異なる方法で処理します。 

（ａ）Best-of アルゴリズム：最小の ODV 品質フラグ値（最高の利用可能な品質；best-of）を有する寄与

値のみを使用します。 次に貢献度の最も高い値の中央値を計算します。最小の ODV 品質フラグを取り、

SEADATANET スキームに対応付けするか、あるいは、もし寄与値の全てのオリジナルフラグが同一であれ

ば、共通のオリジナルフラグ値を使用します。 

（ｂ）Use-all アルゴリズム：全ての寄与値の中央値を計算します。対応付けされた ODV 品質フラグ値の最

大値を取り、SEADATANET スキームに再び対応付けします。 

 

ODV は P35 Aggregation Properties ダイアログを表示し、アルゴリズムの選択とサンプルごとの情報作成のオ

ン/オフを切り替えを許可します。 

 

図 5-2：P35 Aggregation Properties ダイアログ 

 

出力コレクションを開いて、Collection > Browse Info File オプションを使用して未知の変換のリスト（存在す

る場合）および構築された P35 集計変数とその寄与入力変数のリストを表示できます。 
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寄与変数が未知の変換を必要とする場合、この入力変数は無視され、そのデータは集約に使用されません。 変

換に失敗した場合は reiner.schlitzer@awi.de に連絡して新しい変換を ODV 変換データベースに含めるように

依頼してください。 

 

5.5 SDN 整合 ODV コレクション（SDN Harmonized ODV Collection） 

Import > SeaDataNet Formats で作成されたデータコレクションは自動的に変数を整合させ、Export > Data > SDN 

Harmonized ODV Collection で結果を新しいコレクションに書き込むことでさらに処理できます。整合化は、同

じ P01 コードを有する変数の集約と同様に、優先されるターゲット単位への変換を含みます。 単位変換係数

と、整合化されている P01 コードのリストは、ファイル include/import/sdn_contaminants_conversions.xml か

ら読み込めます。整合された変数の名前、単位および説明は P01 altLabel および prefLabel エントリを使って

標準化されますが、値は変わらずに残ります。 

 

同じ P01 コードを持つ複数のソース変数を単一の整合変数に集約する場合、ODV は次の「最良」集約アルゴ

リズム：最小の ODV 品質フラグ値（最高品質；「最良」）の寄与値のみを使用し、「最良」寄与値の中央値

を計算して、SEADATANET スキームに戻って最小の ODV 品質フラグおよびマップを取得するか、または寄

与値の全てのオリジナルフラグが同一の場合は、共通のオリジナルフラグ値を使用します。 

 

作成された整合化された変数のリストは、寄与している元の変数のリストと共に Collection > Browse Info File

オプションを使用して閲覧できます。個々の整合された値のソース変数を明らかにする情報文字列は自動的に

作成されます。 

 

整合コレクション内の変数の順序は次のとおりです： 

⚫ ソースコレクションの主要変数、 

⚫ ソースコレクションで寄与変数が見つかった整合変数、ただし整合化された変数のラベルはアスタ

リスク*から始まることに注意、 

⚫ 整合ファイルで見つからなかったソースコレクションの整合化されなかった変数。 

 

5.6 データおよび格子場のクリップボードへのコピー（Clipboard Copy of Data and 

Gridded Field Values）  

データウィンドウの X, Y, Z データは、データ位置での格子化不適合および自動生成された格子上の格子化値

（格子化がオンの場合は後者の二つのみ）とともに、ウィンドウポップアップメニューの Extras > Clipboard 

Copy オプションを使用してクリップボードにコピーされます。ショートカットとして、マウスが特定のウィ

ンドウ上にある間に Ctrl-C を押してください。ODV はデフォルトでオリジナルの X と Y の値を出力しますが、

ユーザーはウィンドウの現在の投影によって生成された投影値も要求することができます。ODV がデータを

クリップボードにコピーしたら、クリップボードの内容をお気に入りのソフトウェアに貼り付けてさらに処理

mailto:reiner.schlitzer@awi.de
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することができます。マップウィンドウをクリップボードにコピーすると測点の位置やその他のメタデータを

含むリストが作成されます。 

 

5.7 等値面データのエクスポート (Exporting Isosurface Data) 

現在地図上に表示されている全ての測点の等値面データは Export > Isosurface Variables を選択し、ターゲット

ディレクトリと出力ファイル名を選択してエクスポートできます。出力ファイルは測点のメタデータを含み、

汎用 ODV スプレッドシートフォーマットに準拠しています。 

 

5.8 ウィンドウデータのエクスポート（Exporting Window Data）  

ODV メニューバーから Export > Window Data> Map or Window n を選択すると、ODV プロットウィンドウに表

示されている X, Y, Z のデータ値を ASCII ファイルにエクスポートできます。ターゲットディレクトリとフ

ァイル名を選択してください。あるウィンドウが gridding に切り替えられていたら、元のデータ値と共に、

データ位置において格子化に不適な、もしくは（自動生成された）格子点上における格子点値および「貧困な

評価エラー」のエクスポートを選ぶことができます。 

 

5.9 参照データセットのエクスポート（Exporting Reference Datasets） 

ODV のメニューバーから Export > X, Y, Z Window Data as Reference を選択して現在のプロットウィンドウの元

のデータを別の ASCII ファイルに保存し、後でこれらのデータを reference datasets として使用できます。ID 

String フィールドに参照データを識別する説明テキストを入力して OK をクリックしてください。ODV はユー

ザーの ODV ディレクトリにサブディレクトリ<documents>\ ODV\reference\<ID String>を作成し、全てのファ

イルをこのディレクトリに書き出します。ディレクトリが既に存在する場合、ODV は続行する前に現在の内

容を削除する許可を求めてきます。参照データは差分変数を定義するために ODV によって使用されます。 
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6 派生変数 (Derived Variables) 

 

コレクションファイルに保存されている基本変数に加えて、ODV は（一度定義すれば）解析に利用可能で、

基本変数と同様にデータプロットの中で使用できる多数の派生変数を計算できます。派生変数は三種類ありま

す： 

⚫ 海洋物理学および海洋化学で一般に使われるパラメータを含む組み込み派生変数。 

⚫ 任意の ODV コレクションで使用するためにファイルに格納したユーザー定義式のマクロファイル。 

⚫ 現在のコレクションに対してのみ、ユーザーがその場で(on-the-fly)定義した数式。 

 

派生変数を定義または削除するには Current Sample Window ポップアップメニューから Derived Variables オプ

ションを選択するか、メニューバーから View > Derived Variables を選択してください。マクロを追加するには

Choices リストから Expressions, Derivatives, Integrals > Macro File の順に選択してください。ユーザー定義式を

追加するには Expressions, Derivatives, Integrals > Expression を選択してください。組み込み派生変数を追加する

には Choices リストで他の項目を選択してください。 

 

Load from View File ボタンをクリックしてビューファイルから派生変数を読み込むこともできます。ビューフ

ァイルは現在開いているコレクションに属している必要があります。 

 

6.1 組み込み派生変数 (Built-in Derived Variables)  

ODV ソフトウェアには、ポテンシャル水温（温位）、ポテンシャル密度（任意の基準圧力に対する）、中立

密度、ブラントーバイサラ振動数(Brunt-Väisälä Freqency)、力学高度など、多くの海洋物理パラメータの

アルゴリズムが組み込まれています。さらに海水中の二酸化炭素システムのさまざまなパラメータ、多くの

ガス飽和濃度および分圧、そして海洋化学における他の多くの変数も、容易に選択可能な派生変数として利

用可能です。鉛直積分や微分と同様に二つの任意の変数の比のようないくつかの有用な数式もまた利用可能

です。 

Physical Properties（TEOS-10）派生変数グループ（バージョン 4.4.2 の新機能）は、以前の EOS-80 ベースの変

数を置き換え、20 を超える新しい変数を追加しました。下位互換および比較研究を可能にするために Physical 

Properties（EOS-80）派生変数グループはまだ維持されています。 通常は Physical Properties（TEOS-10）グル

ープからの派生変数を使用するべきです。 

 

利用可能な組み込み派生変数の完全なリストを以下に示します。これらの変数は全てユーザーが要求できます。

測点データがメモリに読み込まれると、ODV は要求された全ての派生変数の値を計算します。要求された派

生変数はコレクションファイルに格納されている基本変数と同様に使用および視覚化できます。 

 

組み込み派生変数を定義または削除するには Current Sample Window ポップアップメニューから Derived 

Variables オプションを選択してください。ODV は利用可能な定義済みの派生変数のリストを表示します。利
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用可能な派生変数はテーマ別グループにまとめられて Choices リストに表示されます。 最近使用されたテーマ

別グループが最初に展開されます。他のグループはそれらの名前をクリックすると展開されます。 

 

特定の派生変数を追加するには、Choices リストでこのエントリを選択して（最初に変数が属するグループを

展開する必要があるかもしれませんが）Add を押してください。派生変数がポテンシャル水温（温位）やポテ

ンシャル密度の基準圧力のような追加情報を必要とする場合、ODV は自動的にこの情報を要求します。多く

の派生変数も派生変数の計算に必要な入力変数(群)の識別を必要とします。このキー変数の識別は一度だけ行

う必要があり、関連付けは ODV によって記憶されることに注意してください。必要に応じて Collection > 

Identify Key Variables オプションを使用して、主要変数の関連付けを確認および変更します。主要変数の関連

付けが正しくなければ派生変数の計算値を間違える可能性があります。 

 

派生変数を削除するには Already Defined リストボックスでこの変数を選択して Delete を押すか、削除する項

目を単にダブルクリックしてください。他の派生変数への入力として要求される変数を削除すると、これらの

子変数も削除されることに注意してください。派生変数のパラメータまたは ODV マクロと数式を編集するに

は（これらの特別な派生変数の詳細については下記を参照）、Already Defined リストボックスでそれぞれの変

数を選択して Edit を押してください。 

表 6-1：組み込み派生変数のリスト 

Variable (変数) 注釈 

Carbon  (炭素) 

Alkalinity (アルカリ度) (任意の C 入力ペア)[μmol/kg] (詳細) 

CO*2 (任意の C 入力ペア) [μmol/kg] (詳細) 

CO3
2- (任意の C 入力ペア) [μmol/kg] (詳細) 

DIC (任意の C 入力ペア) [μmol/kg] (詳細) 

fCO2 (任意の C 入力ペア) [μAtm] (詳細) 

HCO3- (任意の C 入力ペア) [μmol/kg] (詳細) 

OmegaA (任意の C 入力ペア) (詳細) 

OmegaC (任意の C 入力ペア) (詳細) 

pCO2 (任意の C 入力ペア) [μAtm] (詳細) 

pH (任意の C 入力ペア) (詳細) 

Revelle Factor (訳注：大気から海洋への CO2 吸収能力の指標) 

(任意の C 入力ペア) 

(d fCO2 / d TCO2) / (fCO2 / TCO2). (詳

細) 

Expressions, Derivatives, Integrals (数式、微分、積分) 



ODV User’s Guide 

 

77 

 

Derivative (微分) 任意の変数(詳細) 

Derivative (二次微分) 任意の変数 

Expression (式) ユーザー定義式 

Integral (積分) 任意の変数(詳細) 

Macro File (マクロファイル) マクロファイルからのユーザー定義表現 

Ratio (比率) 任意の二つの変数 

Gases (ガス) 

AOU [μmol/kg] 

みかけの酸素消費量 AOU = Oxy(飽和

量)-Oxy(現場測定値), ここで Oxy(飽和

量)は，Weiss, Deep Sea Res., 17, 

721-735, 1970 のアルゴリズムを用い

たサンプルのポテンシャル水温および塩

分から計算される。 

CFC-11 Saturation (飽和度) [%] 
Warner & Weiss, Deep Sea Res., 32,1485-

1497, 1985  

CFC-12 Saturation [%] 
Warner & Weiss, Deep Sea Res., 

32,1485-1497, 1985  

CFC-10 Saturation [%] 
Bullister & Wisegarver, Deep Sea Res., 

45,1285-1302,1998 

CFC-113 Saturation [%] 
Bu & Warner, Deep Sea Res., 42,1151-

1161,1995  

CH4 Saturation [%] 
Wiesenburg & Guinasso, J. Chem. Eng.  

Data, 24,356-,1979  

Oxygen Saturation (酸素飽和度) [%] Weiss Deep Sea Res., 17, 721-735, 1970  

pCFC-11 [pptv] 
Warner & Weiss, Deep Sea Res., 

32,1485-1497, 1985 

pCFC-12 [pptv] 
Warner & Weiss, Deep Sea Res., 

32,1485-1497, 1985  

pCFC-10 [pptv] 
Bullister & Wisegarver, Deep Sea Res., 

45,1285-1302,1998 

pCFC-113 [pptv] 
Bu & Warner, Deep Sea Res., 42,1151-

1161, 1995 

pCH4 [ppbv] 
Wiesenburg & Guinasso, J. Chem. Eng. 

Data, 24,356-,1979 
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pSF6 [pptv] 
Bullister, Wisegarver & Menzia, DSR-I, 49 

(1), 175-187,2002  

SF6 Saturation [%] 
Bullister, Wisegarver & Menzia, DSR-I, 49 

(1), 175-187, 2002  

Metadata (メタデータ) 

Cruise ID 航海毎の固有 ID 

Latitude (緯度) 測点緯度から導いた十進角緯度 

Longitude (経度) 
測点経度から導出された十進角経度(現在

の地図領域に調整) 

Meta Variable Value (メタ変数値) メタ変数の数値 

Station Number (測点番号) Station ラベルから派生した番号 

Physical Properties (TEOS-10) 

Absolute Salinity SA（絶対塩分）[g/kg]  TEOS-101)  

Absolute Salinity at Freezing Point（氷結ポイント絶対塩分）               

[g / kg] 

TEOS-101)  

Adiabatic Lapse Rate Γ（断熱経過率）[mdegC/dbar]  TEOS-101)  

Brunt-Väisälä Freqency（ブラントーバイサラ振動数）[cycl/h]  (詳細)  

Cabbeling Coefficient CΘb （キャベリング係数） [10-6 K-2]  TEOS-101)  

Conservative Temperature Θ（保存温度）[degC]  TEOS-101)  

Depth from Pressure [m] TEOS-101)  

Dynamic Enthalpy（動的エンタルピー）[kJ/kg]  TEOS-101)  

Dynamic Height（力学高度）[dyn m]  TEOS-101, 3) （任意の基準圧力）  

Freezing Temperature Θf（凍結温度）[degC]  TEOS-101)  

In situ Density Anomaly σ （現場密度偏差）[kg/m3]  TEOS-101) （現場圧力、水温、塩分を使

用）  

In situ Temperature from Conservative Temperature（保存水温

からの現場水温）[degC]  

TEOS-101) （現場圧力と保存水温を使

用） 

Isentropic Compressibility κ（等エントロピー圧縮率）     

[10-10 Pa-1]  

TEOS-101)  

Latent Heat of Evaporation（蒸発潜熱）[kJ/kg]  TEOS-101)  

Latent Heat of Melting (融解潜熱) [kJ/kg]  TEOS-101)  
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Neutral Density γn (中立密度) [kg/m3]  Jackett & McDougall, J. Phys. Ocean., 

237-263, 1997 (他)  

Potential Density Anomaly σ（ポテンシャル密度偏差）[kg/m3]  TEOS-101) （任意の基準圧力参照）   

Potential Temperature θ（ポテンシャル水温）[degC]  TEOS-101) （任意の基準圧力参照）   

Potential Vorticity Q (ポテンシャル渦度) [10-12 m-1 s-1]  潜在的な渦度（ブラント―バイサラ振動

数 Q = f / g * N2 から派生）  

Practical Salinity from Absolute Salinity（絶対塩分からの実用塩

分） 

TEOS-101)  

Practical Salinity from Conductivity（導電率からの実用塩分） TEOS-101)  

Preformed Salinity S*（予備塩分）[g/kg]  TEOS-101)  

Pressure from Depth [dbar]  TEOS-101)  

Reference Salinity SR （参照塩分）[g/kg]  TEOS-101)  

Saline Contraction Coefficient βΘ（生理食塩水収縮係数）    

[10-3 kg/g]  

TEOS-101)  

Sound Speed（音速）[m/s]  TEOS-101)  

Specific Enthalpy h（比エンタルピー）[kJ/kg]  TEOS-101)  

Specific Entropy η（比エントロピー）[J/(kg*K)] 
TEOS-101)  

Specific Heat Capacity Cp（比熱容量）[J/(kg degC)] 
TEOS-101) 

Specific Internal Energy u（比内部エネルギー）[kJ/kg]  
TEOS-101) 

Specific Volume Anomaly（比容積偏差）[mm3/g] 
TEOS-101,2) 

Spiciness τ0 TEOS-101), McDougall and Krzysik, J. of 
Marine Research, 73, 141-152, 2015 

Spiciness τ1 TEOS-101), McDougall and Krzysik, J. of 
Marine Research, 73, 141-152, 2015 

Spiciness τ2 TEOS-101), McDougall and Krzysik, J. of 
Marine Research, 73, 141-152, 2015 

Stability Ratio Rρ（安定比） TEOS-101) 

Thermal Expansion Coefficient αΘ（熱膨張率）[10-6 K-1] 
TEOS-101) 

Thermobaric Coefficient TΘb （熱圧係数）[10-12 K-1 Pa-1] TEOS-101) 

Turner Angle Tu （二重拡散対流に対する非粘性海水の局所安

定性） 

TEOS-101) 

Physical Properties (EOS80)  

Depth from Pressure (EOS80) [m] Saunders and Fofonoff, Deep-Sea 

Res., 23, 109-111, 1976 
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Freezing Temperature (凍結温度）(EOS80) [degC] F. Millero, UNESCO Tech. Papers in 

the Marine Science, No.28, 29-35, 

1978  

In situ Density Anomaly（現場密度偏差） (EOS80)  [kg/m3] EOS80 

In situ Temperature (現場水温) (EOS80) [degC] EOS80 

Potential Density Anomaly  (ポテンシャル密度偏差) (EOS80)                

[kg/m3] 

EOS80 (任意の基準圧力) 

Potential Temperature (ポテンシャル水温) (EOS80) [degC]  Bryden, Deep Sea Res., 20, 401-

408, 1973 (任意の基準圧力) 

Pressure from Depth (EOS80) [dbar] Saunders, J. Phys. Ocean., 1981  

Sound Speed （音速）(EOS80) [m/s]  Fofonoff & Millard, Unesco Tech. Pa. 

in Mar. Sci., No. 44, 53 pp, 1983  

Specific Heat Capacity Cp（比熱容量）(EOS80) [J/(kg degC)]  F. Millero et al, J. Geoph. Res., 78, 

4499-4507, 1973  

Specific Volume Anomaly（比容積偏差）(EOS80) [mm3/g]  EOS80（任意の参照塩分および水温） 

Special 

Aggregated Variable（集約変数） (詳細) 

Converted Variable（変換済変数） (詳細) 

Data Error Value （データエラー値） 任意の変数の 1-σ データエラー値 

Difference from Reference Data （参照データとの差異） (詳細) 

Interpolated Variable （補間変数） 欠損データを補間値に置き換える 

Patches（パッチ） (詳細) 

Quality Flag Value（品質フラグ値） 変数の品質フラグ値 

String ID（文字列 ID） 任意の TEXT または INDEXED_TEXT メ

タまたはデータ変数の異なる文字列値に

対する整数 ID 値。 

Time （時間） 

Day of Month (station date) 測点日付から派生した十進数表記の月内

通算日 4) 

Day of Month (time variable) 時間変数から派生した十進数表記の月内

通算日 4） 
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Day of Week (station date) 測点日付から派生した十進数表記の曜日

4) 

Day of Week (time variable) 時間変数から派生した十進数表記の曜日

4) 

Day of Year (station date) [days] 測点日付から派生した十進数表記の年内

通算日 4) 

Day of Year (time variable) [days] 時間変数から派生した十進数表記の年内

通算日 4) 

Day Time (station time) [hours] 測点時刻から派生した十進数表記の日内

時間 

Day Time (time variable) [hours] 時間変数から派生した十進数表記の日内

時間 

Month of Year (station date)  測点日付から派生した十進数表記の年内

月 5) 

Month of Year (time variable) 時間変数から派生した十進数表記の年内

月 5） 

Time (station date/time) 測点日時から派生した十進化時間 

Time (time variable) 時間変数から派生した十進化時間 

Year (station date) 測点日付から派生した整数年 

Year (time variable) 時間変数から派生した整数年 

 
1) IOC、SCOR and IAPSO, 2010:The international thermodynamic equation of seawater -  2010: Calculation and 

use of thermodynamic properties. Intergovernmental Oceanographic Commission, Manual and Guides No..56, 

UNESCO (English), 196 pp. 

2) TEOS-10 の比体積偏差は絶対塩分 SA = 35.16504 g/kg および conservative temperature Θ= 0°C を基準として計算される

ことに注意してください。これは実用塩分 SP = 35 psu および現場水温 t = 0°C を基準とした従来の定義とは異なります。 

深海では、値の相対差が 25％に達することがあります。 

3) TEOS-10 比体積偏差(上記 2
)参照)を用います。 

4) 昼間による端数日を含みます。 

5) 月の日と昼間による端数月を含みます。 

 

ブラント―バイサラ振動数（Brunt-Väisälä Freqency） 

ブラント―バイサラ振動数は次のように計算されます：与えられたプロファイルに対して、ODV は最初に一

連の標準層深度を設定し、観測された圧力、水温、塩分を投影します。次に、ブラント―バイサラ振動数が標

準層深度の間隔毎に（新しい TEOS-10 状態方程式 2010 から計算された鉛直密度勾配を使用して）計算され、

間隔の中間点に割り当てられます。最後に、中間点の Brunt-Väisälä 振動数値がプロファイルの元の圧力（ま

http://www.teos-10.org/pubs/TEOS-10_Manual.pdf
http://www.teos-10.org/pubs/TEOS-10_Manual.pdf
http://www.teos-10.org/pubs/TEOS-10_Manual.pdf
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たは深度）値に投影されます。値の投影は線形最小二乗補間を使用して行われます。ODV は N2 ではなく N を

計算することに注意してください。不安定な成層（負の値の平方根）の場合、絶対値の平方根がとられ、負の

符号が割り当てられます。したがって ODV における N の負の値は不安定な状態を示します。ODV は計算を

開始する前に（Good Coverage Criteria をチェックして）測点に十分な入力データが含まれていることを確

認します。データが不足している測点はスキップされます。 

 

海水中の二酸化炭素システムのパラメータ（Parameters of the carbon dioxide system in 

sea water） 

 

海水中の二酸化炭素システムの以下のパラメータは、派生変数として提供されています： 

1. アルカリ度 (ALK)、 

2. 溶存無機炭素 DIC、 

3. CO2 の逃散および分圧（fCO2 及び pCO2 ）、 

4. CO*2, CO32-, および HCO3-の濃度、 

5. pH（Total, SWS, 又は Free scale） 

6. Revelle または均一のバッファ、ファクタ 

7. カルサイトとアラゴナイトの飽和度 [CO32-]*[Ca2+]/Ksp を示す OmegaC と OmegaA 

 

これらの量は全て、次のいずれかの炭酸系入力データペアを使用して計算できます： 

1. ALK, DIC  
2. ALK, pH  
3. ALK, fCO2  
4. ALK, pCO2  
5. DIC, pH  
6. DIC, fCO2  
7. DIC, pCO2  
8. fCO2, pH  
9. pCO2, pH.  

 

これらの炭酸系パラメータの一つを定義するには、Derived Variables ダイアログの Choices リストでそれぞれ

のエントリを選択して Add を押してください。図 6-1 の炭酸系パラメータ設定ダイアログが表示され、要求

された変数に対してさまざまな設定を定義できます。 

 

Equilibrium constants コンボボックスでは文献毎に異なる計算に使用する平衡定数を選択できます。Input ボッ

クスではデータ入力ペアと入力データが測定された条件を指定できます。Output ボックスでは要求された変

数を計算する出力条件を指定できます。要求された変数の種類および選択された Input variables に応じて、い

くつかのエントリは関連性がなく隠されています。 
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以下の変数 pH、fCO2 または pCO2 のいずれかが選択された入力変数に含まれる場合、これらの変数が測定され

たときの圧力と水温を指定する必要があります。pH が入力変数の一つである場合は pH 値が報告される pH ス

ケールを指定する必要もあります。入力圧力の可能な選択肢は(1)In-situ pressure, (2)Select pressure variable お

よび(3)Enter your pressure value here です。入力値が現場圧力である場合は(1)を選択し、データ変数の一つが

入力圧力値を含む場合は(2)を選択し（それぞれの変数は後で識別されます）、実験室の条件など、測定が固

定圧力で行われた場合は(3)を選択します。値を入力するには Enter your pressure value here テキストを選択し

て数値に置き換えます。 

 

入力水温には四つの選択肢があります：(1)In-situ temperature, (2)Potential temperature, （3）Select temperature 

variable および（4Enter your temperature value here で、選択と手順は上記の圧力と同じです。 

 

要求された派生変数が以下の pH、fCO2、pCO2 のいずれかである場合、これらの変数が計算される出力圧力と

水温条件を指定しなければなりません。要求された派生変数が pH の場合は出力 pH スケールを指定する必要

もあります。 

 

平衡定数 (Best Practices Handbook 2007) の推奨される選択は KF を除いて Dicksonet al. (2007)に従ってい

ます：K1 と K2 は Luecker et al. (2007), K0 は Weiss (1974), KS は Dickson (1990), KF は Dicksonand Riley 

(1979), KW は Millero (1995), K1p, K2p, K3p および KSi は Millero (1995) からのもので、カルサイト（方解石）

およびアラゴナイトの溶解度積 Ksp は Mucci（1983）からのものです。平衡定数の圧力依存性は Millero (1995) 

によるものです。 Lewis and Wallace (1998) に要約されている様々な出版物の誤字が考慮されています。 

 

図 6-1：炭酸系パラメータ設定ダイアログ 

 

リン酸塩および/またはケイ酸塩のデータが利用できない場合、それらの濃度値はゼロと仮定されます。 ODV

は Dickson (1981) のアルカリ度の定義を使用して HS, S および NH 3 を除く全ての項目を扱います。pH は反

復ニュートン法を用いて計算されます。 
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Lavigne et al. (2008)の SeaCarb バージョン 2.1.2 ソフトウェアと Matlab 版の CO2SYS v1.01 (Lewis 

and Wallace, 1998; マイアミ大学の Denis Pierrot によって Matlab に移植された) は同じサンプルデータ

で実行され、ODV による全ての炭酸系パラメータについて優れた一致が見られました。  

 

Dickson A. G.，Sabine C. L.. & Christian J. R., 2007. Guide to best practices for ocean CO2 measuremnts. PICES Special 

Publication 3:1-191.  （訳注：日本語訳版は https://www.nodc.noaa.gov/ocads/oceans/Handbook_2007.html より入手でき

る） 

Lavigne, H., A. Proye, J.-P. Gattuso., 2008.SeaCarb：Calculates parameters of the seawater carbonate system. R package 

version 2.1. http://www.obs-vlfr.fr/~gattuso/seacarb.php [Version: June/10/2009]. 

Lewis, E., and D. W. R. Wallace. 1998. Program developed for CO2 System  Calculations. ORNL/CDIAC-105. Carbon Dioxide Information 

Analysis Center, Oak Ridge National Laboratory, U.S. Department of Energy. Oak Ridge, Tennessee. http://cdiac.ornl.gov/oceans/co2rprt.html. 

 

微分（Derivative） 

主要変数に関する微分を計算する変数を選択します（以下で A と指定します; 基本または定義済みの派生変数

を使用できます）。計算は三つのステップで進行します: (１)観測値Ａを主要変数の密集した間隔の標準値の

セットに補間し; （2）微分を標準の中間値で計算し; (3）微分値を元のサンプルの主要変数値に逆補間しま

す。ODV は計算を開始する前に（Good Coverage Criteria をチェックして）測点に十分な入力データが含ま

れていることを確認します。データが不足している測点はスキップします。 

 

積分（Integral） 

主要変数に沿った積分を計算する変数を選択し（以下で A と指定します; 基本または定義済みの派生変数を使

用できます）、積分の開始一次変数値 z0 を指定します（デフォルト：0）。所定の測点の各サンプルに対して、

ODV は z0 からそれぞれの主要変数レベルまでの積分 A*dz を計算します。 

 

積分の単位は量 A の単位に主要変数の単位を掛けたものです。主要変数が深度であり、変数Ａが体積濃度単位

（例えば、１立方メートル当たりのモル数）を有する場合、計算された積分は 1 平方メートル当たりの現存量

に等しくなります。定義により z0 における積分値はゼロであることに注意してください。また ODV は計算を

開始する前に（Good Coverage Criteria をチェックすることによって）測点に十分な入力データが含まれて

いることを確認します。データが不足している測点はスキップします。 

例（主要変数として深度を仮定）：海水の上部 500m の塩分含有量を求めるには、積分の変数として塩分を選

択し、開始値として 0 を使用します。次に 500m での鉛直積分値を（隣接点間を補間することによって）調

べるか、または SURFACE モードで等値面変数として depth=500 での積分を定義します。 

 

集約変数 (Aggregated Variable） 

https://www.nodc.noaa.gov/ocads/oceans/Handbook_2007.html
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集約派生変数は一つ以上の入力変数のデータ値を単一の変数に結合します。これは酸素のようなパラメータが

異なる研究所で測定され、かつ異なる単位を使用して別々の元の酸素変数として報告されている場合に便利で

す。集約派生変数は科学分析のためにさまざまな元の変数を（おそらく単位変換も含めて）単一の変数に統合

することを可能にします。集約変数値の計算は指定されたサンプルの入力変数の値を使用してサンプルごとに

行われます。 

集約派生変数を定義するには、Special グループで Aggregated Variable を選択して Add を押してください。続

いて自動的に現れるダイアログで集約変数に寄与する全ての入力変数を選択し、そして新しい変数の名前と単

位を入力してください。 

 

図 6-2：Aggregated Variable ダイアログ 

 

その後 Aggregated Variable ダイアログが表示されるので（図 6-2 参照）、そこで集約変数のプロパティを微調

整してください。寄与する入力変数ごとに、入力変数の値を集約変数の単位に変換するために使用される適切

な単位変換を指定することが重要です。最初は全ての変換が Identity Transformation,すなわち「入力値を変

更せずに使用」に設定されています。入力変数の変換を定義するには Contributing Variables リストで入力変数

を選択して Conversion ボタンをクリックしてください。次に Conversion コンボボックスから変換の一つを選

択してください。目的の変換がリストに含まれていない場合は General Linear Transformation を選択して独自

の係数とオフセットを指定してください。 

 

単一の集計値が複数の入力値からどのように取得されるかを定義する三つの異なる集計モード：（1）Exclusive, 

(2)Average, (3)Median があります。Exclusive 集計は指定された入力変数の順序で最初に使用可能なデータ値

を使用します。一方 Average モードまたは Median モードでは特定のサンプルについて使用可能な全ての入力

値の平均値または中央値を計算します。 
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入力変数を追加または削除するには Add ボタンと Delete ボタンを使用してください。選択した入力変数の変

換を変更するには Conversion をクリックしてください。デフォルトの変換である Identity Transformation では

入力値は変更されません。必要に応じて Top、Up、Down、Bottom ボタンを使用して入力変数の順序を変更し

てください。Exclusive 集計（デフォルト）では入力変数の順序の中で最初に使用可能な値が使用されるため、

入力変数の順序が重要になります。OK を押して集約変数の定義を完成させてください。 

 

もし一つ以上の入力変数が文字値なら、集約変数もまた、全入力変数の文字値の結合で表される文字値になり

ます。 

 

変換された変数 (Converted Variable)  

変換された派生変数は、さまざまな単位である変数のデータを提供します。変換後の派生変数を定義するには、

Special グループの Converted Variable を選択して Add を押してください。次に、変換する入力変数を選択して

新しい変数の名前と単位を入力し、使用する単位変換を指定してください。目的の変換がリストに含まれてい

ない場合は General Linear Transformation を選択して独自の係数とオフセットを指定してください。 

 

6.2 マクロ（Macros） 

特定のサンプルに対する新しい派生変数の値が、同じサンプルの他の変数値にのみ依存するという条件で、組

み込み派生変数のリストに含まれていない新しい派生変数を実装できます。新しいマクロを定義するには

ODV Macro Editor（下記参照）を使用して、マクロが依存する入力変数と値の計算に使用される代数式を指定

します。その後この情報をマクロファイルに保存します。 

 

現在のサンプルウィンドウのポップアップメニューから Derived Variables を選択して Choices リストから

Expressions, Derivatives, Integrals > Macro File を選択し、保存されているマクロのいずれかを選択します。その

後、マクロの計算に必要な入力変数を特定します。必要な変数の一つが利用できない場合マクロの設定を中止

するために Not Available を押します。 

 

6.2.1 マクロ編集（Macro Editor） 

Tools > Macro Editor を使用して Ocean Data View マクロファイルを編集または作成します。既存のマクロフ

ァイルを選択するか新しいマクロ名を選択して以下の手順に従ってマクロを定義します。Save As を押してマ

クロ名を指定してマクロをファイルに保存してください。 

 

マクロ変数 （Macro Variable） 

Label: マクロ変数のラベル名を入力。ギリシャ記号、(累乗の、べき)指数、(対数の)指標に関する書式制御シ

ーケンスが使用できます。 
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Units: マクロ変数の単位を入力する。ギリシャ記号、(累乗の、べき)指数、(対数の)指標に関する書式制御シ

ーケンスが使用できます。 

Digits:現在のサンプルウィンドウにおいて値を表示する有効桁数を入力します。 

 

コメント (Comments)  
マクロ変数を説明する一行以上のコメント行を入力します。 

 

入力変数 (Input Variables)  

マクロ変数に必要な入力変数を指定します。入力変数を追加するには、そのラベルと単位 New 欄に入力して

<<ボタンを押します。ギリシャ記号、(累乗の、べき)指数、または(対数の)指標の書式制御シーケンスを使用

できます。定義された入力変数を削除するには Defined リストボックスのエントリを選択して<<ボタンを押し

てください。入力変数の数は制限されません。 

 

 

図 6-3：マクロエディタ・ダイアログ 
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式 （Expression） 

Expression in Postfix Notation 欄内にマクロの評価時に実行される代数演算を指定します。式は非演算子が演算

子より先行するポストフィックス記法(後置記法; 逆ポーランド記法としても知られる)で記述する必要があ

ります。もしポストフィックス記法に慣れていなければ Enter Infix Expression ボタンをクリックしてからイン

フィックス記法（中置記法）で式を入力してください。ODV はインフィックス記法の式を変換して Postfix 

Notation 欄に置きます。あるいは Tools > Infix-to-Postfix Converter オプション（ウィンドウズでのみ使用可能)

は、Expression in Postfix Notation 欄内でインフィックス記法の数式からポストフィックス記法に変換するため

に使用できます。 

 

式は一行以上の非演算子と演算子の列で構成します。全てのエントリ(非演算子と演算子)は一文字以上のスペ

ースで区切らなければなりません。非演算子には現在の測点の位置における緯度、経度、日付あるいは標高と

いった現在の測点のメタデータと同様に、定数、入力変数の値、格納値、が使用できます(表 6-2 参照)。 

 

演算子には表 3 に記載されている代数演算子および論理演算子のいずれか一つを使用できます。演算子は必

要な入力値（単項、二項、および三項)の数によって異なりますが、=%n store 演算子を除いた全ての演算子

は正確に一つの結果値を生成します。 

 

マクロ式の評価は単純なスタックベースのスキームを使用して実装されます： 

1. 非演算子は表示されるとおりにスタックの先頭に追加されます。 

2. 演算子はその非演算子のスタックの先頭から取り出し、操作の結果をスタックの先頭に戻します。 

計算が成功したら、スタック上に残っている唯一のエレメントが最終結果です。 

 

表 6-2：ODV 数式の非演算子 

非演算子 意味 

17.3 定数値 

#n 入力変数nの値(n=1、...;例:#1) 

%n 保存値nの値(n=0,...;例:%3) 

%x 現在の測点の緯度 

%y 現在の測点の緯度 

%t 現在の測点の日付時刻メタデータから計算した1900年からの十進化年 

%d 現在の測点の日付時刻メタデータから計算した通日 

%H 現在の測点位置での標高（海抜メートル；陸が正、海が負） 

 

表 6-3：ODV 数式の演算子 
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演算子 結果 注釈 

Unary:x （単項演算子） 

=%n - n (n=0,…番目の保存値 x。値を取得するには％n を使用。   

abs abs(x) 絶対値 

arccos arccos(x) 逆余弦関数（ラジアン）  

arccot arccot(x) 逆余接関数 (ラジアン)  

arcsin arcsin(x) 逆正弦関数（ラジアン）  

arctan arctan(x) 逆正接関数（ラジアン）  

ceil ceil(x) x の切り上げ(x 以上の最小整数値) (ceil(-1.3)=-1; ceil(3.5)=4)  

cos cos(x) 余弦関数 ( x はラジアン)  

cot cot(x) 余接関数（ｘはラジアン）  

exp exp(x) 指数関数  

floor floor(x) x の切り捨て(x 以下の最小整数値) (floor(-1.3)=-2; floor(3.5)=3)  

int int(x) x の整数部(int(-1.3)=-1; int(3.5)=3)  

ln ln(x) 自然対数  

sin sin(x) 正弦関数  

sqrt sqrt(x) 平方根  

! !x 否定演算子(x の否定) (!(0)=1; !(1)=0)  

? 
有効値なら 1 

欠測値なら 0 

欠損値のテスト(ODV 5.0.1 以降)  

Binary: x y operator（二項演算子） 

+ x+y 和 

- x-y 差  

* x*y 積  

/ x/y 比  

** xy べき乗  

min min(x, y) 最小  

max max(x, y) 最大  

== 
1 if x=y 
0 if x!=y 

等値性テスト（等値性比較演算子） 

!= 
1 if x!=y 
0 if x=y 

不等値性テスト（等値性比較演算子） 

>= 
1 if x>=y 
0 if x<y 

より大きいか等しいためのテスト（不等値性比較演算子）  

> 
1 if x>y 

0 if x<=y 
より大きいかのためのテスト（不等値性比較演算子） 

<= 1 if x<=y 以下か等しいかのためのテスト（不等値性比較演算子） 
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0 if x>y 

< 
1 if x<y 

0 if x>=y 
より以下なのかのテスト（不等値性比較演算子） 

& 
1 if x and y non-zero 

0 if x or y zero 
論理積(AND)  

| 
1 if x or y non-zero 

0 if x and y zero 
論理和(OR)  

Ternary: b x y operator （三項演算子） 

IFTE 
x if b is non-zero 

y else 
IF-THEN-ELSE ロジック  

 

基本的な算術演算には演算子+  -  * / **、平方根には sqrt、二つの非演算子の最小値と最大値には min と

max、自然対数と指数関数には ln と exp を使用します。 正弦、余弦、正接、余接には sin, cos, tan, cot

（引数はラジアン）、逆正弦、逆余弦、逆正接、逆余接には arcsin, arccos, arctan, arccot（結果はラ

ジアン）、絶対値には abs、および引数の整数部にはそれぞれ int, floor, ceil があります。さらに、いく

つかの論理演算子と if-then-else 構造の IFTE 演算子があります。 

 

それぞれの入力変数の値を参照するには#1, #2 などの形式の用語を使用します。測点位置での標高（海抜メ

ートルで表し、陸地では正、海域では負）に%H という用語を使用し、観測時間には%t（測点の日付と時刻のメ

タデータから計算される 1900 年以降の十進化年、例えば 1984 年 6 月 27 日の場合は%t= 84.4877）、通日

には%d（測点日のメタデータから計算されます）、（東）経度の %x、（北）緯度の %y がそれぞれあります。 

 

計算の中間結果は演算子=%0, =%1 などを使用して内部変数%0, %1 などに格納できます。格納された値

は%0, %1 などと入力して後で計算に使用できます。この=%n 演算子はそれらの非演算子を消費することに注

意してください：例えば、それぞれの値はスタックから取り除かれます。 

 

非演算子と演算子は一文字以上のスペースで区切らなければなりません。 必要ならば次の行でマクロ式の定

義を続けることができます。 

表 6-4：数式の例 

後置記法式（逆ポーランド記法） 意味 

135 #1 * #2 + PO = 135 * PO4 + O2 (with: PO4 as #1 and O2 as #2)  

%t 80 - 17.6 / exp #1 * 
𝑐∙𝑒 (𝑡𝑡−1980)/17.6  (tritium decay correction to 1980; c as #1 (1980 年まで

のトリチウム減衰補正)) 

#1 ln ln(#1) (natural logarithm) /（自然対数） 

#1 ln 0.43429 *  log(#1) (base-10 logarithm) /（10 を底とする対数） 

0 #1 max  max(0, #1) (maximum value)  

#1 180 < #1 365 + #1 IFTE  if #1<180: (#1+365); else #1 (if-then-else expression)  
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6.3 式 (Expressions) 

派生変数式はマクロに似ています。それらは ODV マクロエディタで定義および編集することができ、それら

は同じ構文と演算子セットを使用します。式を設定するには現在のサンプルウィンドウのポップアップメニュ

ーから Derived Variables を選択し、Choices リストから Expression を選択して Add を押してください。 

ODV はマクロエディタ・ダイアログに似たダイアログを表示します。ラベルフィールドと単位フィールドに

新しい変数のラベルとそれに対応する単位を入力します。次に新しい変数に必要な入力変数を選択してくださ

い。例えば Choices リストで変数を選択して<<を押してください。最後に新しい数量について評価する式を指

定します。サポートされている演算子と一般的な構文ガイドラインについては Macro Editor の Expression のパ

ラグラフを参照してください。OK を押して新しい式の設定を終了します。 

 

現在のサンプルウィンドウのポップアップメニューから Derived Variables オプションを使用して ODV マクロ

と式を編集できます。次に Already Defined リストボックスでそれぞれの変数を選択して Edit を押してくださ

い。Edit Expression で名前を付けて Save As を押すと ODV マクロファイルに式を保存できます。 

 

 

図 6-4：式のダイアログの編集 

 

6.4 差分変数（Difference Variables） 

現在選択されている測点のプロパティ分布を以前に保存された参照データと比較し、プロパティの差を派生変

数として定義することで差分フィールドを作成できます。View > Derived Variables を選択するか、Alt + D を
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押して Special > Difference from Reference を選択してください。次に参照データディレクトリツリーのサブデ

ィレクトリの中から使用したい一つの参照データセットの ExportID.txt ファイルを選択してください。ODV は

そのディレクトリから利用可能な参照データファイルのリストを表示します。Z 変数として差分フィールドを

生成し、かつ適切な X 変数および Y 変数を持つ.oal ファイルを選択してください（例えば、経度と深度の断面

を生成させる場合は参照データファイルの経度が X で深度が Y であることを確認します）。次に現在のコレ

クション内の Z、X、および Y 変数を特定し（もし経度または緯度が必要な場合は Difference from Reference オ

プションを呼び出す前に派生変数としてそれらを定義します）差分変数の定義を完了してください。新しい変

数の名前は Z 変数の名前と参照データセットの識別文字列で構成されています。一度定義すると、どのデータ

プロットでも差分変数を使用できます。 

 

6.5 パッチ（Patches）  

現在画面に表示されているデータプロットの X/Y 空間に多角形を指定することで水隗パッチを定義できます。 

これを行うには、定義に使用したいデータプロット（例えばシータ/ S プロット）の上にマウスを移動し、マ

ウスの右ボタンをクリックします。ポップアップメニューから Extras > Define Patch を選択し（カーソルが十

字形に変わります）、節点の位置でマウスの左ボタンをクリックして多角形パッチの節点を定義します。点を

削除するには、マウスをそれぞれの点の近くに移動して右ボタンをクリックします。Enter キーを押すか、マ

ウスの左ボタンをダブルクリックして多角形の定義を終了してください。多角形は ODV によって自動的に閉

じられることに注意してください。その後 ODV はパッチ名（拡張子なし）の入力を求め、パッチ定義をコレ

クションディレクトリ内のファイルに書き出します。 

図 6-5：パッチを用いて水塊の範囲を特定する 

 

一つのコレクションに対して一つ以上の水塊パッチを定義したら、それらを使用して派生変数 Patches を作成

して活性化することができます。View > Derived Variables を選択して Choices リストから Patches を選択してく
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ださい。利用可能な水塊パッチ（上で説明したように定義済み）を一つ以上選択することで Patches 変数をそ

の内部に構成できます。終了したら OK を押してください。所定のサンプルのパッチ変数を評価するために、

ODV はサンプルが選択されたパッチ多角形の一つの内側にあるかどうかを判定し、（見つかった場合）それ

ぞれのパッチの番号をパッチ値として割り当てます。サンプルが全ての選択パッチの外側にある場合、その値

は欠測値に設定されます。 

 

他の全ての変数（基本変数または派生変数）と同様にデータウィンドウの任意の軸にパッチ変数を使用できま

す。例えば、断面に沿った Z 変数として、または特定の水塊の空間的な広がりを表示するための等値面変数と

して使用します（図 6-5 を参照）。 
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7 等値面変数 (Isosurface Variables)  

多くの場合、特定の時空間面または層上の変数の分布を計算して表示することが科学的に必要です。例えば、

一定の深度または圧力の層、等密度面、あるいは時系列データの場合は一定のタイムスライスです。ODV は

そのような分布を定義するための isosurface variables（等値面変数）を提供します。 定義により等値面変数は

測点ごとに正確に一つの値を持ちます。等値面変数の値は SURFACE スコープのデータウィンドウにプロット

できます。 

 

等値面変数は View > Isosurface Variables を使用するか Isosurface Data Window 上で右クリックして Isosurface 

Variables を選択して定義されます。ODV は Isosurface Variables ダイアログ（図 7-1）を表示するので、ここで

新しい等値面変数を定義、および既存のものの修正または削除してください。一つ以上の既存の等値面変数を

削除するには Already Defined リストでそれぞれのエントリを選択して Delete を押してください。 

 

新しい等値面変数を追加するには、まず New ボックス内に新しい変数を作成してから Add を押してください。

等値面変数を作成するには、（1）ある表面上に表示される変数（表示変数）、（2）表面を定義する変数（表

面変数）、（3）表面上の表面変数の値（表面変数値）の詳細が求められます。数値の表面変数値に加えて first, 

last, minimum または maximum のキーワードを入力することもできます。この欄に数値を入力して表面変数の

数値を指定します。first および last キーワードの場合、ODV は主要変数の並び替え順に従って表示変数の

最初または最後の非欠測値を取得します。Minimum または maximum の場合、ODV は最初に表面変数の最小

値（最大値）でサンプルを決定し、次に与えられたサンプルの表示変数の値を使用します。 

 

図 7-1：等値面変数ダイアログボックス 

 

Already Defined ボックスで等値面変数が選択されている場合は S-Sync ボタンをクリックして同じ等値面を使

用するように他の全ての変数を同期させることができます（等値面の同期）。V-Sync ボタンをクリックして他

の全ての変数を同期させて同じ表示変数を使用することができます（変数同期）。 
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当然ながら、等値面変数の表示変数または表面変数として使用するには、まずポテンシャル密度や圧力などの

派生変数を定義する必要があります。等値面変数の総数は無制限です。現在の測点の等値面変数値は等値面デ

ータウィンドウに表示されます。  

 

Salinity [psu] @ Depth [m] = 500 のような数値表面値を持つ等値面変数の計算は、等値面上で線形補間値を取得

するために利用可能なサンプル（Salinity）値を使用して実行されます。タイプ B（ボトルデータ）または 100

サンプル未満の測点では、測点の全てのデータを考慮して piece-wise linear regression (区分線形回帰)を使

用して補間します。タイプ C で 100 サンプル以上の測点では、線形補間は面の両側にある最も近い二つのサ

ンプルのみ使用します。 

 

補間を実行する前に ODV は表示変数（Salinity）のデータ範囲をチェックし、データが不足していると判断さ

れた場合、補間は試行されず、この測点に対する等値面値は計算されません。データ不足の有意性を評価する

ために使用される有効範囲基準は、オプション Collection > Good Coverage Criteria を使用して検査および修正

できます。 

 

測点の緯度経度と同様に、十進化時間や通日などの測点メタ情報は、常に自動で等値面値として提供されます。 

 

first、last、minimum、maximum キーワードを使用した等値面データの品質は、利用可能なデータの分布とデ

ータ内の顕著な極値の有無に大きく依存します。したがって、これらのキーワードは慎重に使用する必要があ

ります。 

 

キーワード first または last は全ての測点の最初または最後のサンプルが同じ主要変数の値、または海水全体

にわたる範囲にある場合にのみ適用する必要があります。first または last を使用すると、表面または海底の状

態が正しく反映されます。最初と最後のサンプルの深度が測点間で大きく異なる場合、すなわち、ある測点が

海底まで伸びているのに対して他のサンプルが海中の一部しかカバーしていない場合は、これらのキーワード

を使用すべきではありません。 

 

キーワード minimum または maximum は表面変数が顕著な最小(最大)値を示し、利用可能なデータによって明

らかに特徴が解決される領域でのみ使用するべきです。複数の最小(最大)値を持つ測点の場合、表面変数の最

小(最大)値を持つ測点が選択されます。一組の測点の場合、絶対最小(最大)値は異なる最小(最大)値の層にお

いて得られることに注意して下さい。Isosurface Data Window 上で右クリックして Sample Filter > Customize 

Settings > Range の順に選択し、変数(例えば深度、圧力、または時間)の一つの範囲を指定することで、極値の

検索をユーザー定義の間隔に制限する範囲サンプルフィルタを指定できます。 

 

7.1 等値面変数描画（Drawing Isosurface Variables） 
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等値面変数を定義したら、SURFACE スコープのデータウィンドウの Y、Y、Z 軸上でこれらの変数を使用でき

ます。格子場を深度レベルでプロットする場合は、最も近い等深線が自動的にオーバーレイレイヤとして使用

されます。元のデータ点がプロットされている場合は灰色の海底地形図が背景として使用されます。 
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8 選択基準（Selection Criteria）  

8.1 測点フィルタ（Station Filter）  

測点マップの描画中に、ODV はコレクション内の各測点を検査し、現在の測点フィルタ設定が満たされてい

るかどうかを判定します。全てのテストに合格した測点のみが有効と見なされます。これらの測点だけがマッ

プ上に印づけられて、この測点の部分集合だけが以降の閲覧と可視化に使用されます。 

 

   

 

   

 

   

図 8-1：測点フィルタ・ダイアログ・ページ 
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図 8-2：測点フィルタ・ダイアログ・ページ（続き） 

 

測点図のコンテキストメニュー、Current Station Window ポップアップメニュー、またはメインメニューの

View > Station Filter を使用して、測点フィルタ設定を変更できます。例えば Name/Range, Date/Time, Domain, 

Meta Data, Meta Data Quality, Availability, History または Invert のそれぞれのタブをクリックして変更するカテ

ゴリを選択し、関心のある項目を変更します。 

 

Name/Range タブでは、航海ラベル、測点ラベル範囲、測点タイプ、および内部測点 ID 番号の範囲によって

測点を選択できます。航海ラベルを選択するにはリストから特定の航海ラベルを選択するか、Cruise Label フ

ィールドの中に一つ以上の正規表現（ワイルドカード・パタン）を指定します。後者の場合、いずれかの正規

表現に一致する航海ラベルは全て有効と見なされます。航海ラベルに使用できる正規表現の例を表 8-1 にま

とめています。複数の航海ラベルを入力する場合は二本のバー“ || ”を使用してエントリを区切ります。 

 

例：OCE13 [34]  ||  A16N  ||  S05 * 

航海 OCE133 と OCE134 および航海 A16N，および S05 から始まる全ての航海を選択します。 

 

表 8-1：クルーズラベルの正規表現構文およびメタデータのワイルドカード表現 

文字・記号 意味 

任意の文字 
下記のものを除いて、任意の文字はそれ自身を表します。 

例：c は文字 c と一致します。 

? 
これは任意の一文字と一致します。 

例：SAVE_LEG？は SAVE_LEG1、SAVE_LEG9、SAVE_LEGa などに一致します。 

* 

これは 0 個以上の任意の文字と一致します。 

例：I01_*は I01_で始まるラベルに一致します; *06AQ*は中央に 06AQ があるラベル

に一致します。 

[...] 
角括弧([])内に示される文字列セット。文字クラスの範囲内では、範囲外のように

バックスラッシュは特別な意味を持ちません。ダッシュ（-）は文字の範囲を示すた
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めに使用されます。キャレット（^）は最初の文字すなわち左角括弧の直後にある

場合にその文字セットを否定します。 

例：I05 [EW]は I05E と I05W に一致します。LEG [0-2]は LEG0、LEG1、LEG2 に一致

します。SAVE_LEG [^3]は SAVE_LEG3 を除く全ての SAVE_LEG?航海に一致します。  

(empty) 空文字列に一致します。 

(!empty) 空ではない文字列に一致します。 

 

Date/Time タブでは、有効な時間間隔（Period）、有効なカレンダー間隔（Season）、および有効な日中の時間

範囲（Day Time）を指定できます。有効な測点は三基準の全てを満たす必要があります。Season および Day 

Time（カレンダーおよび日中の）範囲は、連続した年または日にまたがることがあります。例えば[Oct/20-

Feb/03]または[21:09-04:15]は、受け入れ可能なカレンダーと日中の範囲です。 

 

Domain カテゴリでは、地図の矩形範囲をそれぞれの経度/緯度の値を指定して定義するか、Zoom ボタンを押

したズーミングによって矩形を定義できます。Poygon ボタンを押してからマウスで多角形の節点を入力する

と、多角形を有効なドメインとして定義できます。多角形は自動的に閉じます。 

 

Meta Data ページは数値メタ変数と文字列メタ変数を別々にカバーする二つの部分に分割されています。どち

らの場合も、最初に上部のコンボボックスから変数を選択してから、満たすべき数値範囲（数値メタ変数）ま

たはワイルドカード式（文字列メタ変数）を指定してください。 

 

数値範囲を指定する場合は、左に低値の境界、右の高値の境界を入力してください。指定した境界間のメタ変

数値を持つ測点だけが有効となります。もし許容値の範囲が低値（または高値）側に無限であれば、低値（ま

たは高値）の境界は空白のままにしてください。あるメタ変数に関するデータを持たない測点を選択するには、

低値の境界に文字列`(empty)’を入力して高値の境界を空白のままにしてください。 

 

ワイルドカード式は、上述したクルーズラベルの例のように、‘||’ で区切られた複数のエントリを持つことが

できます。エントリは OR 論理と組み合わせられ、例えばエントリのどれか一つに合致するメタ値が有効とな

ります。`(empty)’または`(!empty)’文字は、空文字列または空ではない文字列に一致します。ワイルドカー

ド式の構文は表 8-1 にまとめられています。純粋な（ワイルドカード文字を含まない）テキストを入力してメ

タ変数が INDEXED_TEXT 型の値を持つ場合、ODV は入力された文字列がコレクションに存在するかどうか

を示します。これにより特定の用語がコレクション内に存在するかどうかを素早く確認できます。 

 

Meta data Quality タブでは、データ品質フィルタを設定したいメタ変数を選択してから、許容したい品質フラ

グを選択してください。Apply to all variables をクリックすると、選択した変数と同じ品質フラグスキーマを使

用して全メタ変数に対して同じ品質フィルタを適用します。もし選択したメタ変数に対して全ての品質フラグ
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を許容したい場合は Relax this quality filter をクリックしてください。それから Apply to all variables をクリッ

クすると、選択した変数と同じ品質フラグスキーマを使用して全メタ変数の全品質フィルタが緩和されます。 

 

Availability ページでは必須変数として一つ以上のデータ変数を選択できます。測点は必須変数のデータが含ま

れている場合のみ有効と見なされます。複数の必須変数は AND または OR 論理を使用して二つの方法で組み

合わせることができます。AND 論理では全ての必須変数のデータが存在しなければなりませんが、OR 論理で

は一つの必須変数のデータだけで十分です。 

 

History ページｄは、測点の履歴記録にある日付、ユーザー、実行、および記録された説明情報に基づいて測

点を選択できます。User, Action, Description ワイルドカード仕様に一つ以上一致する指定した時間間隔の日付

時刻、ユーザー、行動および説明情報の履歴記録が含まれていれば、その測点は有効となります。履歴記録

によるフィルタリングは、他の基準より多くのコンピュータ的なコストがかかり、特に巨大なデータコレク

ションでは時間がかかることに注意してください。 

 

Invert タブでは測点の選択を反転できます。例えば Invert Selection ボックスをチェックすると、基準を満たさ

ない全ての測点が選択されます。 

 

有効測点フィルタ設定を含むページには、ページ名にアスタリスク(*)が追加されているので簡単に識別でき

ます。特定のページの選択基準を削除するには、それぞれのページタイトルをクリックして Relax Criteria, Map 

Domain または None Required ボタンを押してください。 

 

異なるページ上の選択基準は論理積(AND)を使用して組み合わせられることに注意してください。例えば測点

は、それが全ての測点フィルタ設定を満足する場合にのみ有効と見なさます。終了したら OK を押してくださ

い。ODV は新しい選択基準を使用して測点図を再構築します。 

 

コツ：Availability ページで主要変数を除く全てのデータ変数を選んで論理 OR を選ぶと、主要変数を除くど

のデータがなくても測点を選別できます（空の測点）。Invert ページにおいて、Invert selection ボックスをチ

ェックしてください。Collection > Delete Station Subset オプションを使うとコレクションから空の測点を削除

できます。 

 

8.2 サンプルフィルタ（Sample Filter） 

ODV は等値面変数値の計算と同様に、（SURFACE ウィンドウを除く）各データウィンドウに関して個々のサ

ンプルフィルタを管理します。これらのフィルタはデータ値（範囲およびワイルドカード・フィルタ処理）お

よび/または品質フラグ値（品質フィルタ処理）に基づいてサンプルを受け入れたり拒否したりします。品質

フィルタは受け入れる品質フラグ値を指定します。範囲フィルタ（数値データ変数のみ）は最小および最大の
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許容値を指定します。ワイルドカード・フィルタ（文字列データ変数のみ）は、それぞれの文字列値と一致す

る必要がある一つ以上のワイルドカード仕様を指定します（詳細は下記を参照）。 

 

別々のサンプルフィルタを異なる非 SURFACE データウィンドウに適用することができます（下記参照）。等

値面変数値の計算中に適用される追加のサンプルフィルタがあります。どのような場合でも、指定されたサン

プルは指定された全てのサンプルフィルタ設定を満たす場合にのみ有効と見なされます。有効なサンプルのみ

が異なるデータウィンドウに表示され、有効なサンプルのみが等値面変数値の計算に使用されます。Current 

Sample Window には常に全てのデータが表示され、サンプルフィルタは適用されません。 

 

非 SURFACE データウィンドウのサンプルフィルタを変更するには、ウィンドウ上で右クリックして Sample 

Filter サブメニューのオプション: Accept All Data、Reject Outliers そして Customize Settings から一つを選択し

てください。最初の二つのオプションは自動で使いやすくなっています。三番目のオプションでは、以下に示

す Sample Filter ダイアログのように全てのフィルタ設定を完全に制御できます。Isosurface Data Window を右

クリックしてオプションの一つを選択すると等値面変数の計算に使用されるサンプルフィルタ設定を変更で

きます。 

 

     

図 8-3：サンプル・フィルタ・ダイアログ・ページ 

 

Sample Filter ダイアログを使用するときは、まず Quality や Rang など、それぞれのタブをクリックして変更

するカテゴリを選択して目的の項目を変更してください。 

 

Quality タブでデータ品質フィルタを設定する変数を選択してから、受け入れる品質フラグを選択してくださ

い。選択した変数と同じ品質フラグスキーマを使用して全ての変数に同じ品質フィルタを適用するには Apply 

to all variables をクリックしてください。選択した変数の全ての品質フラグを受け入れる場合は Relax this 
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quality filter をクリックしてください。そして選択した変数と同じ品質フラグスキーマを使用して全ての変数

の全ての品質フィルタを緩和する場合も Apply to all variables をクリックしてください。 

 

（一つ以上の変数に対して）指定した値の範囲内にある値を持つサンプルのみを表示したい場合は Range タ

ブのフィルタ設定を使用します。例えば上層の海中を調べていて深度 0～500m のサンプルのみを見たい場合

は、深度変数を選択して Acceptable Range の下に希望の範囲を入力してください。一度に複数の変数に範囲フ

ィルタを指定できます。テキスト変数には、”N* || Gerad”のように一つ以上のワイルドカード表記を指定で

きます。これにより変数のテキスト値が「N」で始まるか、または「Gerard」に等しいサンプルのみが選択さ

れます。 

 

オーバーレイデータウィンドウのサンプルフィルタを編集すると、オーバーレイウィンドウの変更されたサン

プルフィルタは自動的に親ウィンドウにも適用されます。 
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9 測点図（Station Map） 

9.1 マッププロパティー（Map Properties） 

測点図のプロパティはマップポップアップメニューの Properties オプションまたは View > Window Properties > 

Map より変更できます。これには、地図の領域と投影法、海底地形の表示、海岸線、および陸上地形、測点の

ドットのスタイル、グラフィックスフォントサイズや軸のラベルの色とスタイルなどの一般的なプロパティの

変更が含まれます(図 9-1 と 9-3) 。 

 

図 9-1: マッププロパティダイアログの各ページ (part 1 of 3) 

 

一般 (General) 

General ページではマップで使用されるカラーパレット、マップウィンドウの背景色、基本フォントサイズと

フォントサイズ係数、および軸と軸注釈の色を定義できます。緯経線表示はオンまたはオフに切り替えること

ができます。 

 

表示スタイル（Display Style） 

Display Style ページでマップ内の測点マークの色とサイズを定義します。色に automatic を選択するとデータ

コレクション内の異なる航海に対して異なる色が発生します。ドットサイズを-1 にするとドットサイズは自

動的に定義されます。 

 

投影（Projection） 

Projection ページでは地図投影と投影極の経度と緯度（見る人の位置）を選択します。次の投影が現在利用可

能です:（1）Default Projection, （2）Orthographic (North Polar), （3）Orthographic (Equatorial), （4）Orthographic 

(South Polar), （5）Orthographic (Oblique), （6）Mollweide. デフォルトの投影法は経度と緯度方向が線形で

す。各々の正投影図法は半球形ですが、デフォルト図法およびモルワイデ図法は全球規模です。全ての投影法

でマウスまたはマップ Properties ダイアログの Domain ページを使用した小領域の定義でズームインが可能で
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す（下記参照）。Orthographic (Oblique)投影では、任意の経度/緯度の眼位（極）を指定して、そこから全球を

見ることができます。他の投影法では極の緯度は固定されており、極の経度のみを変更できます。 

 

投影法(2)から(6)ではズーミングによる小領域の定義にコツが要ります。正確な結果が必要な場合はマップ

Properties ダイアログの Domain ページ（下記参照）を使用するか、一時的にデフォルトの投影法に切り替え

てからズーム（それによってサブ領域を定義）して最後に目的の地図投影法に切り替えてください。 

 

レイヤー (Layers)  

ODV には、中解像度または高解像度の海底地形および陸上地形の等値線、海岸線、湖沼、河川、および境界の

データを含む多数のマップリソースパッケージ（Series（シリーズ）と呼びます）が付属しています。中解像度

の全球 GlobHR シリーズは、ODV ソフトウェアとともに自動的にインストールされます。他の利用可能なマッ

プリソースとインストール手順に関する情報は 2.12 章の Map Layer Series セクションを参照してください。 

 

Layers ページで bathymetry-coastline-topography Series を選択し、異なった Layer Set カテゴリ内のレイヤーを

指定します。Draw color bar ボックスをチェックするかチェックを外して、マップのカラーバー描画のオンま

たはオフを切り替えられます。 

 

ODV 測点図で使用する Series を選択する方法は二つ：automatic または manual があります。 

 

  

図 9-2：Map Properties ダイアログ(3 の第 2 部)の各ページ 

 

自動シリーズ選択（Automatic Series Selection） 

Automatic selection チェックボックスをチェックすると自動シリーズ選択に切り替わります。このモードで

ODV は自動的に与えられた地図領域で利用可能な最善のシリーズを決定して測点図にこのシリーズを使用し

ます。地図領域が変更されたときはいつでも（例えばズーミング、またはマップポップアップメニューの Full 

Domain または Global Map オプションを使用したとき）、ODV は新しいドメインに最適なインストール済みシ
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リーズを見つけて使用します。ODV はまた、所定の領域に適した海底地形と陸上地形レイヤーを自動的に選

択します。それぞれのチェックボックスをチェックするか外すことで ocean bathymetry, coastlines, land 

topography, lakes そして rivers と国の borders の描画のオンまたはオフを切り替えられます。 

 

自動シリーズ選択を有効にするには ODV Web サイトから入手可能な高解像度の bathymetry-coastline-

topography シリーズを一つ以上インストールする必要があります。他の利用可能なマップリソースとインス

トール手順に関する情報は 2.12 章の Map Layer Series セクションを参照してください。 

 

独自の特注 Coastline-Bathymetry シリーズを作成し、それを自動シリーズ検索に含めたい場合はシリーズの

領域と空間解像度に関する情報を含む設定ファイルを作成する必要があります。詳細については Preparing 

Custom Coastline and Bathymetry Files の章を参照してください。 

 

手動シリーズ選択 (Manual Series Selection) 

Automatic selection チェックボックスのチェックを外すと手動で bathymetry-coastline-topography シリー

ズを選択できます。また、個々のレイヤーセットを作成してそれらのグラフィカルな外観を指定することもで

きます。このモードでは測点図のデザインを最大限にコントロールできます。 

 

Series コンボボックスをクリックしてインストールされているシリーズを選択することができます。一部のシ

リーズは地域版のため、それぞれのシリーズ領域に対して地図領域を手動で調整する必要があるかもしれませ

ん。一つのシリーズを選択したら、さまざまな Layer Set カテゴリでレイヤーを定義できます（下記参照）。地

図が描画されるとレイヤーセット（およびセット内のレイヤー）は指定された順序で描画されます。 

 

選択されたレイヤーセット（例えば Ocean Bathymetry）に関する情報を取得するには Layer Set Info ボタンをク

リックしてください。選択したレイヤーセットのレイヤーを定義するには Compose ボタンをクリックしてく

ださい。デフォルトレイヤーは全てのカテゴリに対して定義されています。結果の地図表示がニーズに合って

いる場合はレイヤーセットを変更する必要はありません。 
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図 9-3：マップのレイヤー定義ダイアログ 

 

Compose ボタンを押すとレイヤー定義ダイアログ（図 9-3）が表示されます。Available リストでレイヤーを選

択して<<ボタンを押すとレイヤーを追加できます。Selected リストでレイヤーを選択して>>ボタンを押すと

レイヤーを削除できます。Line ボックスと Fill ボックスのプロパティに応じて、所定のレイヤーの塗りつぶし、

および／またはその輪郭を描くことができます。デフォルトの色設定は自動的に適切な色が選ばれる

(automatic)です(推奨)。それぞれのコンボボックスをクリックして、これらの設定を上書きして特定の色を選

択することができます。塗りつぶさない、および／または描きたくない場合は(none)を選択してください。

Selected リスト内の所定のレイヤーのプロパティをクリックすることで変更できます。そして Line と Fill で設

定を変更し、最後に<<をクリックして変更を実行します。 

 

領域（Domain） 

マップのプロパティダイアログの Domain ページで、東経と西経、南緯と北緯を与えて地図の範囲を指定でき

ます。また Full Domain をクリックするとコレクション内の測点がまたがる全範囲の領域（ネイティブ領域）

を、Global Map をクリックすると全球領域を選択することもできます。 

 

 

 

 

 

図 9-4：Map Properties ダイアログの各ページ(part 3 of 3) 

 

注釈（Annotations） 

Annotatinos ページでは地図中で選択した測点（下記参照）に注釈を付けるかどうかを指定できます。選択した

測点の測点ラベルを測点位置の横に描画する場合は Station labels を、注釈に航海ラベルも含める場合は Cruise 

and station labels を選択してください。注釈が不要な場合は No annotations を選択してください。Pick List Editor

を使用して測点の位置を基準にして注釈の位置を変更できることに注意してください（下記参照）。 
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9.2 選択された測点（Picked Stations）  

測点図は選択された測点のリストを保持しています。選択された測点のデータは STATION データウィンドウ

に描画され、選択された測点もデータウィンドウと同じ色と記号を使用して測点図に印付けられます。（例え

ば測点上を左クリックして）現在の測点にして+ (プラスキー)を押すと、その測点が選択リストに追加されま

す。マウスの左ボタンで測点をダブルクリックしても測点を選択リストに追加できます。新しく追加された選

択された測点のデータが全ての STATION データウィンドウに追加され、それが測点図内にも印づけられてい

ることに注意してください。選択リストから測点を削除するには（例えば STATION データウィンドウの一

つのデータポイントをクリックして）現在の測点にして- (マイナスキー)を押します。 

 

マップポップアップメニューから Manage Pick List > Edit Pick List オプションを使用して選択リスト全体を編集

できます。Pick List Editor ダイアログで選択リスト内の全ての測点のプロパティとグラフィカル表示を編集で

きます。リストの順序を変更したり、リストから個々の測点を削除したり、リストを完全に空にしたりするこ

ともできます。 

 

 

図 9-5：選択リストエディタダイアログ 

 

現在のビューに選ばれた測点が含まれているのに STATION データウィンドウが表示されていない場合、選択

された測点は測点図内で測点記号の周りを黒い円で強調表示されます。STATION データウィンドウが作成さ

れるとすぐに選択された記号が再び表示されます。さらに、選択された測点の種類が`B’とは異なる場合、最

初は記号が割り当てられず、測点のサンプル間の線のみが強調表示されます。手動で記号タイプを定義すると、

恒久的に使用する事が出来ます（ODV バージョン 4.2.0 から導入）。 

 

9.3 断面（Sections） 
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SECTION データウィンドウを作図する前に、測点図で断面を定義する必要があります。 新しい断面を定義す

るか、以前に定義した断面を使用するには、地図上で右クリックしてマップポップアップメニューを呼び出し

ます。新しい断面を定義する場合は Manage Section > Define Section を、以前に定義した断面を読み込む場合は

Manage Section > Load Section を選択してください。後者の場合「ファイルを開く」ダイアログから（例えばそ

れをダブルクリックして）断面ファイルを選択してください。新しい断面を作成するとき ODV は一時的に全

面測点図に切り替わるので、断面の中心線を簡単に定義できます。マウスカーソルが十字線に変わったときは、

断面の中心線を定義する一連の点の入力を待っている状態です。 

 

十字線を目的の位置に移動してマウスの左ボタンをクリックして点を入力します。点を削除するにはマウスを

点の近くに移動してマウスの右ボタンをクリックします。一連の点を確定するには ENTER キーを押すか、マ

ウスの左ボタンをダブルクリックして最後の点を指定します。図 9-6 に示すように任意の航跡に沿ったかな

り複雑な断面を作成することができます。 

 

 

                 図 9-6：GEOSECS 西大西洋断面 

 

断面の中心を指定した後、ODV は断面帯に既定の幅を割り当て、既定の断面に沿った座標として開始点（最

初に入力した点）からの距離を選択します。断面の中心を指定すると自動的に表示される Section Properties ダ

イアログ（図 9-7）で、これらおよび他の多くの断面プロパティを変更できます。Section Properties ダイアロ

グは、マップポップアップメニューから Manage Section > Section Properties を選択するといつでも呼び出せま

す。 

 

Section Properties ダイアログで、断面に沿う座標として Distance, Longitude, Latitude または Time の選択、断面

帯の幅の設定、水深値のソースの選択、海底地形断面の色の選択、および断面のタイトルを指定できます。 
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図 9-7：Section Properties ダイアログ 

 

断面には海底地形の多角形を含めることができ、それはいくつかの方法で定義できます：（1）測点の水深メ

タデータを使用、（2）特別な netCDF ファイルで提供される全球または地域のグリッド海底地形データセッ

トを使用、または（3）.gob ファイルからの ODV POLYGON グラフィックスオブジェクトを使用します。格

子化海底地形データは View > Settings > Gridded Bathymetry > Resources オプション（MacOS の場合は odv > 

Preferences > …）を使用してダウンロードおよびインストールできます。断面の海底地形多角形として.gob フ

ァイルの船舶測深データを使用した断面の例を図 9-8 に示します。 

 

注：断面プロットに表示される海底地形図について、プロットの Y 変数が Depth in the Water Column または

Pressure in the Water Column として識別されていることを確認してください。識別を検査および確認するには

Collection > Identify Key Variables オプションを使用してください。 

 

図 9-8：断面の海底地形の多角形として船舶測深データを使用した断面 
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現在の断面図をファイルに保存するには Manage Section > Save Section As オプションを選択します。Manage 

Section > Load Section を選択して保存した断面図を後で読み込むことができます。断面を削除するには Manage 

Section > Remove Section を選択してください。 

 

測点図内で印づけられている断面帯内の全ての測点はその断面に属しています。これら全ての測点のデータは

SECTION データウィンドウにプロットされます。 

 

9.4 測点分布（Station Distributions） 

ポップアップメニューから Extras > Statistics を選択するか、マウスが地図上にあるときに F4（4 番のファンク

ションキー）を押すと、測点図内の測点の空間的および時間的分布のプロットを作成できます。Map Statistics

ダイアログが表示され、現在選択されている測点の時間または季節の分布を見ることができます（それぞれ

Time Histogram または Season Histogram ボタンを押します）。ヒストグラム(度数分布)は別々のダイアログウ

ィンドウに表示されます（図 9-9 を参照）。Save As を押して適切なファイルタイプを選択することで、GIF、

PNG、JPG、または Encapsulated PostScript ファイルにグラフィックスを保存できます。 

 

     

図 9-9：マップ内の測点の時刻と季節のヒストグラム（度数分布）の例 

 

Map Statistics ダイアログで X/Y Distribution を押すと小さなタイル内の測点数を使用して地図領域全体のデー

タ密度を示すプロットが作成されます。この分布図は、特に非常に多数の測点と多数の繰り返しの測点が測点

図の同じ場所にプロットされている場合、密集した測点範囲のエリアの簡単な識別を可能にします。地図を拡

大して上記の手順を繰り返して、より高い空間分解能で測点密度情報を取得できます（図 9-10 を参照）。 
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図 9-10：異なるレベルの空間分解能を有する測点図および測点分布図の例 

 

9.5 経度符号と値の規約 （Longitude Sign and Value Conventions） 

  

1. ODV コレクションの経度メタデータは東経度[0° ―360°]で保存されています。 
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2. Export > Data > ODV Spreadsheet File および Export > Meta Data オプションを使用して(1) [0°―360°] 

または(2) [-180°―180°]の経度出力規約を選択できます。 

3. Export > Window Data および Extras > Clipboard Copy による測点図およびデータウィンドウマップか

らのデータのエクスポートでは、測点図またはデータウィンドウマップで現在使用されている経度値

を作成します（4 を参照）。 

4. 測点図またはデータウィンドウマップの経度メタデータの符号と値は、地図領域がグリニッジ子午線

をまたぐ(b)、もしくはまたがない(a)かに依存します： 

⚫ (a) グリニッジ子午線が地図領域内にない、または東または西の境界線ではない、 

⚫ (b) 領域内部にグリニッジ子午線。 

(a)の場合、地図の経度は常に正で[0°―360°]の範囲です（値は東経度を表します）。（b)の場合は

グリニッジ子午線の東側の緯度は正（東経度）であるのに対し、グリニッジ子午線の西側の緯度は負

（西経度）です。いずれの場合も地図の経度は下図に示すように西から東に単調増加します。 

 

図 9-11：ODV マップにおける経度の規則。 
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10 データウィンドウ（Data Windows） 

10.1 データウィンドウプロパティ（Data Window Properties） 

 

データウィンドウのプロパティは、それぞれのウィンドウを右クリックして Properties オプションを選択するこ

とで変更できます。あるいは View > Win-dow Properties > Window x を使用することもできます（ここで x はウィ

ンドウの番号です）。値の範囲やウィンドウの X, Y, Z 軸上の変数などウィンドウ設定の一部はデータウィンド

ウのポップアップメニューの Set Ranges および X-, Y-, Z-Variable オプションを使用して変更することもできま

す。 

 

     

図 10-1：データウィンドウプロパティダイアログの各ページ (1/2) 

 

データウィンドウの Properties ダイアログは六つのページで構成されています（図10-1および10-5を参照）。 

 

一般（General） 

General ページでは、データウィンドウ、データウィンドウの背景色、現在の測点の強調表示スタイル、基本

フォントサイズとフォントサイズ係数、軸の色と軸の注釈で使われているカラーパレットを定義できます。 軸

上の自動変数ラベルと同様に、格子線はオンまたはオフに切り替えることができます。自動軸タイトルをオフ

にして独自の注釈グラフィックスオブジェクトを作成すると、軸上のテキストをカスタマイズすることができ

ます。 

 

データ（Data）  

Data ページでは、データウィンドウの範囲、X, Y, Z の変数、および様々な軸のプロパティを定義できます。

通常の軸の方向は、X の場合は左から右へ、Y の場合は下から上へ、Z の場合はカラーバー内の下から上に向

かって値は増加します。例えば、海洋深度値を上向きに減少させるためにそれぞれの Reverse range ボックス

をチェックして、一つ以上の軸の方向を反転させることができます。X, Y, Z 軸のプロパティを変更するには

X-Axis Settings, Y-Axis Settings または Color bar Settings をクリックしてください。軸のプロパティダイアログ
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（図 10-2）が表示され、それぞれの軸の値の範囲、軸に沿った線形、対数、または引き伸ばした投影図、ラ

ベル付きおよびラベルなしの目盛りの間隔、ラベル付き軸の位置を指定できます。目盛りの間隔を(automatic) 

に設定すると、ODV は自動的に印の場所と頻度を決定します。Position エントリでは、軸の位置（左または右、

下または上）の選択、またはそれぞれの軸のラベルを完全にオフにすることができます。 

 

注：軸上で十進数の時間変数を検出した場合、ODV は特別なラベル付けの方法を適用します。この場合ユー

ザーはラベルの間隔を変更できません。 

図 10-2: Axis Properties ダイアログ.  

 

ODV は次の X 軸と Y 軸の投影をサポートします：（1）線形（デフォルト）、（2）対数、（3）左（底）延

伸部、（4）左（底）延伸部（強）、（5）中央延伸部、（6）中央延伸部（強）、（7）右（頂）延伸部分、（8）

右（頂）延伸部分（強）。以下は、対数軸と引き伸ばされた上部 Y 軸の使用を示す例の図です。断面図の上層

の分解能が向上していることに注意してください。 

 

表示スタイル（Display Style） 

Display Style ページでは、それぞれの項目をクリックすることで ODV の二つの基本的なプロットタイプ、

Original data と Gridded field を切り替えることができます。 

 

Original data の場合、測定位置におけるカラードット、サイズドット、数値または矢符を得るために Colored 

Dots, Sized Dots, Numbers または Arrows の表示タイプを選択できます。さらに，各 X, Y, Z 変数の品質フラグ

値に応じたカラードットを生成する SCATTER および SECTION プロットにおいて、Colored Dots (X Quality), 

Colored Dots (Y Quality), Colored Dots (Z Quality)を選択できます。これらのプロットタイプはデータの品質管理

の特に有用です。 

Symbol size の下の二つのフィールド内の数値で、ドットのサイズと色、またはフォントのサイズと色を指定し

てください。選択された色は、Z 変数を除いた SECTION、SCATTER、SURFACE の各データウィンドウでの

み有効です。Z 変数を持つデータウィンドウでは、ドットの色（またはサイズ）は Z 値によって決まります。
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STATION ウィンドウでは選択された測点ごとに色が異なります。これらの色は自動的に割り当てられますが、

ユーザーはいつでも変更できます。 Line width エントリは STATION データウィンドウでのみ有効です。 

 

 

  

図 10-3：対数および伸張された上部、Y 軸の使用を示す例。 

 

Sized Dots の場合、ドットの最大サイズは指定された Symbol size の 10 倍となり、塗りつぶしの色は Symbol 

color によって与えられ、ボーダーの色とボーダーの幅は、それぞれデータマークの色とライン幅のエントリ

から引き継がれます。最大 Z 範囲値を表すサンプルドットがデータウィンドウの左下隅にプロットされます。

データウィンドウの Set Ranges オプションを使用して、Z 範囲の最大値を調整できます。サンプルドットとそ

れに関連する注釈は他の位置にドラッグすることができ、新しい位置はビューファイルに記憶されます。 

 

Arrows を選択すると Arrow Properties ダイアログ（図 10-4）が表示され、矢符の x, y 成分を与える変数、

矢符のスケール、線幅、矢符の色を選択できます。Color (automatic)を選択すると矢符の色は矢符の位置にあ

る Z 変数の値によって決まります。もし(automatic)色を使用する場合は Z 変数が定義されていることを確認

してください。Arrow Properties ダイアログを再度呼び出して矢符の設定を変更するには Original data の下

の Arrows エントリをクリックします。 

 

サンプル位置に色付きの点を表示する代わりに、Gridded field をクリックして、Z 変数を持つどのデータウィ

ンドウにおいても（鉛直断面に沿った、あるいは等値面上のプロパティ分布が例）格子化プロパティフィール

ドを作成することができます。まず利用可能な格子化手法である Quick gridding, Weighted-average gridding, 

DIVA gridding から一つを選択します。次に X 軸と Y 軸のそれぞれに適切な平均化長さスケールを指定してく

ださい。長さスケールの値は全軸範囲のパーミル（千分率）で、大きい値ほど平滑化されます。データ内の構

造の保存と滑らかさの間で許容できる妥協点が得られるまで、さまざまな長さスケールの値の使用を試みるべ

きでしょう。Automatic scale lengths チェックボックスをチェックすると、ODV はデータ分布を分析してグリ

ッド長スケールを自動的に選択します。 
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断面ウィンドウにおいて、ODV は等密度線のように成分の等値線を配置する高度な格子化手順である

Isopycnic gridding を提供します。この機能は中立密度 γn またはポテンシャル密度派生変数が定義され、かつ

DIVA による格子化が使用されている場合に利用できます。詳しくは下記を参照してください。 

 

格子化フィールドは、もし不適切に実行された場合、データの表現が不正確になる可能性があります。 

 

全てのＯＤＶ格子化手法は、所定の格子点(x, y）におけるあらゆる推定値に対して無次元の quality value を割

り当てます。Quality value は、推定に使用される全てのデータポイントの推定ポイントからの（それぞれの

平均化スケール長の単位で測定された）距離に基づいています。通常、約 3 より大きい Quality Value は、最

も近い測定が推定ポイントから 2 長さスケールより離れていることを示し、問題があると考えられます。Hide 

bad estimate ボックスをチェックして適切な Quality limit 値を指定することで、それに等しいまたは大きな値

の不適当な推定を非表示にできます。 

 

図 10-4：矢符プロパティダイアログ 

 

Do color shading がチェックされている場合、格子化フィールドは ODV によってカラーシェーディングされま

す。Draw marks がチェックされていて、ドットに対して適切なサイズと色が指定されている場合、実際のデ

ータポイントの位置がプロット内で印づけられます。プロパティフィールドの等値線（下記参照）およびカラ

ーシェーディングは、全ての格子化モードでサポートされています。 

 

図 10-5: データウィンドウのプロパティダイアログの各ページ (2/2)。 
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等高線（Contours）  

データウィンドウプロパティの Contours ページではプロットの等値線を定義できます。このページは Gridded 

field が表示スタイルとして選択されている場合にのみ有効です（上記参照）。等値線の自動選択を指定するに

は Auto-create ボタンをクリックしてください。等値線のセットを手動で追加するには New グループで Start, 

Increment, End の各 Z 値を指定してください。適切な線とラベルのプロパティを選択して<<ボタンを押すと等

値線のセットが Already Defined リストに追加されます。必要ならば異なる Start, Increment, End の値と、場合

によっては異なるラインとラベルのプロパティでこの手順を繰り返します。既存の等値線のプロパティを変更

するには Already Defined リストで選択して New グループのプロパティを変更し、<<ボタンを押して変更を確

定します。 

 

所定の Z 値 z に対応した等値線の描画に加えて、Fill の下から自動またはユーザーが指定した色を使ってｚよ

り大きい Z 値で定義された領域を塗りつぶすことができます。図 10-6b は、全ての等高線に対して Fill の下

の(automatic)を使用して作成されています。 

 

 

図 10-6：（a）連続的に塗りつぶしたフィールドと（b）等高線で塗りつぶしたフィールドの比較 

 

カラーマップ（Color Mapping） 

Color Mapping ページでは、Z 変数値とそれに関連付けられた色との間のマッピングを操作できます。このペ

ージは Z 変数を含むデータウィンドウ（例えばカラー断面または等値面上のカラー分布）に対してのみ有効で

す。Auto Adjust ボタンを押すと、Z 値の分布に基づいて自動的に作成される、おそらく非線形のマッピングが

確立されます。Linear Mapping ボタンを押すとデフォルトの線形カラーマッピングに戻ります。最高の色解像

度を得るために Z 値に対する Median（中線）トラックバーを動かし、Nonlinearity（非線形）トラックバー

を使用して非線形性を高めることによって、カスタマイズされたカラーマッピングを確立できます。 

 

DIVA 設定 (DIVA Settings)  
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DIVA 設定ページでは、DIVA 格子化アルゴリズムを制御するパラメータを操作できます。詳細については

DIVA 格子化手法の説明を参照してください。データウィンドウが DIVA 格子化を使用していない場合、この

ページは無効になります。 

 

10.2 ズーミングと自動計測 (Zooming and Automatic Scaling)  

マウスをウィンドウ上に移動させて、マウスの右ボタンをクリックしてデータウィンドウのポップアップメニ

ューを表示して Full Range または Zoom を選択することで、データプロットの変数の範囲を変更できます。Full 

Range の場合、現在のウィンドウの X 範囲と Y 範囲は、このウィンドウにプロットされた全てのデータ値に対

応するように調整されます。キャンバスポップアップメニューで Full Range（All）を使用すると画面上の全て

のデータプロットを一回の操作で自動スケールできます。 

 

Zoom を選択すると現在のウィンドウの周りに赤いズームフレームが表示されます。このズームフレームを操

作するには、マウスをその端、角、または内側に移動させて、マウスの左ボタンを押して端、角、またはフレ

ーム全体を目的の位置までドラッグします。下/左および上/右の角の x/y 座標はステータスバーの中央部分に

表示されます。ズームフレームの現在の設定を受け入れ、それに応じて変数範囲を調整するには、マウスの左

ボタンをダブルクリックするか、ENTER を押してください。ズーム操作を中止して元の変数範囲を維持したい

場合は Esc キーを押すか、マウスの右ボタンをクリックしてください。 

 

前の段落で説明した通常のズーム手順に加えて、追加のズーム方法(quick-zoom)があり、それは多くの状況で

簡単かつ素早く使えます。マウスがデータウィンドウまたはマップ上にあるときに Ctrl キー（Macintosh シス

テムでは cmd キー）を押したまま、かつマウスの左ボタンを押したままマウスを動かしてズームボックスを

開きます。マウスの左ボタンを離すとズームボックス設定の quick-zoom したウィンドウに適用されます。 

 

変更はズーミングされたウィンドウに適用されます。範囲の同期がオンになっている場合（View > Settings > 

Windows ダイアログページ、MacOS の場合は odv > Preferences > Windows を参照）、修正された変数の一つを

使用して新しい範囲が他のウィンドウにも適用されます。 

 
 

10.3 Z ズーミング (Z-Zooming)  

カラーバー付きの全てのデータウィンドウでは、カラーバーにズーミング（Z ズーミング）して Z 変数の範囲

を変更できます。Z ズーミングを起動するには、そのデータウィンドウの上にマウスを移動し、マウスの右ボ

タンをクリックしてデータウィンドウのポップアップメニューを表示します。Z Zoom を選択すると、それぞ

れのウィンドウのカラーバーの周りに赤いズームフレームが描画されます。上で述べたように、このズームフ

レームを操作してドラッグしてください。ズームフレームの現在の設定を受け入れて、それに応じて Z 変数の

範囲を調整するにはマウスの左ボタンをダブルクリックするか Enter キーを押します。ズーム操作を中止して

元の Z 変数の範囲を維持したい場合は ESC キーを押すかマウスの右ボタンをクリックしてください。 
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変更はズーミングされたウィンドウに適用されます。範囲の同期がオンになっている場合（View > Settings > 

Windows ダイアログページ、MacOS の場合は odv > Preferences > Windows を参照）、修正された変数の一つ

を使用して新しい範囲が他のウィンドウにも適用されます。 

 

10.4 ウィンドウレイアウトの変更（Changing Window Layout） 

測点図の位置とサイズと同様に、数、位置、ゼロ個以上のデータウィンドウはメインメニューの View > Window 

Layout、キャンバスポップアップメニューの Window Layout オプション、またはショートカットキーAlt-W を

押して簡単に変更できます。ODV は現在のレイアウトの輪郭を描き、ウィンドウの移動、サイズ変更、削除、

作成を可能にします。ウィンドウ上でこれらの操作の一つを実行するには、そのウィンドウ上にマウスを移動

し、マウスの右ボタンをクリックして適切なオプションを選択してください。 

 

Move/Resize を選択すると、それぞれのウィンドウの周りに赤いズームフレームが表示されます。このズーム

フレームを移動またはサイズ変更するには、マウスを角、端、または内側に移動し、マウスの左ボタンを押し

たままマウスを動かします。ウィンドウの新しいサイズと位置を受け入れるにはマウスの左ボタンをダブルク

リックするか Enter キーを押してください。ウィンドウ位置を変更せずに Move/Resize 操作を中止するには Esc

キーを押します。オーバーレイウィンドウ（下記参照）は移動やサイズ変更ができないことに注意してくださ

い。 

 

既存のウィンドウの一つにマウスを移動して右クリックして Create New Window または Create Overlay Window 

オプションを選択すると新しいウィンドウが作成されます。どちらの場合も新しいウィンドウの初期プロパテ

ィは既存のものから導入されます。Create New Window を使用する場合、新しいウィンドウは ODV グラフィ

ックスキャンバスの中央に配置されるので、上述の Move/Resize オプションを使用して配置およびサイズを変

更する必要があります。Create Overlay Window を使用するとオーバーレイウィンドウに必要ないくつかのプロ

パティが自動的に設定され、新しいウィンドウは既存のウィンドウ上に適切に揃います。このウィンドウを右

クリックして Properties オプションを選択すると、既存のウィンドウまたは新しいウィンドウのプロパティを

変更できます。ウィンドウの X 軸、Y 軸、Z 軸で新しい変数を選択するには Properties ダイアログの Data ペ

ージを選択し、各軸のコンボボックスで適切な変数を選択します。デフォルトでは変数値は右上がりに増加し

ます。方向を逆にしたい場合（例えばプロファイルの深さ）、それぞれの Reverse range ボックスをチェックし

てください。OK を押すと新しいプロパティが確定します。マップまたはどのデータウィンドウのプロパティ

も Window Layout モードを終了した後でいつでも変更できます（上記を参照）。 

 

マップウィンドウとデータウィンドウを手動で配置するだけでなく、さまざまなレイアウトテンプレートから

選択して定義済みのウィンドウレイアウトを実現することもできます（View メニューまたはキャンバスある
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いはウィンドウレイアウトポップアップメニューから Layout Templates を選択してテンプレートの一つを選

択してください）。 

 

マウスを右クリックして Accept を選択し Window Layout モードを終了すると新しいウィンドウレイアウトが

受け入れられます。変更を破棄して元のウィンドウレイアウトを維持する場合は Cancel を選択してください。 

 

10.5 グラフィックス出力（Graphics Output） 

GIF, PNG, JPG と Tiff ファイル（Files GIF, PNG, JPG and Tiff Files） 

キャンバス全体、個々のデータウィンドウまたはマップは、キャンバスポップアップメニューから Save Canvas 

As、データウィンドウまたはマップポップアップメニューから Save Plot As または Save Map As を選択し、それ

ぞれのファイルタイプを選ぶことによって gif、png、jpg、または tiff ファイルに保存することができます。こ

れらのオプションはショートカットキーでも呼び出すことができます：（1）マウスがキャンバス領域上にあ

るときに Ctrl-S を押すと ODV グラフィックスキャンバスが保存され、（2）マウスをマップまたはデータウ

ィンドウ上に置いて Ctrl-S を押すとそれぞれのデータプロットが保存されます。ODV はファイル保存ダイア

ログを表示し、適切な出力ファイルの種類（GIF（*.gif）、PNG（*.png）、JPG（* .jpg）または TIFF（* .tif））

を選択できます。デフォルトの出力ファイル名は現在のビューの名前から派生することに注意してください。

必要に応じて他の名前や保存先を選択できます。ODV は出力画像の解像度を定義できます。達成可能な最大

解像度はシステムで利用可能なメモリによって制限されることに注意してください。 

 

ポストスクリプトファイル (PostScript Files)  

画面全体または個々のデータウィンドウまたはマップの Encapsulated PostScript.ep ファイルを作成するに

は、キャンバスまたはそれぞれのデータウィンドウまたはマップ上で右クリックして Save Canvas As、Save Plot 

As または Save Map As を選択してください（もしくはマウスがキャンバス、データウィンドウ、またはマップ

上にあるときには Ctrl+S を押してもできます）。ファイルタイプで PostScript（* .eps）を選択し、出力ファイ

ルの名前と保存先を指定してください。その後 ODV は PostScript Settings ダイアログを表示するので、ここで

PostScrip 出力の向きとサイズを指定してください。生成された Encapsulated PostScript ファイルは

PostScript プリンタに送信して印刷したり、LaTeX または Word 文書にインポートしたり、Adobe Illustrator

や Corel Draw などの外部グラフィックスソフトウェアで開いて編集して処理することもできます。ODV.eps

出力ファイルを他の文書に取り込む場合は PostScript Settings 設定ダイアログの Show Collection Info ボックス

のチェックを外してください。 

 

10.6 データ統計（Data Statistics） 

ウィンドウを右クリックして Extras > Statistics を選択するか、マウスがウィンドウ上にあるときに F4 を押す

と、そのデータウィンドウに表示されているデータの統計情報を取得できます。ウィンドウの統計ページが表

示され（図 10-7 を参照）、それぞれのウィンドウの X, Y, (もし存在するなら)Z の各変数の平均、標準偏差、

https://www.sangyo-honyaku.jp/dictionaries
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標準誤差、データ点数、最小値と最大値が表示されます。平均値、標準偏差、標準誤差、データ点数は現在表

示されているデータのみに基づいていますが、最小値と最大値は使用可能な全データに関する値であることに

注意してください。 

各 Histogram を押すと X, Y, (もし存在するなら)Z データの分布ヒストグラムが得られます。ヒストグラムの

例を以下に示します。ヒストグラムは現在表示されているデータのみに基づいています。X/Y Distribution ボタ

ンを押すと X/Y 空間でのデータ分布のプロットが得られます。全てのヒストグラムと分布図は GIF、PNG、

JPG、TIFF、または Encapsulated PostScript ファイルに保存できます。 

 

   

図 10-7：北東太平洋における深さ方向の酸素を示す SCATTER データウィンドウ(左)、およびその統計概要

ダイアログボックス(右)。 

 

  

図 10-8：酸素のデータ分布ヒストグラム(左)および図 10-7 に示されるデータの酸素/深度データ分布(右) 

 

親データウィンドウが現在 Weighted-average または DIVA gridding を使用している場合は Gridding Misfits ボタ

ンが有効になります。このボタンを押すと現在の格子化処理の推定値とデータの差を示すプロットが表示され

ます（図 10-9 参照；訳注：原文では図 10-10 となっているが間違いと思われる）。 
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図 10-9：データ位置における推定値とデータとの差を示すプロットの例。 

 

ウィンドウ上でマウスを右クリックして Statistics > Curve Fitting を選ぶと、そのウィンドウの曲線近似ダイア

ログが表れます（図 10-10 参照；訳注：原文で図 10-8 となっているのは間違いと思われる）。ODV では（1）

最小二乗直線、（2）区分最小二乗直線、および（3）移動平均曲線の三種類の曲線でデータを近似できます。

Fitted Curves グループの一番上のコンボボックスから、これらの曲線タイプの一つを選択できます。次に、あ

てはめる方向を選択します（図 10-7 の例では、深度を関数とする酸素、例えば X(Y)が必要です）。曲線タイ

プ（2）と（3）では、曲線を評価する点の数を指定することもできます（デフォルトは 30；より滑らかな曲

線にするにはより大きい値を選択してください）。移動平均曲線（タイプ 3）の場合は平均の長さスケール（括

弧内の変数の軸範囲のパーミル（千分率）あたり、例えば図 10-7 の Y=深度）を指定できます。平均の長さ

スケールが大きいと滑らかになり、小さければデータ内の構造がより多く保存されます。曲線を作成して結果

を右側のボックスに表示するには Construct Curve を押してください。これらの結果は（Clipboard Copy を押し

て）クリップボードにコピーしてから、外部使用のための他の文書またはアプリケーションに貼り付けること

ができます。 

 

 

図 10-10：曲線近似ダイアログ。 

（訳注：原文では図 10-8 となっているが間違いと思われる） 
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Show Curve を押して作成した曲線をデータウィンドウに追加することもできます。曲線はポリライン（折れ

線）グラフィックスオブジェクトとして追加されることに注意してください。オブジェクトを右クリックして

Properties を選択することで、いつでもオブジェクトのプロパティの編集や変更、またはオブジェクトを削除

できます。 

 

10.7 等密度線（Isopycnals）  

データプロットポップアップメニューの Extras > Isopycnals オプションを選択して T/S データプロットに等密

度線を追加できます。Isopycnal Properties ダイアログで等密度線の基準圧力とそのグラフィカルプロパティを

指定してください。draw isopycnals チェックボックスをチェックする／チェックを外すと等密度線を描画しま

す／描画しません。 

 

Extras > Isopycnals オプションは次の二種類の T/S プロットに対してのみ有効です： 

1. Practical Salinity キー変数として識別されている基本塩分変数が X 軸上に、ODV 派生変数 Potential 

Temperature が Y 軸上にあります。 

2. 派生変数 Absolute Salinity が X 軸上にあり、派生変数 Conservative Temperature が Y 軸上にあります。 

Extras > Isopycnals オプションは無効で、等密度線は他の全ての場合には使用できません。 

 

10.8 フィールドチェックを使用した範囲外値の検出（Finding Outliers using Field 

Checks） 

Weighted-average または DIVA gridding を使用した SECTION または SCATTER データウィンドウでは Extras 

> Find Outliers（Field Check）オプションを使用して Z 変数データの範囲外値を識別および編集ができます。 

 

範囲外値出力ファイルの名前と位置を指定した後、ODV はデータ位置（フィールド値）で Z 値の推定を開始

し、estimate-minus-data の差（不適合）と不適合標準偏差を計算します。不適合標準偏差の 1.5 倍を超えてフ

ィールド値から外れているデータ値は範囲外値と見なされフラグが立てられます。この手順は直前にフラグが

立てられたデータポイントを除外して三回まで繰り返されます。 次に識別された範囲外値のリストを見て、

関連するＺ変数値を調べて編集することができます。 

 

範囲外値を識別するためのこの方法は、疑わしいデータの割合が比較的小さく、データウィンドウの選択され

た格子化した長さスケールがデータに見られる典型的な長さスケールに対応している場合に最も効果的で、格

子化フィールドでは正しく表現されない可能性がある急勾配の領域では注意が必要です。そのような領域で不

適合値が大きいと、データ値自体に問題があるというよりは、推定されたフィールド値が正しくないことを反

映している可能性があります。効率上の理由から、データウィンドウ自体が DIVA gridding を使用している場

合でもフィールドチェックには Weighted-average gridding が使用されます。 
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11 グラフィックスオブジェクト（Graphics Objects）  

キャンバス、マップ、または任意のデータウィンドウにテキスト注釈、記号、線、およびその他の幾何学的オ

ブジェクトを追加できます。ESRI シェープファイルで提供される地勢データを測点図に追加できます。以下

のグラフィックスオブジェクトがサポートされています：（1）テキスト注釈、（2）直線、（3）長方形と正

方形、（4）楕円と円、（5）連続直線（直線セグメントまたはベジエ平滑化）、（6）塗りつぶしポリゴン（直

線セグメントまたはベジエ平滑化）、（7）記号、（8）記号セット、（9）凡例、（10）ファイルからのさま

ざまなオブジェクトタイプ。これらのオブジェクトの詳細な説明は以下の通りです。 

 

グラフィックスオブジェクトは、そのオブジェクトが作成されたキャンバス、マップ、または特定のデータウ

ィンドウの所有になります。キャンバス、マップ、またはデータウィンドウの全てのグラフィックスオブジェ

クトは、それぞれの親ウィンドウが描画されるたびに描画されます。グラフィックスオブジェクトの座標は、

親ウィンドウまたはキャンバスの座標システムで指定されます。キャンバス座標は左下隅から右または上に向

かって cm（センチメートル）です。 

 

オブジェクトの初期の所有権と座標システムは、作成を始めたウィンドウから派生します（下記参照）。グラ

フィックスオブジェクトの他のほとんどのプロパティと同様に、所有権と座標システムはいつでも編集および

変更できます。デフォルトではグラフィックスオブジェクトは親ウィンドウに貼り付けられます。ウィンドウ

のビューポートの外側にオブジェクトを作成する場合は、必ずオブジェクトの Properties ダイアログボックス

の Clip to window ボックスのチェックを外してください（下記参照）。 

 

グラフィックスオブジェクトは現在のビューに属し、ビューファイルに保存されます。 

 

作成 (Creation)  

自動的に作成される凡例を除いて、マップまたはデータウィンドウポップアップメニューから Extras > Add 

Graphics Object > ...  [”...”は目的のオブジェクトタイプを示す]を選択して、他のグラフィックスオブジェクト

を作成および追加できます。またはキャンバスポップアップメニューから Add Graphics Object > ...を選択しま

す。最初の作成後、オブジェクトのさまざまなプロパティを定義するためのダイアログボックスが表示されま

す。これらのプロパティは後でいつでも再度変更できます（下記の Edit を参照）。グラフィックスオブジェク

トは、作成を始めたウィンドウ（またはキャンバス）の所有になり、グラフィックスオブジェクトの座標はそ

れぞれのウィンドウ座標システムにあります。結果としてウィンドウの全てのオブジェクトはそれぞれのウィ

ンドウが移動またはサイズ変更されたときに自動的に追従します。 

 

グラフィックスオブジェクトは、グラフィックスオブジェクトコンテキストメニューの Copy Object オプショ

ンまたはグラフィックスオブジェクト管理ダイアログの Copy ボタンを使用して、既存のオブジェクトのコピ

ーとして作成することもできます（下記参照）。既存のグラフィックスオブジェクトをエクスポートすること
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によって、以前に作成されたODV.gob ファイルからグラフィックスオブジェクトを読み込むこともできます。

断面プロットの海底地形ポリゴン、格子化フィールドを表示するデータウィンドウの等値線、オリジナルのデ

ータを表示するデータウィンドウの色付きデータ点、または測点図の測点選択ポリゴンなど、その他のウィン

ドウオブジェクトも.gob ファイルに書き込まれます。これらの書き込まれたオブジェクトは全て後で読み込ん

でグラフィックスオブジェクトとしてキャンバス、マップ、または任意のデータ・ウィンドウに追加すること

ができます。 

 

編集・削除 (Edit and Delete)  

特定のオブジェクトのプロパティは、その上にマウスを移動して（記号セットの場合はいずれかの記号の上に

マウスを移動して）、マウスの右ボタンをクリックしてポップアップメニューから Properties を選択すると変

更できます。軸ラベル、ユニット矢符ボックス、凡例などの一部のグラフィックスオブジェクトは自動的に作

成および削除されます（自動グラフィックスオブジェクト）。これらのオブジェクトは手動で編集または削除

することはできません（自動軸タイトルはウィンドウの Properties ダイアログの General ページでオン/オフを

切り替えられます）。 

 

（オブジェクトごとに異なる）ダイアログボックスが表示されるので、プロパティを簡単かつ迅速に変更でき

ます。グラフィックスオブジェクトは親ウィンドウに貼り付けられ（window ボックスの Clip をオンにする）、

ウィンドウのデータが描画される前に描画されます（Pre-data plot ボックスをチェックする）。オブジェクト

を削除するには、マウスをオブジェクトの上に移動してマウスの右ボタンをクリックし、Delete Object を選択

してください。 

 

ドラッグ (Dragging)  

グラフィックスオブジェクトの Allow dragging が設定されている場合は、オブジェクトを別の場所にドラッグ

するだけでオブジェクトの位置を変更できます。オブジェクトをドラッグするには、その上にマウスを移動し、

マウスの左ボタンをクリックしたままマウスを動かします。デフォルトでは、ドラッグは実際のデータ値にリ

ンクされている記号セットを除く全てのグラフィックスオブジェクトに対して最初はオンになっています。オ

ブジェクトの Properties ダイアログを使用して Allow dragging 属性をいつでも変更できます（上記参照）。 

 

グラフィックスオブジェクトの管理 (Managing Graphics Objects) 

それぞれの Extras > Manage Graphics Objects オプションを使用して、キャンバス、マップ、または任意のデー

タウィンドウのグラフィックスオブジェクトを管理できます。これにはオブジェクトのプロパティの変更（編

集）、エクスポート、コピー、削除、またはオブジェクトの描画順序の変更が含まれます。 

 

11.1 注釈（Annotations） 
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キャンバス、マップ、またはデータウィンドウポップアップメニューから (Extras >) Add Graphics Object > 

Annotation を選択して注釈を追加できます。十字カーソルが表示されますので、注釈を表示する場所に移動し

て、マウスの左ボタンをクリックしてください。作成を始めたウィンドウがそれぞれのオブジェクトを所有し

ます。注釈を追加（または編集）するときは、注釈テキストの位置、向き（度、反時計回り）、フォントサイ

ズ（ポイント(pt)）、色、および配置パラメータを設定できます。注釈は枠を持つことができ、テキストを描

画する前に注釈矩形を塗りつぶすことができます。これら全てのアイテムに異なる色を選ぶことができます。

ODV の注釈では、さまざまなフォーマット制御シーケンスと自動テキスト置換機能を使用できます。 

 

全てのグラフィックスオブジェクトと同様に、マウスカーソルをその上に移動し、マウスの左ボタンを押した

ままマウスを動かすことで注釈を別の位置にドラッグできます。注釈を編集するには、注釈の上にマウスを移

動してマウスの右ボタンをクリックし、ポップアップメニューから Properties を選択してください。注釈（全

ての注釈）を削除するにはポップアップメニューから Delete Object (Delete All Objects)を選択してください。 

 

データプロットウィンドウの軸ラベルは自動注釈として実装されています。それらはプロットウィンドウが描

画されるときに自動的に作成され、それぞれのデータプロットウィンドウが削除されるときに削除されます。

自動軸タイトルを編集または削除することはできません。軸ラベルの変更を恒久的にするには自動軸タイトル

をオフにし（ウィンドウの Properties ダイアログの General ページを参照）、キャンバスポップアップメニュ

ーから Extras > Add Graphics Object > Annotation を選択して手動で水平および垂直方向の注釈を作成してくだ

さい。 

 

11.2 直線、連続直線とポリゴン（Lines, Polylines and Polygons）  

マップ、データウィンドウ、またはキャンバスポップアップメニューから (Extras >) Add Graphics Object > Line, ... 

> Polyline or ... > Polygon を選択して、直線、連続直線、ポリゴンをマップ、データウィンドウ、またはキャン

バスに追加します。三つの場合の全てにおいてカーソルが十字に変わりますので、オブジェクトの節点を指定

して先に進む必要があります。Line グラフィックスオブジェクトの場合は始点と終点を定義する必要がありま

す。十字カーソルを線の始点に移動してマウスの左ボタンをクリックし、終点に移動してもう一度左ボタンを

クリックしてください。連続直線またはポリゴングラフィックスオブジェクトの場合、最大 1000 個の節点を

定義できます。ポリゴンは ODV によって自動的に閉じられることに注意してください。点を削除したい場合

は十字カーソルを点の近くに移動してマウスの右ボタンをクリックしてください。Enter キーを押すとポリゴ

ンまたは連続直線の点の定義が終了します。 

 

線、連続直線、またはポリゴンの節点を指定すると、ODV は、色、幅、（連続直）線（の種類、およびポリゴ

ンの塗りつぶしの色を定義できるプロパティダイアログを表示します（Line と Polyline では無視されます；ポ

リゴンの塗りつぶしを避けるためには塗りつぶしの色に（none）を選択します）。連続直線とポリゴンは Bezier 

smoothing ボックスをチェックすると線を滑らかにすることができます。 
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線、連続直線、ポリゴンの始点や終点には、矢尻、塗りつぶされた、または塗りつぶされていない点やバーな

どの特殊記号を付けることができます。そのような記号を選択するとプロパティダイアログを介してそれらの

サイズを指定できます。 

 

11.3 矩形と楕円 (Rectangles and Ellipses)  

マップ、データプロット、キャンバスに矩形(正方形)と楕円(円)を追加するには、マップ、データプロット、

キャンバスポップアップメニューから(Extras >) Add Graphics Object, …> Rectangle, … > Ellipse を選んでくださ

い。新しい矩形または楕円の境界ボックスを示す赤いズーム矩形が現れます。ズーム矩形は移動およびサイズ

の変更ができます。設定を確定するには ENTER を、オブジェクトの作成を中止するには ESC を押してくださ

い。ダイアログボックスが現れますので、矩形または楕円のプロパティを定義してください(詳細は線とポリ

ゴン(Lines and Polygons)を参照してください)。 

 

11.4 記号 （Symbols） 

記号(点、正方形、ダイヤモンド、三角形、逆三角形、星、×、プラス)をマップ、データウィンドウ、キャン

バスに追加するには、マップ、 データウィンドウ、キャンバスポップアップメニューから(Extras >) Add 

GraphicsObject > Symbol を選んでください。マウスカーソルが十字形になりますので、記号を表示させたい場

所に移動させてマウスの左ボタンをクリックしてください。Symbol Properties ダイアログボックスが現れたら、

それぞれの記号のプロパティを設定してください。 

 

11.5 記号セットと凡例 (Symbol Sets and Legends) 

選択したデータ点に記号(記号セット)を割り当てて、データウィンドウ中のデータの点のサブセットやマップ

中の測点のサブセットを強調することができます。データウィンドウやマップに記号セットを作成するには、

そのウィンドウ上にマウスを動かして Extras > Add Graphics Object > Symbol Set を選んでください。Symbol Set 

Selection ダイアログボックスが現れたらデータ点のサブセットを選択してください(一つ以上の航海ラベルを

Cruises リストの中から、測点を Stations リストの中から、および/または個々のサンプルを Samples リストの

中から指定してください)。Selected リストに選んだデータ点を追加するには<<ボタンを押してください。全て

の希望する点が選択されてから OK を押すと Symbol Set Selection Properties ダイアログが現れますので、記号

と線の特性を定義してください。記号セットが持つ説明文(凡例)はそれぞれのウィンドウの凡例に自動的に追

加されます(Add to legends ボックスをチェックしてください)。他のグラフィックスオブジェクトとは異なり、

記号セットは選択されたデータ点に関連付けられているのでドラッグできません。記号セット上にマウスを動

かして右ボタンをクリックし、Properties を選択すると、いつでも記号セットの全プロパティを変更すること

ができます。 
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図 11-1：特定の測点のデータを強調表示するために記号セットおよび凡例を使用した SCATTER プロットの

例 

 

データウィンドウまたはマップに記号セットが含まれている場合で、かつ Add to legends オプションがオンの

場合、このウィンドウに現れている全ての記号セットの記号と凡例の説明文を含んだ凡例ボックスが自動的に

表示されます。凡例セットは別の場所にドラッグでき、それらのプロパティ(凡例ボックスの大きさは説明文

のフォントサイズの変更に応じて修正されます)はいつでも修正できます(マウスを凡例セットに移動させて

右ボタンをクリックし、Properties を選んでください)。 

 

11.6 ファイルからのグラフィックスオブジェクト（Graphics Objects from Files） 

ODV は.cdt ファイルからの海底地形、海岸線または地形の等深線、.gob ファイルからのグラフィックスオブジ

ェクト、および ESRI .shp シェープファイルからの地勢の読み込みをサポートしています。マップ、データウ

ィンドウ、またはキャンバスポップアップメニューから(Extras >) Add Graphics Object from File > [type] 選んで

グラフィックスオブジェクトを追加できます。ODV は現在、次のタイプ：（1）Graphics Object File (*.gob)、

（2）CDT File (*.cdt)、および（3）Shapefile (*.shp) をサポートしています。全ての場合において「ファイルを

開く」ダイアログが表示され、グラフィックスオブジェクトを読み込むファイルを選択できます。cdt ファイ

ルと shp ファイルはマップにのみ追加できます。 

 

シェープファイルを開くとファイル内のオブジェクトの種類と数をユーザーに通知します。そして ODV では、

色、線の種類、幅などのグラフィックスプロパティを指定できます。これらのプロパティはシェープファイル

内の全てのオブジェクトに適用されますが、後で Manage Graphic Objects オプションを使用して変更できます

（下記参照）。 

 

シェープファイルに付随する.prj 投影ファイルがある場合、ODV は必要に応じて投影情報を使用して地理座

標を WGS84 に変換します。.prj 投影ファイルが見つからない場合、ODV は全ての地理座標が WGS84 であ

り、-180 から+360 および -90 から+ 90 度の範囲内にあると見なします。ODV は現在、シェープファイル



ODV User’s Guide 

 

129 

 

のポイント、マルチポイント、ライン、マルチライン、ポリゴン、マルチポリゴンをサポートしています。ポ

リゴンの場合は外側の輪だけが描かれます。非常に大きなシェープファイルの描画は遅くなることがあります。 

 

11.7 グラフィックスオブジェクトの管理（Managing Graphics Objects） 

各領域を右クリックして Manage Graphics Objects または Extras > Manage Graphics Objects を選択すると、キャ

ンバス、マップ、またはデータウィンドウの全てのグラフィックスオブジェクトの完全なリストを取得できま

す。 

図 11-2：Graphics Objects ダイアログ。 

 

Graphics Objects ダイアログ（図 11-2）が表示され、個々のオブジェクト、オブジェクトのサブグループ、ま

たはオブジェクトのリスト全体を選択できます。一つ以上のオブジェクトを選択した場合は Delete を押して

選択した全てのオブジェクトを削除するか、Export を押して後で再利用するために選択した全てのオブジェク

トを.gob または.shp ファイルにエクスポートできます。一つのオブジェクトだけを選択した場合は、そのオブ

ジェクトをコピーするか（Copy を押す）、またはそのオブジェクトのプロパティを変更することもできます

（Edit を押す）。描画順序を変更して、オブジェクトを最前面（Foreground または Up）または後面（Background 

または Down）に近づけることもできます。 

 

複数のオブジェクトをシェープファイルにエクスポートする場合、ODV は選択されたセット内の全てのオブ

ジェクトタイプに対して個別のファイルを作成します。最初のものを除く全ての作成されたシェープファイル

に対して、ODV は自動的にオブジェクトタイプを記述しているファイル名文字列に追加します（例：_points、

_polygons、または_lines）。エクスポートされたオブジェクトの少なくとも一つが記号セットの場合、全ての記

号と記号セットはマルチポイントジオメトリを持つシェープファイルに書き込まれます。エクスポートされた

オブジェクトの少なくとも一つがポリゴンの場合、全ての線とポリゴンはポリゴンとしてシェープファイルに

書き込まれます。 

 

現在のシェープファイルのエクスポートの実行にはいくつかの制限があります：（a）CDT ファイルオブジェ

クトと注釈は未だシェープファイルにエクスポートできません；（b）投影情報.prj ファイルは書き出されませ
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ん（全ての地理座標は WGS84 と見なされます）；（c）記号セットを除いて属性.dbf ファイルは書き出されま

せん（記号セットの場合、凡例文字列は属性 Name で書き出されます）；（d）全てのオブジェクトは最初の

レイヤーだけが書き出され、マルチレイヤーはサポートされていません。 
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12 コレクションの操作（Working with Collections） 

 

12.1 コレクションのコピー、パッケージング、名前の変更、削除 （Copying, Packaging, 

Renaming and Deleting Collections） 

Collection > Copy を使用して現在開いているコレクションのコピーを作成し、Collection > Move/Rename を使用

して現在開いているコレクションの名前を変更 (あるいは移動も)できます。Collection> Delete を使用して現在

開いているコレクションを削除できます。古い ODVGENERIC コレクションを削除する場合はコレクション

のビューおよびセクションファイルを手動で削除する必要があります。 

 

Collection > Create Snapshot オプションを使用して、コレクションを zip ファイルにパッケージ化できます。 

これは、コレクションのバックアップコピーを作成するときや、コレクションを友人と共有するときに便利で

す。パッケージ化によってソースコレクションは変更されません。 

 

12.2 並び替えと圧縮（Sorting and Condensing） 

コレクション内の測点が航海順に並べられている場合、ODV の測点検索および選択アルゴリズムは最も効率

的に機能します。したがって多数の測点のインポート、置換、マージ、または削除した後は、コレクションを

並び替えて圧縮することをお勧めします。Collection > Sort and Condense を選択して並び替えと圧縮の手順を呼

び出します。 

 

12.3 測点の削除（Deleting Stations） 

ODV のメインメニューから Collection > Delete Station Subset を選択すると現在選択されている測点をコレクシ

ョンから削除できます。現在の測点のみを削除するには Collection > Delete Current Station を選択します。コレ

クションディスクファイル内で削除された測点のデータスペースは、コレクションを並べ替えて圧縮するまで

解放されません。 

 

12.4 コレクションプロパティの変更（Changing Collection Properties） 

重要な注意：このセクションで説明されている操作を行う前に Collection > Create Snapshot オプションを使用

して現在のコレクションのバックアップコピーを作成してください。 

 

ODVGENERIC および ODVCF5 コレクションは Collection > Properties > Convert to ODVCF6 オプションを使用

して新しい ODVCF6 コレクション形式に変換できます。 

 

開いている ODVCF6 コレクションのプロパティは Collection > Properties オプションを使用して変更できます。 

General, Meta Variables, Data Variables の三つのサブオプションがあります。General オプションではデータフ

ィールド（GeneralField、Ocean、Atmosphere、Land、IceSheet、SeaIce、Sediment）、データタイプ
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（GeneralType、Pro-files、Trajectories、TimeSeries）、およびデータの並び替えに使用される主要変数を

定義できます。データフィールドとタイプのエントリは現在使用されていません。ただし将来の ODV バージ

ョンではデータフィールドに応じてさまざまな派生変数のセットが提供されるか、データタイプに応じてさま

ざまなデフォルトの作図スタイルが適用される可能性があります。 

 

Meta Variables と Data Variables オプションはメタデータとデータ変数セットの修正を可能にします。これに

は新しい変数の追加、既存の変数の削除、変数の並べ替え、データタイプ、バイト長、変数の品質フラグに使

用される品質フラグスキーマなどの変数のプロパティの変更が含まれます。最初の 12 個のメタ変数は必須で、

削除したり並べ替えたりすることはできません。 

 

コレクションのデータフィールド、データタイプ、または変数のラベル、単位、小数点以下の桁数の変更など

の一部の修正は、コレクションの設定または変数ファイルに新しいエントリを記録することで対処できる単純

な変更です。変数の追加または削除、コレクションの主要変数の変更、または変数のデータタイプまたは品質

フラグスキーマの変更は、コレクションのメタデータとデータファイルの完全な書き換えを必要とする重大な

変更です。 

 

コレクションの書き換えが発生すると、元のコレクションが ODVCF5 または ODVGENERIC であっても、新しい

コレクションは常に新しい ODVCF6 コレクション形式（.odv コレクション）を使用します。新しい ODVCF6 コ

レクション形式には ODV 4.6.0 以上が必要です。 

 

12.5 キー変数の関連付け（Key Variable Associations） 

多くの派生変数は、派生変数の計算に必要な入力変数の識別を必要とします。キー変数の識別は、派生変数の

最初の定義中に行われ、選択された変数はコレクションの設定ファイルに記録されます。後で派生変数が再度

要求された場合は、記録されているキー変数情報が使用され、ユーザーに再度要求が出されることはありませ

ん。 

Collection > Identify Key Variables を使用して現在のキー変数の関連付けを調べて変更できます。Identify Key 

Variables ダイアログが現れると、左側にキー変数のリスト、右側にデータ変数のリストが表示されます。関連

する項目はアスタリスク（*）で印付けられています。リストのいずれかでそのような項目をクリックすると

ODV は他のリストに関連項目を表示します。Undo 押すと関連付けを解除できます。Undo All を押すと全ての

関連付けが解除されて全てのキー変数が未定義のままになります。 

 

二つのリストで関連項目を選択して Associate を押すと関連付けが確立されます。データ変数のリストに含ま

れていないキー変数リスト内の項目は Not Available ボタンを押すことによって使用不可としてマークされま

す。このような項目はキー変数リスト内ではマイナス記号（-）で印付けられています。 

 

重要な注意：キー変数の関連付けに失敗すると、影響を受ける派生変数の値が間違い、かつ意味のないものに

なる可能性があります。例えばキー変数 Practical Salinity [psu]が誤ってデータ変数 Oxygen [μmolkg-1]に関連付
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けられていたとします。これは Practical Salinity [psu]を入力変数として要求する全ての派生変数（例えばポテ

ンシャル水温、ポテンシャル密度など）が、塩分の代わりに酸素値を使用するため、誤った値を返す原因にな

ります。疑わしい派生変数の値を受け取ったときには、先ず Collection > Identify Key Variables オプションを使

用してキー変数の関連付けの有効性の検証をチェックするべきです。 

 

 

図 12-1：Identify Key Variables ダイアログ 

 

12.6 有効範囲の基準（Good Coverage Criteria） 

標準層への内挿やさまざまな派生変数の計算など、一部の ODV 操作では sufficient（十分な）入力データが利

用可能であることが必要です。例えば、力学高度の計算には水温と塩分のデータの完全なプロファイルが必要

です。また、データポイント間のギャップが大きすぎてもいけません。Collection > Good Coverage Criteria を使

用して、所定の変数のデータが十分であること考慮するために満たさなければならない基準を指定できます。

これらの基準は特定の操作によって必要な全ての変数に適用されます。一つ以上の必須変数がテストに失敗し

た場合、それぞれの操作は実行されません。 

 

許容ギャップの仕様は二つの項の最小値であり、一つは主要変数値 Z（プロファイルデータコレクションの場

合は深さまたは圧力）に依存し、もう一つは第二定数項です。大きなデータギャップを許容する場合は、両方

の行の最初のフィールドに大きな値を入力してください。 

 

12.7 コレクション情報の閲覧（Browsing Collection Information） 

コレクション情報（Collection Info） 

全てのコレクションには、そのコレクション内のデータに関するフリーテキストの説明があります。この情報

はコレクションの情報ファイルに保存されています。Collection > Browse Info File を選択すると現在開いている

コレクションの情報ファイルを表示または編集できます。 
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航海目録（Cruise Inventory） 

Collection > Browse Inventory を選択すると現在開いているコレクションの航海目録表を表示します。航海 ID、

測点数、サンプル数、測点 ID、経度と緯度の範囲、期間、および各基本変数のデータ可用性指標に関する情報

が全ての航海に関して提供されます。データ可用性指標は一桁の数字で、例えば 9 ならばサンプルの 90％以

上が所定の変数のデータを含んでいることを示します。五つの変数ごとに”.”、そして 10 個の変数ごとに”|”

で区切ります。”-” はこのクルーズでは所定の変数に関するデータがないことを示しています。別のウィンド

ウには所定のクルーズのデータを含む変数のリストが表示されます。 

 

コレクションログファイル（Collection Logfile） 

コレクションの内容を変更する全ての操作（作成、データのインポート、測点の削除など）はコレクションロ

グファイルに記録されます。メタデータやデータの編集は測点の履歴（ODVCF6）またはコレクションログフ

ァイル（ODVCF5 と ODGENERIC）に記録されます。Current Station Window の測点 ID の見出しの上にマウ

スを置くと測点の履歴が表示されます。コレクションログファイルは Collection > Browse Log File オプション

を使用して表示できます。 

 

12.8 変数のプロパティ（Properties of Variables） 

現在の測点または現在のサンプルリストウィンドウを右クリックして Properties オプションを選択するとメタ

変数とデータ変数のプロパティを変更できます。変数のリストから変更したいものを選択して Edit を押して

ください。選択した変数のプロパティダイアログで変数ラベル、単位、コメントの文字列を編集できます。現

在の測点またはサンプルウィンドウに値を表示するために使用される桁数を変更することもできます。 

 

12.9 データの編集（Editing Data） 

現在の測点のメタデータとデータ値、およびそれらに関連付けられている品質フラグを編集し、変更した値を

ディスク上のコレクションデータファイルに保存できます。 

 

測点メタデータ （Station Metadata） 

現在の測点のメタデータを修正するには、現在の測点リストウィンドウを右クリックして Edit > Metadata を

選択してください。現在の測点のメタデータを示す Edit Station Metadata ダイアログが表示されます。個々の

エントリを編集するには、それぞれの値フィールドをダブルクリックしてください。特定の品質フラグを変更

するには、そのフィールドをクリックしてから Change Quality Flag ボタンをクリックして新しい品質フラグ

を選択してください。 

 

Edit Station Metadata ダイアログで OK をクリックすると新しいメタデータがコレクションファイルに書き込

まれます。変更を破棄して現在の測点のメタデータを変更しない場合は Cancel を押してください。OK が押さ

れて、編集された変数が値タイプ INDEXED_TEXT を持つならば、あなたは現在のインスタンスのみ、または
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前の文字列の全ての発生を修正するオプションを持っています。Modify all instances を選択すると、テキスト

内の間違いを修正したり、コレクション内の航海ラベルなどの項目を一回の編集操作で全体を修正したりでき

ます。 

 

編集操作は測点の履歴（ODVCF6）またはコレクションログファイル（ODVCF5 と ODVGENERIC）に記録さ

れます。Current Station Window の測点 ID の見出しの上にマウスを置くと測点の履歴が表示されます。コレク

ションログファイルは Collection > Browse Log File オプションを使用して表示できます。 

 

図 12-2：Edit Station Metadata ダイアログ 

 

測点データ （Station Data） 

現在の測点の所定の変数のデータを修正するには、現在のサンプルリストウィンドウ内の特定の変数を右クリ

ックして Edit Data を選択してください。現在の測点の全てのサンプルに対する変数のデータ値と品質フラグ

を示す Edit Data ダイアログが表示されます。現在のサンプル（初期選択）またはユーザー定義のサンプルサ

ブセットのデータ値と品質フラグを変更できます。マウスを左クリックしながら標準の拡張選択キーCtrl と

Shift を押してデータリストのサンプルサブセットを定義してください。Select All をクリックして全てのサン

プルを選択するか Invert Selection を押して現在の選択を反転させてください。 

 

単一のデータ項目を選択した場合は Change Value をクリックして新しい数値を入力することによってその値

を変更できます。データリストで複数のサンプルを選択した場合 Change Value ボタンは無効になります。

Delete Value(s）ボタンを押すと選択した全てのサンプルのデータ値が削除されます。元のデータ値は永久に失

われるので、このボタンは慎重に使用してください。 

 

警告：Change Value オプションを使って主要変数の値（深さ、圧力、時間など）を編集するのは危険であり、

予期せぬ影響が生じる可能性があることに注意してください。具体的には、主要変数の値の変更は現在の測点
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内のサンプルの順序に影響を与え、編集中のサンプルはプロファイル（または時系列）内で上下に移動して、

編集後にサンプル ID が変わる可能性があります。これが発生した場合、編集後の Current Sample Window に

は編集されたサンプルは表示されなくなりますが、並べ替え後に編集されたサンプルの場所を持っているサン

プルはこれにはあてはまりません。 

 

サンプル値の編集と削除は、どうしても必要なときにだけ行ってください。 通常は実際のデータ値を変更せ

ずに、選択したサンプルのデータ品質フラグを変更するべきです。これは、Change Quality Flag(s）ボタンをク

リックして利用可能なフラグのリストから新しい品質フラグを選択することによって行われます。OK を押す

とディスクへの変更が保存され、Cancel を押すと編集セッションが中止されて測点データは元の形式のままに

なります。 

 

品質フラグの値を使用してデータをフィルタリングできます。編集操作は測点の履歴（ODVCF6）またはコレ

クションログファイル（ODVCF5 と ODVGENERIC）に記録されます。Current Station Window の測点 ID の見

出しの上にマウスを置くと測点の履歴が表示されます。コレクションログファイルは Collection > Browse Log 

File オプションを使用して表示できます。 

 

現在の測点の所定のサンプルのデータを修正するには現在のサンプルリストウィンドウを右クリックして

Edit Sample Data を選択してください。現在のサンプルの全てのデータ変数のデータ値と品質フラグを示す Edit 

Sample Data ダイアログが表示されます。特定の変数のデータ値または品質フラグを変更するには、その変数

をクリックしてから Change Value, Delete Value, または Change Quality Flag ボタンをクリックします。 

 

サンプルリストウィンドウを右クリックしてオプション Delete Current Sample を選択すると、現在のサンプル

（全てのデータ変数の全てのデータ値を含む）を削除できます。あるいはサンプルリストウィンドウを右クリ

ックしてオプション Add New Sample を選択すると新しいサンプルを追加することもできます。新しいサンプ

ルの主要変数値を入力して OK を押してください。 
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図 12-3：データ編集ダイアログ(所定の変数の全てのサンプル値) 

 

 

図 12-4：Edit Sample Data ダイアログ(所定のサンプルの全ての変数値) 

 

品質フラグ値（Quality Flag Values） 

上記の方法に加えて、Current Sample ウィンドウで変数を右クリックし、Assign Quality Flags サブメニュー: (1) 

Current Sample, (2) All Samples of Current Station, (3) All Samples in Window n, (4) All Samples of Valid Stations,  (5) 

All Samples in Collection.のいずれかのオプションを使用して、所定の変数のデータの品質フラグ値を変更する

こともできます。 
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品質フラグの変更が適用されるサンプルのセットは選択したオプションによって異なり、現在のサンプルのみ

（オプション 1）からコレクション内の全ての測点の全てのサンプル（5）までの範囲です。オプション 3 で

は、現在のデータウィンドウ n に表示されている変数のデータに新しい品質フラグを割り当てることができま

す。オプション 4 と 5 では、現在マップに表示されている全ての測点の全てのサンプル（有効な測点）または

コレクション内の全ての測点の全てのサンプルに新しい QF 値を適用します。 

オプション 3 から 5 は潜在的に非常に大きなサンプルのセットを変更するため、変更を加える前にユーザー

が確認する必要があります。 

 

サブメニューオプションの一つを選択した後に ODV は Assign Quality Flags ダイアログを表示します（図 12-

5）。このダイアログでは、割り当てる新しい品質フラグ値を選択し、このフラグを現在の値に関係なく全て

のサンプルに割り当てるか、特定の QF 値のみに等しい（または等しくない）サンプルに割り当てるかを指定

します。この操作は、測点の履歴（ODVCF6）またはコレクションログファイル（ODVCF5 と ODVGENERIC）

に記録されます。Current Station Window の測点 ID の見出しの上にマウスを置くと、測点の履歴が表示されま

す。現在マップに表示されている全ての測点の履歴レコードは Export > Station History オプションを使用して

テキストファイルにエクスポートできます。コレクションログファイルは Collection > Browse Log File オプシ

ョンを使用して表示できます。 

 

 

図 12-5：品質フラグの割り当てダイアログ 

 

12.10 パスワードプロテクション（Password Protection） 

ODVCF6 コレクションは Collection > Properties > Change Password オプションを使用してパスワードで保護で

きます。Change Collection Password ダイアログで現在のパスワードを入力し（コレクションが現在パスワード

で保護されていない場合は空白のままにします）、新しいパスワードを二回入力します。現在保護されている
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コレクションのパスワード保護を解除するには、古いパスワードを入力して New Password と New Password 

(repeated) を空白のままにします。 

 

パスワードで保護されたコレクションを開くと ODV はユーザーにパスワードの入力を求めます。入力したパ

スワードが正しくないとアクセスは拒否されます。コレクションのパスワードは安全な場所に保管してくださ

い。パスワードを紛失するとデータコレクションにアクセスできなくなります。 
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13 NetCDF ファイルの操作 (Working with NetCDF Files) 

NetCDF はソフトウェアライブラリのセットで、配列指向の科学データの作成、アクセス、および共有をサポ

ートする自己記述型でマシンに依存しないデータフォーマットです。NetCDF は気候研究やその他の地球科学

の分野で広く使用されています。多くの重要なデータセットとモデル出力ファイルは netCDF フォーマットで

配布されています。 

 

NetCDF ファイルは以下のプロパティを持っています： 

⚫ Self-Describing. （自己記述型） netCDF ファイルは、そのファイルに含まれているデータについて

の情報を含みます。 

⚫ Architecture-independent. （アーキテクチャ非依存）NetCDF ファイルは、異なる方法で収録されて

いる整数、文字、および浮動小数点数であっても、どのコンピュータからでもアクセスできる形式で

表されます（訳注：原文には書いていませんが、（CPU の違いによる）ビックエンディアン、リトル

エンディアンを意識することなくアクセス可能、ということだと思われます）。 

⚫ Direct-access. (直接アクセス)  大きなデータセットの小さなサブセットには、最初に全てのデータを

読み込まなくても、効率的にアクセスできます。 

⚫ Appendable. (追記可能) データセットをコピーしたり、その構造を再定義したりすることなく、デー

タを一次元で netCDF ファイルに追加することができます。NetCDF ファイルの構造は変更するこ

とができますが、これによってデータセットがコピーされることがあります。 

⚫ Sharable. (共有可能) 一人の作成者と複数の利用者が同じ netCDF ファイルに同時にアクセスする

ことができます。 

 

NetCDF データモデルは非常に一般的であり、netCDF ファイルの構造と内容はかなり異なります。NetCDF

データセットの交換と共有を容易にして促進するために、いくつかの規約が定義されています。 

二つの規約（CF と COARDS; 詳細な仕様については、

http://www.unidata.ucar.edu/packages/netcdf/conventions.html を参照）が気候研究者やモデラーによって広く

使用されており、多くのデータセットが CF/COARDS 準拠の netCDF ファイルとして利用可能です。そのよ

うなデータセットの例は、http://www.cdc.noaa.gov/PublicData/、http://ferret.wrc.noaa.gov/ （訳注：現在リ

ンクが切れているようです）、http://ingrid.ldeo.columbia.edu/ または

http://www.epic.noaa.gov/epic/ewb/ （訳注：現在リンクが切れているようです）からダウンロードで

きます。NetCDF についての詳細は、NetCDF の Web ページ 

http://www.unidata.ucar.edu/packages/netcdf/ を参照してください。 

  

13.1 NetCDF サポート（NetCDF Support）  

ODV は CF/COARDS に準拠したファイルを含むものの、これに限定されない広範囲な netCDF ファイルを開

くことができます。これらのファイルはローカルファイルシステムまたはリモート OPeNDAP サーバーに存

http://www.unidata.ucar.edu/packages/netcdf/conventions.html
http://www.cdc.noaa.gov/PublicData/、http:/ferret.wrc.noaa.gov/
http://ingrid.ldeo.columbia.edu/
http://www.unidata.ucar.edu/packages/netcdf/
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在します。NetCDF ファイルが正常に開かれると、ODV はあたかもデータが ODV データコレクションに保存

されているかのようにファイル内のデータをユーザーに提示します。ODV はクリック可能な測点図を作成し、

コレクションに関してはほとんどのタイプのグラフィックス出力をサポートします。書き込み権限が必要なオ

プションは利用できずグレー表示されます。ODV は netCDF ファイルを読み取り専用として扱い、これらの

ファイルを変更することは決してありません。NetCDF ファイルはプラットフォームに依存せず、サポートさ

れている全てのプラットフォームで同じファイルを使用できることに注意してください。 

 

NetCDF ファイルの中の所定の変数 S のデータは一次元または多次元配列として格納されます。時空間変数の

次元のセットには三つの空間座標 X, Y, Z と時間座標 T が含まれます。これらの次元をＳ(Ｔ, Ｚ, Ｙ, Ｘ)と

して順序付けることは規約であり、例えばＸは最も速く、Ｔは最も遅く変化する次元になります。地球科学デ

ータの場合、X と Y は経度と緯度を表し、Z は海洋の深さや気圧、大気中の高度、堆積物や氷床コアの深さな

どの鉛直座標です。NetCDF ファイルが複数の X, Y, Z, T 座標系を含むことは可能です。例えばモデル出力の

netCDF ファイルには、グリッドインターフェイスで定義された速度データだけでなく、モデルグリッドの中

心で定義されたデータ（トレーサー濃度など）を含めるのが一般的です。ODV は一度に一つの X, Y, Z, T 座

標系しか扱うことができないため、対応する次元は netCDF セットアップ中に選択する必要があります（下記

参照）。 

 

NetCDF ファイルを開くときの ODV ユーザーの主な課題は、空間と時間の次元を正しく識別し、複数の座標

系で状況を把握して、適切な主要変数を選択することです。例えば主要変数として Z を選択すると netCDF フ

ァイルは全ての(X, Y）位置に nT 個の測点を持つ鉛直プロファイルデータベースに変換されます。この場合の

測点の総数は nT * nY *nX です。ここで nK は次元 K の長さです。あるいは T を主要変数として選択した場合、

netCDF ファイルのデータは時系列として解釈されます。この場合（X, Y, Z）ポイントごとに一つの測点（時

系列）となり、測点の総数は nZ * nY * nX です。 

 

最高レベルのユーザーコントロールを提供するために、ODV は netCDF ファイルが初めて開かれたときに

netCDF セットアップウィザードを表示します。この四ページのダイアログのさまざまなコントロールは自動

的に定義された設定で初期化されます。多くの場合、ユーザーは Next を押して設定を確認し、最後に Finish を

押すだけで済みます。これらの設定は ODV によって記憶され、ファイルを再度開いたときにセットアップウ

ィザードは表示されません。以下の方法で ODV にセットアップウィザードを表示させることができます：（1）

（例えば File > Open オプションで）netCDF ファイルを開き、（例えば File > Recent Files オプションで）同じ

netCDF ファイルを再度開く、または（2）netCDF ファイルが開いている間に Collection > Properties > NetCDF 

Setup を使用します。 

 

ローカルファイルシステム上の netCDF ファイル（拡張子は .nc または .cdf である必要があります）を開く

には、ODV アイコンまたはウィンドウにファイルをドロップするか、File > Open を選択して標準のファイル

選択ダイアログでファイルを選択します。NetCDF ファイルを開く前に File > Recent Files オプションを使って
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ファイルにアクセスすることもできます。さらに、ODV をコマンドラインから起動し、netCDF ファイル名を

コマンドライン引数として指定することもできます。 

 

リモートの OPeNDAP サーバー上の netCDF ファイルを開くには File > Open Remote オプションを使用して

netCDF フ ァ イ ル へ の URL を 入 力 し て く だ さ い （ 例 ：

http://motherlode.ucar.edu:8080/thredds/dodsC/testdods/coads_climatology.nc）。 

netCDF フ ォ ー マ ッ ト の 公 開 気 候 デ ー タ リ ソ ー ス へ の URL は イ ン タ ー ネ ッ ト 上 、 例 え ば

http://www.esrl.noaa.gov/psd/thredds/catalog で見つけることができます。 

 

ODV は netCDF ファイルを開き、ファイルに含まれる次元と変数に関する情報を取得します。ODV はまた、

全てのグローバル属性と変数の全ての属性を取得し、この情報を ncdump –h < file>が生成する形式と同じ形式

で ASCII ファイルに書き出します。このファイルはセットアップウィザードの最初のページにある View 

NetCDF Header ボタン（下記参照）をクリックするか、Collection > Browse Info File オプションを使用していつ

でも表示できます。 

 

13.2 NetCDF セットアップ（NetCDF Setup） 

netCDF ファイルが分析されると、ODV は必要な情報を集めるための四ページのウィザードを表示します。 

 

NetCDF 次元の選択（Selecting NetCDF dimensions）  

セットアップウィザードの最初のページ（図 13-1）にはファイルに含まれている次元のリストが表示されま

す。最初に全ての次元が選択されます。ただし複数の X, Y, Z, T 座標系で、これらの系の一つのみが選択されて

いる場合を除きます。所定の次元の選択に対して、これらの次元で定義された netCDF 変数のセットは、

Corresponding netCDF variables リストに表示されます。NetCDF dimensions リストで選択されていない次元に依

存する netCDF ファイル内の他の変数は Corresponding netCDF variables として表示されません。対応する次元

を選択しない限り、これらの変数は使用できません。拡張選択テクニック（Ctrl キーまたは Shift キーを押しな

がらマウスの左ボタンをクリック）を使用して、使用する必要がある全ての次元を選択してください。共通の

次元 X（経度）、Y（緯度）、Z（深度/高さ）、および T（時間）に複数の座標が指定されている場合は、必ず

各方向に一つのみを選択してください。 

 

NetCDF ファイルのヘッダー情報を（ncdump-h と同様に）表示するには View NetCDF Header ボタンを押して

ください。ユーザーがファイルの構造と内容に慣れていないなら、これは常にされるべきです。 

http://www.esrl.noaa.gov/psd/thredds/catalog
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図 13-1:netCDF セットアップウィザード(手順 1/4) 

 

メタデータ情報の指定（Specifying metadata information）  

セットアップウィザードの二ページ目（図 13-2）で、経度、緯度、データの日時などのメタデータを提供す

る netCDF 変数を識別する必要があります。多くの場合、ODV はそれぞれの変数を自動的に識別して関連付

けることができます。このような自動的に関連付けられたメタ変数はアスタリスク(*)で印付けられます。 

 

場合によっては自動設定を変更して手動で netCDF ファイル（NetCDF variables リスト）の変数と ODV メタ

変数（Meta variables リスト）の間の関連付けを確立する必要があります。 

 

NetCDF 変数とメタ変数の間の（一対一の）関連付けを確立するには NetCDF variables リストの中の netCDF

変数と Meta variables リストの中のメタ変数を選択して Associate を押してください。NetCDF メタ変数と ODV

メタ変数（通常 netCDF 時間変数に必要）の間の変換を確立するには上記のように二つの変数を選択してから

Convert を押してください。コンボボックスから利用可能な変換オプションの一つを選択して OK を押してく

ださい。General Linear Transformation では倍率とオフセット（位置・距離）を指定してください。 

 

多くの netCDF ファイルは、特定の開始日からの日数または時間数で与えられる相対時間を使用します。この

情報を活用して日と時間のメタ情報を取得することができます。これを行うには NetCDF variables リストで相

対時間を、Meta variables リストで Year を選択してから Convert を押してください。ODV は自動的に変換を確

立しようとします。うまく行かなかった場合、ODV は手動での適切な変換アルゴリズム選択を促します。ODV

は基準日がグレゴリオ暦に基づいている事に注意してください。ODV 日付値はグレゴリオ暦の日付です。 

 

メタ変数（例えば航海など）のデフォルト値は Meta variables リストで選択して Set Default を押すことで変更

できます。 

 

メタ変数 Cruise, Station, Type は ODV によって自動的に設定されるので手動で設定する必要はありません。

NetCDF ファイルに日付と時刻の情報が含まれていない場合、Year, Month, Day, Hour, Minute, Second のメタ変
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数は関連付けられていないままかもしれません。しかしながらウィザードの次のページに進む前に Longitude 

と Latitude のメタ変数は常に関連付けられていなければなりません。 

図 13-2：netCDF セットアップウィザード(ステップ 2 of 4) 

 

主要変数の選択 (Selecting the primary variable)  

セットアップウィザードの三ページ目（図 13-3）で主要変数を選択します。この変数は ODV コレクションで

主要変数の役割を果たし、データが鉛直プロファイルまたは時系列として解釈されるかどうかを決定します。

例えば Depth または他の鉛直次元が主要変数として使用される場合、測点は鉛直プロファイルを表示します。 

Time 変数を使用する場合、測点は時系列を表示します。Year メタ変数がウィザードの二ページ目で定義され

た場合は Use decimal date/time 項目が有効になり、測点ヘッダーから派生した十進化時間変数（units=YEARS）

を主要変数として使用できます（時系列では日付/時刻メタ情報は時系列の開始を参照し、それらは一定値で

す。） 

 

NetCDF ファイルには層の正確な値を明示する変数（例えば深度=0m または深度＝1000ｍ、など）を指定し

ない、水平格子上のデータ値（例えば大気―海洋境界面を横切るフラックス、または特定深度層での濃度）が

頻繁に含まれています。そのような場合は Use dummy variable 項目を選択してください。 

図 13-3：netCDF セットアップウィザード(ステップ 3 of 4) 
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次元の部分設定（Subsetting dimensions） 

大規模な netCDF データセットを扱うときは、データアクセスを関心のある範囲と深さ、または時間範囲に制

限すると便利です。デフォルトで ODV は測点の総数が 300,000 を超えないように経度と緯度の範囲の増分

値（ストライド）を調整します。 

 

手動で任意の座標変数をサブセット化することもマップにズームインして範囲を絞り込むこともできます。特

定の範囲をサブセット化するには NetCDF dimensions リストで対応する項目を選択して Subset Dimension ボタ

ンを押してください。ODV にはそれぞれの座標値のリストが表示され、この座標の開始インデックス、増分、

終了インデックスを指定できます。新しいインデックスセットを受け入れるには OK を押してください。サブ

セット化する全ての範囲に対してこの手順を繰り返します。 

 

関心のあるサブ領域を定義するには Zoom into Map ボタンをクリックしてから赤いズームボックスを目的の範

囲にサイズを変更または移動して Enter ボタンを押すか、マウスの左ボタンをダブルクリックして選択してく

ださい。ズーム操作を中止するには ESC キーを押すかマウスを右クリックしてください。 

 

 

図 13-4：netCDF セットアップウィザード(手順 4/4) 

 

NetCDF ファイルの探索（Exploring the netCDF file） 

NetCDF セットアップウィザードの四つのステップ全てが完了すると ODV は測点図を描き、ネイティブの

ODV データコレクションに使用しているのと同じ方法で netCDF ファイル内のデータを調べることができま

す。ODV は netCDF ファイルを読み取り専用のデータセットとして扱い、これらのファイルには書き込めま

せん。したがってデータ書き込みアクセスを必要とする全てのオプションが無効になります。これには全ての

データインポートオプション、メタデータとデータオプションの編集、およびほとんどのコレクション操作オ

プションも含まれます。 
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ODV は netCDF セットアップの設定をビューファイルに保存し、次回 netCDF ファイルを開いたときにこれ

らの設定を使用します。すでに開いている netCDF ファイルに新しい設定を適用したい場合は、File > Recent 

Files オプションを使って netCDF ファイルをもう一度開きます。 

 

NetCDF リモートアクセス（Remote netCDF access）  

リモートの netCDF ファイルで作業するときのデータアクセス速度は、インターネット接続の帯域幅と、発行

されたデータ要求の種類に依存します。主要変数の長さが大きい場合（上記参照）、（例えば地図をクリック

することが引き金となる）個々の測点データを取得するには、かなり時間がかかります。これは、例えば

netCDF ファイルが数千の圧力または深度値のプロファイルデータ（例えば CTD データ）、または数千の記

録時間を有する時系列データ（例えば流速計データ）を含む場合に起こります。そのような場合は不要なデー

タ検索を引き起こさないように、意図せずに測点図をクリックしないようにしてください。 

 

リモートの netCDF ファイルで作業する場合、ODV SECTION ウィンドウのデータを読み込むには非常に時

間がかかります。したがってそのような場合、セクションを定義および管理するためのオプションは無効にな

ります。NetCDF セットアップウィザードの四ページ目で緯度（経度）範囲を部分設定化し、一つの値だけを

選択することで東西（または子午線）断面に沿って分布を表示することができます。Collection > Properties > 

NetCDF Setup を選択するといつでもセットアップウィザードに入ることができます。次に派生変数 Metadata > 

Longitude（Metadata > Latitude）を定義して X 上の派生経度（緯度）変数、Y 上の鉛直座標、Z として表示す

る変数を使用して SCATTER ウィンドウを確立してください。 

 

数値データに加えて ODV 4.7.4 以降では netCDF ファイルからテキスト変数のデータを抽出して Current 

Sample Window にテキストを表示します。Current Sample Window にはさらに多くの変数が表示されており、

変数の名前と順序は以前のバージョンの ODV とは異なります。変数の順序は次のとおりです：主要変数、ア

ルファベット順の数値変数リスト、アルファベット順のテキスト変数リスト。ODV 変数名はファイル内の

netCDF 変数名で、units エントリは units 属性から取られます。全ての ODV 変数は netCDF 変数の long_name, 

comment および convention 属性の連結で構築されたコメント文字列を持ちます。ODV は Current Sample 

Window 内の変数の上にマウスを移動するとコメントを含む ODV 変数の詳細を表示します。 

 

変数名の一部として_QC 接尾辞を含む netCDF 変数は自動的に品質フラグ変数として扱われ、それらの値は親

変数の品質フラグとして ODV によって使用されます。変数名の一部として_STD または_ERROR 接尾辞を含む

netCDF 変数は自動的に親変数のデータエラー変数として扱われます。 

 

注：ODV 4.7.3 以前を使用して netCDF ファイル用に作成されたビューは、ODV 4.7.4 以降では変数の数

と順序の違いにより正しく表示されない可能性があります。問題が発生した場合は等値面変数を再定義し、

データウィンドウの X, Y, Z 軸で変数を再割り当てしてください。 
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14 ツール（Tools） 

14.1 地衡流（Geostrophic Flows） 

Tools > Geostrophic Flows オプションを使用して現在の断面に垂直な地衡流を計算し視覚化することができま

す。結果を受け取る.odv 出力コレクションの名前を指定し、深度、等密度またはその他の等値面を選択して参

照レイヤーを定義します。デフォルトで出力コレクションは親コレクションディレクトリのサブディレクトリ

GeoVel に書き込まれます。このサブディレクトリは、まだ作成されていない場合は自動的に作成されます。 

ODV は計算を開始し、測点ペアの結果と地衡流速度を上記で指定された.odv コレクションに出力します。 

 

完了したら計算のログファイルを表示して、測点ペアと地衡流速度データを含む新しく作成されたコレクショ

ンを開きます。ズームして適切な地図領域を定義し、F11 キーを押して断面レイアウトに切り替えてください。

それから一つ以上のプロットウィンドウの Z 変数として Geostr. Vel. [cm/s], Geostr. Vel. (north comp.) [cm/s] そ

して/または Geostr. Vel. (east comp.) [cm/s]を定義します。与えられた測点ペア A-> B:alpha の測点ラベルは、そ

のペアで使用されている測点の元の測点番号 A と B、および正の Geostr. Vel.フロー値  (alpha=0:東向き;  

alpha=90:北向き; 等)の方向 alpha で構成されています。メタ変数 Distance は二つの測点間の距離を km で表

したものです。 

 

地衡流速度は二つの各層観測点間の力学高度の差から導き出されます。計算は二段階で行われます：（１）最

初に二つの測点のデータが区分線形最小二乗法によって一組の標準層にマッピングされます。（2）次に両方

の測点について標準層での力学高度が計算され、標準層での測点ペアの地衡流速度が力学高度の差から得られ

ます。ODV はコレクション内の全ての変数の平均値（ペア平均）も計算します。ペア平均と地衡流速度は、ど

ちらも二つの測点間の中間点におけるもので、ODV はそれらの値を二つの測点間の中間点に位置する virtual

ペア測点の出力.odv コレクションに書き出します。ペア測点の測点ラベルには関連する元の測点の測点ラベル

が含まれています。 

 

地衡流速度は、赤道付近または疎な（密でない）各層観測の測点では計算されません。結果はデータエラーの

影響を非常に受けやすいため Tools > Geostrophic Flows オプションを呼び出す前に、セクションの水温と塩分

データを慎重に品質管理することが不可欠です。続行する一つの方法は Edit Data オプションを使用して疑わ

しいデータに Questionable または Bad フラグを付与し、適切なサンプルフィルタ設定を適用して Good および 

Unknown データのみを受け入れることです。また適切な測点フィルタ設定を適用することで特定の遠征調査

の測点のみが計算に含まれ、断面を横断する他の航海の測点が除外されているか確認してください。海水（柱）

の一部だけを覆っている測点は排除し、海面から海底までの完全なプロファイルのみ使用してください。 

 

14.2 二次元推定（2D Estimation） 

Weighted-average または DIVA 格子化法を使用するデータウィンドウでは、それぞれのデータウィンドウのポ

ップアップメニューから Extras > 2D Estimation オプションを選択して、任意のユーザー指定の X-Y 点におけ
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る Z 値の推定を実行できます。ユーザー指定の X-Y 位置での推定 Z 値は、画面に表示されているウィンドウ

の格子化フィールドの生成にも使用されているものと同じパラメータ設定を使用して、ウィンドウの現在の格

子化法を適用することによって得られます。 

 

格子化フィールドの場合、ユーザー指定の X-Y 位置での結果は格子平均長さスケールの大きさによって異な

ります：スケールが大きいと滑らかなフィールドになりますが、スケールが小さいとデータ内の小規模な現象

が維持されます。また、長さスケールは現在の X と Y の範囲のパーミル（千分率）で指定されることにも注意

してください。ズームインまたはズームアウトして軸範囲を変更すると平均長さスケール値も変わるため 2D 

Estimation の結果にも影響します。データプロットの Properties ダイアログを使用してデータウィンドウに表

示された分布が満たされるまで長さスケールを調整してください。それから Extras > 2D Estimation オプション

を呼び出してください。 

 

ODV は、推定が要求される点の X-Y 座標を持つファイル（以降 input file（入力ファイル）と呼びます）を求

めます。このファイルは 2D Estimation オプションを呼び出す前に準備する必要があります。適切な列ラベル

を含むオプションのヘッダー行と、一行につき TAB で区切られた一組の X-Y 座標ペアを持つ無制限の追加行

を含む、通常の ASCII フォーマットでなければなりません。デフォルトでは、ODV はコレクションの misc サ

ブディレクトリから入力ファイルを検索しますので、入力ファイルをそこに配置すると選択プロセスが簡単に

なります。 

 

入力ファイル内の各Ｘ-Ｙ点について、ＯＤＶはＺ値を推定し、推定値をそれぞれのＸ座標およびＹ座標とと

もに出力ファイルに書き出します。出力ファイルは入力ファイルと同じディレクトリに書き込まれ、ファイル

名は<name>_ est.<ext>の形式になります。ここで<name>.<ext>は入力ファイルの名前です。出力ファイルの各

行には、一つの推定点の X, Y, Z の値が含まれています。-1.e10 の Z 値は、特定の X-Y 点がどのデータ点か

らも遠く離れていて信頼できる推定が実行できなかったことを示しています。ウィンドウ領域の外側、または

ウィンドウの品質制限を超える領域（プロットの白い部分）の Z 値は-1.e10 に設定されます。 

 

入力ファイルには X と Y に加えて追加の列が含まれる場合があることに注意してください。元の X-Y 値と同

様に追加の列の内容が出力ファイルにコピーされ、推定された Z 値が各行に追加されます。ある変数 A が追

加の列に含まれていると、推定された Z 値に対する A をプロットし、変数間の相関を分析するのが容易にな

ります。入力ファイルに列を追加する場合は X 座標と Y 座標が最初の二列にあることを確認してください。 

 

14.3 三次元推定（3D Estimation） 

Tools > 3D Estimation を選択して、任意の地理的位置における基本変数または派生変数の値を推定できます。 

ODV は Z 変数の推定値を求める対象となる地点の経度、緯度、および深度の値を含む ASCII ファイルを求め

ます。この 3D 点定義ファイルは Tools > 3D Estimation オプションを呼び出す前に準備する必要があります。 

ポイント定義ファイルを作成するときは、一行につき一つずつポイントを入力し、十進角の経度、緯度、およ
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び深度の値の順で並べます。各値は一つ以上のスペースで区切ります。ODV は推定を実行する変数を選択さ

せ、推定に使用する x, y, z の平均長さスケールを指定させます。経度と緯度の長さスケールは現在のマップ

範囲のパーミル（千分率）で、深さの長さスケールの単位はメートルです。平均長さスケールの値を大きくす

ると滑らかな推定値になります。3D Estimation では現在地図に表示されている全ての測点における全ての元

のデータ点が使用されます。所定のデータ点が特定のターゲット位置で推定に影響する重みは、データ点とタ

ーゲット点間の距離に反比例します。出力ファイルには入力ファイルで指定された全ての経度、緯度、および

深度点に対して一行の結果が含まれています。各行には以下に示す意味を持つ六つの数値: x, y, z, v, d, n が含

まれます： 

x, y, z      （入力ファイルで指定された）経度、緯度、深度 

v      推定値 

d      推定点からの平均データ x, y, z 位置の正規化距離（平均長さスケールの単位） 

n      使用されたデータ点の数 

 

注：Tools > 3D Estimation オプションは Depth in Water Column [m] および／または Pressure in Water Column 

[db]のキー変数が識別されている場合にのみ有効になります。必要に応じてそのような関連付けを確立するに

はオプション Collection > Identify Key Variables を使用してください。 

 

14.4 ボックス平均 (Box Averaging) 

ODV を使用して所定の経度－緯度－深度ボックス内の基本変数または派生変数の平均と標準偏差を計算でき

ます。現在マップに表示されている測点のみが考慮され、要求されたボックス内の測点とデータ点のみが実際

に平均と標準偏差に使用されます。Box Averaging オプションを呼び出す前に、適切な測点選択基準を指定し

て、さまざまな測点サブセット、年、月、または季節の平均を取得できます。ボックス平均を呼び出すにはメ

インメニューから Tools > Box Averaging を選択します。ODV は出力が生成されるボックスのジオメトリ情報

を含む ASCII ボックス定義ファイルを要求します。その後 ODV は基本変数と派生変数のリストを表示するの

で、平均化手順に対して一つ以上の変数を選択してください。ボックス定義ファイルは Box Averaging オプシ

ョンを呼び出す前に準備する必要があります。 

 

ボックス定義ファイルのフォーマットは次のとおりです： 

⚫ 通常の ASCII で、一行につき一つのボックスを

定義した、六つの数字（一つ以上のスペースで区

切られたもの） 

⚫ 数字の意味（図を参照）：lon lat dep（ボックス

の中心）Δlon Δlat Δdep（ボックスのサイズ）。 経

度と緯度は十進角で、深さはメートル。 
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ボックス定義ファイルを指定すると ODV は作業を開始します。平均化している間 ODV はデータの異常値を

チェックし、平均から標準偏差の三倍以内のデータのみを使用します。出力はボックス定義ファイルのディレ

クトリに書き込まれます。出力ファイル名は、ボックス定義ファイル名、処理される変数のラベル、および拡

張子.est で構成されています。 

 

.est 出力ファイルの形式は次のとおりです： 

⚫ 通常の ASCII、ボックス定義ファイルの一行につき一行の出力、TAB で区切られた 10 個の値 

⚫ 値の意味：lon lat dep（ボックス定義ファイルと同じ）𝑙𝑜𝑛   𝑙𝑎𝑡  𝑑𝑒𝑝  𝑣𝑎𝑙  σ  nu  nr 

 

𝑙𝑜𝑛  𝑙𝑎𝑡 𝑑𝑒𝑝  𝑣𝑎𝑙 は使用されたデータの平均経度、緯度、深度および変数値、σ は変数値の標準偏差、nu は使

用されたデータ点数、および nr は棄却されたデータ点数です。データ点の値と平均𝑣𝑎𝑙との差が標準偏差 σ

の三倍を超えた場合、そのデータ点は棄却されます。平均𝑣𝑎𝑙の誤差は次のように計算できることに注意して

ください。 

𝜎𝑚 = 𝜎/√𝑛𝑢 

 

もしボックス内にデータ点が見つからなければ𝑣𝑎𝑙は-1.e10 に設定されます。データ点が一つしか見つからな

ければ σ は 1.e10 に設定されます。 

 

また、所定のボックスに使用される個々のデータ値は全て#<box-number>_<var-name>.dat という形式の名前の

ASCII ファイルに出力されます。ここで<box-number>はそれぞれのボックス番号を表し（例えばボックス定

義ファイルの行番号など）、<var-name>は平均が計算された変数名を表します。.dat ファイル中の値の意味

は次のとおりです：サンプル ID、経度、緯度、深度、十進化年、年内通算日、値、加重、使用/棄却フラグ。.dat

ファイルは後続のボックス平均要求によって上書きされることに注意してください。要求された平均の総数が

5000 を超えると.dat ファイルは書き出されません。 

 

注意：Tools > Box Averaging オプションは Depth in Water Column [m]キー変数が識別されている場合にのみ有

効になります。必要に応じて Collection > Identify Key Variables オプションを使用して関連付けを確立してくだ

さい。 

 

14.5 異常値の検出（Finding Outliers） 

Tools > Find Outliers > Range Check を選択すると、ユーザーが指定した値の範囲内または範囲外のデータ値を持

つサンプルに関して現在選択されている測点をスキャンできます。あるいは Tools > Find Outliers > Spike Check

を選択すると、スパイクに関して現在選択されている測点をスキャンすることもできます。いずれも変数の一

覧からスキャンする変数を選択して Sample Range にチェックの摘要を指定してください。範囲チェックの場

合は値の範囲の値を指定し Action の下から指定した範囲内もしくは範囲外の値を検索するか選択してくださ

い。OK を押すとスキャンが開始されます。ODV は見つかった異常値の数を報告し、異常値のリストを表示し

ます。 
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ODV では異常値サンプルのデータ値および／または品質フラグを調べたり変更したりすることもできます。

Inspect and Edit Outliers をチェックすると、ODV は全ての識別された異常値にアクセスし、それぞれの値を削

除したり、値に関連付けられた品質フラグを変更したりできます。Apply to All を押すと ODV は選択された操

作を全ての異常値に適用します。それ以外の場合、ユーザーは個々の異常値に対するアクションが促されます。

現在編集されている異常値はデータプロットに印付けられていることに注意してください。 

 

14.6 重複測点の検出（Finding Duplicate Stations） 

Tools > Find Duplicate Stations を選択すると、現在有効な測点セット（地図に表示されている測点）で、同じま

たはほぼ同じ位置および時間の測点（重複測点）をスキャンできます。検出された重複測点のグループに関す

る情報はファイルに書き出されます。二つの測点が重複と見なされるように、占有時間と地理的位置の最大許

容差を指定して OK を押してから、重複検索の出力を受け取るファイルを選択してください。 

 

ODV は重複検索を実行し、検出された重複測点グループに関する情報を選択した出力ファイルに書き出しま

す。次の情報が各測点に提供されます：（1）測点 ID、（2）航海ラベル、（3）測点ラベル、（4）測点タイ

プ、（5）日時、（6）経度、（7）緯度、 （8）サンプル数、（9）最も深いサンプル、（10）基本変数 2 か

ら nVar までの可用性指標（例えば 7 はサンプルの 70～79％が特定の変数に関するデータを含んでいること

を示しています）。 

 

ODV は見つかったグループと重複測点の数を報告します。それぞれのボックスをチェックして重複測点を表

示し（view the duplicate station list）、重複測点を調べて編集することができます（inspect and edit the duplicate 

stations）。重複測点の編集を選択した場合は、重複測点グループごとに Duplicate Station Action ダイアログ（図

14-1）が表示されます。グループ内の一つの測点を除いた全ての測点を削除するか、グループ内の全ての測点

のデータをグループの最初の測点に統合することができます。これらの操作はコレクションファイルの内容を

変更するため元に戻すことはできません。 

 

図 14-1：Duplicate Station Action ダイアログ 

 

指定したアクションを残りの全ての重複測点グループに適用する場合は Apply to All をクリックしてください。

グループを変更しない場合は Keep を、重複測点の編集を中止するには Cancel を押してください。 

 

https://www.sangyo-honyaku.jp/dictionaries
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注：重複測点スキャンの計算負荷は測点数の二乗に比例し、何百万もの測点を含む大規模コレクションでは数

時間かかることがあります。そのような場合は地図領域を（ズームまたは手動で地図領域を設定することによ

って）サブ領域に分割して、全てのサブ領域に対して別々にスキャンを実行してください。 

 

14.7 海洋計算機（Ocean Calculator） 

ODV では Tools > Ocean Calculator オプションを呼び出して海洋物理および海洋化学に関する 40 以上の一般

的に使用される変数の計算およびプロットが可能です。Ocean Calculator ダイアログ（図 14-2）では、先ず

Variables リストから計算したい変数を選択します。次に Input values に入力値を入力し、最後に Evaluate ボタ

ンを押すと Result 欄で指定した入力による変数値を受け取れます。 

 

三つから成る start : increment : end を指定して一つ以上の入力変数に対する入力値のセットの計算を要求でき

ます。例えば Temperature 入力値に-2：1：35 を指定すると、-2〜35℃間で 1℃毎の入力温度に対する選択さ

れた変数が繰り返し計算されます。複数入力が指定されている場合、ユーザーが選んだ他のソフトウェアを使

用してさらに処理または作図ができるようにするために ODV は全ての入力変数値と計算結果をクリップボー

ドにコピーします。 

図 14-2：Ocean Calculator ツール 

 

一つまたは二つの入力変数に複数の入力値がある場合、ODV は図 14-3 および図 14-4 に示すように 1D 曲線

または 2D 等値図を自動的に作成します。 
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図 14-3：複数の入力値を持つ一つの入力変数の曲線プロット 

 

     

図 14-4：複数の入力値を持つ二つの入力変数の等値線図 

 

Settings ボタンを押して計算機の設定を変更できます。Calculator Settings ダイアログ（図 14-5）では、海水

（柱）の鉛直座標（Pressure [dbar]または Depth [m]）、デフォルトの塩分入力変数（Practical Salinity [psu]また

は Absolute Salinity [g/kg]）、平衡定数のセット、海水中の炭酸パラメータの計算に使用される炭酸データ入力

ペアおよび pH スケール（入力と出力）を指定できます。ODV はユーザー設定と Ocean Calculatory を呼び出

す間の最後の入力値を記憶します。Ocean Calculator が開いている間も ODV を使い続けることができます。 

 

多くの関数は入力として元々absolute salinity を要求することに注意してください。Practical salinity が入力変

数として選択されると ODV は入力された実用塩分値を絶対塩分値に自動的に変換し、変換された絶対塩分値

を使用してネイティブ関数を呼び出します。実用塩分から絶対塩分への変換は地理的位置によって異なります。

したがって実用塩分欄に加えて経度と緯度の入力欄も利用可能です。いくつかの関数は塩分入力設定に関係な

く一種類の塩分入力に対してのみ利用可能です。絶対塩分が入力として必要とされるものの実用塩分データの

みが利用可能である場合、最初のステップで Absolute Salinity SA [g/kg]関数を使用して実用塩分から絶対塩分

に変換します。あるいは実用塩分が入力として要求されるものの絶対塩分データのみが利用可能である場合、

二つの塩分タイプの間で変換するために Practical Salinity from Absolute Salinity [psu] 関数を使用します。 
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図 14-5：Calculator Settings ダイアログ 
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15 雑録（Miscellanea） 

15.1 ドラッグ＆ドロップ（Drag-and-Drop） 

サポートされているほとんどのプラットフォームでは、ODV でサポートされているファイルを ODV ウィン

ドウまたはアイコンにドラッグ＆ドロップができます。ドロップされたファイルの拡張子に応じて ODV は次

のことを行います： 

.odv または.var：現在のコレクションまたは netCDF ファイルを閉じて、ドロップされたコレクション

を開きます。 

 

.nc または.cdf：現在のコレクションまたは netCDF ファイルを閉じて、ドロップされた netCDF ファイ

ルを開きます。 

 

.txt（ODV スプレッドシートファイル）：現在開いているコレクションにデータを読み込むか、開いて

いるコレクションがない場合は.txt ファイルと同じ名前の新しいコレクションを作成し、新しく作成し

たコレクションにデータをインポートします。 

 

ODV でサポートされているファイル名もコマンドライン引数として使用できます。次のように入力して任意

の端末ウィンドウから ODV を起動します：odv [ファイル名[.拡張子]] 。ファイル名には、絶対パス名また

は ODV を起動したディレクトリからの相対パス名を使用することに注意してください。相対パス名を使用す

る場合“.”と“..”は使用できません。コマンドライン引数を使用して、 

1. ODV を起動して既存のコレクションを開く：ファイル名にはコレクション名を使用します。 拡張子

を省略するとデフォルトの.odv が使用されます。 

2. 新しいコレクションを作成してデータをインポートする：ファイル名にはインポートするデータフ

ァイルの名前（ODV のインポートタイプの一つ、例えば.o4x や.txt でなければなりません）を使用

します。この場合は拡張子を入力する必要があります。ODV は読み込みファイルのあるディレクト

リに新しいコレクションを作成してファイルからデータをインポートします。データ変数はデータ

ファイルの情報から決定されます。 

 

15.2 ODV コマンドファイル（ODV Command Files） 

コレクションを開く、特定のビューファイルを読み込む、グラフィックスまたはデータ出力ファイルを作成す

るなど、頻繁に使用する操作のコマンドは ODV コマンドファイルに保存できます。ODV コマンドファイルは

File > Execute Command File オプションまたは” -x cmd_file “コマンドラインオプションを使用していつでも（バ

ッチモードで）実行できます。ODV コマンドファイルのデフォルトの拡張子は.cmd です。デフォルトの置き

場所はユーザーのドキュメントディレクトリ内のディレクトリ ODV/cmd_files です。まだ存在していない場合

はディレクトリ cmd_files を作成してコマンドファイルをこのディレクトリに配置します。 
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以下のコマンドが ODV コマンドファイルで現在サポートされています。プラットフォームに依存しないよう

にするために ODV コマンドファイルに表示される全てのファイル名にはスラッシュ”/”をパス区切り文字と

して使用する必要があります。set_base_directory コマンドを使用して base directory 定義すると、それ以降の

全ての相対ファイル名は base directory に対する相対パスと見なされます。base directory が定義されておらず、

コレクションまたは netCDF ファイルが開かれている場合、相対ファイル名はコレクションまたは netCDF デ

ィレクトリを基準にした相対パスと見なされます。複数の引数は、set_var コマンドを除きカンマ“,”で区切る

必要があります。set_var コマンドの場合は変数名と値の間の区切り文字として“=”を使用します。一部のコマ

ンドで使用されるウィンドウインデックスパラメータ iw は、グラフィックスキャンバスの場合は-1、マップ

の場合は 0、データウィンドウの場合は正の整数値になります。ODV コマンドファイルの行は 255 文字を超

えてはいけません。コメント文字＃の右側にあるものは全てコメントと見なされて実行されません。 

 

注意：delete または import コマンドを含むコマンドファイルはデータコレクションを変更して意図しない効果

をもたらします。そのようなコマンドファイルを実行する前に Collection > Create Snapshot を介してコレクシ

ョンのバックアップを作成しておいてください。 

 
create_annotation（注釈の作成）      iw, x, y, orientation, textAlign, “text” 

正の x 軸から反時計回りに orientation 度方向沿いの（ウィンドウ iw 座標系の）位置 x, y にウィンドウ iw のテキスト注釈 text

を作成します。textAlign は(x, y）に対するテキストの配置を決定します：中央＿中央 0、中央_上 1、中央_下 2、右_上 3、右_

下 4、左_上 5、左_下 6、右_中央 7、左_中央 8。iw と textAlign は整数、x, y, orientation は浮動小数点数です。注釈テキストは

“”文字で囲む必要があります。 

例：create_annotation -1, 10., 8., 30., 0, “Some Text” 

 

create_collection（コレクションの作成）      collection, collection_type 

データ変数 collection_type のテンプレートセットを使用して collection コレクションを作成します。Collection_type は次のいずれか

です：ARGOPROFILES, ARGOTRAJECTORIES, GTSPP, MEDATLASBOTTLE, MEDATLASCTD, MEDATLASTIMESERIES, 

MEDATLASPROFILES, MEDATLASSEDIMENTTRAP, WORLDOCEANDATABASE. 注：collection が既に存在する場合は新しいバージョンが

作成される前に既存のバージョンが削除されます。 

例：create_collection c:/data/ARGO_Atlantic.odv, ARGOPROFILES 

 

delete_collection（コレクションの削除）      collection 

現在開いている collection コレクションを削除します。 Collection 引数は前の open_collection の呼び出しで使用されたものと同

じでなければなりません。 

例：delete_collection c:/data/ARGO_Atlantic.odv 

 

delete_stations_matching（同一測点の削除）      metavarLabel1, metavarLabel2, … 

現在開いているコレクション内で一つ以上のメタ変数 metavarLabel1, metavarLabel2 などに関して指定した値に一致する全ての測

点を削除します。一致させる値は後に続く行から delete_stations_end 行までの間で指定します。もし metavarLabel1, metavarLabel2

などの全てのメタ変数値が指定行の一つの値に一致すると、その測点は一致とみなされます。論理 AND は所定の指定行上にあ

り、論理 OR は行間にあります。指定値はタブで区切ります。結果の概要はログファイル<path>.log に書き出されます。ここで

<path>はディレクトリおよびこのコマンドを含むコマンドファイルのファイル名を表します。 

例：delete_stations_matching “LOCAL_CDI_ID”, “EDMO_CODE” 

    77AR1993_11 H71 545 

    Delete_stations_end 
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export_data（データのエクスポート）      data_file 

export_data（データのエクスポート）      data_file, var_ids, derived_var_ids, extended_metavar_ids, quality_flag_export,  

    error_export, info_export, history_export, compact_export, do_zip 

現在の測点を data_file ファイルにエクスポートします。エクスポートフォーマットは data_file 拡張子に依存します：(1).txt - 汎

用 ODV スプレッドシート、(2).odv - ODV コレクション、(3).nc – netCDF4. 

 

var_ids, derived_var_ids, extended_metavar_ids は、エクスポートされる基本データ変数、導変数、拡張メタ変数の varIds を定義しま

す。これらの varIds は、角括弧に囲まれた varId の空白区切りのリスト：[vgroup1 vgroup2 ...]で指定します。vgroups は以下の

値を持つことができます：’:’ (全変数), ‘m:n’ (m から n までの varIds を持つ変数で、m, :, n の間に空白はありません), ‘m’ 

(varId m を持つ変数)。[]は空リストを表します。 

 

ODV アプリケーションウィンドウの右側にあるリストウィンドウの中にある各変数の上にマウスを置くことで、メタおよびデー

タ変数の varIds を回復できることに注意してください。 

 

残り全ての引数は 1 か 0 の整数値です。これらの引数は、データ品質フラグ、（もしあれば）データエラー値、データ情報値、

（もしあれば）履歴レコードをエクスポートするか(値が 1 の場合)、しないか（値が 0 の場合）を制御します。compact_export

は、メタデータが測点の最初のサンプルに対してのみエクスポートするか(1), 全てのサンプルに対してか(0)を制御します。この

引数はスプレッドシートエクスポートに関してのみ効果があります。エクスポートしたデータは、もし do_zip が 1 ならば zip ファ

イルに収録されます。 

 

上述の最初の export_data 版を使う場合は、次のデフォルト引数が適用されます： 

[:], [], [:], 1, 1, 1, 1, 1, 0 

 

例：export_data c:/out/odv_data.txt 

    export_data c:/out/odv_data.nc, [1:5 20:21], [32001], [], 1, 1, 0, 0, 0, 0 

    export_data c:/out/odv_data.odv, [:], [:], [], 1, 1, 1, 1, 0, 1 

 

export_graphics （グラフィックスのエクスポート）      iw, graphics_file, dpi [,width, height, extend_rect, drawing_style, 

      transparent_background ] 
dpi ドット/インチの解像度を使用してファイル graphics_file にウィンドウ iw のグラフィックスを出力します。Graphics_file 拡張

子.eps, .gif, .png または.jpg を使うとそれぞれ PostScript, GIF, PNG または JPEG 形式で出力します。Dpi 引数は PostScript 出

力には使用されませんが、それでも与える必要があります。 

 

Width, height, extended_rect, drawing_style および transparent_background 引数はオプションです。 

 

Width と height を与えるときは出力イメージのピクセル幅と高さを指定してください。両方の既定値は-1 で、この場合のイメージ

サイズは選択された dpi 解像度だけで決まります。 

 

Extended_rect 引数の既定値は drawing_style（以下参照）が NORMAL なら 1（真）で、drawing_style が PURE なら 0（偽）です。

作成されるイメージは extended_rect 値が 0 なら表示領域に限定されます。それ以外では軸ラベル、カラーバーおよびウィンドウの

全グラフィックオブジェクトを含んだ領域に拡張されます。 

 

Drawing_style 引数は NORMAL（既定値）または PURE となります。データ表示出力を得たいがフレーム、カラーバー、または軸

ラベルは不要な場合は PURE を指定してください。 

 

Transparent_background 引数は、イメージ形式が tiff で drawing_style が PURE なら 1（真）が既定値となります。それ以外では

transparent_background は 0（偽）です。Jpg イメージでは背景を透明にできないことに注意してください。 

例：export_graphics –1, c:/output/odv_graph.eps, 300 

    export_graphics 1, GeoTIFF_example.tif, 300, -1, -1, 0, PURE, 1 
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import_data（データの読み込み）      file_spec, import_type 

インポートルート import_type を使用して file_spec を満たす全てのファイルからデータを読み込みます。Import_type は次のいずれ

かです：ARGOPROFILES, ARGOTRAJECTORIES, GTSPP, MEDATLASPROFILES, MEDATLASTIMESERIES, MEDATLASSEDIMENTTRAP, 

MEOPPROFILES, WORLDOCEANDATABASE. File_spec は、単一のインポートファイルのパス名、ワイルドカード・ファイルの指定、ま

たはインポートするファイルのパス名を含む.lst リストファイルのパス名です。File_spec は絶対パス名または前の set_base_directory

コマンドで指定した base directory からの相対パスでなければなりません。.lst リストファイルのエントリは絶対パス名でなければ

なりません。 

例：import_data c:/data/*.nc, ARGOPROFILES 

 

load_view（ビューの読み込み）      view_file 

ビューファイル view_file を読み込みます。View_file は.xview ファイルまたは.cfg ファイルです。load_view は後方互換性のために

サポートされている load_cfg と同等です。$FullScreenMap$, $OnePickWin$, $Two-PickWin$, $SixPickWin$, $OneScatterWin$, 

$TwoScatterWin$, $SixScatterWin$, $OneSectionWin$, $TwoSectionWin$, $ThreeSectionWin$, $FiveSectionWin$, $SixSectionWin$, 

$OneIsoSurfaceWin$, $TwoIsoSurfaceWin$, $ThreeIsoSurfaceWin$, $FiveIsoSurfaceWin$, $EightIsoSurfaceWin$, $ElevenI-soSurfaceWin$, 

$FiveMixedWin$, $FromFileWin$または$OneIsoSurfaceOneScatterWin$をテンプレートビューの一つを読み込むのに使用します。 

例：load_view c:/views/abc.xview  

 

open_collection（コレクションを開く）      collection[, view_file] 

コレクション collection を開き、ビューview_file を読み込みます。View_file 引数はオプションです。$Full-ScreenMap$, 

$OnePickWin$, $TwoPickWin$, $SixPickWin$, $OneScatterWin$, $TwoScatterWin$, $SixScatterWin$, $OneSectionWin$, $TwoSectionWin$, 

$ThreeSectionWin$, $FiveSectionWin$, $Six-SectionWin$, $OneIsoSurfaceWin$, $TwoIsoSurfaceWin$, $ThreeIsoSurfaceWin$, 

$FiveIsoSurface-Win$, $EightIsoSurfaceWin$, $ElevenIsoSurfaceWin$, $FiveMixedWin$, $FromFileWin$または 

$OneIsoSurfaceOneScatterWin$をテンプレートビューの一つを読み込むのに使用します。  

注：パスワードで保護されたコレクションを ODV コマンドファイルで開いて使用することはできません。 

例：open_collection c:/ewoce/WoceBtl.odv 

open_collection c:/ewoce/WoceBtl.odv, $FullScreenMap$ 

 

open_data_file（データファイルを開く）      data_file 

Data_file 内の一連の変数を使用してコレクションを作成して開き、data_file から新しく作成されたコレクションにデータを読み込

みます。Data_file は汎用 ODV スプレッドシートフォーマットに準拠し、拡張子が.txt である必要があります。新しいコレクション

はデータファイルのディレクトリに作成され、その名前はデータファイルのベース名です。この名前とパスを持つ既存のコレクシ

ョンはユーザーに許可を求めることなく削除されます。 

例：open data_file c：/ewoce/WoceData.txt 

 

quit（終了） 

ODV を終了します。 

例：quit 

 

save_view（ビューの保存）      view_file 

現在のビューを view_file ファイルに保存します。View_file の拡張子は.xview でなければなりません。 

例：save_view c:/cfg_files/abc.xview 

 

set_annotation_style（注釈のスタイルの設定）      ptSize, textColor, bckgrdColor, frameColor, frameWidth 

Create_anotation に続いて作成されたテキスト注釈のスタイルを設定します。ptSize はポイント単位のフォントサイズ、textColor は

テキストの色、bckgrdColor はテキスト境界ボックスの背景色、frameColor はテキスト境界ボックスの枠の色、frameWidth はテキス
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ト境界ボックスを囲む枠の幅です。全ての色は現在のカラーパレットのインデックス値として指定されています。背景ボックスま

たは背景フレームが描画されないようにするには bckgrdColor または frameColor あるいはその両方に-1 を指定します。注：

set_annotation_style の全ての引数は整数です。デフォルト値は 16, 0, -1, -1, 0 です。これはボックスまたはフレームなしで 16

ポイントの黒いテキストを生成します。 

例：set_annotation_style 24、8、7、0、1 

 

set_axis_full_ranges（全範囲軸の設定）      iw 

データウィンドウ iw（1 から始まるウィンドウインデックス）または全てのデータウィンドウ（iw = -1）の x, y, z 軸範囲を全範囲に

設定します。iw=0 の場合、マップ領域を現在有効な測点をカバーする領域に設定します。 

例：set_axis_full_ranges -1 

set_axis_full_ranges 0 

 

set_axis_range（軸範囲の設定）       iw, axis, v0, v1 

ウィンドウ iw（-1 と 0 は不可）の軸 axis（可能な値：x, y または z）の範囲値を v0（左/下）と v1（右/上）に設定します。v0 と v1

が指定されていない場合は全てのウィンドウデータで有効な軸が全範囲になります。 

例：set_axis_range 1, x, 34, 37 

set_axis_range 1, y, ,  

 

set_base_directory（ベースディレクトリの設定）     base_directory 

ベースディレクトリを定義します。全ての後続のファイル名は全て絶対パス名または base_directory からの相対名と見なされます。 

例：set_base_directory c:/ewoce/data 

 

set_var（変数の設定）     var_name = string 

変数 var_name の値を string に設定します。以降の行の変数は％var_name％として使用できます。 

例：set_var OUTDIR = c:/tmp 

export_data %OUTDIR%/A15_OXYGEN.txt  

 

以下は、コレクションを開いてビューを読み込み、注釈を追加し、キャンバス全体とデータウィンドウ 1 に二

つの画像ファイルをそれぞれ書き込み、現在選択されている測点のデータを ODV スプレッドシートファイル

に出力して、最後に ODV が終了する ODV コマンドファイルの例です。  

 
set_var   OUTDIR = c:/tmp 
set_base_directory  c:/data/eWOCE/data/whp/bottle 
set_annotation_style  18, 0, 7, 0, 1 
open_collection  WoceBtl.odv 
load_view   atlanticSections/A15_OXYGEN.xview 
create_annotation  1, -13.18,65.83,0, 6, "Test"  
export_graphics  -1, %OUTDIR%/A15_OXYGEN.png, 100  
export_graphics  1, %OUTDIR%/A15_OXYGEN_1.png, 200  
export_data   %OUTDIR%/A15_OXYGEN.txt  
quit  

 

15.3 カラーパレット (Color Palettes)  

ODV スタイルのカラーパレットは 177 色を定義します（図 15-1 参照）。 

⚫ 0-15: 基本色 

⚫ 16-31: グレースケール 

⚫ 32-144: カラー陰影に使用されるメインパレット 
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⚫ 145-160: 地図の海底地形および大陸に使用される色 

⚫ 161-176: 地図の陸上地形に使用される色 

 

図 15-1：ODV デフォルトカラー・パレット 

 

ODV には、さまざまなレインボーパレット、単色または二色パレット（BlueOnly、BlueRed など）、および

さまざまなグレースケールパレットが付属しています。さらに ODV にはさまざまな種類の色覚異常の影響を

受けている人々の知覚改善が向上する Viridis パレット（Anton Velo 氏の好意による）も含まれています。 

 

図 15-2：Viridis カラーパレット 

 

ウィンドウを右クリックして Properties オプションを選択し、General ページの Palette コンボボックスから使

用可能なパレットファイルの一つを選択することで、マップまたはデータウィンドウの別のカラーパレットを

選択できます。ODV は新しいパレットを使用してマップまたはデータウィンドウを再描画します。 

 

Windows では PalEdt.exe アプリケーションを使用して既存のパレットを変更したり新しいパレットを作成し

たりできます。PalEdt.exe は Tools > Palette Editor を選択して ODV から呼び出すことができます。 

 

15.4 アニメーション（Animations） 

ODV では、それぞれのウィンドウを右クリックして Extras > Animation を選択し、Metadata Time, Metadata 

Time of Year, Variable Range, Isosurface のいずれかのサブオプションを選択することで、マップあるいはあら

ゆるデータウィンドウのアニメーション GIF を作成できます。その後の手順は以下の通りです。 

 

（1）Metadata Time: 
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開始日 t0、間隔ステップ tStep（日数）、間隔幅 tWidth（日数）、生成するフレーム数 n、および間隔タイプを

指定してください。その後 ODV は n 時間間隔を構成し、Date/Time > Period 測点フィルタ設定にはそれぞれ

の開始日と終了日を使用します。 

 

選択した間隔タイプに応じて間隔 i（i = 0、…、n-1）の開始日と終了日は次のように定義されます: 

 

間隔のタイプ（Interval Type） 間隔 i の開始日(Start of interval i) 間隔 i の終了日(End of Interval i) 

Zero Width (幅なし) 𝑡0  + 𝑖 ·  𝑡𝑆𝑡𝑒𝑝 𝑡0  + 𝑖 ·  𝑡𝑆𝑡𝑒𝑝 

Fixed Width (固定幅) 𝑡0  + 𝑖 ·  𝑡𝑆𝑡𝑒𝑝 𝑡0  + 𝑖 ·  𝑡𝑆𝑡𝑒𝑝 + 𝑡𝑊𝑖𝑑𝑡ℎ 

Fixed Start (開始日固定) 𝑡0   𝑡0  + (𝑖 + 1) ·  𝑡𝑆𝑡𝑒𝑝 

Fived End (終了日固定) 𝑡0  + 𝑖 ·  𝑡𝑆𝑡𝑒𝑝 𝑡0  + 𝑛 ·  𝑡𝑆𝑡𝑒𝑝 

 

そのような時間間隔ごとに、それぞれの時間ウィンドウ内にメタデータ日付を持つこれらの測点のみを含むマ

ップが再構築されます。アニメーションがデータウィンドウの場合、このデータウィンドウも現在選択されて

いる測点セットからのデータのみを使用して再描画されます。現在のマップまたはデータウィンドウがアニメ

ーションファイルに追加されます。 

 

 (2) Metadata Time of Year: 

開始月日 t0, 間隔ステップ tStep（日数）、間隔幅 tWidth（日数）、生成するフレーム数 n、および間隔タイプ

を指定してください。次に ODV は n 時間間隔を構成し、Date/Time > Season 測点フィルタ設定にはそれぞれ

の開始日と終了日を使用します。選択した間隔タイプに応じて間隔 i の開始日と終了日（i = 0、…、n-1）は上

の表のように定義されます。 

 

そのような時間間隔ごとに、それぞれの時間枠にメタデータの月と日がある測点のみを含めて、マップが再構

築されます。データコレクションに複数年の期間からの測点が含まれている場合は、一年以上のデータが使用

されることがあります。アニメーションがデータウィンドウの場合、このデータウィンドウも現在選択されて

いる測点セットからのデータのみを使用して再描画されます。 現在のマップまたはデータウィンドウがアニ

メーションファイルに追加されます。 

 

 (3) Variable Range:  

このオプションは等値面以外のデータウィンドウでのみ使用できます。有効な変数を選択し、開始値 v0, 間隔

ステップ tStep、間隔幅 vWidth、生成するフレーム数 n、および間隔タイプを指定してください。ODV は有効

な変数に対して n 個の間隔を作成し、選択された変数のサンプルフィルタ設定にはそれぞれの開始値と終了値

を使用します。 

 

選択した区間タイプに応じて、区間 i の開始値と終了値（i = 0、…、n-1）は次のように定義されます。 

 

間隔のタイプ（Interval Type） 間隔 i の開始日(Start of interval i) 間隔 i の終了日(End of Interval i) 

Zero Width (幅なし) 𝑣0  + 𝑖 ·  𝑣𝑆𝑡𝑒𝑝 𝑣0  + 𝑖 ·  𝑣𝑆𝑡𝑒𝑝 

Fixed Width (固定幅) 𝑣0  + 𝑖 ·  𝑣𝑆𝑡𝑒𝑝 𝑣0  + 𝑖 ·  𝑣𝑆𝑡𝑒𝑝 + 𝑣𝑊𝑖𝑑𝑡ℎ 

Fixed Start (開始日固定) 𝑣0   𝑣0  + (𝑖 + 1) ·  𝑣𝑆𝑡𝑒𝑝 

Fived End (終了日固定) 𝑣0  + 𝑖 ·  𝑣𝑆𝑡𝑒𝑝 𝑣0  + 𝑛 · 𝑣𝑆𝑡𝑒𝑝 
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そのような間隔ごとに、それぞれの変数値の間隔からのデータのみを含めて、データウィンドウが再描画され

ます。現在のデータウィンドウのスナップショットがアニメーションファイルに追加されます。 

 
 (4) Isosurface :  

このオプションは等値面データウィンドウだけに使用できます。開始値 s0, 間隔ステップ ds, および生成する

フレーム数 n を選択します。ODV は n 個の等値面値を作成し、そのような値ごとにデータウィンドウを再構

築します。現在のデータウィンドウのスナップショットがアニメーションファイルに追加されます。 

 

全てのアニメーションに対して、ODV は現在のアニメーション間隔を示すアニメーションバーを描画します。

アニメーションバーはそれぞれのウィンドウの下の中央にあります。 

 

15.5 海底地形の地名辞典（Gazetteer of Undersea Features） 

ODV は海山、海嶺、破砕帯、トラフ、海盆などの海底地形を識別するために使用できます。地名辞典オプショ

ンを呼び出すには、マップのポップアップメニューから Extras > Gazetteer を選択すると地名辞典（gazetteer）
ダイアログボックスが表示され、特定のデータベースを選択したり、地形の選択基準や ODV が描く地名記号

のサイズや色を指定したりできます。Switch On ボタンを押すと（または地名辞典の設定を変更した場合は 

Update）、選択した地名辞典データベースから情報が読み込まれ、地図上の地形の位置に記号が表示されます。

マウスを地形記号の近くに移動すると地形の名前を表示するポップアップウィンドウが表示されます。地形記

号をオフにするには地名辞典（gazetteer）ダイアログボックスを再度表示して Switch Off ボタンを押してく

ださい。 

 
ODV 配布パッケージではいくつかの地名辞典を提供しています：（1）国際水路局(International Hydrographic 

Bureau（IHB）)の GazetteerGEBCO.gzt、（2）米国国防測量庁（US Defense Mapping Agency）の Gazet-teerBGN.gzt，  

（3）WHP_Sections.gzt（WOCE 海洋観測プログラム（WOCE Hydrographic Programme）で実施された観測断面の

集大成）。地名辞典ダイアログボックスを使用して地形タイプおよび／または地名の部分文字列を指定するこ

とで地名サブセットを選択できます。名前とタイプの選択は大文字と小文字を区別しないことに注意してくだ

さい。地形の名前（またはその名前の一部）がわかっていてその場所を特定する場合は地名辞典の地形選択を

使用します（地形記号を表示するには地図を全球で開く必要がある場合があります）。地名辞典の設定は設定

ファイルに保存されません。最初にコレクションを開くときは常に地名辞典オプションはオフになっています。 

 

地名辞典ファイルは編集および拡張することができます。独自の新しい地名辞典データベースを作成すること

もできます。ODV で私家版地名辞典を使用する場合、ファイルの拡張子は.gzt で、ODV 地名辞典ディレクト

リ（<home>\odv_local\gazetteers、ここで<home>はホーム・ディレクトリを表す）に配置され、以下の仕様を

満たしている必要があります： 

 
ファイルの最初の行は％GZT01:で始まり、その後にファイル名が続くこと。 

 

それから、％で始まり、任意のコメントを含む 7 行があること。 

 

次の行は、Feature;Type;No;East-Longitude;North-Latitude;North-Latitude;で、 その後に空白行

が一行あること。 

 

ファイルの残りの部分には実際のアイテム定義が含まれていること。各地形は別々の行にリストされて

いること。 
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地形の名前、その種類、経度/緯度の点数、経度/緯度のエントリはセミコロン「;」で区切ります。 経度は東
経（0-360 または-180-180）で指定します。 経度/緯度の点数は最大 1500、行の長さは最大 200,000 文字
です。 
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16 付録（Appendix） 

16.1 マウスとキーボードの操作 (Mouse and Keyboard Actions) 

表 16-1: ODV の準備状態のマウス操作 

1）MacOS システムでは cmd キーを押しながらマウスをクリックしてドラッグします。 

2）シングルボタンマウスの MacOS システムでは Alt キーを押しながらマウスをクリックすると右ボタンクリックをシミュレートでき

ます。 

3）シングルボタンマウスの MacOS システムでは Alt キーと Shft キーを押しながらマウスをクリックすると Shft 右マウスボタンクリッ

クをシミュレートできます。 

動作 対象 応答 

   

L-Click Map 

Data Window 

現在の測点として一番近くの測点を選択します。 

最も近いサンプルを現在のサンプルとして選択し、親測点を現在の測

点として選択します。 

   

Shft L-Click 
 

Map 

 

Data Window 

最も近い測点を現在の測点として選択します。 同じ場所にある複数

の測点リストから選択できます。 

現在のサンプルとして最も近いサンプルを選択します。 同じ場所に

ある複数のサンプルのリストから選択できます。 

   

L-DbleClick Map 最も近い測点をpick listに追加し、この測点のデータをSTATION デー

タウィンドウに追加します。 

   

L-Drag 
 

GObject 

 

Canvas, Map,  

Data Window 

グラフィックスオブジェクトをドラッグします（ドラッグが可能な場

合）。キャンバスをドラッグします（スクロールバーがある場合）。 

   

Ctrl L-Drag 1)  

 
MapData 

Window  

地図をクイック・ズームします。 

データウィンドウをクイック・ズームします。 

   

R-Click 2) Canvas, Map, 

Data Window, 

GObject, Data 

List Windows 

要素選択コンテキストメニューを呼び出します。 

Shft R-Click 3) Map, Data 

Window 

地図またはデータウィンドウの Extras メニューを呼び出します。 
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表 16-2：共通のキーを押す動作 

キー 応答 

  

Enter or 
Return 

現在の測点を pick list に追加し、この測点のデータを STATION データウィンドウがあれば

それに追加します。 ウィンドウレイアウトモードでは、現在のレイアウトを受け入れて通

常モードに戻ります。 

  

Del or 
Backspace 

マウスが指しているグラフィックスオブジェクトを削除します。グラフィックスオブジェク

ト上にない場合は pick list から現在の測点を削除し、STATION データウィンドウがあれば

そこからこの測点のデータを削除します。ウィンドウレイアウトモードではマウスがあるウ

ィンドウを削除します。 

  

# 内部シーケンス番号による新しい現在の測点の選択を可能にします。 

→ 次の測点を現在の測点として選択します。 

← 前の測点を現在の測点として選択します。 

HOME 最初のサンプルを現在のサンプルとして選択します。 

↓ 次のサンプルを現在のサンプルとして選択します。 

↑ 前のサンプルを現在のサンプルとして選択します。 

END 最後のサンプルを現在のサンプルとして選択します。 

PgDn 現在のサンプルを下げます（前進させます）。 

PgUp 現在のサンプルを上げます（後退させます）。 

Ctrl-? 1) (Mac)  
F1 2) (others) 

ODV ヘルプ文書を表示します。 

F4 2)  マウスがあるウィンドウのデータ統計を表示します。 

F5 2) キャンバス全体またはマウスがあるウィンドウを再描画します。 

F8 2) 全画面マップ・レイアウトに切り替えます。 

F9 2) 六つの STATION ウィンドウレイアウトに切り替えます。 

F10 2) 二つの SCATTER ウィンドウレイアウトに切り替えます。 

F11 2)  三つのセクションウィンドウレイアウトに切り替えます。 

F12 2)  一つの SURFACE ウィンドウレイアウトに切り替えます。 

  

Ctrl-Plus or 
Ctrl-Wheel 1) 

マウス位置でズームインします。 

Ctrl-Minus or 
Ctrl-Wheel 1) 

マウス位置でズームアウトします。 

Ctrl-A 1)  マウスがあるウィンドウに注釈を追加します。 
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Ctrl-C 1) マウスがあるウィンドウのデータまたは格子化フィールドをクリップボードにコピーする

か、マウスがグラフィックスオブジェクトの上にある場合は、そのオブジェクトのコピー

を作成します。 

Ctrl-F 1) マウスがあるウィンドウ（または全てのデータウィンドウ）の X, Y, Z 範囲をフルレンジ

に調整します。 

Ctrl-N 1) 新しい ODV コレクションを作成します。 

Ctrl-O 1) ODV コレクション、netCDF ファイル、またはサポートされている ASCII データファイル

を開きます。 

Ctrl-R 1) マウスがあるウィンドウを移動またはサイズ変更します（ウィンドウレイアウトモードの

み）。 

Ctrl-S 1) マウスがあるウィンドウ（またはキャンバス全体）を画像ファイル（gif、png、jpg、また

は PostScript）に保存します。 

Ctrl-W or  
Ctrl+F4 1) 

現在のコレクションまたはnetCDFファイルを閉じます。 

Ctrl-Y  最後に取り消したビューの変更をやり直します。 

Ctrl-Z  最後のビューの変更を元に戻します。 

  

Alt-D 派生変数の定義を許可します。 

Alt-P マウスがあるウィンドウまたはグラフィックスオブジェクトのプロパティ変更を許可しま

す。 

Alt-S 測点フィルタ設定の変更を許可します。 

Alt-W ウィンドウレイアウトの変更を許可します。 

Alt-Z 全ての変更を元に戻します。 

  

Shft-E メタデータまたはサンプルデータを変更します。 

Shft-L ファイルのビュー設定を読み込みます。 

Shft-S  

 
サンプルフィルタ設定（範囲と品質フィルタ）の変更を許可します。 

  

Ctrl-, 1) 
(Mac only) 

ODV settingsダイアログを開きます。 

ESC  

 
現在の操作を中止します（操作によってサポートされている場合）。ウィンドウレイアウ

トモードでは、行われた全てのレイアウト変更をキャンセルし、通常モードに戻ります。 

Ctrl-Q 1) (Mac)  
Alt-F4 (others)  

ODVを終了します。 

1）MacOS システムでは cmd キーを押しながらもう一方のキーを押します。 

2）MacOS システムではファンクションキーを押しながら fn キーを押します。Mac システム環境設定のキーボード・タブで「標準ファ

ンクションキーとして F1、F2 などの全てのキーを使う」をチェックした場合、fn キーは必要ありません。 
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表 16-3：ズームモードまたは Z ズームモードでのマウスとキーの押し動作 

動作（Action）  対象（Object）  応答（Response）  

   

L-Drag 
 

ズーム矩形の境界と角 ズーム矩形のサイズを変更します。 

   

L-DbleClick or ENTER どこでも 現在の設定を受け入れてズームを終了します。 

R-Click1) or ESC どこでも 変更を破棄してズームを中止します。 

1）シングルボタンマウスの MacOS システムでは Alt キーを押しながらマウスをクリックするとマウスの右ボタンクリックをシミュレ

ートできます。 

 

表 16-4：GetPoints モードでのマウスとキーを押す動作 

動作（Action）  対象（Object）  応答（Response）  

   

L-Click 

 
キャンバス、マップ、

データウィンドウ 

現在のポイントをリストに加えます。 

   

R-Click 1) 

 
キャンバス、マップ、

データウィンドウ 

リストから一番近いポイントを削除します。 

   

ENTER どこでも 現在の設定を受け入れて GetPoints を終了します。 

   

ESC どこでも GetPoints を中断します。 

1）シングルボタンマウスの MacOS システムでは Alt キーを押しながらマウスをクリックするとマウスの右ボタンクリックをシミュレ

ートできます。 

 

16.2 品質フラグスキーム (Quality Flag Schemes) 

ODV は海洋学のコミュニティで現在使用されているほとんどの品質フラグスキームをサポートしています。

これらのスキームのいずれか一つを所定のメタデータまたはデータ変数の品質フラグに符号化するため使用

することができます。サポートされているスキームの概要、品質フラグコードの一覧とその意味、およびスキ

ーム間のコードマッピングについては、表16-5および ODV_QualityFlagSets.pdf ファイルを参照してください。 

 

表 16-5：ODV でサポートされている品質フラグスキーム。異なるスキーム間の品質フラグ値と値マッピン

グの完全なリストについては、ODV_QualityFlagSets.pdf ファイルを参照してください。 

SchemaID  Comment  

ARGO Argo quality codes. (Argo 品質コード) 参照: Argo data management, ユーザーマニュア

ル, Version 2.1, https://nrlgodae1.nrlmry.navy.mil/argo/argo-dm-user-

https://nrlgodae1.nrlmry.navy.mil/argo/argo-dm-user-manual.pdf
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manual.pdf (訳注：http://www.usgodae.org/argo/argo-dm-user-manual.pdf で

はたどり着きません) 

BODC BODC quality codes. (BODC 品質コード) 参照: 

http://www.bodc.ac.uk/data/codes_and_formats/re-quest_format/ 

ESEAS European Sea Level Service quality codes. (European Sea Level Service 品質コード) 参照: 

www.eseas.org/eseas-ri/deliv-erables/d1.2/ESEAS_QC_29032005.doc （訳注：time out

になり接続できません） 

GTSPP GTSPP quality codes. (GTSPP 品質コード) 参照: http://www.meds-sdmm.dfo-

mpo.gc.ca/meds/Data-bases/OCEAN/GTSPPcodes_e.htm（訳注：リンク先がありません） 

IODE IODE data quality flags. (IODE データ品質フラグ) 参照: 

http://www.iode.org/index.php?op-
tion=com_oe&task=viewDocumentRecord&docID=10762 

OCEANSITES OceanSITES quality flags. (OceanSITES 品質フラグ) 参照: 

http://www.oceansites.org/docs/oceans-ites_user_manual_version1.2.doc 

ODV ODV generic quality flags. (ODV 一般品質フラグ) 参照: ODV User’s Guide, 

http://odv.awi.de/en/docu-mentation/ 

QARTOD Qartod 品質フラグ quality flags. (Qartod 品質フラグ) 参照: 

https://cdn.ioos.noaa.gov/media/2017/12/QARTOD-Data-Flags-
Manual_Final_version1.1.pdf 

PANGAEA PANGAEA generic quality flags. (Qartod 品質フラグ) 参照: 

http://wiki.pangaea.de/wiki/Quality_flag 

SEADATANET SeaDataNet quality codes. (SeaDataNet 品質コード) 参照: 

http://seadatanet.maris2.nl/v_bodc_vocab/browse_export.asp?l=L201&order=e

ntrykey&all=yes 

SMHI Swedish Meteorological and Hydrographic Institute quality codes. (Swedish Meteorological 

and Hydrographic Institute 品質コード)  

WOCEBOTTLE WOCE bottle value quality codes. (WOCE ボトル値品質コード) 参照: 

http://cchdo.ucsd.edu/WHP_Exchange_Description.pdf  

WOCECTD WOCE CTD value quality codes. (WOCE CTD 値品質コード) 参照: 

http://cchdo.ucsd.edu/WHP_Exchange_Description.pdf  

WOCESAMPLE WOCE WHP quality flags for the water bottle itself. (WOCE WHP 採水ボトル自身の品質フラ

グ) 参照: http://cchdo.ucsd.edu/WHP_Exchange_Description.pdf  

WOD World Ocean Database individual observed level quality codes. (World Ocean Database 個々

の観測レベル品質コード) 参照: 

ftp://ftp.nodc.noaa.gov/pub/WOD05/DOC/wod05_tutorial.pdf  

WODSTATION World Ocean Database entire station quality flags. (World Ocean Database 測点全体の品質

フラグ) 参照: ftp://ftp.nodc.noaa.gov/pub/WOD05/DOC/wod05_tutorial.pdf  

 

16.3 汎用ＯＤＶスプレッドシートフォーマット（Generic ODV Spreadsheet Format）  

https://nrlgodae1.nrlmry.navy.mil/argo/argo-dm-user-manual.pdf
http://www.bodc.ac.uk/data/codes_and_formats/re-quest_format/
http://www.iode.org/index.php?op-tion=com_oe&task=viewDocumentRecord&docID=10762
http://www.iode.org/index.php?op-tion=com_oe&task=viewDocumentRecord&docID=10762
http://www.oceansites.org/docs/oceans-ites_user_manual_version1.2.doc
http://odv.awi.de/en/docu-mentation/
https://cdn.ioos.noaa.gov/media/2017/12/QARTOD-Data-Flags-Manual_Final_version1.1.pdf
https://cdn.ioos.noaa.gov/media/2017/12/QARTOD-Data-Flags-Manual_Final_version1.1.pdf
http://wiki.pangaea.de/wiki/Quality_flag
http://seadatanet.maris2.nl/v_bodc_vocab/browse_export.asp?l=L201&order=entrykey&all=yes
http://seadatanet.maris2.nl/v_bodc_vocab/browse_export.asp?l=L201&order=entrykey&all=yes
http://cchdo.ucsd.edu/WHP_Exchange_Description.pdf
http://cchdo.ucsd.edu/WHP_Exchange_Description.pdf
http://cchdo.ucsd.edu/WHP_Exchange_Description.pdf
ftp://ftp.nodc.noaa.gov/pub/WOD05/DOC/wod05_tutorial.pdf
ftp://ftp.nodc.noaa.gov/pub/WOD05/DOC/wod05_tutorial.pdf
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汎用 ODV スプレッドシートフォーマットは、データ作成者とデータユーザーの間でデータを交換するための

推奨フォーマットです。汎用スプレッドシートフォーマットは ODV コレクションへのデータの自動インポー

トが可能で、ユーザーの操作は不要です。ODV はコレクションからデータをエクスポートするときにも汎用

スプレッドシートフォーマットを使用します。出力されたデータセットはファイル内のデータを編集および変

更した後に、同じまたは別のコレクションに簡単に再インポートできます。開いているコレクションから汎用

スプレッドシートファイルへのデータのエクスポートは Export > ODV Spreadsheet オプションを使って行いま

す。 

 

汎用 ODV スプレッドシートファイルは ASCII エンコーディングを使用しており、推奨されるファイル拡張子

は.txt です。測点のメタデータとデータは別々の列に表示されます。メタデータとデータの列は任意の順序で

並べることができます。全てのメタデータおよびデータ列にはオプションの品質フラグ列があります。品質フ

ラグ列は、それが属するメタデータまたはデータ列の後のどこにでも表示できます。品質フラグ値はサポート

されている品質フラグスキームのいずれかになります（表 16-5 を参照）。ファイル内の列の総数は無制限で

す。ファイル内のコメント以外の行（下記参照）は全て同じ列数を持たなければなりません。個々の列は TAB

またはセミコロンで区切ります。 

 

通常、ODV スプレッドシートファイルは多くの航海からの多くの測点のデータを保持しています。ファイル

内の行数、および個々の行の長さは無制限です。汎用 ODV スプレッドシートファイルには（1）コメント行、

（2）列ラベル行、（3）データ行の三種類の行があります。 

 

16.3.1 コメント行（Comment Lines） 

コメント行は、行の最初の二文字として二つのスラッシュ//で始まり、自由形式の任意のテキストを含むこと

ができます。コメント行は原則としてファイル内のどこにでも置くことができますが、最も一般的にはファイ

ルの先頭に配置され、データの説明、発信者に関する情報、またはファイルに含まれる変数の定義を含みます。

コメント行はオプションです。 

 

コメント行は ODV または他のソフトウェアによって利用される可能性のある構造化された情報を伝えるため

に使用されることがあります。例は、公式のパラメータ辞書内の変数定義への参照を含む SeaDataNet プロ

ジェクトで使用される//SDN_parameter_mapping ブロック、または特定の属性名の値を含む ODV で定義され

た//<attribute_name>行です。現在定義されている属性名を表 16-6 にまとめています。//<History>を除く全て

の構造化コメント行は列ラベル行と最初のデータ行の前のファイルの先頭になければなりません。//<History>

のコメント行には与えられた測点の履歴情報が含まれています。それらは、それらが属する測点の最後のデー

タ行の後かつ次の測点の最初のデータ行の前に現れます。 

 

//<MetaVariable>および//<DataVariable>コメント行にはファイル内のメタデータおよびデータ変数の仕様が

含まれています。これらの行はオプションです。もしあれば、値は以下のタグに関して与えられます：label, 

value_type, qf_schema, significant_digits, および comment. //<MetaVariable>コメント行にも var_type タグを含め
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ることができます。//<DataVariable>コメント行には is_primary_variable タグも含めることができます。label

タグ以外の全てのタグはオプションです。タグ値は二重引用符で囲む必要があります。label 値はファイル内

の列ラベルの一つの名前および単位の部分と一致している必要があり、value_type は BYTE、SIGNED_BYTE, 

SHORT, UNSIGNED_SHORT, INSIGNED_INTEGER FLOAT, DOUBLE, TEXT:nn (nn はテキストのバイト

長) または INDEXED_TEXT のいずれかでなければなりません。qf_schema は ARGO, BODC, ESEAS, GTSPP, 

IODE, OCEANSITES, ODV, QARTOD, PANGEA, SEADATANET, SMHI, WOCEBOTTLE, WOCECTD, 

WOCESAMPLE, WOD または WODSTATION のいずれかでなければなりません。key_variable は”Depth in 

Water Column [m]”, “Pressure in Water Column [db]”, “Temperature [degC]”, “Practical Salinity 

[psu]”または Collection>Identify Key Variables で得られる Identify Key Variables ダイアログの Key Variables リ

ストのラベルの中の一つでなければなりません。 

 

Var_type タ グ が //<MetaVariable> コ メ ン ト 行 に 存 在 す る 場 合 、 値 は METABASIC, METACRUISE, 

METASTATION, METATYPE, METALONGITUDE, METALATITUDE, METADAY, METAMINUTE, 

METAMONTH, METAHOUR, METAYEAR, METASECOND, METABOTDEPTH, METALOCALCDIID, 

METAEDMOCODE,  METASENSORDEPTH, METADURATION, METAEXTRACRUISEINFO, 

METAORIGCRUISE,  METAORIGSTATION, METAINVESTIGATOR, METAGTSPPDATATYPE, 

METACOMMENTSLINK,  METACRUISEREPORTLINK, METAREFERENCE, 

METASDNINSTRUMENTINFO のいずれかでなければなりません。is_primary_variable は主要データ変数の場

合は”T”、その他全ての変数の場合は”F”に設定されます。//<MetaVariable>および//<DataVariable>コメント行

の例を以下の表に示します。Export > Data > ODV Spreadsheet File で作成された全ての ODV スプレッドシート

ファイルには、全てのメタデータとデータ変数のためのそのような行が含まれています。 

 

表 16-6：ODV でサポートされているコメント行の属性名のまとめ 

Attribute Name  Possible Values  

File information 

Creator ファイルの作成者を指定するフリーテキスト。 

例：//<Creator>rschlitz@GSYSP168</Creator> 

CreateTime ISO 8601 拡張フォーマットでのファイル作成時刻。 

例：//<CreateTime>2008-05-16T09:53:45.2</CreateTime> 

Encoding ファイルで使用されているエンコーディング。有効なエントリは UTF-8, ISO-

8859-1, latin 1, windows-1258, MacRoman, macintosh です。 

例：//<Encoding>UTF-8</Encoding> 

MissingValueIndicators ファイル内の欠損値インジケータのリスト。複数のエントリはスペースで区切

ります。 

例：//<MissingValueIndicators>-9 -99.9 -9999</MissingValueIndicators> 

Software ファイルの作成に使用されたソフトウェア。 
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例：//<Software>Ocean Data View - Version 4.7.7</Software> 

Source ソースコレクションの絶対パス。 

例：//<Source>C:/eWOCE/data/whp/bottle/WoceBtl</Source> 

SourceLastModified ISO 8601 拡張フォーマットでのソースコレクションの最終更新日時。 

例：//<SourceLastModified>2003-11-11T19:53:45.2</SourceLastModified> 

Version ファイルのバージョン。 

例：//<Version>ODV Spreadsheet V4.6</Version> 

Data information 

DataField ファイル内のデータフィールドの説明。 有効なエントリは次の通り：

GeneralField, Ocean, Atmosphere, Land, IceSheet, SeaIce, Sediment 

例：//<DataField>Ocean</DataField> 

DataType ファイル内のデータの種類の説明。 有効なエントリ：GeneralType, Profiles, 

TimeSeries, Trajectories 

例：//<DataType>Profiles</DataType> 

Description 自由テキストによるデータコレクションの説明。 

例：//<Description>Data from the South Atlantic Ventilation Experiment 

(1987-1989)</Description> 

History 指定された測点の履歴記録。 履歴記録は測点の最後のデータ行の後に配置する

必要があります。 

例：//<History>2015-10-09T09:28:18 xxx@yyy IMPORT (ADD) from 

D:/data/ARK-XXVII-1_cnv_seabird/d003-01.cnv (last modified: 
2015-10-08T13:21:45; byte size: 524146427 MD5: 
9c567f786c781d78865ecb589afd2bd8)</History> 

Metadata- and data variable information 

MetaVariable ファイルに含まれるメタ変数の説明（上記の詳細を参照）。 

例：//<MetaVariable>label="Cruise Report" 

value_type="INDEXED_TEXT" qf_schema="ODV" significant_digits="0" 
comment=""</MetaVariable> 

DataVariable ファイルに含まれるデータ変数の説明（上記の詳細を参照）。 

例：//<DataVariable>label="SALNTY [pss-78]" value_type="FLOAT" 

qf_schema="ODV" significant_digits="3" is_primary_variable="F" 
com-ment="Practical salinity from bottle sample"</DataVariable> 

 

16.3.2 列ラベル（Column Labels） 

列のラベルを含む一行は必須です。この列ラベル行は常に存在していて、データ行の前に置かれていて、かつ

ファイルの最初のコメント以外の行である必要があります。 

 

汎用 ODV スプレッドシートファイルは、全ての必須メタ変数の列を提供し（表 3-3 を参照）、列ラベルとし

て次のラベルを使用する必要があります：Cruise, Station, Type. サポートされている日付/時刻形式の一つ、
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Longitude[degree_east], Latitude[degrees_north], Bot. Depth [m]. 経度と緯度の値は十進角で指定する必要があり

ます。推奨される日付/時刻形式は ISO 8601 で、これは日付と時刻を yyyy-mm-ddThh:mm:ss.sss として一列

にまとめたものです。 

 

経度と緯度の値は、全てのスペックが一つ以上のスペースで区切られて一列に表示されていれば、度、分、秒

（秒はオプション）として代わりに指定することもできます。サポートされているフォーマットには“32 18 

23.1 N”, ”32 18.756 N”, ”32° 18' 23.1'' N”, または”32°18'23.1''N”があります。 度数(°)を使用すると Latin 

1 以外のファイルエンコードで問題が発生する可能性があることに注意してください。経度と緯度を度、分、

秒で指定する場合は列ヘッダーに Latitude [deg min]と Longitude [deg min]を使用する必要があります。十進角

の経度と緯度のラベル Lon（°E）と Lat（°N）は推奨されませんが、下位互換性のために引き続きサポートさ

れています。 

 

注：以下に説明するメタデータ列およびデータ列のラベル修飾子は非推奨です。代わりにメタデータとデータ

変数のプロパティを指定するために//<MetaVariable>と//<DataVariable>のコメント行を使用してください

（上記参照）。 

 

メタデータ列ラベル（Metadata column labels） 

メタデータラベルには、が指定された値型およびバイト長のメタ変数を表す 

:METAVAR:<valueType>:<valueBytes> 

形式の修飾子があります。valueType は次のいずれかです：BYTE, SIGNED_BYTE, SHORT, UNSIGNED_SHORT, 

INTEGER, UNSIGNED_INTEGER, FLOAT, DOUBLE, TEXT または INDEXED_TEXT. valueBytes は値ごとのバイト数

を表し valueType=TEXT の場合にのみ指定する必要があります。valueBytes 値は、テキストフィールドに格納

される最大文字数を表します（デフォルトの長さ：21 バイト）。文字の一つは文字列の終了に使用され、実

際のメタデータテキストには使用できないことに注意してください。例えば 21 バイトの TEXT フィールドに

は最大 20 文字のメタデータテキストを格納できます。INDEXED_TEXT 変数は任意の長さの文字列を格納で

きます。文字列が長くて可変長の場合、または同じ文字列が何度も使用される場合は、この値型を使用する必

要があります。 

例： Longitude[degree_east]:METAVAR:DOUBLE 

Citation:METAVAR:TEXT:81 

URL:METAVAR:INDEXED_TEXT 

 

注：修飾子は、スプレッドシートファイルがコレクション作成用のテンプレートとして使用されている場合、

例えばファイルを ODV にドロップする、File > Open でファイルを開く、または File > New で新規コレクショ

ンを作成するときにファイルをテンプレートとして選択する場合にのみ使用されます。既存のコレクションに

ファイルを読み込んでも効果はありません。 

 

データ列ラベル（Data column labels） 
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データ変数ラベルには、Depth [m]のように角括弧[]で囲まれた単位指定を含める必要があります。単位のない

変数は[] units の部分（例：Species Count）を含むべきではありません。 

 

データ変数ラベルは、次の形式の修飾子を持つことができます。 

:PRIMARYVAR:<valueType>:<valueBytes>:<SchemaID> 
 

ここでは、valueType は次のいずれかになります：BYTE, SIGNED_BYTE, SHORT, UNSIGNED_SHORT, 

INTEGER, UNSIGNED_INTEGER, FLOAT, DOUBLE, TEXT, または INDEXED_TEXT. valueBytes 値ごとの

バイト数を表し、valueType=TEXT の場合、または SchemaID エントリが存在する場合にのみ指定する必要が

あります。TEXT の場合、valueBytes 値はテキストフィールドに格納される最大文字数を表します（デフォル

トの長さ：21 バイト）。文字の一つは文字列の終了に使用され、実際のデータテキストには使用できないこ

とに注意してください。例えば、21 バイトの TEXT フィールドには、最大 20 文字のメタデータテキストを

格納できます。INDEXED_TEXT 変数は任意の長さの文字列を格納できます。文字列が長くて可変長の場合、

または同じ文字列が何度も使用される場合は、この値型を使用する必要があります。 

 

SchemaID は次のいずれかです：ARGO, BODC, ESEAS, GTSPP, IODE, OCEANSITES, ODV, QARTOD, 

PANGAEA, SEADATANET, SMHI, WOCEBOTTLE, WOCECTD, WOCESAMPLE, WOD, ま た は 

WODSTATION. 変数に関連する品質フラグ列（下記参照）がある場合は、品質フラグ列の SchemaID が優先

されます。 

 

この列が主要変数であることを示すために：PRIMARYVAR 修飾子を使用できるのは、1 つの列ラベルだけです。 

 

例： Depth[m]:PRIMARYVAR:DOUBLE 

Sample Number:SHORT 

Salinity[psu] 

Phosphate[~$m~#mol/kg]:FLOAT:4:WOCEBOTTLE 

Sediment Type:INDEXED_TEXT:4:SEADATANET 

 

注：スプレッドシートファイルがコレクション作成用のテンプレートとして使用されている場合、例えばファ

イルを ODV にドロップする、File > Open でファイルを開く、または File > New で新しいコレクションを作成

するときにファイルをテンプレートとして選択する場合にのみ使用されます。既存のコレクションにファイル

を読み込んでも効果はありません。 

 

データ列は、関連する品質フラグ、データエラー、およびデータ情報列を持つことができます。これらの補助

列は通常、それらが属するデータ列の直後に続きます。 

 

品質フラグ列ラベル（Quality flag column labels） 
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品質フラグの列ラベルは、それらが属するメタデータまたはデータ変数、および使用されている特定の品質フ

ラグスキームを自動的に識別できるように、次の命名規則に従う必要があります。 

 

汎用 ODV スプレッドシート品質フラグラベルは、次のいずれかの形式で指定できます： 

⚫ QV<Text>:<SchemaID>:<ParentColumnLabel> 
⚫ QV<Text>:<SchemaID>:STATION 
⚫ QV<Text>:<SchemaID>:SAMPLE 
⚫ QF 

 

<Text>は任意のオプションの文字列、<SchemaID>はサポートされている品質フラグスキーマ識別子の一つで

（表 16-5 を参照）、<ParentColumnLabel>は品質フラグ列が属する変数の列ラベルです。品質フラグラベルの

<Text>, <SchemaID>および<ParentColumnLabel>の部分はオプションです。<SchemaID>項目がない場合は、品質

フラグ値は汎用 ODV 品質フラグであると見なされます。<ParentColumnLabel>部分がない場合は、品質フラグ

は品質フラグ列の前の変数に属していると見なされます。<Text>項目が存在する場合は区切り文字`:’を含め

ることはできません。<Text>は ODV によって評価または使用されないことにも注意してください。この項目

は、この機能を必要とするアプリケーション（例えば、QV1、QV2 など）に固有の列ラベルを与えるためにの

み含まれています。 

 

<SchemaID> は ARGO, BODC, ESEAS, GTSPP, IODE, OCEANSITES, ODV, QARTOD, PANGEA, 

SEADATANET, SMHI, WOCEBOTTLE, WOCECTD, WOCESAMPLE, WODまたはWODSTATIONのいずれ

かの一つです。品質フラグスキーマの詳細については表16-5を参照してください。 

 

個々のデータ値の品質フラグ値に加えて、ODV は測点全体の一般的な品質測面を記述する測点全体品質フラ

グ（特定の測点に対する単一のフラグ、例えば WOCE 測点全体フラグ）を、そのサンプルに対して行われる

全ての測定の品質に影響を与える可能性があるサンプリング装置に関する問題を示すために使用されるサン

プル品質フラグと同様にサポートします（サンプルごとに一つのフラグ）。全ての測点およびサンプル品質フ

ラグは列ラベルの<ParentColumnLabel>部分に STATION または SAMPLE という語で示されます。 

 

品質フラグラベルの QV 構文は ODV バージョン 3 以前では認識されません。ODV3 と互換性を保つには品質

フラグ列のラベルとして QF を使用する必要があります。そのような場合、品質フラグ値は汎用 ODV フラグ

であり、それらは品質フラグ列の前の変数に属していると想定されます。 

 

表 16-7：品質フラグの列ラベルの例 

品質フラグ列ラベル  コメント  

QV or QF  左側で最も近いデータ変数の汎用 ODV 品質フラグ。 

QV:SEADATANET  左側で最も近いデータ変数の SeaDataNet 品質フラグ。 

QV:ARGO:Nitrate（硝酸塩） 

[umol/kg]  

ラベル Nitrate [umol/kg]の変数に対するアルゴ品質フラグ。 
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QV:ODV:Nitrate [umol/kg]  
or  
QV::Nitrate [umol/kg]  

ラベル Nitrate [umol/kg]の変数に対する汎用 ODV 品質フラグ。 

QV:WOCESAMPLE:SAMPLE  WOCESAMPLE サンプラー品質フラグ。 

QV:WODSTATION:STATION  WODSTATION 測点全体の品質フラグ。 

QV::STATION  測点全体の汎用 ODV 品質フラグ。 

 

データエラー列ラベル（Data error column labels）  

全てのデータ列は、それぞれのデータ値の 1-σ 不確実性を含む関連データエラー列を持つことができます。デ

ータエラー列ラベルは、それらが属するデータ変数を自動的に識別できるようにするために、次の命名規則に

従う必要があります： 

⚫ STANDARD_DEV<Text><::ParentColumnLabel>  

 

<Text>は任意のオプションの文字列で、<ParentColumnLabel>はデータエラー列が属する変数の列ラベルです。

<Text>と<ParentColumn-Label>の部分はオプションです。 <ParentColumnLabel>部分がない場合は、データエラ

ーはデータエラー列の前のデータ変数に属していると見なされます。<Text>項目が存在する場合は、区切り文

字`:’を含めることはできません。<Text>は ODV によって評価または使用されないことにも注意してください。

この項目は、この機能を必要とするアプリケーション（例えば STANDARD_DEV1, STANDARD_DEV2 など）

に固有の列ラベルを与えるためにのみ含まれています。 

 

表 16-8：データエラー列のラベル例 

データエラー列ラベル コメント 

STANDARD_DEV  左側で最も近いデータ変数のデータエラー。 

STANDARD_DEV::Nitrate [umol/kg]  ラベル Nitrate [umol kg]の変数に対するデータエラー。 

 

データ情報列ラベル（Data info column labels） 

全てのデータ列にはそれぞれのデータ値の情報文書への情報テキストまたは URL を含む関連データ情報列を

含めることができます。データ情報列ラベルは、それらが属するデータ変数を自動的に識別できるようにする

ために、次の命名規則に従う必要があります： 

⚫ INFOS<Text><::ParentColumnLabel>  
 

<Text>は任意のオプションの文字列で、品質フラグラベルの<ParentColumnLabel>部分はオプションです。

<ParentColumnLabel>部分がない場合、データ情報はデータ情報列の前のデータ変数に属していると見なされ

ます。<Text>項目が存在する場合は区切り文字`:’を含めることはできません。<Text>は ODV によって評価ま

たは使用されないことにも注意してください。この項目は、この機能を必要とするアプリケーション（例えば

INFOS1, INFOS2 など）に固有の列ラベルを与えるためにのみ含まれています。 
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表 16-9：データ情報列ラベルの例 

データ情報列ラベル コメント 

INFOS  左側で最も近いデータ変数のデータに関する情報。 

INFOS::Nitrate [umol/kg]  ラベル Nitrate [umol/kg]の変数に関するデータ情報。 

 

重要な注意：列ラベルにはスプレッドシートファイルで使用されている列区切り文字を含めないでください。 

 

16.3.3 データ列 (Data Lines) 

列ラベル行に続くコメント以外の行は全てデータ行と見なされます。全てのデータ行は列ラベル行と同じ列数

を持たなければなりません。各データ行には一つのサンプルのメタデータとデータが含まれています。所定の

測点の全てのサンプルは連続順でなければなりませんが並び替えられている必要はありません。欠測値は空欄、

-1.e10 値、または na（使用不可 (not available）)や NaN（数字ではない (not a number）)のような

テキスト指示子によって示されることがあります。ファイル内の欠損値インジケータとして-9 や-9999 など

の 特 殊 な 値 が 使 用 さ れ て い る 場 合 は 、 全 て の デ ー タ 行 よ り 前 の フ ァ イ ル の 先 頭 近 く に お い て

//<MissingValueIndicators>-9 -9999</MissingValueIndicators>形式の属性行で特殊な値を指定する必

要があります。 

 

測点ラベルは測点メタ変数の長さに制限されています（デフォルト：20 文字）。測点ラベルに番号を使用す

ると内部ソートおよび選択機能が強化されるので推奨されます。 

 

測点タイプ Type は単一の文字列です。サンプル数が約 250 未満の測点には B（ボトル採水データなど）を、

サンプル数が 250 を超える測点には C（CTD、XBT など）を使用してください。Type に*を指定すると ODV

が選択します。Bot. Depth の値が使用できない時はこのフィールドを空欄のままにしてください。 

 

測点のメタデータは所定の測点の最初の行に指定する必要があります。測点の残りの行のメタデータフィール

ドはファイルサイズを縮小するために空のままになることがあります（コンパクトスプレッドシート形式）。

汎用 ODV スプレッドシートファイルは通常、多くの航海からの多くの測点のデータを保存します。次の測点

の最初のサンプルのメタデータとデータは前の測点の最後のサンプルの直後に続きます。測点間に区切り線は

ありません。 

 

数値は小数点を示すためにピリオド`.’またはカンマ`,’を使用できます（例えば 2,57 と 2.57 は両方とも有効

な入力です）。入力が二重引用符で囲まれている場合それらは処理の前に自動的に削除されます。 

 

TEXT 型のデータ変数は文字エンコーディングごとに一バイトを使用します。テキスト値が ASCII 文字セット

（コード 0～126）に厳密に制限されている場合 ODV コレクションはプラットフォームおよび国に依存しま

せん。非 ASCII 文字の使用は同じプラットフォーム上の同じ地域内では正常に機能しますが、非 ASCII 文字



ODV User’s Guide 

 

177 

 

は異なるプラットフォームまたは異なる地域では正しく表示されない可能性があります。データコレクション

がプラットフォームに依存しないようにするために ASCII のみのテキストを常に使用する必要があります。 

 

テキスト型データ変数の値ごとに格納できる最大バイト数（バイト長）は固定されており、コレクションの作

成時に指定する必要があります。実際に要求されたバイト長はテキスト終了のための追加の 1 バイトを含ま

なければなりません。例えばテキスト変数が 40 文字のテキストを格納する場合は 41 バイト必要です。テキ

スト変数のバイト長は 2 より小さくすることはできず、それ以外は任意です。5001 などの大きなバイト長を

選択すると長いテキストに対応できますが、個々のテキスト値は全て指定されたバイト数を占めるのでコレク

ションファイルも大きくなります。特定のテキスト値が Web サイトの DOI または URL を表す場合、ODV は

その値をクリックすることを許可し、Web ブラウザで DOI または URL を開きます。大量のテキストを直接

使用する代わりに URL または DOI を使用することを検討してください。 

 

16.4 ODV スプレッドシートでサポートされている日付と時間形式（Supported Date 

and Time Formats in ODV Spreadsheet Files） 

 

ODV は単一列の ISO 8601 日付/時刻フォーマットをサポートしています。これは ODV のインポートおよび

エクスポートファイルで推奨される日付/時刻フォーマットです。さらに ODV は科学界で一般的に使用され

ている多くのカスタムファイルフォーマットの一つで提供されるデータの簡単なインポートを可能にするた

めに、他のさまざまな日付および時刻フォーマットもサポートします。これには日、月、年の値の順序が異な

る場合や、個々の列に日、月、年、時、および分のデータがある場合のような、多くの日付／時刻の仕様が含

まれています。 

 

表 16-10 の列ラベルの使用は ODV による自動日付/時刻識別を可能にするために強く推奨されます（小文字、

大文字、または大/小文字混合）。ODV スプレッドシート出力ファイルのデフォルトの日付/時刻フォーマット

は ISO 8601 です。 

 

表 16-10：サポートされている日付フォーマット（列ラベルは大文字、小文字、または大/小文字混合） 

列ラベル  コメント 

yyyy-mm-dd hh:mm 

または 

yyyy-mm-ddThh:mm 

または 

yyyy-mm-ddThh:mm:ss.sss  

ISO8601。ODV 推奨の日付/時刻フォーマット。 日付と時刻を一つの列

にまとめます。 

例: Feb/23/2006 10:23h は 2006-02-23 10:23 または 2006-02-

23T10:23 となります。  

Time [xxx since yyyy-mm-dd]  指定された参照日 yyyy-mm-dd 以降の xxx（日数または年数）の単位の十進

数値としての日時。 

例: Jan/02/2012 12h は Time [days since 2012-01-01] = 1.5 となり

ます。 
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mon/day/yr  

または  

mm/dd/yyyy  

日付は一列に、時間は別に提供されます。 

例：Feb/23/2006 は 02/23/2006 となります。 

dd/mm/yyyy  日付は一列に、時間は別に提供されます。 

例：Feb/23/2006 は 23/02/2006 となります。 

yyyy/mm/dd  日付は一列に、時間は別に提供されます。 

例：Feb/23/2006 は 2006/02/23 となります。 

mmddyyyy  日付は一列に、時間は別に提供されます。 

例：Feb/23/2006 は 02232006 となります。 

ddmmyyyy  日付は、一列に、時間は別に提供されます。 

例：Feb/23/2006 は 23022006 となります。 

yyyymmdd  日付は一列に、時間は別に提供されます。 

例：Feb/23/2006 10:23h は 20060223 10:23 となります。 

year  
month  
day  

個々の列の日付情報（任意の順序） 時間は別に提供されます。 

例：Feb/23/2006 は 2006 02 23 となります。  

 

表 16-11：サポートされている時間フォーマット（列ラベルは大文字、小文字、または大/小文字混合） 

列ラベル  コメント  

hh:mm  時刻は一列で 日付は別に提供されます。 

例：10:23h は 10:23 となります。 

hhmm  時刻は一列で 日付は別に提供されます。 

例：10:23h は 1023 となります。  

hour  
minute  

個々の列の時間情報（任意の順序）。日付は別に提供されます。 

例：10:23h は 10 23 となります。 

 

16.5 注釈内の制御シーケンスと機能  (Control Sequences and Functions in 

Annotations) 

 

表 16-12：ODV 注釈内のフォーマット制御シーケンス 

制御シーケンス 動作 

~$ Symbol フォント（ギリシャ文字）に切り替えます。 

~# 通常のテキストフォントに切り替えます。 

~% パーミル（千分率）記号（‰）を生成します。 

~^ 次の文字を上付き文字として描きます。 

~_ 次の文字を下付き文字として描きます。 
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&#<code>; Unicode 文字<code>を生成します。<code>は十進数（例：169）または

16 進数（例：x00A9）のコードです。 

例：“~$S~＃CO~_ 2 [~$ m~＃mol/kg]”は“ΣCO2 [μmol/kg]”を生成します。“&#x00A9; No Name”を選

択すると、“© No Name”が生成されます。 

 

 

 

図 16-1：ギリシャ語の記号とラテン語の等価語 

 

表 16-13：ODV の注釈で利用可能な自動関数 

機能 置換テキスト 

=collection() 現在のコレクションのフルパス 

=collectionName() 現在のコレクションの名前（拡張子を除く） 

=collectionStationCount() 現在のコレクション内の測点数 

=date() 現在の日付 

=section() 現在のセクション（section）ファイルのフルパス 

=software() ODV ソフトウェア名およびバージョン 

=time() 現在の時刻 

=user() ユーザー名とホスト名 

=validStationCount() 現在測点マップに表示されている測点の数 

=view() 現在のビューファイルのフルパス 

=viewName() 現在のビューファイルの名前（拡張子を除く） 

 

16.6 格子化手法（Gridding Methods） 

ODV では、次の三つの方法：Quick gridding, Weighted-average gridding, DIVA gridding のいずれかを使用して、

不規則な間隔で配置されたオリジナルデータを等間隔または不等間隔の矩形格子（等値線およびグラフィック

ス表示または格子点値の出力）に投影できます。 

 

Quick gridding は速度に最適化された加重平均アルゴリズムで、利用可能なデータに対して一回のループだけ

で全格子点の推定値を計算します。Quick gridding は、他のアルゴリズムでは時間がかかりすぎる場合、例え

ば数百万のデータポイントを含む場合にのみ使用してください。Weighted-average gridding は、より洗練され
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た加重平均アルゴリズムを使用しており、データ範囲が広く均一である場合には良好な結果が得られます。

Weighted-average gridding はデフォルトの格子化手法です。DIVA gridding は他の方法よりも高度ですが計算コ

ストは高くなります。DIVA 格子化手法は、出版物や Web ページの最終的なグラフを作成するときには常に

使用してください。注：Isopycnic gridding 機能は DIVA 格子化手法が有効な場合にのみ使用可能です。 

 

16.6.1 加重平均格子化（Weighted-Average Gridding） 

等間隔の矩形格子が使用される Quick gridding とは対照的に、ODV は加重平均または DIVA 格子化が要求され

る場合、可変解像度の矩形格子を構築して使用します。この場合、データ密度に応じて X 方向と Y 方向の格

子間隔が変わります。高データ密度を有する領域では高解像度（小さなグリッド間隔）となり、一方で疎なサ

ンプリングの領域では低解像度の粗い格子が使用されます。海洋観測断面では、データ範囲が通常良好な上層

および境界流域では空間分解能が高く、データ範囲が疎な外洋地域や深層部では粗い分解能の格子となります。 

 

格子の構築後、成分の推定値𝑐𝑖 = ∑ 𝛼𝑖𝑑𝑖𝑖 / ∑ 𝛼𝑖𝑖 は、単純な加重平均スキームを使用して全ての格子点(+)で計算

されます。効率上の理由から、格子点からごく近傍のデータ値 di のみが合計の対象となります（下図を参照）。

データと格子点との間の距離が増すにつれて、重み αi は指数関数的に減少します：𝛼𝑖 = 𝑒−𝑟，ここで r =

 (∆ 𝑥 ∕ 𝐿𝑥  )² +(∆ 𝑦 ∕ 𝐿𝑦)² ，Lx および Ly はそれぞれＸ方向およびＹ方向にそれぞれ分けた平均の長さスケ

ール を表します。 

 

図 16-2：格子点（+）でのデータ値（赤い記号）の加重平均。詳細は本文を参照してください。 

 

平均化された長さスケールは領域によって異なり、局所的な格子間隔に比例します。すわなち、小さい平均長

さスケールは小さい格子間隔を有する区域（例えば海洋上層、または境界流領域などの高分解能格子）におい

て使用され、一方で大きい格子間隔を有する範囲においては大きい平均長さスケールが自動的に適用されます。

空間的に変化する長さスケールのこのアプローチは、データ範囲が密な領域における小規模の特徴を分解する

ことを可能にし、同時にデータ範囲が疎な他の領域においては滑らかで安定した場を提供します。Display 

Options ダイアログでユーザーが指定した長さスケール Lx0 と Ly0 は、それぞれの軸範囲のパーミル（千分率）

あたりで計測され、データカ範囲が最も小さい領域（最も粗いグリッド）を表します。加重平均アルゴリズム
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の ODV 実装は、数千のデータポイントを持つフィールドであっても、数秒以内のフィールド推定を可能にす

るために速度に関して非常に最適化されています。 

 

全ての格子点について推定値が得られると、そのフィールドはスクリーン上に表示するために陰影付けおよび

等値線化ルーチンに渡されます。 

 

16.6.2 DIVA 格子化（DIVA Gridding） 

DIVA はリエージュ大学（http://modb.oce.ulg.ac.be/mediawiki/index.php/DIVA）で開発された格子化ソフトウ

ェアで、ODV に組み込まれている加重平均法よりも優れた点がいくつかあります。DIVA を使用すると最適補

間（OI）に匹敵する最適な方法でデータを分析および補間することができます。OI とは異なり、DIVA は海岸

線と海底地形の特徴も考慮に入れて、推定が行われる領域を構造化して細分化します。計算は特定のグリッド

領域に適応した有限要素メッシュで実行されます。 

 

有限要素メッシュの生成、解析パラメータの最適化、格子化領域の計算に必要な DIVA ツールは ODV インス

トールパッケージに含まれています。DIVA gridding オプションは Properties > Display Style ダイアログ（Z 変数

を持つデータウィンドウ）においてデフォルトで使用可能です。このオプションを選択し、適切な X と Y の

相関長スケールを指定するか、Automatic scale lengths チェックボックスをチェックして DIVA 格子化を有効

にしてください。ODV は DIVA の操作に必要な全てのファイルを自動的に（作業ディレクトリ

<user>/diva/work/ yyyy-mm-ddThh-mm-ss に；ここで<user>は ODV ユーザーディレクトリを、yyyy-mm-ddThh-

mm -ss は個々の ODV インスタンスの起動日付時刻を表します）作成し、DIVA メッシュ生成および領域推定

ステップを実行し、ODV による領域のグラフィカル表示のために DIVA 出力を読み取ります。 

 

他の格子化アルゴリズムと同様に、推定領域の滑らかさはデータウィンドウの Properties ダイアログの Display 

Style ページで X と Y の長さスケールを調整することによって制御されます。目盛りの長さの値はそれぞれの

軸範囲のパーミル（千分率）あたりで、大きい値は滑らかな領域になります。データ S/N 比や格子化領域の設

定方法（下記の Domain Separation を参照）などの他の DIVA パラメータは、データウィンドウの Properties ダ

イアログの DIVA 設定ページからアクセスできます。ODV がシャットダウンされると、DIVA 作業ディレクト

リとその全ての内容が削除されることに注意してください。 

 

DIVA の専門家は DIVA 設定ファイル<user> /diva/diva.settings を編集して追加の DIVA パラメータを調整で

きます。 

 
Non-negativity Constraint 

Quick gridding または weighted-averaging gridding などの加重平均法では、常に最小データ値と最大データ値の

間の区間にある推定値が生成されるので、これらの推定値は観測値の範囲を超えることはありません。DIVA

格子化法はこの点で異なり、データ範囲を超える格子領域値を生成することがあります。特別な場合として、

全てのデータ値が正（またはゼロ）で負にならない領域を期待している場合でも、X/Y 範囲の一部の領域で負

http://modb.oce.ulg.ac.be/mediawiki/index.php/DIVA
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の格子値が発生する可能性があります。負でないことが保証されている変数（例えば化学トレーサの濃度）を

格子化し、DIVA が負の濃度の領域を生成するような場合は、そのような非現実的な値を防ぐために DIVA 設

定ページの「負のグリッド値の回避」チェックボックスをチェックしてください。  

 
Domain Separation 

DIVA 格子化は、一般的に疎で不均一なデータ範囲の場合（図 16-3 を参照）、および陸地、海嶺または他の

海底地形の障壁（図 16-4 を参照）によって全く異なるプロパティ値を持つ小地域に分離されている場合に、

Quick gridding または Weighted-aver-age gridding よりも優れた結果をもたらします。一方、Quick gridding や

Weighted-average gridding で使われる加重平均スキームは、障壁を越えて誤った情報を伝えてしいますが、こ

れは DIVA 格子化では発生しません。 

 

DIVA 範囲分離機能は二種類のデータウィンドウで有効になります：（1）Y 軸に Depth または Pressure があ

り、断面の海底地形が表示されている断面プロット、（2）X 軸と Y 軸にそれぞれ経度と緯度を持ち、Z 変数

としてコレクション変数または等値面変数を持つデータウィンドウ（マップ）。Z 等値面変数の面変数は Depth

または Pressure in Water Column 変数でなければならないことに注意してください（キー変数の関連付けを参

照）。 

 

（1）断面図では、範囲の分離に断面海底地形多角形を使用するか、範囲の分離を使用せずに X/Y ウィンドウ

範囲全体を単一の範囲として扱うかを選択できます（図 10-5 の DIVA 設定ページを参照）。 

 

 
図 16-3：不均一なデータ範囲を持つフィールドに対する（a）加重平均と（b）DIVA 格子化法の比較。 

 

（2）マップ内の範囲分離は、格子化海底地形データおよび閾値水深値に基づいています。指定された閾値水

深よりも浅い水深の地域は全てバリアと見なされます。ODV では標準格子上の標高データと閾値水深を含む

適切な海底地形ファイルを選択できます（図 10-5 の DIVA 設定ページを参照）。デフォルトで ODV は 6’×6’

でサブサンプリングされたグローバル GEBCO 等深線（ディレクトリの GEBCO1.nc ファイル）を使用します。

これは海盆規模または全球地図領域に対して十分な解像度を提供します（図 16-3 および 16-4）。非常に小
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さな領域では、デフォルトの等深線ファイルの 6’x6’の解像度では信頼性の高い陸域バリア検出には粗すぎる

ため、カスタム等深線ファイルをユーザーが用意する必要があります。新しい 0.5’解像度の GEBCO_08 海底

地形の地域サブセットを含むファイルは、リクエストに応じて配信できます。 

 

カスタム等深線ファイルは netCDF フォーマットでなければならず、それらは<install>/include/GEBCO1.nc と

同じ論理構造を持ち、<install>/include に記録されなければなりません（<install>はあなたの ODV インストー

ルディレクトリを表します）。DIVA にカスタム等深線ファイルを使用するには、ウィンドウの Properties ダ

イアログの Domain Selection > Map on the DIVA Settings ページの Domain Selection > Map でファイルを選択しま

す。 

 

選択した等深線ファイルで特定の領域での解像度が不十分な場合、ODV は領域の分離を自動的にオフにしま

す。 

 

閾値水深には、特定の水深値またはキーワード(automatic)を入力できます。(automtic)が使用され、Z 変数が

Depth または Pressure 等値面で定義された等値面変数である場合、等値面の深度（または圧力）が、閾値水深

として使用されます。このような場合、ODV は深度（または圧力）変数を識別できる必要があります。オプシ

ョン Collection > Identify Key Variables を使用してキー変数 Depth in Water Column [m] （または Pressure in Water 

Column [db])が Depth（または Pressure)変数に関連付けられていることを確認してください。等値面変数がキ

ーワード first を使用して定義されている場合（例えば XXX @ Depth [m] = first）、1m の自動閾値水深が使用さ

れます。 

 

 

図 16-4：分離された海域の（a）加重平均と（b）DIVA 格子化法の比較。加重平均格子化法のケース（a）

におけるカリブ海の太平洋の値の影響に注意してください。 

 

DIVA の実行時間は他のグリッド方法よりも多少長くなりますが、出版品質の図のために DIVA 格子化の使用

を常に考えるべきです。 

 

System requirements and troubleshooting: DIVAパッケージを正しく動作させるには、最低2GBのRAMを搭載し
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たコンピュータが必要です。DIVAを実行してプロットウィンドウが白のままになっている場合は、他のアプ

リケーションを閉じてメモリを解放してからもう一度やり直してみてください。 

 

16.6.3 等密度格子化 （Isopycnic Gridding） 

海洋における海水や成分の移動は一定密度の表面（等密度線）に沿って最も効果的であり、直交座標に沿って

等密度線が急勾配な領域（フロント領域）で相応しくなく、かつ観測データの大きな誤表示につながる可能性

があります。 

 

例として図 16-5 に 30°N 付近のガルフストリーム地域の東西断面に沿った硝酸塩データを示します。（a）

のオリジナルデータでは σ0=27.725 の等密度線に沿った顕著な硝酸塩極大層が明らかであり、これはこの海

域の沿岸近くで約 300m の深さから沖合では約 1000m まで深くなっています。デカルト格子（ｂ）では、等

密度の全深度範囲にわたって連続硝酸塩極大層を再現することができず、特に約５００ｍ深では沿岸および沖

合において低硝酸塩水の影響によって小さすぎる推定値を導き出しています。対照的に等密度格子化ではこの

影響を受けずに、より現実的な分布を生成しています（c）。 

 

等密度格子化は強い潮流や前線がある地域など、等密度線の勾配が急な海域では常に使用する必要があるでし

ょう。 

 

 

図 16-5：（a）ガルフストリーム地域の元の硝酸塩データ、および（b）デカルト座標と（c）等密度格子の

比較。 

 

ウィンドウの Properties ダイアログの Display Style ページにある Isopycnic gridding ボックスをチェックして、

等密度格子化をセクション単位で要求できます（図 10-1 を参照）。このオプションは、中立密度 γn またはポ

テンシャル密度派生変数が定義されていて、かつ DIVA 格子化が使用されている場合にのみ有効です。また、

中性密度 γn は一部の海域（例えば北極）では利用できないことに注意してください。そのような場合は代わり

にポテンシャル密度変数を使用してください。 
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海洋観測データが最高品質でない場合 Isopycnic gridding は質の悪い結果を生む可能性があります。このオプ

ションは品質管理されたデータセットにのみ使用し、適切なサンプル品質フィルタを適用してデータの外れ値

を確実に除外してください。等密度格子化に使用される密度変数（定義されている場合はγn、そうでない場合

は最初に定義されたポテンシャル密度偏差変数）の値が深さとともに厳密に単調増加することも重要です（基

準圧力からかけ離れたポテンシャル密度変数はこの要求を妨げるかもしれません）。常に中立密度γn を使用す

ることをお勧めします；ただし北極圏では γn は定義されないので σ0 を使用してください。 

 

16.7 ODV ディレクトリ構造（ODV Directory Structure） 

ODV のデフォルトのインストールディレクトリは、Windows の場合は c:¥Program Files¥Ocean Data View（mp）、

MacOS の場合は/Applications/ODV、Linux および UNIX の場合は/usr/local/ odv です（以降では<install>と表

記）。MacOS, Linux, UNIX では次のパス指定でバックスラッシュ(訳注：日本語キーボードでは円記号(\))

をスラッシュ(/)に置き換えてください。インストールディレクトリには特定の目的に必要なファイルを含む

さまざまなサブディレクトリがあります。マクロファイル、パレットファイル、サンプルデータコレクション

など、ユーザーによって変更される可能性のあるインストールファイルはユーザーのドキュメントディレクト

リの下のサブディレクトリ ODV にインストールされます（以降では<user>と表記）。 

 

下記はODVによって使用されるディレクトリのリストです： 

 

<install>\bin_w32   Windowsプラットフォームの場合 

<install>\bin_macx  MacOSプラットフォームの場合 

<install>\bin_linux-i386  Linux i386プラットフォームの場合 

<install>\bin_solaris-sparc  SUN Solaris Sparcプラットフォームの場合 

<install>\bin_irix6.5_mips  SGI Irixプラットフォームの場合 

<install>\bin_aix-powerpc  IBM AIX powerpcプラットフォームの場合 

ODV実行ファイル、ツール、およびPostScriptプリアンブルファイル 

 
<install>\coast\GlobHR 

全球の中解像度海岸線および海底地形ファイル 

 
<install>\doc 

ODV HTMLヘルプファイル（ODV Webページから入手可能なPDFバージョン） 

 
<install>\include 

ＯＤＶインクルードファイルのデフォルトディレクトリ（例えばGEBCO1全球海底地形）。特定の

ファイルを含むサブディレクトリがいくつかあることに注意してください。 

 
<install>\include\atmhist 

各種微量ガスの大気中濃度の変移 
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<install>\samples 

ODVサンプルファイルのディレクトリ。これらのファイルをデータ読み込みまたはマクロファイル

のテンプレートとして使用します。 

 
<user>\cmd_files 

ODVコマンドファイル（.cmd） 

 
<user>\data 

ODVデータコレクションのベースディレクトリ。ODVデータコレクションは原則として読み書き可

能（ハードディスク、メモリースティックなど）または読み取り専用（DVD、CD-ROMなど）の記憶

媒体上のどこにでも置くことができますが、全てのコレクションをこのディレクトリの下に管理する

ことをお勧めします。全てのコレクションはそれ自身のサブディレクトリに格納してください。 

 
<user>\diva 

DIVA作業ディレクトリ（DIVAが使用されている場合にのみ存在） 

 
<user>\export 

Export > Window Dataでエクスポートしたデータセットのベースディレクトリ 

 
<user>\gazetteers 

ODV地名辞典データベースファイル 

 
<user>\macros 

 ODVマクロファイル（.mac） 

 
<user>\palettes 

ODVパレットファイル（.pal） 

 
<user>\reference 

Export > Window Data as Reference を通してエクスポートした参照データセットのベースディレクト

リ 
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